rebuilt with patch for libdav1d 1.0.0 [release 3.0.17.3-2mamba;Fri Apr 01 2022]
This commit is contained in:
parent
e60dec875c
commit
baa2907d8b
60
vlc-3.0.17.3-libdav1d-1.0.0.patch
Normal file
60
vlc-3.0.17.3-libdav1d-1.0.0.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
--- vlc-3.0.17.3/modules/codec/dav1d.c.orig 2022-04-01 10:38:16.386188801 +0200
|
||||||
|
+++ vlc-3.0.17.3/modules/codec/dav1d.c 2022-04-01 10:46:08.645646867 +0200
|
||||||
|
@@ -63,10 +63,16 @@
|
||||||
|
set_category(CAT_INPUT)
|
||||||
|
set_subcategory(SUBCAT_INPUT_VCODEC)
|
||||||
|
|
||||||
|
+#if DAV1D_API_VERSION_MAJOR >= 6
|
||||||
|
+ add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_THREADS,
|
||||||
|
+ THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
|
||||||
|
+ add_obsolete_string("dav1d-thread-tiles") // unused with dav1d 1.0
|
||||||
|
+#else
|
||||||
|
add_integer_with_range("dav1d-thread-frames", 0, 0, DAV1D_MAX_FRAME_THREADS,
|
||||||
|
THREAD_FRAMES_TEXT, THREAD_FRAMES_LONGTEXT, false)
|
||||||
|
add_integer_with_range("dav1d-thread-tiles", 0, 0, DAV1D_MAX_TILE_THREADS,
|
||||||
|
THREAD_TILES_TEXT, THREAD_TILES_LONGTEXT, false)
|
||||||
|
+#endif
|
||||||
|
vlc_module_end ()
|
||||||
|
|
||||||
|
/*****************************************************************************
|
||||||
|
@@ -294,6 +300,11 @@
|
||||||
|
return VLC_ENOMEM;
|
||||||
|
|
||||||
|
dav1d_default_settings(&p_sys->s);
|
||||||
|
+#if DAV1D_API_VERSION_MAJOR >= 6
|
||||||
|
+ p_sys->s.n_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
|
||||||
|
+ if (p_sys->s.n_threads == 0)
|
||||||
|
+ p_sys->s.n_threads = __MAX(1, vlc_GetCPUCount());
|
||||||
|
+#else
|
||||||
|
p_sys->s.n_tile_threads = var_InheritInteger(p_this, "dav1d-thread-tiles");
|
||||||
|
if (p_sys->s.n_tile_threads == 0)
|
||||||
|
p_sys->s.n_tile_threads =
|
||||||
|
@@ -303,6 +314,7 @@
|
||||||
|
p_sys->s.n_frame_threads = var_InheritInteger(p_this, "dav1d-thread-frames");
|
||||||
|
if (p_sys->s.n_frame_threads == 0)
|
||||||
|
p_sys->s.n_frame_threads = (i_core_count < 16) ? i_core_count : 16;
|
||||||
|
+#endif
|
||||||
|
p_sys->s.allocator.cookie = dec;
|
||||||
|
p_sys->s.allocator.alloc_picture_callback = NewPicture;
|
||||||
|
p_sys->s.allocator.release_picture_callback = FreePicture;
|
||||||
|
@@ -313,12 +325,19 @@
|
||||||
|
return VLC_EGENERIC;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if DAV1D_API_VERSION_MAJOR >= 6
|
||||||
|
+ msg_Dbg(p_this, "Using dav1d version %s with %d threads",
|
||||||
|
+ dav1d_version(), p_sys->s.n_threads);
|
||||||
|
+
|
||||||
|
+ dec->i_extra_picture_buffers = (p_sys->s.n_threads - 1);
|
||||||
|
+#else
|
||||||
|
msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
|
||||||
|
dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
|
||||||
|
|
||||||
|
+ dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
|
||||||
|
+#endif
|
||||||
|
dec->pf_decode = Decode;
|
||||||
|
dec->pf_flush = FlushDecoder;
|
||||||
|
- dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
|
||||||
|
|
||||||
|
dec->fmt_out.video.i_width = dec->fmt_in.video.i_width;
|
||||||
|
dec->fmt_out.video.i_height = dec->fmt_in.video.i_height;
|
63
vlc.spec
63
vlc.spec
@ -1,10 +1,10 @@
|
|||||||
%define dirver %(echo %version | cut -d_ -f1)
|
%define dirver %(echo %version | cut -d_ -f1 | cut -d. -f1-3)
|
||||||
%define pkgver %(echo %version | tr _ -)
|
%define pkgver %(echo %version | tr _ -)
|
||||||
%define with_pulseaudio 1
|
%define with_pulseaudio 1
|
||||||
|
|
||||||
Name: vlc
|
Name: vlc
|
||||||
Version: 3.0.16
|
Version: 3.0.17.3
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: The VideoLAN client
|
Summary: The VideoLAN client
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -25,14 +25,17 @@ Patch11: vlc-2.2.2-lua-5.3.patch
|
|||||||
Patch12: vlc-2.2.4-qt5-5.7.0-atomic.patch
|
Patch12: vlc-2.2.4-qt5-5.7.0-atomic.patch
|
||||||
Patch13: vlc-3.0.3-libqt5-5.12.0.patch
|
Patch13: vlc-3.0.3-libqt5-5.12.0.patch
|
||||||
Patch14: vlc-3.0.11.1-libqt5-5.15.patch
|
Patch14: vlc-3.0.11.1-libqt5-5.15.patch
|
||||||
|
Patch15: vlc-3.0.17.3-libdav1d-1.0.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: fluidsynth-devel
|
#ld-linux.so.2(GLIBC_2.3): .so link not found
|
||||||
|
#ld-linux.so.2: .so link not found
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libQt5Svg-devel
|
||||||
|
BuildRequires: libQt5X11Extras-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libSDL-devel
|
||||||
BuildRequires: libSDL_image-devel
|
BuildRequires: libSDL_image-devel
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
@ -47,14 +50,17 @@ BuildRequires: liba52dec-devel
|
|||||||
BuildRequires: libaa-devel
|
BuildRequires: libaa-devel
|
||||||
BuildRequires: libacl-devel
|
BuildRequires: libacl-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libaom-devel
|
||||||
BuildRequires: libarchive-devel
|
BuildRequires: libarchive-devel
|
||||||
BuildRequires: libass-devel
|
BuildRequires: libass-devel
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libattr-devel
|
||||||
BuildRequires: libavahi-devel
|
BuildRequires: libavahi-devel
|
||||||
BuildRequires: libavc1394-devel
|
BuildRequires: libavc1394-devel
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
|
BuildRequires: libb2-devel
|
||||||
BuildRequires: libbluray-devel
|
BuildRequires: libbluray-devel
|
||||||
BuildRequires: libbrotli-devel
|
BuildRequires: libbrotli-devel
|
||||||
BuildRequires: libbsd-devel
|
BuildRequires: libbsd-devel
|
||||||
@ -66,6 +72,7 @@ BuildRequires: libchromaprint-devel
|
|||||||
%ifarch x86_64 %{ix86}
|
%ifarch x86_64 %{ix86}
|
||||||
BuildRequires: libcrystalhd-devel
|
BuildRequires: libcrystalhd-devel
|
||||||
%endif
|
%endif
|
||||||
|
BuildRequires: libdav1d-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libdbus-devel
|
||||||
BuildRequires: libdc1394-devel
|
BuildRequires: libdc1394-devel
|
||||||
BuildRequires: libdca-devel
|
BuildRequires: libdca-devel
|
||||||
@ -79,6 +86,7 @@ BuildRequires: libexpat-devel
|
|||||||
BuildRequires: libfaad2-devel
|
BuildRequires: libfaad2-devel
|
||||||
BuildRequires: libffi-devel
|
BuildRequires: libffi-devel
|
||||||
BuildRequires: libflac-devel
|
BuildRequires: libflac-devel
|
||||||
|
BuildRequires: libfluidsynth-devel
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreeglut-devel
|
BuildRequires: libfreeglut-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
@ -88,17 +96,20 @@ BuildRequires: libgcc
|
|||||||
BuildRequires: libgcrypt-devel
|
BuildRequires: libgcrypt-devel
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libgmp-devel
|
BuildRequires: libgmp-devel
|
||||||
BuildRequires: libgnutls-devel
|
BuildRequires: libgnutls-devel
|
||||||
|
BuildRequires: libgomp-devel
|
||||||
BuildRequires: libgoom2-devel
|
BuildRequires: libgoom2-devel
|
||||||
BuildRequires: libgpg-error-devel
|
BuildRequires: libgpg-error-devel
|
||||||
BuildRequires: libgpm-devel
|
BuildRequires: libgpm-devel
|
||||||
BuildRequires: libgraphite2-devel
|
BuildRequires: libgraphite2-devel
|
||||||
BuildRequires: libgst-plugins-base-devel
|
BuildRequires: libgst-plugins-base-devel
|
||||||
BuildRequires: libgstreamer-devel
|
BuildRequires: libgstreamer-devel
|
||||||
BuildRequires: libgtk-devel
|
BuildRequires: libgtk3-devel
|
||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
|
BuildRequires: libidn2-devel
|
||||||
BuildRequires: libjack-devel
|
BuildRequires: libjack-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: libkate-devel
|
BuildRequires: libkate-devel
|
||||||
@ -129,7 +140,6 @@ BuildRequires: libpostproc-ffmpeg-devel
|
|||||||
BuildRequires: libprojectM-devel
|
BuildRequires: libprojectM-devel
|
||||||
BuildRequires: libprotobuf-devel
|
BuildRequires: libprotobuf-devel
|
||||||
BuildRequires: libpulseaudio-devel
|
BuildRequires: libpulseaudio-devel
|
||||||
BuildRequires: libqt5-devel
|
|
||||||
BuildRequires: libraw1394-devel
|
BuildRequires: libraw1394-devel
|
||||||
BuildRequires: libreadline-devel
|
BuildRequires: libreadline-devel
|
||||||
BuildRequires: librsvg-devel
|
BuildRequires: librsvg-devel
|
||||||
@ -143,6 +153,8 @@ BuildRequires: libslang-devel
|
|||||||
BuildRequires: libsmbclient-devel
|
BuildRequires: libsmbclient-devel
|
||||||
BuildRequires: libsoxr-devel
|
BuildRequires: libsoxr-devel
|
||||||
BuildRequires: libspeex-devel
|
BuildRequires: libspeex-devel
|
||||||
|
BuildRequires: libspeexdsp-devel
|
||||||
|
BuildRequires: libsrt-devel
|
||||||
BuildRequires: libssh2-devel
|
BuildRequires: libssh2-devel
|
||||||
BuildRequires: libssp-devel
|
BuildRequires: libssp-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
@ -166,33 +178,15 @@ BuildRequires: libvorbis-devel
|
|||||||
BuildRequires: libvorbisidec-devel
|
BuildRequires: libvorbisidec-devel
|
||||||
BuildRequires: libvpx-devel
|
BuildRequires: libvpx-devel
|
||||||
BuildRequires: libx264-devel
|
BuildRequires: libx264-devel
|
||||||
|
BuildRequires: libx265-devel
|
||||||
BuildRequires: libxcb-devel
|
BuildRequires: libxcb-devel
|
||||||
BuildRequires: libxcb-keysyms-devel
|
BuildRequires: libxcb-keysyms-devel
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
BuildRequires: libzvbi-devel
|
BuildRequires: libzvbi-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
#BuildRequires: libaudiofile-devel
|
|
||||||
#BuildRequires: libe2fs-devel
|
|
||||||
#BuildRequires: libglitz-devel
|
|
||||||
#BuildRequires: libid3tag-devel
|
|
||||||
#BuildRequires: liboil-devel
|
|
||||||
#BuildRequires: libpixman-devel
|
|
||||||
#BuildRequires: libsysfs-devel
|
|
||||||
#BuildRequires: libtiff-devel
|
|
||||||
#BuildRequires: libxvidcore-devel
|
|
||||||
#BuildRequires: libtelepathy-glib-devel
|
|
||||||
#BuildRequires: liblame-devel
|
|
||||||
#BuildRequires: libfaac-devel
|
|
||||||
#BuildRequires: libpth-devel
|
|
||||||
#BuildRequires: libwxBase2.8-unicode-devel
|
|
||||||
#BuildRequires: libwxGTK2.8-unicode-devel
|
|
||||||
#BuildRequires: ORBit2-devel
|
|
||||||
#BuildRequires: libladcca-devel
|
|
||||||
#BuildRequires: libtremor-devel
|
|
||||||
#BuildRequires: libopencv-devel
|
|
||||||
BuildRequires: lua52
|
|
||||||
BuildRequires: libfreerdp-devel
|
BuildRequires: libfreerdp-devel
|
||||||
BuildRequires: liblive-devel
|
BuildRequires: liblive-devel
|
||||||
BuildRequires: libprojectM-devel >= 3.1.7
|
BuildRequires: libprojectM-devel >= 3.1.7
|
||||||
@ -237,12 +231,14 @@ Install this package if you need to build Videolan Client plugins or intend to l
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{dirver}
|
%setup -q -n %{name}-%{version}
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
#%patch11 -p1
|
#%patch11 -p1
|
||||||
|
%patch15 -p1
|
||||||
|
|
||||||
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
||||||
@ -471,6 +467,15 @@ fi
|
|||||||
%doc ChangeLog README THANKS
|
%doc ChangeLog README THANKS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.17.3-2mamba
|
||||||
|
- rebuilt with patch for libdav1d 1.0.0
|
||||||
|
|
||||||
|
* Sat Mar 12 2022 Automatic Build System <autodist@mambasoft.it> 3.0.17.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 07 2022 Automatic Build System <autodist@mambasoft.it> 3.0.17-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Jun 20 2021 Automatic Build System <autodist@mambasoft.it> 3.0.16-1mamba
|
* Sun Jun 20 2021 Automatic Build System <autodist@mambasoft.it> 3.0.16-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user