rebuilt with ffmpeg2
require vlc-pulseaudio-plugin [release 2.2.2-3mamba;Thu Apr 14 2016]
This commit is contained in:
parent
666587f91e
commit
83165a7f6e
@ -19,3 +19,16 @@
|
||||
QT_PATH="$(eval $PKG_CONFIG --variable=exec_prefix Qt5Core)"
|
||||
QT_HOST_PATH="$(eval $PKG_CONFIG --variable=host_bins Qt5Core)"
|
||||
for ac_prog in moc-qt5 moc
|
||||
--- vlc-2.2.2/configure.ac.orig 2016-04-15 16:52:28.646023118 +0200
|
||||
+++ vlc-2.2.2/configure.ac 2016-04-15 16:53:10.962987772 +0200
|
||||
@@ -3754,10 +3754,6 @@
|
||||
AC_MSG_WARN([Not building Qt Interface with X11 helpers.])
|
||||
])
|
||||
|
||||
- PKG_CHECK_EXISTS([Qt5Core >= 5.5.0 Qt5Core < 5.6.0], [
|
||||
- AC_MSG_ERROR(["You cannot build VLC with Qt-5.5.0. You need to backport I78ef29975181ee22429c9bd4b11d96d9e68b7a9c"])
|
||||
- ])
|
||||
-
|
||||
QT_PATH="$(eval $PKG_CONFIG --variable=exec_prefix Qt5Core)"
|
||||
QT_HOST_PATH="$(eval $PKG_CONFIG --variable=host_bins Qt5Core)"
|
||||
AC_PATH_PROGS(MOC, [moc-qt5 moc], moc, ["${QT_HOST_PATH}" "${QT_PATH}/bin" "${CONTRIB_DIR}/bin"])
|
||||
|
28
vlc.spec
28
vlc.spec
@ -11,7 +11,7 @@
|
||||
%endif
|
||||
Name: vlc
|
||||
Version: 2.2.2
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: The VideoLAN client
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -219,11 +219,13 @@ BuildRequires: libtar >= 1.2.20
|
||||
BuildRequires: libtag-devel >= 1.9
|
||||
BuildRequires: libfreerdp-devel
|
||||
BuildRequires: libshine-devel
|
||||
BuildRequires: ffmpeg2-devel
|
||||
#Requires: avahi-compat-howl
|
||||
#Requires: avahi-compat-libdns_sd
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libqt5-plugins
|
||||
Requires: vlc-pulseaudio-plugin = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-mozilla-plugin
|
||||
Obsoletes: %{name}-mozilla-plugin
|
||||
|
||||
@ -297,10 +299,15 @@ This package contains VLC plugins for PulseAudio.
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
export LIBV4L2_LIBS=-L%{_libdir}/libv4l/ LIBV4L2_CFLAGS=-I%{_includedir}
|
||||
export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
||||
./bootstrap
|
||||
|
||||
#export LIBV4L2_LIBS=-L%{_libdir}/libv4l/ LIBV4L2_CFLAGS=-I%{_includedir}
|
||||
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
%configure \
|
||||
PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig \
|
||||
LIBS_access_smb="-L%{_libdir}/samba" \
|
||||
--disable-rpath \
|
||||
--enable-dvdread \
|
||||
--enable-dvbpsi \
|
||||
--enable-vcd \
|
||||
@ -311,7 +318,6 @@ export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
--enable-swscale \
|
||||
--enable-faad \
|
||||
--enable-xvideo \
|
||||
--enable-dv \
|
||||
--enable-flac \
|
||||
--enable-tremor \
|
||||
--enable-theora \
|
||||
@ -323,10 +329,8 @@ export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
--enable-alsa \
|
||||
--enable-jack \
|
||||
--enable-dca \
|
||||
--disable-waveout \
|
||||
--disable-macosx \
|
||||
--disable-ncurses \
|
||||
--enable-xosd \
|
||||
--enable-sdl \
|
||||
--enable-vcdx \
|
||||
--enable-live555 \
|
||||
@ -338,16 +342,15 @@ export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
--enable-goom \
|
||||
--enable-skins2 \
|
||||
--disable-lirc \
|
||||
--enable-dirac \
|
||||
--enable-twolame \
|
||||
--enable-telepathy \
|
||||
%ifarch %{ix86}
|
||||
--enable-loader \
|
||||
%else
|
||||
--without-contrib \
|
||||
%endif
|
||||
--disable-dv \
|
||||
--enable-tremor
|
||||
--enable-tremor \
|
||||
LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
|
||||
LIBS="-L%{_libdir}/ffmpeg2"
|
||||
|
||||
%make
|
||||
#CFLAGS="%{optflags} -Wimplicit-function-declaration"
|
||||
@ -373,6 +376,7 @@ export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
%makeinstall
|
||||
|
||||
%find_lang vlc
|
||||
@ -505,6 +509,10 @@ fi
|
||||
#%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-3mamba
|
||||
- rebuilt with ffmpeg2
|
||||
- require vlc-pulseaudio-plugin
|
||||
|
||||
* Sat Mar 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
|
||||
- rebuilt with liblua 5.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user