rebuilt with liblua 5.3 [release 2.2.2-2mamba;Sat Mar 26 2016]
This commit is contained in:
parent
e1a9c59bf4
commit
666587f91e
30
vlc-2.2.2-lua-5.3.patch
Normal file
30
vlc-2.2.2-lua-5.3.patch
Normal file
@ -0,0 +1,30 @@
|
||||
commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23
|
||||
Author: Vinson Lee <vlee@freedesktop.org>
|
||||
Date: Thu Feb 5 14:48:53 2015 -0800
|
||||
|
||||
lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0 compatibility.
|
||||
|
||||
In Lua 5.3.0, luaL_checkint was deprecated.
|
||||
|
||||
This patch fixes this build error with Lua 5.3.0.
|
||||
|
||||
lua/demux.c: In function ‘vlclua_demux_peek’:
|
||||
lua/demux.c:55:5: error: implicit declaration of function ‘luaL_checkint’ [-Werror=implicit-function-declaration]
|
||||
int n = luaL_checkint( L, 1 );
|
||||
^
|
||||
|
||||
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
|
||||
Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
|
||||
|
||||
diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
|
||||
index efd94f1..85c7fc1 100644
|
||||
--- a/modules/lua/vlc.h
|
||||
+++ b/modules/lua/vlc.h
|
||||
@@ -38,6 +38,7 @@
|
||||
#include <vlc_stream.h>
|
||||
#include <vlc_demux.h>
|
||||
|
||||
+#define LUA_COMPAT_APIINTCASTS
|
||||
#define LUA_COMPAT_MODULE
|
||||
#include <lua.h> /* Low level lua C API */
|
||||
#include <lauxlib.h> /* Higher level C API */
|
8
vlc.spec
8
vlc.spec
@ -11,7 +11,7 @@
|
||||
%endif
|
||||
Name: vlc
|
||||
Version: 2.2.2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: The VideoLAN client
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -28,6 +28,7 @@ Patch7: vlc-2.0.7-libva-1.2.patch
|
||||
Patch8: vlc-2.0.7-libflac-1.3.0.patch
|
||||
Patch9: vlc-2.2.0-vorbisidec.patch
|
||||
Patch10: vlc-2.2.2-no-qt5-check.patch
|
||||
Patch11: vlc-2.2.2-lua-5.3.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: enca-devel
|
||||
@ -292,10 +293,12 @@ This package contains VLC plugins for PulseAudio.
|
||||
#%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
export LIBV4L2_LIBS=-L%{_libdir}/libv4l/ LIBV4L2_CFLAGS=-I%{_includedir}
|
||||
export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
%configure \
|
||||
LIBS_access_smb="-L%{_libdir}/samba" \
|
||||
--enable-dvdread \
|
||||
@ -502,6 +505,9 @@ fi
|
||||
#%endif
|
||||
|
||||
%changelog
|
||||
* Sat Mar 26 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-2mamba
|
||||
- rebuilt with liblua 5.3
|
||||
|
||||
* Mon Feb 15 2016 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user