update to 2.2.4 [release 2.2.4-1mamba;Wed Jul 13 2016]
This commit is contained in:
parent
0b7f0fc48e
commit
53b729c54a
183
vlc-2.2.4-qt5-5.7.0-atomic.patch
Normal file
183
vlc-2.2.4-qt5-5.7.0-atomic.patch
Normal file
@ -0,0 +1,183 @@
|
|||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/actions_manager.cpp vlc-2.2.4.patched/modules/gui/qt4/actions_manager.cpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/actions_manager.cpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/actions_manager.cpp 2016-07-13 01:29:46.334802354 +0200
|
||||||
|
@@ -25,10 +25,11 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include "actions_manager.hpp"
|
||||||
|
+
|
||||||
|
#include <vlc_vout.h>
|
||||||
|
#include <vlc_keys.h>
|
||||||
|
|
||||||
|
-#include "actions_manager.hpp"
|
||||||
|
|
||||||
|
#include "dialogs_provider.hpp" /* Opening Dialogs */
|
||||||
|
#include "input_manager.hpp" /* THEMIM */
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/adapters/seekpoints.hpp vlc-2.2.4.patched/modules/gui/qt4/adapters/seekpoints.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/adapters/seekpoints.hpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/adapters/seekpoints.hpp 2016-07-13 01:36:11.476820842 +0200
|
||||||
|
@@ -26,14 +26,14 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#include <vlc_common.h>
|
||||||
|
-#include <vlc_interface.h>
|
||||||
|
-#include <vlc_input.h>
|
||||||
|
-
|
||||||
|
#include <QObject>
|
||||||
|
#include <QList>
|
||||||
|
#include <QMutex>
|
||||||
|
|
||||||
|
+#include <vlc_common.h>
|
||||||
|
+#include <vlc_interface.h>
|
||||||
|
+#include <vlc_input.h>
|
||||||
|
+
|
||||||
|
class SeekPoint
|
||||||
|
{
|
||||||
|
public:
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/components/controller.cpp vlc-2.2.4.patched/modules/gui/qt4/components/controller.cpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/components/controller.cpp 2016-04-25 18:02:43.000000000 +0200
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/components/controller.cpp 2016-07-13 01:34:10.335122301 +0200
|
||||||
|
@@ -26,6 +26,12 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <QToolButton>
|
||||||
|
+#include <QHBoxLayout>
|
||||||
|
+#include <QRegion>
|
||||||
|
+#include <QSignalMapper>
|
||||||
|
+#include <QTimer>
|
||||||
|
+
|
||||||
|
#include <vlc_vout.h> /* vout_thread_t for FSC */
|
||||||
|
|
||||||
|
/* Widgets */
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/components/playlist/playlist_model.hpp vlc-2.2.4.patched/modules/gui/qt4/components/playlist/playlist_model.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/components/playlist/playlist_model.hpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/components/playlist/playlist_model.hpp 2016-07-13 01:38:39.097459814 +0200
|
||||||
|
@@ -29,11 +29,6 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#include <vlc_input.h>
|
||||||
|
-#include <vlc_playlist.h>
|
||||||
|
-#include "vlc_model.hpp"
|
||||||
|
-#include "playlist_item.hpp"
|
||||||
|
-
|
||||||
|
#include <QObject>
|
||||||
|
#include <QEvent>
|
||||||
|
#include <QSignalMapper>
|
||||||
|
@@ -43,6 +38,12 @@
|
||||||
|
#include <QModelIndex>
|
||||||
|
#include <QAction>
|
||||||
|
|
||||||
|
+#include <vlc_input.h>
|
||||||
|
+#include <vlc_playlist.h>
|
||||||
|
+#include "vlc_model.hpp"
|
||||||
|
+#include "playlist_item.hpp"
|
||||||
|
+
|
||||||
|
+
|
||||||
|
class PLItem;
|
||||||
|
class PLSelector;
|
||||||
|
class PlMimeData;
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/dialogs/messages.hpp vlc-2.2.4.patched/modules/gui/qt4/dialogs/messages.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/dialogs/messages.hpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/dialogs/messages.hpp 2016-07-13 01:27:12.000220784 +0200
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
void sinkMessage( const MsgEvent * );
|
||||||
|
bool matchFilter( const QString& );
|
||||||
|
|
||||||
|
- atomic_uint verbosity;
|
||||||
|
+ unsigned int verbosity;
|
||||||
|
static void MsgCallback( void *, int, const vlc_log_t *, const char *,
|
||||||
|
va_list );
|
||||||
|
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/dialogs/vlm.hpp vlc-2.2.4.patched/modules/gui/qt4/dialogs/vlm.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/dialogs/vlm.hpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/dialogs/vlm.hpp 2016-07-13 01:32:18.019407147 +0200
|
||||||
|
@@ -31,12 +31,13 @@
|
||||||
|
|
||||||
|
#ifdef ENABLE_VLM
|
||||||
|
|
||||||
|
+#include <QDateTime>
|
||||||
|
+
|
||||||
|
#include <vlc_vlm.h>
|
||||||
|
|
||||||
|
#include "ui/vlm.h"
|
||||||
|
#include "util/qvlcframe.hpp"
|
||||||
|
#include "util/singleton.hpp"
|
||||||
|
-#include <QDateTime>
|
||||||
|
|
||||||
|
enum{
|
||||||
|
QVLM_Broadcast,
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/input_manager.hpp vlc-2.2.4.patched/modules/gui/qt4/input_manager.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/input_manager.hpp 2016-04-25 18:02:43.000000000 +0200
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/input_manager.hpp 2016-07-13 01:28:09.437062815 +0200
|
||||||
|
@@ -29,9 +29,10 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include "qt4.hpp"
|
||||||
|
+
|
||||||
|
#include <vlc_input.h>
|
||||||
|
|
||||||
|
-#include "qt4.hpp"
|
||||||
|
#include "util/singleton.hpp"
|
||||||
|
#include "adapters/variables.hpp"
|
||||||
|
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/menus.cpp vlc-2.2.4.patched/modules/gui/qt4/menus.cpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/menus.cpp 2015-10-29 19:18:32.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/menus.cpp 2016-07-13 01:21:30.256823693 +0200
|
||||||
|
@@ -34,12 +34,13 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include "menus.hpp"
|
||||||
|
+
|
||||||
|
#include <vlc_common.h>
|
||||||
|
#include <vlc_intf_strings.h>
|
||||||
|
#include <vlc_vout.h> /* vout_thread_t */
|
||||||
|
#include <vlc_aout.h> /* audio_output_t */
|
||||||
|
|
||||||
|
-#include "menus.hpp"
|
||||||
|
|
||||||
|
#include "main_interface.hpp" /* View modifications */
|
||||||
|
#include "dialogs_provider.hpp" /* Dialogs display */
|
||||||
|
diff -ru vlc-2.2.4/modules/gui/qt4/qt4.hpp vlc-2.2.4.patched/modules/gui/qt4/qt4.hpp
|
||||||
|
--- vlc-2.2.4/modules/gui/qt4/qt4.hpp 2015-02-02 20:42:29.000000000 +0100
|
||||||
|
+++ vlc-2.2.4.patched/modules/gui/qt4/qt4.hpp 2016-07-13 01:22:29.520717970 +0200
|
||||||
|
@@ -29,12 +29,13 @@
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#define QT_NO_CAST_TO_ASCII
|
||||||
|
+#include <QString>
|
||||||
|
+
|
||||||
|
#include <vlc_common.h> /* VLC_COMMON_MEMBERS for vlc_interface.h */
|
||||||
|
#include <vlc_interface.h> /* intf_thread_t */
|
||||||
|
#include <vlc_playlist.h> /* playlist_t */
|
||||||
|
|
||||||
|
-#define QT_NO_CAST_TO_ASCII
|
||||||
|
-#include <QString>
|
||||||
|
|
||||||
|
#if ( QT_VERSION < 0x040600 )
|
||||||
|
# error Update your Qt version to at least 4.6.0
|
||||||
|
--- vlc-2.2.4/modules/visualization/projectm.cpp.orig 2016-07-13 02:11:35.900475637 +0200
|
||||||
|
+++ vlc-2.2.4/modules/visualization/projectm.cpp 2016-07-13 02:11:25.897492411 +0200
|
||||||
|
@@ -31,6 +31,8 @@
|
||||||
|
|
||||||
|
#include <assert.h>
|
||||||
|
|
||||||
|
+#include <libprojectM/projectM.hpp>
|
||||||
|
+
|
||||||
|
#include <vlc_common.h>
|
||||||
|
#include <vlc_plugin.h>
|
||||||
|
#include <vlc_aout.h>
|
||||||
|
@@ -40,7 +42,6 @@
|
||||||
|
#include <vlc_filter.h>
|
||||||
|
#include <vlc_rand.h>
|
||||||
|
|
||||||
|
-#include <libprojectM/projectM.hpp>
|
||||||
|
|
||||||
|
/*****************************************************************************
|
||||||
|
* Module descriptor
|
26
vlc.spec
26
vlc.spec
@ -10,7 +10,7 @@
|
|||||||
%define mozilla_sdk_dir %(pkg-config --variable=sdkdir libxul)
|
%define mozilla_sdk_dir %(pkg-config --variable=sdkdir libxul)
|
||||||
%endif
|
%endif
|
||||||
Name: vlc
|
Name: vlc
|
||||||
Version: 2.2.3
|
Version: 2.2.4
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The VideoLAN client
|
Summary: The VideoLAN client
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
@ -29,6 +29,7 @@ Patch8: vlc-2.0.7-libflac-1.3.0.patch
|
|||||||
Patch9: vlc-2.2.0-vorbisidec.patch
|
Patch9: vlc-2.2.0-vorbisidec.patch
|
||||||
Patch10: vlc-2.2.2-no-qt5-check.patch
|
Patch10: vlc-2.2.2-no-qt5-check.patch
|
||||||
Patch11: vlc-2.2.2-lua-5.3.patch
|
Patch11: vlc-2.2.2-lua-5.3.patch
|
||||||
|
Patch12: vlc-2.2.4-qt5-5.7.0-atomic.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: enca-devel
|
BuildRequires: enca-devel
|
||||||
@ -287,7 +288,7 @@ This package contains VLC plugins for PulseAudio.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{dirver}
|
%setup -q -n %{name}-%{dirver}
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< ___EOF
|
#:<< _EOF
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
#%patch1 -p1
|
#%patch1 -p1
|
||||||
#%patch4 -p1
|
#%patch4 -p1
|
||||||
@ -296,17 +297,18 @@ This package contains VLC plugins for PulseAudio.
|
|||||||
#%patch7 -p1
|
#%patch7 -p1
|
||||||
#%patch8 -p1
|
#%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
#%patch10 -p1
|
||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
|
%patch12 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< ___EOF
|
|
||||||
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
||||||
#export LIBV4L2_LIBS=-L%{_libdir}/libv4l/ LIBV4L2_CFLAGS=-I%{_includedir}
|
#export LIBV4L2_LIBS=-L%{_libdir}/libv4l/ LIBV4L2_CFLAGS=-I%{_includedir}
|
||||||
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||||
%configure \
|
%configure \
|
||||||
|
BUILDCC=gcc \
|
||||||
PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig \
|
PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig \
|
||||||
LIBS_access_smb="-L%{_libdir}/samba" \
|
LIBS_access_smb="-L%{_libdir}/samba" \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
@ -354,9 +356,13 @@ This package contains VLC plugins for PulseAudio.
|
|||||||
LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
|
LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
|
||||||
LIBS="-L%{_libdir}/ffmpeg2"
|
LIBS="-L%{_libdir}/ffmpeg2"
|
||||||
|
|
||||||
|
%ifarch arm
|
||||||
|
LD_PRELOAD=/usr/lib/librsvg-2.so %make
|
||||||
|
%else
|
||||||
%make
|
%make
|
||||||
#CFLAGS="%{optflags} -Wimplicit-function-declaration"
|
%endif
|
||||||
|
|
||||||
|
#CFLAGS="%{optflags} -Wimplicit-function-declaration"
|
||||||
|
|
||||||
# --enable-glide \
|
# --enable-glide \
|
||||||
# --with-wx-config-path=/path/to/your/wxWidgets-2.6.3
|
# --with-wx-config-path=/path/to/your/wxWidgets-2.6.3
|
||||||
@ -379,7 +385,11 @@ This package contains VLC plugins for PulseAudio.
|
|||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||||
|
%ifarch arm
|
||||||
|
LD_PRELOAD=/usr/lib/librsvg-2.so %makeinstall
|
||||||
|
%else
|
||||||
%makeinstall
|
%makeinstall
|
||||||
|
%endif
|
||||||
|
|
||||||
%find_lang vlc
|
%find_lang vlc
|
||||||
|
|
||||||
@ -429,6 +439,9 @@ fi
|
|||||||
#%{_libdir}/vlc/plugins/3dnow
|
#%{_libdir}/vlc/plugins/3dnow
|
||||||
%{_libdir}/vlc/plugins/access
|
%{_libdir}/vlc/plugins/access
|
||||||
%{_libdir}/vlc/plugins/access_output
|
%{_libdir}/vlc/plugins/access_output
|
||||||
|
%ifarch arm
|
||||||
|
%{_libdir}/vlc/plugins/arm_neon
|
||||||
|
%endif
|
||||||
%{_libdir}/vlc/plugins/audio_filter
|
%{_libdir}/vlc/plugins/audio_filter
|
||||||
%{_libdir}/vlc/plugins/audio_mixer
|
%{_libdir}/vlc/plugins/audio_mixer
|
||||||
%dir %{_libdir}/vlc/plugins/audio_output
|
%dir %{_libdir}/vlc/plugins/audio_output
|
||||||
@ -511,6 +524,9 @@ fi
|
|||||||
#%endif
|
#%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.4-1mamba
|
||||||
|
- update to 2.2.4
|
||||||
|
|
||||||
* Wed May 04 2016 Automatic Build System <autodist@mambasoft.it> 2.2.3-1mamba
|
* Wed May 04 2016 Automatic Build System <autodist@mambasoft.it> 2.2.3-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user