posttrans: remove invalid option when running vlc-cache-gen [release 3.0.6-2mamba;Sun Feb 03 2019]
This commit is contained in:
parent
f75121a53d
commit
46dfa8e1d2
10
vlc-3.0.3-libqt5-5.12.0.patch
Normal file
10
vlc-3.0.3-libqt5-5.12.0.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- vlc-3.0.3/modules/gui/qt/components/simple_preferences.cpp.orig 2019-01-09 11:10:31.304881196 +0100
|
||||
+++ vlc-3.0.3/modules/gui/qt/components/simple_preferences.cpp 2019-01-09 11:10:40.218918878 +0100
|
||||
@@ -39,6 +39,7 @@
|
||||
#include <QSignalMapper>
|
||||
#include <QVBoxLayout>
|
||||
#include <QScrollArea>
|
||||
+#include <QButtonGroup>
|
||||
|
||||
#include <QStyleFactory>
|
||||
#include <QSettings>
|
50
vlc.spec
50
vlc.spec
@ -1,4 +1,5 @@
|
||||
%define dirver %(echo %version | sed "s|[a-z]*||g")
|
||||
%define dirver %(echo %version | cut -d_ -f1)
|
||||
%define pkgver %(echo %version | tr _ -)
|
||||
|
||||
#%if "%{stage1}" == "1"
|
||||
#%define with_mozilla 0
|
||||
@ -10,15 +11,15 @@
|
||||
%define mozilla_sdk_dir %(pkg-config --variable=sdkdir libxul)
|
||||
%endif
|
||||
Name: vlc
|
||||
Version: 2.2.8
|
||||
Release: 1mamba
|
||||
Version: 3.0.6
|
||||
Release: 2mamba
|
||||
Summary: The VideoLAN client
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.videolan.org/
|
||||
Source: http://download.videolan.org/pub/videolan/vlc/%{dirver}/vlc-%{version}.tar.xz
|
||||
Source: http://download.videolan.org/pub/videolan/vlc/%{dirver}/vlc-%{pkgver}.tar.xz
|
||||
Patch0: %{name}-2.0.1-freetype.patch
|
||||
Patch1: %{name}-1.1.4.1-upnp-1.6.7.patch
|
||||
Patch4: %{name}-1.1.7-jack_autoconnect_true.patch
|
||||
@ -30,6 +31,7 @@ Patch9: vlc-2.2.0-vorbisidec.patch
|
||||
Patch10: vlc-2.2.2-no-qt5-check.patch
|
||||
Patch11: vlc-2.2.2-lua-5.3.patch
|
||||
Patch12: vlc-2.2.4-qt5-5.7.0-atomic.patch
|
||||
Patch13: vlc-3.0.3-libqt5-5.12.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: enca-devel
|
||||
@ -300,6 +302,7 @@ This package contains VLC plugins for PulseAudio.
|
||||
#%patch10 -p1
|
||||
%patch11 -p1
|
||||
#%patch12 -p1
|
||||
%patch13 -p1
|
||||
|
||||
%build
|
||||
# FIXME: bootstrap: build with ffmpeg2 is correct, but libs are relinked with ffmpeg at install
|
||||
@ -309,7 +312,6 @@ This package contains VLC plugins for PulseAudio.
|
||||
#export PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig
|
||||
%configure \
|
||||
BUILDCC=gcc \
|
||||
PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig \
|
||||
LIBS_access_smb="-L%{_libdir}/samba" \
|
||||
--disable-rpath \
|
||||
--enable-dvdread \
|
||||
@ -325,7 +327,6 @@ This package contains VLC plugins for PulseAudio.
|
||||
--enable-flac \
|
||||
--enable-tremor \
|
||||
--enable-theora \
|
||||
--enable-mkv \
|
||||
--enable-xvideo \
|
||||
--disable-directx \
|
||||
--enable-aa \
|
||||
@ -335,8 +336,6 @@ This package contains VLC plugins for PulseAudio.
|
||||
--enable-dca \
|
||||
--disable-macosx \
|
||||
--disable-ncurses \
|
||||
--enable-sdl \
|
||||
--enable-vcdx \
|
||||
--enable-live555 \
|
||||
--enable-screen \
|
||||
--enable-speex \
|
||||
@ -353,8 +352,13 @@ This package contains VLC plugins for PulseAudio.
|
||||
--without-contrib \
|
||||
%endif
|
||||
--enable-tremor \
|
||||
LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
|
||||
LIBS="-L%{_libdir}/ffmpeg2"
|
||||
LUAC=/usr/bin/luac-5.2 LUA_LIBS="`pkg-config --libs lua5.2`"
|
||||
|
||||
# PKG_CONFIG_PATH=%{_libdir}/ffmpeg2/pkgconfig \
|
||||
#LIBS="-L%{_libdir}/ffmpeg2"
|
||||
# --enable-mkv \
|
||||
# --enable-sdl \
|
||||
# --enable-vcdx \
|
||||
|
||||
%ifarch arm
|
||||
LD_PRELOAD=/usr/lib/librsvg-2.so %make
|
||||
@ -406,7 +410,7 @@ echo "InitialPreference=8" >> %{buildroot}%{_datadir}/applications/vlc.desktop
|
||||
|
||||
%posttrans
|
||||
if [ $1 -ge 1 ]; then
|
||||
%{_libdir}/vlc/vlc-cache-gen -f %{_libdir}/vlc/plugins
|
||||
%{_libdir}/vlc/vlc-cache-gen %{_libdir}/vlc/plugins
|
||||
fi
|
||||
:
|
||||
|
||||
@ -419,6 +423,7 @@ fi
|
||||
%{_bindir}/vlc-wrapper
|
||||
%{_datadir}/pixmaps/vlc.png
|
||||
%{_datadir}/applications/vlc.desktop
|
||||
%{_datadir}/metainfo/vlc.appdata.xml
|
||||
%dir %{_datadir}/vlc
|
||||
%{_datadir}/vlc/*
|
||||
%{_kde4_datadir}/solid/actions/vlc-*.desktop
|
||||
@ -432,6 +437,8 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libvlc.so.*
|
||||
%{_libdir}/libvlccore.so.*
|
||||
%{_libdir}/vlc/libvlc_pulse.so.*
|
||||
%{_libdir}/vlc/libvlc_xcb_events.so.*
|
||||
%dir %{_libdir}/vlc
|
||||
%{_libdir}/vlc/libvlc_vdpau.so.*
|
||||
%{_libdir}/vlc/lua
|
||||
@ -467,6 +474,8 @@ fi
|
||||
%{_libdir}/vlc/plugins/control
|
||||
%{_libdir}/vlc/plugins/demux
|
||||
%{_libdir}/vlc/plugins/gui
|
||||
%{_libdir}/vlc/plugins/keystore
|
||||
%{_libdir}/vlc/plugins/logger
|
||||
%{_libdir}/vlc/plugins/lua
|
||||
%{_libdir}/vlc/plugins/meta_engine
|
||||
%{_libdir}/vlc/plugins/misc
|
||||
@ -478,9 +487,12 @@ fi
|
||||
%{_libdir}/vlc/plugins/plugins.dat
|
||||
%{_libdir}/vlc/plugins/services_discovery
|
||||
#%{_libdir}/vlc/plugins/sse2
|
||||
%{_libdir}/vlc/plugins/spu
|
||||
%{_libdir}/vlc/plugins/stream_extractor
|
||||
%{_libdir}/vlc/plugins/stream_filter
|
||||
%{_libdir}/vlc/plugins/stream_out
|
||||
%{_libdir}/vlc/plugins/text_renderer
|
||||
%{_libdir}/vlc/plugins/vaapi
|
||||
%{_libdir}/vlc/plugins/video_chroma
|
||||
%{_libdir}/vlc/plugins/video_filter
|
||||
%{_libdir}/vlc/plugins/video_output
|
||||
@ -498,6 +510,10 @@ fi
|
||||
%{_libdir}/libvlc.so
|
||||
%{_libdir}/libvlccore.la
|
||||
%{_libdir}/libvlccore.so
|
||||
%{_libdir}/vlc/libvlc_pulse.la
|
||||
%{_libdir}/vlc/libvlc_pulse.so
|
||||
%{_libdir}/vlc/libvlc_xcb_events.la
|
||||
%{_libdir}/vlc/libvlc_xcb_events.so
|
||||
%{_libdir}/vlc/libvlc_vdpau.la
|
||||
%{_libdir}/vlc/libvlc_vdpau.so
|
||||
#%{_bindir}/vlc-config
|
||||
@ -524,6 +540,18 @@ fi
|
||||
#%endif
|
||||
|
||||
%changelog
|
||||
* Sun Feb 03 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.6-2mamba
|
||||
- posttrans: remove invalid option when running vlc-cache-gen
|
||||
|
||||
* Sat Feb 02 2019 Automatic Build System <autodist@mambasoft.it> 3.0.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 09 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.5-1mamba
|
||||
- update to 3.0.5
|
||||
|
||||
* Wed Aug 22 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.3_1-1mamba
|
||||
- update to 3.0.3_1
|
||||
|
||||
* Wed Dec 27 2017 Automatic Build System <autodist@mambasoft.it> 2.2.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user