rebuilt by autoport with build requirements: libprocps-devel>=0:4.0.5-1mamba [release 4.9.1-2mamba;Thu Dec 26 2024]
This commit is contained in:
parent
fbeafaf0d1
commit
a3b655f605
@ -1,14 +0,0 @@
|
|||||||
diff -Nru italc-2.0.0.orig/lib/src/LocalSystem.cpp italc-2.0.0/lib/src/LocalSystem.cpp
|
|
||||||
--- italc-2.0.0.orig/lib/src/LocalSystem.cpp 2011-08-03 23:18:00.000000000 +0200
|
|
||||||
+++ italc-2.0.0/lib/src/LocalSystem.cpp 2013-04-28 18:12:28.663832552 +0200
|
|
||||||
@@ -30,6 +30,10 @@
|
|
||||||
#include <QtGui/QWidget>
|
|
||||||
#include <QtNetwork/QHostInfo>
|
|
||||||
|
|
||||||
+#ifdef ITALC_BUILD_LINUX
|
|
||||||
+#include <unistd.h>
|
|
||||||
+#include <sys/types.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifdef ITALC_BUILD_WIN32
|
|
||||||
|
|
46
veyon-4.9.1-procps-ng-4.0.5.patch
Normal file
46
veyon-4.9.1-procps-ng-4.0.5.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
--- veyon-4.9.1/plugins/platform/linux/LinuxCoreFunctions.cpp.orig 2024-12-28 16:57:48.531677012 +0100
|
||||||
|
+++ veyon-4.9.1/plugins/platform/linux/LinuxCoreFunctions.cpp 2024-12-28 16:58:15.485765174 +0100
|
||||||
|
@@ -508,18 +508,18 @@
|
||||||
|
|
||||||
|
while ((stack = procps_pids_get(info, PIDS_FETCH_TASKS_ONLY)))
|
||||||
|
{
|
||||||
|
- const auto ppid = PIDS_VAL(PPidItemIndex, s_int, stack, info);
|
||||||
|
+ const auto ppid = PIDS_VAL(PPidItemIndex, s_int, stack);
|
||||||
|
|
||||||
|
if (ppid == parentPid)
|
||||||
|
{
|
||||||
|
if (visitParent == false || visitor(stack, info))
|
||||||
|
{
|
||||||
|
- ppids.append(PIDS_VAL(PidItemIndex, s_int, stack, info));
|
||||||
|
+ ppids.append(PIDS_VAL(PidItemIndex, s_int, stack));
|
||||||
|
}
|
||||||
|
}
|
||||||
|
else if (ppids.contains(ppid) && visitor(stack, info))
|
||||||
|
{
|
||||||
|
- ppids.append(PIDS_VAL(PidItemIndex, s_int, stack, info));
|
||||||
|
+ ppids.append(PIDS_VAL(PidItemIndex, s_int, stack));
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
--- veyon-4.9.1/plugins/platform/linux/LinuxServerProcess.cpp.orig 2024-12-28 16:54:37.040013169 +0100
|
||||||
|
+++ veyon-4.9.1/plugins/platform/linux/LinuxServerProcess.cpp 2024-12-28 16:54:55.967082118 +0100
|
||||||
|
@@ -102,7 +102,7 @@
|
||||||
|
LinuxCoreFunctions::forEachChildProcess([=](const pids_stack* stack, const pids_info* info)
|
||||||
|
{
|
||||||
|
Q_UNUSED(info)
|
||||||
|
- const pid_t tid = PIDS_VAL(0, s_int, stack, info);
|
||||||
|
+ const pid_t tid = PIDS_VAL(0, s_int, stack);
|
||||||
|
if (tid > 0 && ::kill(tid, sig) < 0 && errno != ESRCH)
|
||||||
|
{
|
||||||
|
vCritical() << "kill() failed with" << errno;
|
||||||
|
--- veyon-4.9.1/plugins/platform/linux/LinuxSessionFunctions.cpp.orig 2024-12-28 16:51:23.464253982 +0100
|
||||||
|
+++ veyon-4.9.1/plugins/platform/linux/LinuxSessionFunctions.cpp 2024-12-28 16:51:48.047356554 +0100
|
||||||
|
@@ -380,7 +380,7 @@
|
||||||
|
{
|
||||||
|
Q_UNUSED(info)
|
||||||
|
static constexpr auto EnvironItemIndex = 2;
|
||||||
|
- const auto environ = PIDS_VAL(EnvironItemIndex, strv, stack, info);
|
||||||
|
+ const auto environ = PIDS_VAL(EnvironItemIndex, strv, stack);
|
||||||
|
|
||||||
|
if (environ != nullptr)
|
||||||
|
{
|
11
veyon.spec
11
veyon.spec
@ -1,6 +1,6 @@
|
|||||||
Name: veyon
|
Name: veyon
|
||||||
Version: 4.9.1
|
Version: 4.9.1
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Cross-platform computer monitoring and classroom management
|
Summary: Cross-platform computer monitoring and classroom management
|
||||||
Group: Graphical Desktop/Applications/Educational
|
Group: Graphical Desktop/Applications/Educational
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,7 +8,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://veyon.io/it/
|
URL: https://veyon.io/it/
|
||||||
Source: https://github.com/veyon/veyon.git/v%{version}/veyon-%{version}.tar.bz2
|
Source: https://github.com/veyon/veyon.git/v%{version}/veyon-%{version}.tar.bz2
|
||||||
Patch2: italc-2.0.0-fix-missing-includes.patch
|
Patch0: veyon-4.9.1-procps-ng-4.0.5.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -43,7 +43,9 @@ BuildRequires: libstdc++6-devel
|
|||||||
BuildRequires: libvncserver-devel
|
BuildRequires: libvncserver-devel
|
||||||
BuildRequires: qt6-qt5compat-devel
|
BuildRequires: qt6-qt5compat-devel
|
||||||
BuildRequires: qt6-qthttpserver-devel
|
BuildRequires: qt6-qthttpserver-devel
|
||||||
|
BuildRequires: qt6-qtwebsockets-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libprocps-devel >= 0:4.0.5-1mamba
|
||||||
Provides: italc
|
Provides: italc
|
||||||
Obsoletes: italc <= 2.0.2
|
Obsoletes: italc <= 2.0.2
|
||||||
|
|
||||||
@ -54,7 +56,7 @@ Cross-platform computer monitoring and classroom management.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch2 -p1
|
%patch 0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
@ -86,6 +88,9 @@ Cross-platform computer monitoring and classroom management.
|
|||||||
%doc COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 26 2024 Automatic Build System <autodist@openmamba.org> 4.9.1-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libprocps-devel>=0:4.0.5-1mamba
|
||||||
|
|
||||||
* Sat Nov 30 2024 Automatic Build System <autodist@openmamba.org> 4.9.1-1mamba
|
* Sat Nov 30 2024 Automatic Build System <autodist@openmamba.org> 4.9.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user