automatic version update by autodist [release 3.9.0-1mamba;Mon Nov 18 2013]

This commit is contained in:
Automatic Build System 2024-01-05 18:54:28 +01:00
parent 1758212314
commit cc1ba28192
4 changed files with 245 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# valgrind
Valgrind is a GPL'd system for debugging and profiling x86-Linux programs.
With the tools that come with Valgrind, you can automatically detect many memory management and threading bugs, avoiding hours of frustrating bug-hunting, making your programs more stable. You can also perform detailed profiling to help speed up your programs.
The Valgrind distribution includes five tools: two memory error detectors, a thread error detector, a cache profiler and a heap profiler.
Several other tools have been built with Valgrind.

View File

@ -0,0 +1,52 @@
Modified: trunk/configure.in
===================================================================
--- trunk/configure.in 2011-12-27 18:43:32 UTC (rev 12322)
+++ trunk/configure.in 2011-12-29 08:24:55 UTC (rev 12323)
@@ -778,6 +778,13 @@
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
;;
+ 2.15)
+ AC_MSG_RESULT(2.15 family)
+ AC_DEFINE([GLIBC_2_15], 1, [Define to 1 if you're using glibc 2.15.x])
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
darwin)
AC_MSG_RESULT(Darwin)
AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
@@ -791,7 +798,7 @@
*)
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.14])
+ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.15])
AC_MSG_ERROR([or Darwin libc])
;;
esac
--- valgrind-3.7.0.orig/coregrind/Makefile.am
+++ valgrind-3.7.0/coregrind/Makefile.am
@@ -495,7 +495,8 @@
m_gdbserver/powerpc-altivec64l.xml
# so as to make sure these get copied into the install tree
-pkglib_DATA = $(GDBSERVER_XML_FILES)
+vgdatadir = $(pkglibdir)
+vgdata_DATA = $(GDBSERVER_XML_FILES)
# so as to make sure these get copied into the tarball
EXTRA_DIST += $(GDBSERVER_XML_FILES)
diff -Nur valgrind-3.7.0.orig/Makefile.am valgrind-3.7.0/Makefile.am
--- valgrind-3.7.0.orig/Makefile.am
+++ valgrind-3.7.0/Makefile.am
@@ -61,7 +61,8 @@
# default.supp, as it is built from the base .supp files at compile-time.
dist_noinst_DATA = $(SUPP_FILES)
-pkglib_DATA = default.supp
+vgdatadir = $(pkglibdir)
+vgdata_DATA = default.supp
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = valgrind.pc

View File

@ -0,0 +1,24 @@
diff -Nru valgrind-3.7.0.orig/configure valgrind-3.7.0/configure
--- valgrind-3.7.0.orig/configure 2012-04-24 11:36:16.140356302 +0000
+++ valgrind-3.7.0/configure 2012-04-24 11:39:35.086185118 +0000
@@ -5133,8 +5133,9 @@
| head -n 1 \
| $SED 's/i686-apple-darwin10//' \
| $SED 's/i686-apple-darwin11//' \
+ | $SED 's/x86_64-openmamba-linux-gnu-gcc//' \
| $SED 's/^[^0-9]*\([0-9.]*\).*$/\1/'`
is_clang="notclang"
if test "x`${CC} --version | head -n 1 | $SED 's/\(clang\) version.*/\1/'`" = "xclang" ; then
is_clang="clang"
diff -Nru valgrind-3.7.0.orig/configure.in valgrind-3.7.0/configure.in
--- valgrind-3.7.0.orig/configure.in 2011-11-05 11:13:30.000000000 +0000
+++ valgrind-3.7.0/configure.in 2012-04-24 11:39:55.894955837 +0000
@@ -109,6 +109,7 @@
| head -n 1 \
| $SED 's/i686-apple-darwin10//' \
| $SED 's/i686-apple-darwin11//' \
+ | $SED 's/x86_64-openmamba-linux-gnu-gcc//' \
| $SED 's/^[^0-9]*\([0-9.]*\).*$/\1/'`]
is_clang="notclang"

163
valgrind.spec Normal file
View File

@ -0,0 +1,163 @@
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: valgrind
Version: 3.9.0
Release: 1mamba
Summary: Valgrind Memory Debugger
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://valgrind.org/
Source: http://valgrind.org/downloads/valgrind-%{version}.tar.bz2
Patch0: %{name}-3.7.0-x86_64-fix-gcc-detection.patch
Patch1: %{name}-3.7.0-glibc-2.15.patch
License: GPL
BuildRequires: perl >= %perl_major_ver
BuildRequires: gdb >= 6.3
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libmpi-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
%description
Valgrind is a GPL'd system for debugging and profiling x86-Linux programs.
With the tools that come with Valgrind, you can automatically detect many memory management and threading bugs, avoiding hours of frustrating bug-hunting, making your programs more stable. You can also perform detailed profiling to help speed up your programs.
The Valgrind distribution includes five tools: two memory error detectors, a thread error detector, a cache profiler and a heap profiler.
Several other tools have been built with Valgrind.
%package devel
Group: Development/Libraries
Summary: Static libraries and headers for %{name}
Requires: %{name} = %{version}
%description devel
Valgrind is a GPL'd system for debugging and profiling x86-Linux programs.
With the tools that come with Valgrind, you can automatically detect many memory management and threading bugs, avoiding hours of frustrating bug-hunting, making your programs more stable. You can also perform detailed profiling to help speed up your programs.
The Valgrind distribution includes five tools: two memory error detectors, a thread error detector, a cache profiler and a heap profiler.
Several other tools have been built with Valgrind.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
#%patch1 -p1
# use our own find-requires
%define __find_provides %{_builddir}/%{name}-%{version}/find_provides.sh
# don't provide `libpthread.so.0' library
cat > find_provides.sh << EOF
#! /bin/sh
%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu} | \
grep -v "libpthread.so.0*"
EOF
chmod +x find_provides.sh
sed -i "s|armv7|arm|" configure.ac
%build
autoreconf
%configure \
%ifarch x86_64
--enable-only64bit
%endif
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
# note: do *not* strip the debug info off stage2 or libpthread.so
%makeinstall
mv -f %{buildroot}%{_defaultdocdir}/%{name} \
%{buildroot}%{_defaultdocdir}/%{name}-%{version}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/callgrind_*
%{_bindir}/cg_annotate
%{_bindir}/cg_diff
%{_bindir}/cg_merge
%{_bindir}/valgrind
%{_bindir}/valgrind-di-server
%{_bindir}/valgrind-listener
%{_bindir}/ms_print
%{_bindir}/vgdb
%dir %{_libdir}/valgrind/
%{_libdir}/valgrind/*
%{_mandir}/man1/valgrind.*
%{_mandir}/man1/callgrind_*.1*
%{_mandir}/man1/cg_annotate.1*
%{_mandir}/man1/cg_diff.1*
%{_mandir}/man1/cg_merge.1*
%{_mandir}/man1/ms_print.1*
%{_mandir}/man1/valgrind-listener.1*
%{_mandir}/man1/vgdb.1*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/valgrind
%{_includedir}/valgrind/*
%{_libdir}/pkgconfig/valgrind.pc
%doc FAQ.txt NEWS README*
%changelog
* Mon Nov 18 2013 Automatic Build System <autodist@mambasoft.it> 3.9.0-1mamba
- automatic version update by autodist
* Tue Jan 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.1-2mamba
- rebuilt with libboost 1.52
* Fri Oct 12 2012 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
- automatic version update by autodist
* Sun Aug 19 2012 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
- automatic version update by autodist
* Tue Jul 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.7.0-2mamba
- rebuilt with glibc 2.15 (patch added)
* Thu Mar 15 2012 Automatic Build System <autodist@mambasoft.it> 3.7.0-1mamba
- automatic version update by autodist
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
- automatic update by autodist
* Sun Dec 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.6.0-1mamba
- update to 3.6.0
* Tue Sep 01 2009 Automatic Build System <autodist@mambasoft.it> 3.5.0-1mamba
- automatic update by autodist
* Fri Mar 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-1mamba
- automatic update by autodist
* Fri Jan 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.0-1mamba
- automatic update by autodist
* Wed Jul 16 2008 gil <puntogil@libero.it> 3.3.1-1mamba
- update to 3.3.1
- removed buildrequires: libXorg-devel
* Thu Jun 08 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.2.0-1qilnx
- update to version 3.2.0 by autospec
* Fri Sep 23 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.4.1-1qilnx
- update to version 2.4.1 by autospec
- created devel package
* Fri Dec 10 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.0-2qilnx
- removed `libpthread.so.0' from the list of the package provides
* Fri Dec 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.0-1qilnx
- package created by autospec