update to 3.16.1 [release 3.16.1-1mamba;Fri Dec 11 2020]
This commit is contained in:
parent
81d73a388c
commit
c8ca3f31af
13
valgrind-3.16.1-respect-flags-mpi.patch
Normal file
13
valgrind-3.16.1-respect-flags-mpi.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Naur valgrind-3.7.0.orig//mpi/Makefile.am valgrind-3.7.0/mpi/Makefile.am
|
||||
--- valgrind-3.7.0.orig/mpi/Makefile.am 2011-10-26 17:24:23.000000000 -0400
|
||||
+++ valgrind-3.7.0/mpi/Makefile.am 2011-11-10 16:03:14.000000000 -0500
|
||||
@@ -7,9 +7,6 @@
|
||||
CC = $(MPI_CC)
|
||||
DEFS =
|
||||
DEFAULT_INCLUDES =
|
||||
-CPPFLAGS =
|
||||
-CFLAGS =
|
||||
-LDFLAGS =
|
||||
|
||||
EXTRA_DIST = \
|
||||
mpiwrap_type_test.c
|
@ -1,7 +1,7 @@
|
||||
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||
|
||||
Name: valgrind
|
||||
Version: 3.14.0
|
||||
Version: 3.16.1
|
||||
Release: 1mamba
|
||||
Summary: Valgrind Memory Debugger
|
||||
Group: Development/Tools
|
||||
@ -12,14 +12,15 @@ URL: http://valgrind.org/
|
||||
Source: ftp://sourceware.org/pub/valgrind/valgrind-%{version}.tar.bz2
|
||||
Patch0: %{name}-3.7.0-x86_64-fix-gcc-detection.patch
|
||||
Patch1: %{name}-3.7.0-glibc-2.15.patch
|
||||
Patch2: valgrind-3.16.1-respect-flags-mpi.patch
|
||||
License: GPL
|
||||
BuildRequires: perl >= %perl_major_ver
|
||||
BuildRequires: gdb >= 6.3
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libmpi-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
#BuildRequires: libmpi-devel
|
||||
BuildRequires: perl >= %perl_major_ver
|
||||
BuildRequires: gdb >= 6.3
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
|
||||
%description
|
||||
@ -37,20 +38,23 @@ Requires: %{name} = %{version}
|
||||
%description devel
|
||||
Valgrind is a GPL'd system for debugging and profiling x86-Linux programs.
|
||||
With the tools that come with Valgrind, you can automatically detect many memory management and threading bugs, avoiding hours of frustrating bug-hunting, making your programs more stable. You can also perform detailed profiling to help speed up your programs.
|
||||
|
||||
The Valgrind distribution includes five tools: two memory error detectors, a thread error detector, a cache profiler and a heap profiler.
|
||||
Several other tools have been built with Valgrind.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< ___EOF
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
%patch2 -p1
|
||||
# use our own find-requires
|
||||
%define __find_provides %{_builddir}/%{name}-%{version}/find_provides.sh
|
||||
|
||||
# don't provide `libpthread.so.0' library
|
||||
# don't provide 'libpthread.so.0' library
|
||||
cat > find_provides.sh << EOF
|
||||
#! /bin/sh
|
||||
%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu} | \
|
||||
@ -61,9 +65,12 @@ chmod +x find_provides.sh
|
||||
|
||||
sed -i "s|armv7|arm|" configure.ac
|
||||
|
||||
%build
|
||||
autoreconf
|
||||
|
||||
%build
|
||||
# NOTE: 3.6.1: mpi wrapper does not build with openmpi 4.0
|
||||
%configure \
|
||||
--with-mpicc=/bin/false \
|
||||
%ifarch x86_64
|
||||
--enable-only64bit
|
||||
%endif
|
||||
@ -92,14 +99,22 @@ mv -f %{buildroot}%{_defaultdocdir}/%{name} \
|
||||
%{_bindir}/valgrind-listener
|
||||
%{_bindir}/ms_print
|
||||
%{_bindir}/vgdb
|
||||
%dir %{_libdir}/valgrind/
|
||||
%dir %{_libdir}/valgrind
|
||||
%{_libdir}/valgrind/*
|
||||
%ifarch x86_64
|
||||
%dir %{_libexecdir}/valgrind
|
||||
%{_libexecdir}/valgrind/dh_view.*
|
||||
%else
|
||||
%dir %{_prefix}/libexec/valgrind
|
||||
%{_prefix}/libexec/valgrind/dh_view.*
|
||||
%endif
|
||||
%{_mandir}/man1/valgrind.*
|
||||
%{_mandir}/man1/callgrind_*.1*
|
||||
%{_mandir}/man1/cg_annotate.1*
|
||||
%{_mandir}/man1/cg_diff.1*
|
||||
%{_mandir}/man1/cg_merge.1*
|
||||
%{_mandir}/man1/ms_print.1*
|
||||
%{_mandir}/man1/valgrind-di-server.1*
|
||||
%{_mandir}/man1/valgrind-listener.1*
|
||||
%{_mandir}/man1/vgdb.1*
|
||||
%doc AUTHORS COPYING
|
||||
@ -109,9 +124,14 @@ mv -f %{buildroot}%{_defaultdocdir}/%{name} \
|
||||
%dir %{_includedir}/valgrind
|
||||
%{_includedir}/valgrind/*
|
||||
%{_libdir}/pkgconfig/valgrind.pc
|
||||
%dir %{_docdir}/valgrind-%{version}
|
||||
%{_docdir}/valgrind-%{version}/*
|
||||
%doc FAQ.txt NEWS README*
|
||||
|
||||
%changelog
|
||||
* Fri Dec 11 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 3.16.1-1mamba
|
||||
- update to 3.16.1
|
||||
|
||||
* Fri Oct 26 2018 Automatic Build System <autodist@mambasoft.it> 3.14.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user