147 lines
4.8 KiB
RPMSpec
147 lines
4.8 KiB
RPMSpec
%define ruby_apiver %(echo %ruby_version|cut -d. -f1-2).0
|
|
Name: vagrant
|
|
Version: 2.2.16
|
|
Release: 1mamba
|
|
Summary: A tool for building and distributing development environments
|
|
Group: Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.vagrantup.com
|
|
Source: https://github.com/hashicorp/vagrant.git/v%{version}/vagrant-%{version}.tar.bz2
|
|
Source1: https://github.com/hashicorp/vagrant-installers.git/v%{version}.dev+build-ruby-2.6.7/vagrant-installers-%{version}.tar.bz2
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libffi-devel
|
|
BuildRequires: libruby-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ruby
|
|
BuildRequires: go
|
|
Requires: ruby
|
|
Requires: libarchive-tools
|
|
Requires: VirtualBox
|
|
|
|
%description
|
|
Vagrant is a tool for building and distributing development environments.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -a1
|
|
mv vagrant-installers-%{version} vagrant-installers
|
|
touch .gitignore
|
|
|
|
%build
|
|
gem build vagrant.gemspec
|
|
|
|
cd vagrant-installers/substrate/launcher
|
|
go get github.com/mitchellh/osext
|
|
|
|
go build \
|
|
-trimpath \
|
|
-buildmode=pie \
|
|
-ldflags "-extldflags \"${LDFLAGS}\"" \
|
|
-o vagrant
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
INSTALLERS_DIR=vagrant-installers/substrate
|
|
EMBEDDED_DIR=%{buildroot}%{_datadir}/vagrant/embedded
|
|
|
|
install -d %{buildroot}/usr/{bin,share/bash-completion/completions}
|
|
install -d ${EMBEDDED_DIR}/rgloader
|
|
|
|
install -Dm644 ${INSTALLERS_DIR}/common/gemrc ${EMBEDDED_DIR}/etc/gemrc
|
|
install -Dm644 ${INSTALLERS_DIR}/{common,linux}/rgloader/* \
|
|
${EMBEDDED_DIR}/rgloader/
|
|
|
|
echo "{ \"vagrant_version\": \"%{version}\" }" > ${EMBEDDED_DIR}/manifest.json
|
|
|
|
GEM_PATH=${EMBEDDED_DIR}/gems/%{version} GEM_HOME="$GEM_PATH" \
|
|
GEMRC=${EMBEDDED_DIR}/etc/gemrc \
|
|
gem install %{name}-%{version}.gem --no-document --prerelease
|
|
|
|
install -Dm755 ${INSTALLERS_DIR}/launcher/vagrant \
|
|
%{buildroot}%{_datadir}/vagrant/bin/vagrant
|
|
|
|
ln -s %{_datadir}/vagrant/bin/vagrant %{buildroot}%{_bindir}/vagrant
|
|
|
|
install -Dm644 contrib/bash/completion.sh \
|
|
%{buildroot}%{_datadir}/bash-completion/completions/vagrant
|
|
|
|
install -Dm644 contrib/vim/vagrantfile.vim \
|
|
%{buildroot}%{_datadir}/vim/vimfiles/ftdetect/vagrantfile.vim
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/vagrant
|
|
%dir %{_datadir}/vagrant
|
|
%dir %{_datadir}/vagrant/bin
|
|
%{_datadir}/vagrant/bin/vagrant
|
|
%dir %{_datadir}/vagrant/embedded
|
|
%dir %{_datadir}/vagrant/embedded/etc
|
|
%{_datadir}/vagrant/embedded/etc/gemrc
|
|
%dir %{_datadir}/vagrant/embedded/gems/
|
|
%dir %{_datadir}/vagrant/embedded/gems/%{version}
|
|
%{_datadir}/vagrant/embedded/gems/%{version}/*
|
|
%{_datadir}/vagrant/embedded/manifest.json
|
|
%dir %{_datadir}/vagrant/embedded/rgloader
|
|
%{_datadir}/vagrant/embedded/rgloader/loader.rb
|
|
%{_datadir}/vagrant/embedded/rgloader/rgloader26.linux.x86_64.so
|
|
%{_datadir}/vim/vimfiles/ftdetect/vagrantfile.vim
|
|
%{_datadir}/bash-completion/completions/vagrant
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Sat Jun 05 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.16-1mamba
|
|
- update to 2.2.16
|
|
|
|
* Wed Mar 31 2021 Automatic Build System <autodist@mambasoft.it> 2.2.15-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 23 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.14-1mamba
|
|
- update to 2.2.14
|
|
|
|
* Fri May 15 2020 Automatic Build System <autodist@mambasoft.it> 2.2.9-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 09 2020 Automatic Build System <autodist@mambasoft.it> 2.2.8-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 29 2020 Automatic Build System <autodist@mambasoft.it> 2.2.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 19 2019 Automatic Build System <autodist@mambasoft.it> 2.2.6-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 08 2019 Automatic Build System <autodist@mambasoft.it> 2.2.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 02 2019 Automatic Build System <autodist@mambasoft.it> 2.2.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 17 2019 Automatic Build System <autodist@mambasoft.it> 2.2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 20 2018 Automatic Build System <autodist@mambasoft.it> 2.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 24 2018 Automatic Build System <autodist@mambasoft.it> 2.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 22 2018 Automatic Build System <autodist@mambasoft.it> 2.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 13 2018 Automatic Build System <autodist@mambasoft.it> 2.1.5-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 10 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.4-1mamba
|
|
- update to 2.1.4
|
|
|
|
* Mon Jul 16 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.2-1mamba
|
|
- package created using the webbuild interface
|