update to 6.0 [release 6.0-1mamba;Wed Apr 27 2011]
This commit is contained in:
parent
d09e1d88c9
commit
49b3d33d46
@ -1,2 +1,7 @@
|
|||||||
# unzip
|
# unzip
|
||||||
|
|
||||||
|
The zip program is a compression and file packaging utility.
|
||||||
|
Zip is analogous to a combination of the UNIX tar and compress commands and is compatible with PKZIP (a compression and file packaging utility for MS-DOS systems).
|
||||||
|
|
||||||
|
Install the zip package if you need to compress files using the zip program.
|
||||||
|
|
||||||
|
27
unzip-5.51-link-segv.patch
Normal file
27
unzip-5.51-link-segv.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff -pur unzip-5.51/unix/unix.c unzip-5.51-fix/unix/unix.c
|
||||||
|
--- unzip-5.51/unix/unix.c 2004-04-12 02:29:58.000000000 +0200
|
||||||
|
+++ unzip-5.51-fix/unix/unix.c 2005-04-18 08:54:06.000000000 +0200
|
||||||
|
@@ -1002,6 +1002,7 @@ void close_outfile(__G) /* GRR: chang
|
||||||
|
ush z_uidgid[2];
|
||||||
|
int have_uidgid_flg;
|
||||||
|
|
||||||
|
+ fchmod(fileno(G.outfile), 0400);
|
||||||
|
fclose(G.outfile);
|
||||||
|
|
||||||
|
/*---------------------------------------------------------------------------
|
||||||
|
@@ -1049,10 +1050,13 @@ void close_outfile(__G) /* GRR: chang
|
||||||
|
"warning: symbolic link (%s) failed\n",
|
||||||
|
FnFilter1(G.filename)));
|
||||||
|
free(slnk_entry);
|
||||||
|
- fclose(G.outfile);
|
||||||
|
+ if (G.outfile)
|
||||||
|
+ fclose(G.outfile);
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
- fclose(G.outfile); /* close "link" file for good... */
|
||||||
|
+
|
||||||
|
+ if (G.outfile)
|
||||||
|
+ fclose(G.outfile); /* close "link" file for good... */
|
||||||
|
slnk_entry->target[ucsize] = '\0';
|
||||||
|
if (QCOND2)
|
||||||
|
Info(slide, 0, ((char *)slide, "-> %s ",
|
11
unzip-5.51-rpmoptflags.patch
Normal file
11
unzip-5.51-rpmoptflags.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- unzip-5.42/unix/Makefile.rpmoptflags Mon May 21 10:57:51 2001
|
||||||
|
+++ unzip-5.42/unix/Makefile Mon May 21 10:58:22 2001
|
||||||
|
@@ -735,7 +735,7 @@
|
||||||
|
# Linux (Posix, approximately SysV): virtually any version since before 0.96,
|
||||||
|
# for any platform. Change "-O" to "-O3" or whatever, as desired...
|
||||||
|
linux_noasm: unix_make
|
||||||
|
- $(MAKE) unzips CC=gcc LD=gcc CF="-O -Wall -I. $(LOC)"
|
||||||
|
+ $(MAKE) unzips CC=gcc LD=gcc CF="$(RPM_OPT_FLAGS) -D_GNU_SOURCE -Wall -I. $(LOC)"
|
||||||
|
|
||||||
|
# Linux with lcc compiler: __inline__ (stat.h) not recognized, and must edit
|
||||||
|
# /usr/include/gnu/types.h to get rid of "long long" if __LCC__ defined. -O3
|
41
unzip-5.52-CVE-2005-4667.patch
Normal file
41
unzip-5.52-CVE-2005-4667.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
--- unzip-5.52.orig/unzpriv.h
|
||||||
|
+++ unzip-5.52/unzpriv.h
|
||||||
|
@@ -783,6 +783,7 @@
|
||||||
|
# define TIMET_TO_NATIVE(x)
|
||||||
|
# define NATIVE_TO_TIMET(x)
|
||||||
|
#endif
|
||||||
|
+ /*
|
||||||
|
#ifndef SSTAT
|
||||||
|
# ifdef WILD_STAT_BUG
|
||||||
|
# define SSTAT(path,pbuf) (iswild(path) || stat(path,pbuf))
|
||||||
|
@@ -790,6 +791,8 @@
|
||||||
|
# define SSTAT stat
|
||||||
|
# endif
|
||||||
|
#endif
|
||||||
|
+ */
|
||||||
|
+# define SSTAT stat
|
||||||
|
#ifndef STRNICMP
|
||||||
|
# ifdef NO_STRNICMP
|
||||||
|
# define STRNICMP zstrnicmp
|
||||||
|
@@ -2271,17 +2274,18 @@
|
||||||
|
* (char *)(sprintf sprf_arg, (buf))) == EOF)
|
||||||
|
*/
|
||||||
|
#ifndef Info /* may already have been defined for redirection */
|
||||||
|
+# define wsizesnprintf(buf, ...) snprintf (buf, WSIZE-1, __VA_ARGS__)
|
||||||
|
# ifdef FUNZIP
|
||||||
|
# define Info(buf,flag,sprf_arg) \
|
||||||
|
- fprintf((flag)&1? stderr : stdout, (char *)(sprintf sprf_arg, (buf)))
|
||||||
|
+ fputs((char *)(wsizesnprintf sprf_arg, (buf)), (flag)&1? stderr : stdout)
|
||||||
|
# else
|
||||||
|
# ifdef INT_SPRINTF /* optimized version for "int sprintf()" flavour */
|
||||||
|
# define Info(buf,flag,sprf_arg) \
|
||||||
|
- (*G.message)((zvoid *)&G, (uch *)(buf), (ulg)sprintf sprf_arg, (flag))
|
||||||
|
+ (*G.message)((zvoid *)&G, (uch *)(buf), (ulg)wsizesnprintf sprf_arg, (flag))
|
||||||
|
# else /* generic version, does not use sprintf() return value */
|
||||||
|
# define Info(buf,flag,sprf_arg) \
|
||||||
|
(*G.message)((zvoid *)&G, (uch *)(buf), \
|
||||||
|
- (ulg)(sprintf sprf_arg, strlen((char *)(buf))), (flag))
|
||||||
|
+ (ulg)(wsizesnprintf sprf_arg, strlen((char *)(buf))), (flag))
|
||||||
|
# endif
|
||||||
|
# endif
|
||||||
|
#endif /* !Info */
|
39
unzip-5.52-can-2005-2475.patch
Normal file
39
unzip-5.52-can-2005-2475.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
diff -ru unzip-5.52/unix/unix.c ../BUILD/unzip-5.52-fix/unix/unix.c
|
||||||
|
--- unzip-5.52/unix/unix.c 2005-10-03 07:58:18.000000000 +0000
|
||||||
|
+++ unzip-5.52-fix/unix/unix.c 2005-10-03 08:04:44.000000000 +0000
|
||||||
|
@@ -1043,6 +1043,17 @@
|
||||||
|
int have_uidgid_flg;
|
||||||
|
|
||||||
|
fchmod(fileno(G.outfile), 0400);
|
||||||
|
+
|
||||||
|
+/*---------------------------------------------------------------------------
|
||||||
|
+ Change the file permissions from default ones to those stored in the
|
||||||
|
+ zipfile. It is necessary to change permissions before fclose command.
|
||||||
|
+ ---------------------------------------------------------------------------*/
|
||||||
|
+
|
||||||
|
+#ifndef NO_CHMOD
|
||||||
|
+ if (fchmod(fileno(G.outfile), 0xffff & G.pInfo->file_attr))
|
||||||
|
+ perror("chmod (file attributes) error");
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
fclose(G.outfile);
|
||||||
|
|
||||||
|
/*---------------------------------------------------------------------------
|
||||||
|
@@ -1154,17 +1165,6 @@
|
||||||
|
" (warning) cannot set times"));
|
||||||
|
#endif /* ?AOS_VS */
|
||||||
|
}
|
||||||
|
-
|
||||||
|
-/*---------------------------------------------------------------------------
|
||||||
|
- Change the file permissions from default ones to those stored in the
|
||||||
|
- zipfile.
|
||||||
|
- ---------------------------------------------------------------------------*/
|
||||||
|
-
|
||||||
|
-#ifndef NO_CHMOD
|
||||||
|
- if (chmod(G.filename, filtattr(__G__ G.pInfo->file_attr)))
|
||||||
|
- perror("chmod (file attributes) error");
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
} /* end function close_outfile() */
|
||||||
|
|
||||||
|
#endif /* !MTS */
|
389
unzip-6.0-iconv.patch
Normal file
389
unzip-6.0-iconv.patch
Normal file
@ -0,0 +1,389 @@
|
|||||||
|
Based on https://bugzilla.altlinux.org/show_bug.cgi?format=multiple&id=4871
|
||||||
|
Note: For UTF-8 locale this patch uses Cyrillic CP866 by default.
|
||||||
|
See CHARSET_MAP below.
|
||||||
|
diff -ur unzip60.old/unix/unix.c unzip60/unix/unix.c
|
||||||
|
--- unzip60.old/unix/unix.c 2010-06-24 13:09:57.000000000 +0300
|
||||||
|
+++ unzip60/unix/unix.c 2010-06-24 13:14:28.000000000 +0300
|
||||||
|
@@ -30,6 +30,9 @@
|
||||||
|
#define UNZIP_INTERNAL
|
||||||
|
#include "unzip.h"
|
||||||
|
|
||||||
|
+#include <iconv.h>
|
||||||
|
+#include <langinfo.h>
|
||||||
|
+
|
||||||
|
#ifdef SCO_XENIX
|
||||||
|
# define SYSNDIR
|
||||||
|
#else /* SCO Unix, AIX, DNIX, TI SysV, Coherent 4.x, ... */
|
||||||
|
@@ -1907,3 +1910,93 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
#endif /* QLZIP */
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+typedef struct {
|
||||||
|
+ char *local_charset;
|
||||||
|
+ char *archive_charset;
|
||||||
|
+} CHARSET_MAP;
|
||||||
|
+
|
||||||
|
+/* A mapping of local <-> archive charsets used by default to convert filenames
|
||||||
|
+ * of DOS/Windows Zip archives. Currently very basic. */
|
||||||
|
+static CHARSET_MAP dos_charset_map[] = {
|
||||||
|
+ { "ANSI_X3.4-1968", "CP850" },
|
||||||
|
+ { "ISO-8859-1", "CP850" },
|
||||||
|
+ { "CP1252", "CP850" },
|
||||||
|
+ { "UTF-8", "CP866" },
|
||||||
|
+ { "KOI8-R", "CP866" },
|
||||||
|
+ { "KOI8-U", "CP866" },
|
||||||
|
+ { "ISO-8859-5", "CP866" }
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+char OEM_CP[MAX_CP_NAME] = "";
|
||||||
|
+char ISO_CP[MAX_CP_NAME] = "";
|
||||||
|
+
|
||||||
|
+/* Try to guess the default value of OEM_CP based on the current locale.
|
||||||
|
+ * ISO_CP is left alone for now. */
|
||||||
|
+void init_conversion_charsets()
|
||||||
|
+{
|
||||||
|
+ const char *local_charset;
|
||||||
|
+ int i;
|
||||||
|
+
|
||||||
|
+ /* Make a guess only if OEM_CP not already set. */
|
||||||
|
+ if(*OEM_CP == '\0') {
|
||||||
|
+ local_charset = nl_langinfo(CODESET);
|
||||||
|
+ for(i = 0; i < sizeof(dos_charset_map)/sizeof(CHARSET_MAP); i++)
|
||||||
|
+ if(!strcasecmp(local_charset, dos_charset_map[i].local_charset)) {
|
||||||
|
+ strncpy(OEM_CP, dos_charset_map[i].archive_charset,
|
||||||
|
+ sizeof(OEM_CP));
|
||||||
|
+ break;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/* Convert a string from one encoding to the current locale using iconv().
|
||||||
|
+ * Be as non-intrusive as possible. If error is encountered during covertion
|
||||||
|
+ * just leave the string intact. */
|
||||||
|
+static void charset_to_intern(char *string, char *from_charset)
|
||||||
|
+{
|
||||||
|
+ iconv_t cd;
|
||||||
|
+ char *s, *d, *buf;
|
||||||
|
+ size_t slen, dlen, buflen;
|
||||||
|
+ const char *local_charset;
|
||||||
|
+
|
||||||
|
+ if(*from_charset == '\0')
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
+ buf = NULL;
|
||||||
|
+ local_charset = nl_langinfo(CODESET);
|
||||||
|
+
|
||||||
|
+ if((cd = iconv_open(local_charset, from_charset)) == (iconv_t)-1)
|
||||||
|
+ return;
|
||||||
|
+
|
||||||
|
+ slen = strlen(string);
|
||||||
|
+ s = string;
|
||||||
|
+ buflen = 4*slen;
|
||||||
|
+ if (buflen > OUTBUFSIZ) // this should prevent crashes on some VERY long names
|
||||||
|
+ buflen = OUTBUFSIZ;
|
||||||
|
+ dlen = buflen;
|
||||||
|
+ d = buf = malloc(buflen + 1);
|
||||||
|
+ if(!d)
|
||||||
|
+ goto cleanup;
|
||||||
|
+ bzero(buf,buflen);
|
||||||
|
+ if(iconv(cd, &s, &slen, &d, &dlen) == (size_t)-1)
|
||||||
|
+ goto cleanup;
|
||||||
|
+ strncpy(string, buf, buflen);
|
||||||
|
+
|
||||||
|
+ cleanup:
|
||||||
|
+ free(buf);
|
||||||
|
+ iconv_close(cd);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/* Convert a string from OEM_CP to the current locale charset. */
|
||||||
|
+inline void oem_intern(char *string)
|
||||||
|
+{
|
||||||
|
+ charset_to_intern(string, OEM_CP);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/* Convert a string from ISO_CP to the current locale charset. */
|
||||||
|
+inline void iso_intern(char *string)
|
||||||
|
+{
|
||||||
|
+ charset_to_intern(string, ISO_CP);
|
||||||
|
+}
|
||||||
|
diff -ur unzip60.old/unix/unxcfg.h unzip60/unix/unxcfg.h
|
||||||
|
--- unzip60.old/unix/unxcfg.h 2009-04-16 21:36:12.000000000 +0300
|
||||||
|
+++ unzip60/unix/unxcfg.h 2010-06-24 13:14:28.000000000 +0300
|
||||||
|
@@ -227,4 +227,30 @@
|
||||||
|
/* wild_dir, dirname, wildname, matchname[], dirnamelen, have_dirname, */
|
||||||
|
/* and notfirstcall are used by do_wild(). */
|
||||||
|
|
||||||
|
+
|
||||||
|
+#define MAX_CP_NAME 25
|
||||||
|
+
|
||||||
|
+#ifdef SETLOCALE
|
||||||
|
+# undef SETLOCALE
|
||||||
|
+#endif
|
||||||
|
+#define SETLOCALE(category, locale) setlocale(category, locale)
|
||||||
|
+#include <locale.h>
|
||||||
|
+
|
||||||
|
+#ifdef _ISO_INTERN
|
||||||
|
+# undef _ISO_INTERN
|
||||||
|
+#endif
|
||||||
|
+#define _ISO_INTERN(str1) iso_intern(str1)
|
||||||
|
+
|
||||||
|
+#ifdef _OEM_INTERN
|
||||||
|
+# undef _OEM_INTERN
|
||||||
|
+#endif
|
||||||
|
+#ifndef IZ_OEM2ISO_ARRAY
|
||||||
|
+# define IZ_OEM2ISO_ARRAY
|
||||||
|
+#endif
|
||||||
|
+#define _OEM_INTERN(str1) oem_intern(str1)
|
||||||
|
+
|
||||||
|
+void iso_intern(char *);
|
||||||
|
+void oem_intern(char *);
|
||||||
|
+void init_conversion_charsets(void);
|
||||||
|
+
|
||||||
|
#endif /* !__unxcfg_h */
|
||||||
|
diff -ur unzip60.old/unzip.c unzip60/unzip.c
|
||||||
|
--- unzip60.old/unzip.c 2009-04-16 21:26:52.000000000 +0300
|
||||||
|
+++ unzip60/unzip.c 2010-06-24 13:20:11.000000000 +0300
|
||||||
|
@@ -327,11 +327,21 @@
|
||||||
|
-2 just filenames but allow -h/-t/-z -l long Unix \"ls -l\" format\n\
|
||||||
|
-v verbose, multi-page format\n";
|
||||||
|
|
||||||
|
+#ifndef UNIX
|
||||||
|
static ZCONST char Far ZipInfoUsageLine3[] = "miscellaneous options:\n\
|
||||||
|
-h print header line -t print totals for listed files or for all\n\
|
||||||
|
-z print zipfile comment -T print file times in sortable decimal format\
|
||||||
|
\n -C be case-insensitive %s\
|
||||||
|
-x exclude filenames that follow from listing\n";
|
||||||
|
+#else /* UNIX */
|
||||||
|
+static ZCONST char Far ZipInfoUsageLine3[] = "miscellaneous options:\n\
|
||||||
|
+ -h print header line -t print totals for listed files or for all\n\
|
||||||
|
+ -z print zipfile comment -T print file times in sortable decimal format\
|
||||||
|
+\n -C be case-insensitive %s\
|
||||||
|
+ -x exclude filenames that follow from listing\n\
|
||||||
|
+ -O CHARSET specify a character encoding for DOS, Windows and OS/2 archives\n\
|
||||||
|
+ -I CHARSET specify a character encoding for UNIX and other archives\n";
|
||||||
|
+#endif /* !UNIX */
|
||||||
|
#ifdef MORE
|
||||||
|
static ZCONST char Far ZipInfoUsageLine4[] =
|
||||||
|
" -M page output through built-in \"more\"\n";
|
||||||
|
@@ -666,6 +676,7 @@
|
||||||
|
-C match filenames case-insensitively -L make (some) names \
|
||||||
|
lowercase\n %-42s -V retain VMS version numbers\n%s";
|
||||||
|
#else /* !VMS */
|
||||||
|
+#ifndef UNIX
|
||||||
|
static ZCONST char Far UnzipUsageLine4[] = "\
|
||||||
|
modifiers:\n\
|
||||||
|
-n never overwrite existing files -q quiet mode (-qq => quieter)\n\
|
||||||
|
@@ -674,6 +685,18 @@
|
||||||
|
-U use escapes for all non-ASCII Unicode -UU ignore any Unicode fields\n\
|
||||||
|
-C match filenames case-insensitively -L make (some) names \
|
||||||
|
lowercase\n %-42s -V retain VMS version numbers\n%s";
|
||||||
|
+#else /* UNIX */
|
||||||
|
+static ZCONST char Far UnzipUsageLine4[] = "\
|
||||||
|
+modifiers:\n\
|
||||||
|
+ -n never overwrite existing files -q quiet mode (-qq => quieter)\n\
|
||||||
|
+ -o overwrite files WITHOUT prompting -a auto-convert any text files\n\
|
||||||
|
+ -j junk paths (do not make directories) -aa treat ALL files as text\n\
|
||||||
|
+ -U use escapes for all non-ASCII Unicode -UU ignore any Unicode fields\n\
|
||||||
|
+ -C match filenames case-insensitively -L make (some) names \
|
||||||
|
+lowercase\n %-42s -V retain VMS version numbers\n%s\n\
|
||||||
|
+ -O CHARSET specify a character encoding for DOS, Windows and OS/2 archives\n\
|
||||||
|
+ -I CHARSET specify a character encoding for UNIX and other archives\n\n";
|
||||||
|
+#endif /* !UNIX */
|
||||||
|
#endif /* ?VMS */
|
||||||
|
#else /* !UNICODE_SUPPORT */
|
||||||
|
#ifdef VMS
|
||||||
|
@@ -803,6 +826,10 @@
|
||||||
|
#endif /* UNICODE_SUPPORT */
|
||||||
|
|
||||||
|
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ init_conversion_charsets();
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#if (defined(__IBMC__) && defined(__DEBUG_ALLOC__))
|
||||||
|
extern void DebugMalloc(void);
|
||||||
|
|
||||||
|
@@ -1336,6 +1363,11 @@
|
||||||
|
argc = *pargc;
|
||||||
|
argv = *pargv;
|
||||||
|
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ extern char OEM_CP[MAX_CP_NAME];
|
||||||
|
+ extern char ISO_CP[MAX_CP_NAME];
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
while (++argv, (--argc > 0 && *argv != NULL && **argv == '-')) {
|
||||||
|
s = *argv + 1;
|
||||||
|
while ((c = *s++) != 0) { /* "!= 0": prevent Turbo C warning */
|
||||||
|
@@ -1517,6 +1549,35 @@
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
#endif /* MACOS */
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ case ('I'):
|
||||||
|
+ if (negative) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: encodings can't be negated"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ } else {
|
||||||
|
+ if(*s) { /* Handle the -Icharset case */
|
||||||
|
+ /* Assume that charsets can't start with a dash to spot arguments misuse */
|
||||||
|
+ if(*s == '-') {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ strncpy(ISO_CP, s, sizeof(ISO_CP));
|
||||||
|
+ } else { /* -I charset */
|
||||||
|
+ ++argv;
|
||||||
|
+ if(!(--argc > 0 && *argv != NULL && **argv != '-')) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ s = *argv;
|
||||||
|
+ strncpy(ISO_CP, s, sizeof(ISO_CP));
|
||||||
|
+ }
|
||||||
|
+ while(*(++s)); /* No params straight after charset name */
|
||||||
|
+ }
|
||||||
|
+ break;
|
||||||
|
+#endif /* ?UNIX */
|
||||||
|
case ('j'): /* junk pathnames/directory structure */
|
||||||
|
if (negative)
|
||||||
|
uO.jflag = FALSE, negative = 0;
|
||||||
|
@@ -1592,6 +1653,35 @@
|
||||||
|
} else
|
||||||
|
++uO.overwrite_all;
|
||||||
|
break;
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ case ('O'):
|
||||||
|
+ if (negative) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: encodings can't be negated"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ } else {
|
||||||
|
+ if(*s) { /* Handle the -Ocharset case */
|
||||||
|
+ /* Assume that charsets can't start with a dash to spot arguments misuse */
|
||||||
|
+ if(*s == '-') {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ strncpy(OEM_CP, s, sizeof(OEM_CP));
|
||||||
|
+ } else { /* -O charset */
|
||||||
|
+ ++argv;
|
||||||
|
+ if(!(--argc > 0 && *argv != NULL && **argv != '-')) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -O argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ s = *argv;
|
||||||
|
+ strncpy(OEM_CP, s, sizeof(OEM_CP));
|
||||||
|
+ }
|
||||||
|
+ while(*(++s)); /* No params straight after charset name */
|
||||||
|
+ }
|
||||||
|
+ break;
|
||||||
|
+#endif /* ?UNIX */
|
||||||
|
case ('p'): /* pipes: extract to stdout, no messages */
|
||||||
|
if (negative) {
|
||||||
|
uO.cflag = FALSE;
|
||||||
|
diff -ur unzip60.old/unzpriv.h unzip60/unzpriv.h
|
||||||
|
--- unzip60.old/unzpriv.h 2010-06-24 13:09:57.000000000 +0300
|
||||||
|
+++ unzip60/unzpriv.h 2010-06-24 13:23:06.000000000 +0300
|
||||||
|
@@ -3008,7 +3008,7 @@
|
||||||
|
!(((islochdr) || (isuxatt)) && \
|
||||||
|
((hostver) == 25 || (hostver) == 26 || (hostver) == 40))) || \
|
||||||
|
(hostnum) == FS_HPFS_ || \
|
||||||
|
- ((hostnum) == FS_NTFS_ && (hostver) == 50)) { \
|
||||||
|
+ ((hostnum) == FS_NTFS_/* && (hostver) == 50*/)) { \
|
||||||
|
_OEM_INTERN((string)); \
|
||||||
|
} else { \
|
||||||
|
_ISO_INTERN((string)); \
|
||||||
|
diff -ur unzip60.old/zipinfo.c unzip60/zipinfo.c
|
||||||
|
--- unzip60.old/zipinfo.c 2009-02-08 19:04:30.000000000 +0200
|
||||||
|
+++ unzip60/zipinfo.c 2010-06-24 13:14:31.000000000 +0300
|
||||||
|
@@ -457,6 +457,10 @@
|
||||||
|
int tflag_slm=TRUE, tflag_2v=FALSE;
|
||||||
|
int explicit_h=FALSE, explicit_t=FALSE;
|
||||||
|
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ extern char OEM_CP[MAX_CP_NAME];
|
||||||
|
+ extern char ISO_CP[MAX_CP_NAME];
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#ifdef MACOS
|
||||||
|
uO.lflag = LFLAG; /* reset default on each call */
|
||||||
|
@@ -501,6 +505,35 @@
|
||||||
|
uO.lflag = 0;
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ case ('I'):
|
||||||
|
+ if (negative) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: encodings can't be negated"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ } else {
|
||||||
|
+ if(*s) { /* Handle the -Icharset case */
|
||||||
|
+ /* Assume that charsets can't start with a dash to spot arguments misuse */
|
||||||
|
+ if(*s == '-') {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ strncpy(ISO_CP, s, sizeof(ISO_CP));
|
||||||
|
+ } else { /* -I charset */
|
||||||
|
+ ++argv;
|
||||||
|
+ if(!(--argc > 0 && *argv != NULL && **argv != '-')) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ s = *argv;
|
||||||
|
+ strncpy(ISO_CP, s, sizeof(ISO_CP));
|
||||||
|
+ }
|
||||||
|
+ while(*(++s)); /* No params straight after charset name */
|
||||||
|
+ }
|
||||||
|
+ break;
|
||||||
|
+#endif /* ?UNIX */
|
||||||
|
case 'l': /* longer form of "ls -l" type listing */
|
||||||
|
if (negative)
|
||||||
|
uO.lflag = -2, negative = 0;
|
||||||
|
@@ -521,6 +554,35 @@
|
||||||
|
G.M_flag = TRUE;
|
||||||
|
break;
|
||||||
|
#endif
|
||||||
|
+#ifdef UNIX
|
||||||
|
+ case ('O'):
|
||||||
|
+ if (negative) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: encodings can't be negated"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ } else {
|
||||||
|
+ if(*s) { /* Handle the -Ocharset case */
|
||||||
|
+ /* Assume that charsets can't start with a dash to spot arguments misuse */
|
||||||
|
+ if(*s == '-') {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -I argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ strncpy(OEM_CP, s, sizeof(OEM_CP));
|
||||||
|
+ } else { /* -O charset */
|
||||||
|
+ ++argv;
|
||||||
|
+ if(!(--argc > 0 && *argv != NULL && **argv != '-')) {
|
||||||
|
+ Info(slide, 0x401, ((char *)slide,
|
||||||
|
+ "error: a valid character encoding should follow the -O argument"));
|
||||||
|
+ return(PK_PARAM);
|
||||||
|
+ }
|
||||||
|
+ s = *argv;
|
||||||
|
+ strncpy(OEM_CP, s, sizeof(OEM_CP));
|
||||||
|
+ }
|
||||||
|
+ while(*(++s)); /* No params straight after charset name */
|
||||||
|
+ }
|
||||||
|
+ break;
|
||||||
|
+#endif /* ?UNIX */
|
||||||
|
case 's': /* default: shorter "ls -l" type listing */
|
||||||
|
if (negative)
|
||||||
|
uO.lflag = -2, negative = 0;
|
88
unzip.spec
Normal file
88
unzip.spec
Normal file
@ -0,0 +1,88 @@
|
|||||||
|
%define src_ver %(echo %version | tr -d .)
|
||||||
|
|
||||||
|
Name: unzip
|
||||||
|
Version: 6.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A file compression and packaging utility compatible with PKZIP
|
||||||
|
Group: Applications/Archiving
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.info-zip.org/pub/infozip/
|
||||||
|
Source: ftp://ftp.info-zip.org/pub/infozip/src/unzip%{src_ver}.tgz
|
||||||
|
Patch0: %{name}-5.51-rpmoptflags.patch
|
||||||
|
Patch1: %{name}-5.51-link-segv.patch
|
||||||
|
Patch2: %{name}-5.52-can-2005-2475.patch
|
||||||
|
Patch3: %{name}-5.52-CVE-2005-4667.patch
|
||||||
|
Patch4: %{name}-6.0-iconv.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The zip program is a compression and file packaging utility.
|
||||||
|
Zip is analogous to a combination of the UNIX tar and compress commands and is compatible with PKZIP (a compression and file packaging utility for MS-DOS systems).
|
||||||
|
|
||||||
|
Install the zip package if you need to compress files using the zip program.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n unzip%{src_ver}
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
#%patch2 -p1 -b .can-2005-2475
|
||||||
|
#%patch3 -p1 -b .can-2005-4667
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
|
ln -sf unix/Makefile Makefile
|
||||||
|
|
||||||
|
sed -i "s|CC=gcc |CC=%{_host}-gcc |" Makefile
|
||||||
|
sed -i "s|LD=gcc |LD=%{_host}-gcc |" Makefile
|
||||||
|
sed -i "s|AS=gcc |AS=%{_host}-gcc |" Makefile
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%make linux_noasm LF2="" CC=%{_host}-gcc
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeoldinstall \
|
||||||
|
LF2="" \
|
||||||
|
MANDIR=%{buildroot}%{_mandir}/man1
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%doc README BUGS LICENSE
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Apr 27 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 6.0-1mamba
|
||||||
|
- update to 6.0
|
||||||
|
|
||||||
|
* Tue Mar 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 5.52-5mamba
|
||||||
|
- specfile updated
|
||||||
|
|
||||||
|
* Fri Mar 03 2006 Davide Madrisan <davide.madrisan@qilinux.it> 5.52-4qilnx
|
||||||
|
- security update for CVE-2005-4667
|
||||||
|
|
||||||
|
* Wed Oct 05 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 5.52-3qilnx
|
||||||
|
- spec file fixed and updated
|
||||||
|
|
||||||
|
* Mon Oct 03 2005 Davide Madrisan <davide.madrisan@qilinux.it> 5.52-2qilnx
|
||||||
|
- security fix QSA-2005-112 (CAN-2005-2475)
|
||||||
|
|
||||||
|
* Wed Aug 03 2005 Davide Madrisan <davide.madrisan@qilinux.it> 5.52-1qilnx
|
||||||
|
- update to version 5.52 by autospec
|
||||||
|
|
||||||
|
* Mon Apr 18 2005 Davide Madrisan <davide.madrisan@qilinux.it> 5.51-1qilnx
|
||||||
|
- update to version 5.51 by autospec
|
||||||
|
- fixed manpages path
|
||||||
|
- fix several problem with unpacking zipfiles containing symlinks
|
||||||
|
|
||||||
|
* Mon Jul 14 2003 Silvan Calarco <silvan.calarco@qinet.it> 5.50-1qilnx
|
||||||
|
- creation of unzip package
|
Loading…
Reference in New Issue
Block a user