rebuilt by autoport with build requirements: libgnustep-base-devel>=0:1.30.0-1mamba [release 1.10.8-2mamba;Sun Jan 05 2025]
This commit is contained in:
parent
41b50bf361
commit
00baadae32
@ -2,3 +2,4 @@
|
|||||||
|
|
||||||
The command-line utilities lsar and unar are capable of listing and extracting files respectively in several formats including RARv5, RAR support includes encryption and multiple volumes, unar can serve as a free and open source replacement of unrar.
|
The command-line utilities lsar and unar are capable of listing and extracting files respectively in several formats including RARv5, RAR support includes encryption and multiple volumes, unar can serve as a free and open source replacement of unrar.
|
||||||
|
|
||||||
|
|
||||||
|
42
unar-1.10.8-int-conversion.patch
Normal file
42
unar-1.10.8-int-conversion.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
Without this change, GCC 14 will fail compilation with an error:
|
||||||
|
|
||||||
|
XADRAR5Parser.m: In function ‘+[XADRAR5Parser recognizeFileWithHandle:firstBytes:name:]’: XADRAR5Parser.m:79:5: warning: ‘XADRAR5Parser’ may not respond to ‘+signatureLocationInData:’
|
||||||
|
79 | off_t signatureLocation = [self signatureLocationInData:data];
|
||||||
|
| ^~~~~
|
||||||
|
XADRAR5Parser.m:79:5: warning: (messages without a matching method signature will be assumed to return ‘id’ and accept ‘...’ as arguments)
|
||||||
|
XADRAR5Parser.m:79:31: error: initialization of ‘off_t’ {aka ‘long int’} from ‘id’ makes integer from pointer without a cast
|
||||||
|
79 | off_t signatureLocation = [self signatureLocationInData:data];
|
||||||
|
| ^
|
||||||
|
|
||||||
|
Submitted upstream: <https://github.com/MacPaw/XADMaster/pull/161>
|
||||||
|
|
||||||
|
diff --git a/XADMaster-1.10.8/XADRAR5Parser.m b/XADMaster-1.10.8/XADRAR5Parser.m
|
||||||
|
index b89d841c959b4b9d..9f609d4cf05994c6 100644
|
||||||
|
--- a/XADMaster-1.10.8/XADRAR5Parser.m
|
||||||
|
+++ b/XADMaster-1.10.8/XADRAR5Parser.m
|
||||||
|
@@ -74,12 +74,6 @@ static inline BOOL IsZeroHeaderBlock(RAR5HeaderBlock block) { return IsZeroBlock
|
||||||
|
return 8;
|
||||||
|
}
|
||||||
|
|
||||||
|
-+(BOOL)recognizeFileWithHandle:(CSHandle *)handle firstBytes:(NSData *)data name:(NSString *)name
|
||||||
|
-{
|
||||||
|
- off_t signatureLocation = [self signatureLocationInData:data];
|
||||||
|
- return signatureLocation != RAR5SignatureNotFound;
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
+ (off_t)signatureLocationInData:(NSData *)data {
|
||||||
|
const uint8_t *bytes=[data bytes];
|
||||||
|
int length=[data length];
|
||||||
|
@@ -98,6 +92,12 @@ static inline BOOL IsZeroHeaderBlock(RAR5HeaderBlock block) { return IsZeroBlock
|
||||||
|
return RAR5SignatureNotFound;
|
||||||
|
}
|
||||||
|
|
||||||
|
++(BOOL)recognizeFileWithHandle:(CSHandle *)handle firstBytes:(NSData *)data name:(NSString *)name
|
||||||
|
+{
|
||||||
|
+ off_t signatureLocation = [self signatureLocationInData:data];
|
||||||
|
+ return signatureLocation != RAR5SignatureNotFound;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+(NSArray *)volumesForHandle:(CSHandle *)handle firstBytes:(NSData *)data name:(NSString *)name
|
||||||
|
{
|
||||||
|
// Check if multipart
|
11
unar.spec
11
unar.spec
@ -1,7 +1,7 @@
|
|||||||
%global detectorver 1.1
|
%global detectorver 1.1
|
||||||
Name: unar
|
Name: unar
|
||||||
Version: 1.10.8
|
Version: 1.10.8
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Multi-format extractor
|
Summary: Multi-format extractor
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,6 +10,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://theunarchiver.com/command-line
|
URL: https://theunarchiver.com/command-line
|
||||||
Source: https://github.com/MacPaw/XADMaster/archive/v%{version}/unar-%{version}.tar.gz
|
Source: https://github.com/MacPaw/XADMaster/archive/v%{version}/unar-%{version}.tar.gz
|
||||||
Source1: https://github.com/MacPaw/universal-detector/archive/%{detectorver}/universal-detector-%{detectorver}.tar.gz
|
Source1: https://github.com/MacPaw/universal-detector/archive/%{detectorver}/universal-detector-%{detectorver}.tar.gz
|
||||||
|
Patch0: unar-1.10.8-int-conversion.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -22,17 +23,18 @@ BuildRequires: libstdc++6-devel
|
|||||||
BuildRequires: libwavpack-devel
|
BuildRequires: libwavpack-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libgnustep-base-devel >= 0:1.29.0-1mamba
|
BuildRequires: libgnustep-base-devel >= 0:1.30.0-1mamba
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The command-line utilities lsar and unar are capable of listing and extracting files respectively in several formats including RARv5, RAR support includes encryption and multiple volumes, unar can serve as a free and open source replacement of unrar.
|
The command-line utilities lsar and unar are capable of listing and extracting files respectively in several formats including RARv5, RAR support includes encryption and multiple volumes, unar can serve as a free and open source replacement of unrar.
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -c -a1
|
%setup -q -c -a1
|
||||||
mv universal-detector-%{detectorver} UniversalDetector
|
mv universal-detector-%{detectorver} UniversalDetector
|
||||||
|
|
||||||
|
%patch 0 -p1 -b .int-conversion
|
||||||
|
|
||||||
# recursively remove executable bit from every file, skipping directories
|
# recursively remove executable bit from every file, skipping directories
|
||||||
find . -type f -print0 | xargs -0 chmod -x
|
find . -type f -print0 | xargs -0 chmod -x
|
||||||
|
|
||||||
@ -66,6 +68,9 @@ install -pm644 Extra/unar.bash_completion %{buildroot}%{_datadir}/bash-completio
|
|||||||
%doc XADMaster-%{version}/libxad/lgpl.txt
|
%doc XADMaster-%{version}/libxad/lgpl.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 05 2025 Automatic Build System <autodist@mambasoft.it> 1.10.8-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libgnustep-base-devel>=0:1.30.0-1mamba
|
||||||
|
|
||||||
* Sat Oct 14 2023 Automatic Build System <autodist@mambasoft.it> 1.10.8-1mamba
|
* Sat Oct 14 2023 Automatic Build System <autodist@mambasoft.it> 1.10.8-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user