python 2.7 mass rebuild [release 0.33-3mamba;Sat May 25 2013]
This commit is contained in:
parent
246cb4ec3c
commit
f1c401fa3e
@ -1,2 +1,4 @@
|
||||
# ufw
|
||||
|
||||
Ufw stands for Uncomplicated Firewall, and is program for managing a netfilter firewall. It provides a command line interface and aims to be uncomplicated and easy to use.
|
||||
|
||||
|
12
ufw-0.30.1-enabled_by_default.patch
Normal file
12
ufw-0.30.1-enabled_by_default.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru ufw-0.30.1.orig/conf/ufw.conf ufw-0.30.1/conf/ufw.conf
|
||||
--- ufw-0.30.1.orig/conf/ufw.conf 2011-03-22 19:00:03.000000000 +0100
|
||||
+++ ufw-0.30.1/conf/ufw.conf 2011-11-01 11:59:15.685309653 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
# Set to yes to start on boot. If setting this remotely, be sure to add a rule
|
||||
# to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp'
|
||||
-ENABLED=no
|
||||
+ENABLED=yes
|
||||
|
||||
# Please use the 'ufw' command to set the loglevel. Eg: 'ufw logging medium'.
|
||||
# See 'man ufw' for details.
|
13
ufw-0.30.1-initscript-chkconfig.patch
Normal file
13
ufw-0.30.1-initscript-chkconfig.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Nru ufw-0.30.1/src/ufw-init ufw-0.30.1.patched/src/ufw-init
|
||||
--- ufw-0.30.1/src/ufw-init 2011-03-22 19:00:03.000000000 +0100
|
||||
+++ ufw-0.30.1.patched/src/ufw-init 2011-11-01 02:24:15.287328646 +0100
|
||||
@@ -2,6 +2,9 @@
|
||||
#
|
||||
# ufw-init: helper script to be used by ufw itself
|
||||
#
|
||||
+# chkconfig: 2345 26 91
|
||||
+# description: UFW (Uncomplicated Firewall) init script
|
||||
+#
|
||||
# Copyright 2008-2009 Canonical Ltd.
|
||||
#
|
||||
# This program is free software: you can redistribute it and/or modify
|
10
ufw-0.30.1-load_netbios_ipt_module.patch
Normal file
10
ufw-0.30.1-load_netbios_ipt_module.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff -Nru ufw-0.30.1.orig/conf/ufw.defaults ufw-0.30.1/conf/ufw.defaults
|
||||
--- ufw-0.30.1.orig/conf/ufw.defaults 2011-03-22 19:00:03.000000000 +0100
|
||||
+++ ufw-0.30.1/conf/ufw.defaults 2012-07-11 03:15:14.849308227 +0200
|
||||
@@ -39,5 +39,5 @@
|
||||
IPT_SYSCTL=#CONFIG_PREFIX#/ufw/sysctl.conf
|
||||
|
||||
# extra connection tracking modules to load
|
||||
-IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc"
|
||||
+IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"
|
||||
|
117
ufw.spec
Normal file
117
ufw.spec
Normal file
@ -0,0 +1,117 @@
|
||||
%define subversion 0
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: ufw
|
||||
Version: 0.33
|
||||
Release: 3mamba
|
||||
Summary: ufw is Uncomplicated Firewall a cli front end to iptables
|
||||
Group: System/Libraries/Python
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: https://launchpad.net/ufw
|
||||
Source: http://launchpad.net/ufw/%{majver}/%{version}/+download/ufw-%{version}.tar.gz
|
||||
Patch0: %{name}-0.30.1-initscript-chkconfig.patch
|
||||
Patch1: %{name}-0.30.1-enabled_by_default.patch
|
||||
Patch2: %{name}-0.30.1-load_netbios_ipt_module.patch
|
||||
License: GPL
|
||||
Requires: python >= %python_version
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: iptables
|
||||
BuildRequires: iptables-ipv6
|
||||
Requires: iptables
|
||||
Requires: iptables-ipv6
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Ufw stands for Uncomplicated Firewall, and is program for managing a netfilter firewall. It provides a command line interface and aims to be uncomplicated and easy to use.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
%{__python} setup.py build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python} setup.py install \
|
||||
--root="%{buildroot}"
|
||||
install -D %{buildroot}/lib/ufw/ufw-init %{buildroot}/etc/init.d/ufw-init
|
||||
|
||||
%post
|
||||
# new install
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/chkconfig --add ufw-init
|
||||
service ufw-init restart
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
#erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
service ufw-init stop
|
||||
/sbin/chkconfig --del ufw-init
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/default/ufw
|
||||
%dir %{_sysconfdir}/ufw
|
||||
%config(noreplace) %{_sysconfdir}/ufw/*.rules
|
||||
%config(noreplace) %{_sysconfdir}/ufw/*.conf
|
||||
%{_sysconfdir}/init.d/ufw-init
|
||||
%dir %{_sysconfdir}/ufw/applications.d
|
||||
%{_sysconfdir}/ufw/applications.d/ufw-*
|
||||
%{_sbindir}/ufw
|
||||
%dir /lib/ufw
|
||||
/lib/ufw/ufw-init
|
||||
/lib/ufw/ufw-init-functions
|
||||
/lib/ufw/user.rules
|
||||
/lib/ufw/user6.rules
|
||||
%dir %{_datadir}/ufw
|
||||
%dir %{_datadir}/ufw/iptables
|
||||
%{_datadir}/ufw/iptables/*.rules
|
||||
%{python_sitearch}/ufw-%{version}-py*.egg-info
|
||||
%{python_sitearch}/ufw/*.py
|
||||
%{python_sitearch}/ufw/*.pyc
|
||||
%{_mandir}/man8/*.8.gz
|
||||
%{_datadir}/ufw/messages/*.mo
|
||||
|
||||
%changelog
|
||||
* Sat May 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.33-3mamba
|
||||
- python 2.7 mass rebuild
|
||||
|
||||
* Wed Sep 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.33-2mamba
|
||||
- don't replace *.rules configuration files on upgrade
|
||||
|
||||
* Tue Sep 04 2012 Automatic Build System <autodist@mambasoft.it> 0.33-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 11 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.30.1-4mamba
|
||||
- load netbios ipt module by default to make samba work
|
||||
|
||||
* Tue Nov 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.30.1-3mamba
|
||||
- added patch to enable ufw by default
|
||||
|
||||
* Tue Nov 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.30.1-2mamba
|
||||
- initscript: add chkconfig support and enable by default
|
||||
|
||||
* Mon Oct 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.30.1-1mamba
|
||||
- update to 0.30.1
|
||||
|
||||
* Fri Mar 18 2011 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.30.0-1mamba
|
||||
- update to 0.30.3
|
||||
|
||||
* Wed Jul 07 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.29.3-2mamba
|
||||
- added pre and postun scripts
|
||||
|
||||
* Wed Jul 07 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.29.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user