added a patch to fix libexecdir in systemd file [release 1.0.5-2mamba;Tue Apr 01 2014]
This commit is contained in:
parent
db7ca4a625
commit
3efc2c0d26
@ -1,2 +1,4 @@
|
|||||||
# udisks
|
# udisks
|
||||||
|
|
||||||
|
UDisks provides a daemon, D-Bus API and command line tools for managing disks and storage devices.
|
||||||
|
|
||||||
|
124
udisks-1.0.1-Update-to-latest-LVM2-API.patch
Normal file
124
udisks-1.0.1-Update-to-latest-LVM2-API.patch
Normal file
@ -0,0 +1,124 @@
|
|||||||
|
From 2b2fcf80841972b70ad695a5a1ed74487d4fd37a Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Zeuthen <davidz@redhat.com>
|
||||||
|
Date: Wed, 19 May 2010 13:01:31 -0400
|
||||||
|
Subject: [PATCH] Update to latest LVM2 API
|
||||||
|
|
||||||
|
See
|
||||||
|
|
||||||
|
http://lists.freedesktop.org/archives/devkit-devel/2010-April/000783.html
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
src/probers/udisks-lvm-pv-export.c | 30 ++++++++++--------------------
|
||||||
|
2 files changed, 11 insertions(+), 21 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 469be5f..a9141bf 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -170,7 +170,7 @@ AC_SUBST(DEVMAPPER_LIBS)
|
||||||
|
have_lvm2=no
|
||||||
|
AC_ARG_ENABLE(lvm2, AS_HELP_STRING([--disable-lvm2], [disable LVM2 support]))
|
||||||
|
if test "x$enable_lvm2" != "xno"; then
|
||||||
|
- PKG_CHECK_MODULES(LVM2, lvm2app >= 2.1,
|
||||||
|
+ PKG_CHECK_MODULES(LVM2, lvm2app >= 2.2,
|
||||||
|
[AC_DEFINE(HAVE_LVM2, 1, [Define if LVM2 is available]) have_lvm2=yes],
|
||||||
|
have_lvm2=no)
|
||||||
|
AC_SUBST(LVM2_CFLAGS)
|
||||||
|
diff --git a/src/probers/udisks-lvm-pv-export.c b/src/probers/udisks-lvm-pv-export.c
|
||||||
|
index 5675fb8..ee6d8ed 100644
|
||||||
|
--- a/src/probers/udisks-lvm-pv-export.c
|
||||||
|
+++ b/src/probers/udisks-lvm-pv-export.c
|
||||||
|
@@ -47,7 +47,7 @@ find_vg_for_pv_uuid (lvm_t lvm_ctx,
|
||||||
|
struct lvm_pv_list *pv_list;
|
||||||
|
dm_list_iterate_items (pv_list, pvs)
|
||||||
|
{
|
||||||
|
- char *uuid;
|
||||||
|
+ const char *uuid;
|
||||||
|
pv_t pv = pv_list->pv;
|
||||||
|
|
||||||
|
uuid = lvm_pv_get_uuid (pv);
|
||||||
|
@@ -58,10 +58,8 @@ find_vg_for_pv_uuid (lvm_t lvm_ctx,
|
||||||
|
if (out_pv != NULL)
|
||||||
|
*out_pv = pv;
|
||||||
|
ret = vg;
|
||||||
|
- dm_free (uuid);
|
||||||
|
goto out;
|
||||||
|
}
|
||||||
|
- dm_free (uuid);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -79,12 +77,12 @@ find_vg_for_pv_uuid (lvm_t lvm_ctx,
|
||||||
|
static void
|
||||||
|
print_vg (vg_t vg)
|
||||||
|
{
|
||||||
|
- char *s;
|
||||||
|
+ const char *s;
|
||||||
|
struct dm_list *pvs;
|
||||||
|
struct dm_list *lvs;
|
||||||
|
|
||||||
|
- s = lvm_vg_get_uuid (vg); g_print ("UDISKS_LVM2_PV_VG_UUID=%s\n", s); dm_free (s);
|
||||||
|
- s = lvm_vg_get_name (vg); g_print ("UDISKS_LVM2_PV_VG_NAME=%s\n", s); dm_free (s);
|
||||||
|
+ s = lvm_vg_get_uuid (vg); g_print ("UDISKS_LVM2_PV_VG_UUID=%s\n", s);
|
||||||
|
+ s = lvm_vg_get_name (vg); g_print ("UDISKS_LVM2_PV_VG_NAME=%s\n", s);
|
||||||
|
g_print ("UDISKS_LVM2_PV_VG_SIZE=%" G_GUINT64_FORMAT "\n", lvm_vg_get_size (vg));
|
||||||
|
g_print ("UDISKS_LVM2_PV_VG_FREE_SIZE=%" G_GUINT64_FORMAT "\n", lvm_vg_get_free_size (vg));
|
||||||
|
g_print ("UDISKS_LVM2_PV_VG_EXTENT_SIZE=%" G_GUINT64_FORMAT "\n", lvm_vg_get_extent_size (vg));
|
||||||
|
@@ -117,17 +115,14 @@ print_vg (vg_t vg)
|
||||||
|
str = g_string_new (NULL);
|
||||||
|
dm_list_iterate_items (pv_list, pvs)
|
||||||
|
{
|
||||||
|
- char *uuid;
|
||||||
|
+ const char *uuid;
|
||||||
|
guint64 size;
|
||||||
|
guint64 free_size;
|
||||||
|
pv_t pv = pv_list->pv;
|
||||||
|
|
||||||
|
uuid = lvm_pv_get_uuid (pv);
|
||||||
|
if (uuid != NULL)
|
||||||
|
- {
|
||||||
|
- g_string_append_printf (str, "uuid=%s", uuid);
|
||||||
|
- dm_free (uuid);
|
||||||
|
- }
|
||||||
|
+ g_string_append_printf (str, "uuid=%s", uuid);
|
||||||
|
size = lvm_pv_get_size (pv);
|
||||||
|
g_string_append_printf (str, ";size=%" G_GUINT64_FORMAT, size);
|
||||||
|
free_size = lvm_pv_get_free (pv);
|
||||||
|
@@ -173,8 +168,8 @@ print_vg (vg_t vg)
|
||||||
|
str = g_string_new (NULL);
|
||||||
|
dm_list_iterate_items (lv_list, lvs)
|
||||||
|
{
|
||||||
|
- char *uuid;
|
||||||
|
- char *name;
|
||||||
|
+ const char *uuid;
|
||||||
|
+ const char *name;
|
||||||
|
gboolean is_active;
|
||||||
|
guint64 size;
|
||||||
|
lv_t lv = lv_list->lv;
|
||||||
|
@@ -195,11 +190,6 @@ print_vg (vg_t vg)
|
||||||
|
g_string_append_printf (str, "active=%d", is_active);
|
||||||
|
g_string_append_c (str, ' ');
|
||||||
|
}
|
||||||
|
-
|
||||||
|
- if (uuid != NULL)
|
||||||
|
- dm_free (uuid);
|
||||||
|
- if (name != NULL)
|
||||||
|
- dm_free (name);
|
||||||
|
}
|
||||||
|
g_print ("UDISKS_LVM2_PV_VG_LV_LIST=%s\n", str->str);
|
||||||
|
g_string_free (str, TRUE);
|
||||||
|
@@ -212,9 +202,9 @@ print_vg (vg_t vg)
|
||||||
|
static void
|
||||||
|
print_pv (pv_t pv)
|
||||||
|
{
|
||||||
|
- char *s;
|
||||||
|
+ const char *s;
|
||||||
|
|
||||||
|
- s = lvm_pv_get_uuid (pv); g_print ("UDISKS_LVM2_PV_UUID=%s\n", s); dm_free (s);
|
||||||
|
+ s = lvm_pv_get_uuid (pv); g_print ("UDISKS_LVM2_PV_UUID=%s\n", s);
|
||||||
|
g_print ("UDISKS_LVM2_PV_NUM_MDA=%" G_GUINT64_FORMAT "\n", lvm_pv_get_mda_count (pv));
|
||||||
|
|
||||||
|
/* TODO: ask for more API in liblvm - pvdisplay(8) suggests more information
|
||||||
|
--
|
||||||
|
1.7.0.1
|
||||||
|
|
28
udisks-1.0.4-udev-197.patch
Normal file
28
udisks-1.0.4-udev-197.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
commit c73b5ab54378ec6d7df9948c46ce87f98587af9a
|
||||||
|
Author: Tom Gundersen <teg@jklm.no>
|
||||||
|
Date: 2 days ago
|
||||||
|
|
||||||
|
udev: remove redundant call to deprecated pci-db
|
||||||
|
|
||||||
|
The binary is no longer shipped with systemd/udev. The functionality
|
||||||
|
is taken over by a builtin, which is ran for all devices, rendering
|
||||||
|
this rule superfluous.
|
||||||
|
|
||||||
|
Cc: Jan de Groot <jgc@archlinux.org>
|
||||||
|
Signed-off-by: Tom Gundersen <teg@jklm.no>
|
||||||
|
|
||||||
|
diff --git a/data/80-udisks.rules b/data/80-udisks.rules
|
||||||
|
index d1c8c5d..4bf2b37 100644
|
||||||
|
--- a/data/80-udisks.rules
|
||||||
|
+++ b/data/80-udisks.rules
|
||||||
|
@@ -1,10 +1,6 @@
|
||||||
|
# Do not edit this file, it will be overwritten on updates
|
||||||
|
#
|
||||||
|
|
||||||
|
-# import names for PCI storage controllers
|
||||||
|
-#
|
||||||
|
-SUBSYSTEM=="pci", ACTION=="add|change", ENV{ID_MODEL_FROM_DATABASE}=="", ATTR{class}=="0x01*", IMPORT{program}="pci-db %p"
|
||||||
|
-
|
||||||
|
# Set eSATA port type for known eSATA CardBus adapters - first we want to ensure
|
||||||
|
# the device is on a cardbus controller (upper PCI device) - then we check
|
||||||
|
# vid/pid (lower PCI device)
|
24
udisks-1.0.5-systemd-libexecdir.patch
Normal file
24
udisks-1.0.5-systemd-libexecdir.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru udisks-1.0.5.orig/data/Makefile.am udisks-1.0.5/data/Makefile.am
|
||||||
|
--- udisks-1.0.5.orig/data/Makefile.am 2014-03-10 09:57:48.000000000 +0100
|
||||||
|
+++ udisks-1.0.5/data/Makefile.am 2014-04-01 16:05:56.924208225 +0200
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
systemdservice_DATA = $(systemdservice_in_files:.service.in=.service)
|
||||||
|
|
||||||
|
$(systemdservice_DATA): $(systemdservice_in_files) Makefile
|
||||||
|
- @sed -e "s|\@libexecdir\@|$(prefix)/lib/udisks|" $< > $@
|
||||||
|
+ @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
|
||||||
|
endif
|
||||||
|
|
||||||
|
udevrulesdir = $(slashlibdir)/udev/rules.d
|
||||||
|
diff -Nru udisks-1.0.5.orig/data/Makefile.in udisks-1.0.5/data/Makefile.in
|
||||||
|
--- udisks-1.0.5.orig/data/Makefile.in 2014-03-10 10:04:33.000000000 +0100
|
||||||
|
+++ udisks-1.0.5/data/Makefile.in 2014-04-01 16:06:14.665014923 +0200
|
||||||
|
@@ -722,7 +722,7 @@
|
||||||
|
cp $< $@
|
||||||
|
|
||||||
|
@HAVE_SYSTEMD_TRUE@$(systemdservice_DATA): $(systemdservice_in_files) Makefile
|
||||||
|
-@HAVE_SYSTEMD_TRUE@ @sed -e "s|\@libexecdir\@|$(prefix)/lib/udisks|" $< > $@
|
||||||
|
+@HAVE_SYSTEMD_TRUE@ @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
|
||||||
|
|
||||||
|
clean-local :
|
||||||
|
rm -f *~ $(service_DATA) $(dbusconf_DATA) $(systemdservice_DATA)
|
174
udisks.spec
Normal file
174
udisks.spec
Normal file
@ -0,0 +1,174 @@
|
|||||||
|
Name: udisks
|
||||||
|
Version: 1.0.5
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Storage Management Service
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.freedesktop.org/wiki/Software/udisks
|
||||||
|
Source: http://hal.freedesktop.org/releases/udisks-%{version}.tar.gz
|
||||||
|
Patch0: udisks-1.0.1-Update-to-latest-LVM2-API.patch
|
||||||
|
Patch1: udisks-1.0.4-udev-197.patch
|
||||||
|
Patch2: udisks-1.0.5-systemd-libexecdir.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatasmart-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libdbus-glib-devel
|
||||||
|
BuildRequires: libdevmapper-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libparted-devel
|
||||||
|
BuildRequires: libsg3_utils-devel
|
||||||
|
BuildRequires: polkit-devel
|
||||||
|
BuildRequires: udev-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: intltool
|
||||||
|
BuildRequires: libblkid-devel
|
||||||
|
BuildRequires: libsepol-devel
|
||||||
|
BuildRequires: libuuid-devel
|
||||||
|
Requires: dbus
|
||||||
|
Requires: dosfstools
|
||||||
|
Requires: e2fsprogs
|
||||||
|
Requires: mdadm
|
||||||
|
Requires: mtools
|
||||||
|
Requires: smp_utils
|
||||||
|
Requires: udev
|
||||||
|
Requires: util-linux
|
||||||
|
Requires: xfsprogs
|
||||||
|
Obsoletes: DeviceKit-disks
|
||||||
|
Provides: DeviceKit-disks
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
UDisks provides a daemon, D-Bus API and command line tools for managing disks and storage devices.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: DeviceKit-disks-devel
|
||||||
|
Provides: DeviceKit-disks-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
UDisks provides a daemon, D-Bus API and command line tools for managing disks and storage devices.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package apidocs
|
||||||
|
Summary: %{name} API documentation
|
||||||
|
Group: Documentation
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Obsoletes: DeviceKit-disks-apidocs
|
||||||
|
Provides: DeviceKit-disks-apidocs
|
||||||
|
|
||||||
|
%description apidocs
|
||||||
|
UDisks provides a daemon, D-Bus API and command line tools for managing disks and storage devices.
|
||||||
|
|
||||||
|
This package contains %{name} API documentation.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--enable-gtk-doc
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
ln -s udisks %{buildroot}%{_bindir}/devkit-disks
|
||||||
|
ln -s udisks.1 %{buildroot}%{_datadir}/man/man1/devkit-disks.1
|
||||||
|
|
||||||
|
chmod 644 %{buildroot}%{_sysconfdir}/profile.d/udisks-bash-completion.sh
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sysconfdir}/avahi/services/udisks.service
|
||||||
|
%{_sysconfdir}/dbus-1/system.d/*.conf
|
||||||
|
%{_sysconfdir}/profile.d/udisks-bash-completion.sh
|
||||||
|
%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
|
||||||
|
#%attr(0700,root,root) %dir %{_localstatedir}/run/udisks
|
||||||
|
/lib/systemd/system/udisks.service
|
||||||
|
/lib/udev/rules.d/80-udisks.rules
|
||||||
|
/lib/udev/udisks-dm-export
|
||||||
|
#/lib/udev/udisks-lvm-pv-export
|
||||||
|
/lib/udev/udisks-part-id
|
||||||
|
/lib/udev/udisks-probe-ata-smart
|
||||||
|
/lib/udev/udisks-probe-sas-expander
|
||||||
|
/sbin/umount.udisks
|
||||||
|
%{_bindir}/udisks
|
||||||
|
%{_bindir}/udisks-tcp-bridge
|
||||||
|
%{_bindir}/devkit-disks
|
||||||
|
#%{_libdir}/polkit-1/extensions/libudisks-action-lookup.so
|
||||||
|
%{_datadir}/polkit-1/actions/*.policy
|
||||||
|
%{_libexecdir}/udisks-daemon
|
||||||
|
%{_libexecdir}/udisks-helper-ata-smart-collect
|
||||||
|
%{_libexecdir}/udisks-helper-ata-smart-selftest
|
||||||
|
%{_libexecdir}/udisks-helper-change-filesystem-label
|
||||||
|
%{_libexecdir}/udisks-helper-change-luks-password
|
||||||
|
%{_libexecdir}/udisks-helper-create-partition
|
||||||
|
%{_libexecdir}/udisks-helper-create-partition-table
|
||||||
|
%{_libexecdir}/udisks-helper-delete-partition
|
||||||
|
%{_libexecdir}/udisks-helper-drive-benchmark
|
||||||
|
%{_libexecdir}/udisks-helper-drive-detach
|
||||||
|
%{_libexecdir}/udisks-helper-drive-poll
|
||||||
|
%{_libexecdir}/udisks-helper-fstab-mounter
|
||||||
|
%{_libexecdir}/udisks-helper-linux-md-check
|
||||||
|
%{_libexecdir}/udisks-helper-linux-md-remove-component
|
||||||
|
%{_libexecdir}/udisks-helper-mdadm-expand
|
||||||
|
%{_libexecdir}/udisks-helper-mkfs
|
||||||
|
%{_libexecdir}/udisks-helper-modify-partition
|
||||||
|
%{_datadir}/dbus-1/system-services/org.freedesktop.UDisks.service
|
||||||
|
%{_mandir}/man1/udisks.1.gz
|
||||||
|
%{_mandir}/man7/udisks.7.gz
|
||||||
|
%{_mandir}/man8/udisks-daemon.8.gz
|
||||||
|
%{_mandir}/man1/udisks-tcp-bridge.1.gz
|
||||||
|
%{_mandir}/man1/devkit-disks.1.gz
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/dbus-1/interfaces/org.freedesktop.UDisks*.xml
|
||||||
|
#%{_libdir}/polkit-1/extensions/libudisks-action-lookup.*a
|
||||||
|
%{_datadir}/pkgconfig/udisks.pc
|
||||||
|
%doc HACKING NEWS README doc/TODO
|
||||||
|
|
||||||
|
%files apidocs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gtk-doc/html/udisks
|
||||||
|
%{_datadir}/gtk-doc/html/udisks/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.5-2mamba
|
||||||
|
- added a patch to fix libexecdir in systemd file
|
||||||
|
|
||||||
|
* Sat Mar 15 2014 Automatic Build System <autodist@mambasoft.it> 1.0.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Feb 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.4-2mamba
|
||||||
|
- patch: drop rule using pci-db missing in udev >= 197
|
||||||
|
|
||||||
|
* Tue Apr 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.4-1mamba
|
||||||
|
- update to 1.0.4
|
||||||
|
|
||||||
|
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 1.0.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Feb 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-1mamba
|
||||||
|
- update to 1.0.2
|
||||||
|
|
||||||
|
* Wed Oct 27 2010 gil <puntogil@libero.it> 1.0.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user