automatic rebuild by autodist [release 0.36-2mamba;Sun Aug 11 2013]
This commit is contained in:
parent
f67b494220
commit
f5713b2d10
@ -1,2 +1,6 @@
|
||||
# ucspi-unix
|
||||
|
||||
unixclient and unixserver are command-line tools for building UNIX domain client-server applications. unixclient connects to a UNIX domain socket and runs a program of your choice. unixserver creates a UNIX domain socket, waits for incoming connections and, for each connection, runs a program of your choice.
|
||||
|
||||
unixclient and unixserver conform to UCSPI, the UNIX Client-Server Program Interface, using UNIX domain sockets. UCSPI tools are available for several different networks.
|
||||
|
||||
|
20
ucspi-unix-0.36-fixbuild.patch
Normal file
20
ucspi-unix-0.36-fixbuild.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -ru ucspi-unix-0.36.orig/conf-cc ucspi-unix-0.36/conf-cc
|
||||
--- ucspi-unix-0.36.orig/conf-cc 2002-06-10 23:12:06.000000000 +0200
|
||||
+++ ucspi-unix-0.36/conf-cc 2009-09-22 17:17:50.297617079 +0200
|
||||
@@ -1,3 +1,3 @@
|
||||
-gcc -W -Wall -O -g -I/usr/local/bglibs/include
|
||||
+gcc -W -Wall -O -g -I/usr/include/bglibs
|
||||
|
||||
This will be used to compile .c files.
|
||||
diff -ru ucspi-unix-0.36.orig/env.c ucspi-unix-0.36/env.c
|
||||
--- ucspi-unix-0.36.orig/env.c 2002-06-10 23:12:06.000000000 +0200
|
||||
+++ ucspi-unix-0.36/env.c 2009-09-22 17:21:05.605372209 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
-#include <sysdeps.h>
|
||||
+//#include <sysdeps.h>
|
||||
|
||||
extern const char* utoa(unsigned long);
|
||||
|
61
ucspi-unix.spec
Normal file
61
ucspi-unix.spec
Normal file
@ -0,0 +1,61 @@
|
||||
Name: ucspi-unix
|
||||
Version: 0.36
|
||||
Release: 2mamba
|
||||
Summary: UNIX-domain socket client-server command-line tools
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://untroubled.org/ucspi-unix/
|
||||
Source: http://untroubled.org/ucspi-unix/ucspi-unix-%{version}.tar.gz
|
||||
Patch0: ucspi-unix-0.36-fixbuild.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libbg-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
unixclient and unixserver are command-line tools for building UNIX domain client-server applications. unixclient connects to a UNIX domain socket and runs a program of your choice. unixserver creates a UNIX domain socket, waits for incoming connections and, for each connection, runs a program of your choice.
|
||||
|
||||
unixclient and unixserver conform to UCSPI, the UNIX Client-Server Program Interface, using UNIX domain sockets. UCSPI tools are available for several different networks.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
echo %{_bindir} >conf-bin
|
||||
echo %{_mandir} >conf-man
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
rm -fr %{buildroot}
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
mkdir -p %{buildroot}%{_mandir}
|
||||
echo %{buildroot}%{_bindir} >conf-bin
|
||||
echo %{buildroot}%{_mandir} >conf-man
|
||||
make installer instcheck
|
||||
./installer
|
||||
./instcheck
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/unixcat
|
||||
%{_bindir}/unixclient
|
||||
%{_bindir}/unixserver
|
||||
%{_mandir}/man1/unixclient.1.gz
|
||||
%{_mandir}/man1/unixserver.1.gz
|
||||
%doc COPYING NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Sun Aug 11 2013 Automatic Build System <autodist@mambasoft.it> 0.36-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Sep 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.36-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user