automatic version update by autodist [release 2014b-1mamba;Fri Mar 28 2014]
This commit is contained in:
parent
25c293a645
commit
fd4a9484b3
@ -1,2 +1,4 @@
|
|||||||
# tzdata
|
# tzdata
|
||||||
|
|
||||||
|
This package contains data files with rules for various timezones around the world.
|
||||||
|
|
||||||
|
34
javazic-fixup.patch
Normal file
34
javazic-fixup.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
--- sun/util/calendar/LocalGregorianCalendar.java.keiths 2007-09-07 14:48:19.000000000 -0700
|
||||||
|
+++ sun/util/calendar/LocalGregorianCalendar.java 2007-09-07 14:52:58.000000000 -0700
|
||||||
|
@@ -120,8 +120,7 @@ public class LocalGregorianCalendar exte
|
||||||
|
static LocalGregorianCalendar getLocalGregorianCalendar(String name) {
|
||||||
|
Properties calendarProps = null;
|
||||||
|
try {
|
||||||
|
- String homeDir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("java.home"));
|
||||||
|
+ String homeDir = (String) System.getProperty("java.home");
|
||||||
|
final String fname = homeDir + File.separator + "lib" + File.separator
|
||||||
|
+ "calendars.properties";
|
||||||
|
calendarProps = (Properties) AccessController.doPrivileged(new PrivilegedExceptionAction() {
|
||||||
|
--- sun/util/calendar/ZoneInfoFile.java.keiths 2007-09-07 14:54:58.000000000 -0700
|
||||||
|
+++ sun/util/calendar/ZoneInfoFile.java 2007-09-07 14:55:36.000000000 -0700
|
||||||
|
@@ -1021,8 +1021,7 @@ public class ZoneInfoFile {
|
||||||
|
byte[] buffer = null;
|
||||||
|
|
||||||
|
try {
|
||||||
|
- String zi_dir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("user.zoneinfo.dir"));
|
||||||
|
+ String zi_dir = (String) System.getProperty("user.zoneinfo.dir");
|
||||||
|
File dir = null;
|
||||||
|
if (zi_dir != null)
|
||||||
|
dir = new File(zi_dir);
|
||||||
|
@@ -1035,8 +1034,7 @@ public class ZoneInfoFile {
|
||||||
|
}
|
||||||
|
|
||||||
|
if (dir == null) {
|
||||||
|
- String homeDir = (String) AccessController.doPrivileged(
|
||||||
|
- new sun.security.action.GetPropertyAction("java.home"));
|
||||||
|
+ String homeDir = (String) System.getProperty("java.home");
|
||||||
|
zi_dir = homeDir + File.separator + "lib" + File.separator
|
||||||
|
+ "zi";
|
||||||
|
}
|
303
tzdata-2011b-c.patch
Normal file
303
tzdata-2011b-c.patch
Normal file
@ -0,0 +1,303 @@
|
|||||||
|
diff -r -c tzdata2011b/leapseconds tzdata2011b/leapseconds
|
||||||
|
*** tzdata2011b/leapseconds Thu Dec 16 12:24:20 2010
|
||||||
|
--- tzdata2011b/leapseconds Mon Feb 14 09:30:33 2011
|
||||||
|
***************
|
||||||
|
*** 1,5 ****
|
||||||
|
# <pre>
|
||||||
|
! # @(#)leapseconds 8.10
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
--- 1,5 ----
|
||||||
|
# <pre>
|
||||||
|
! # @(#)leapseconds 8.11
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
***************
|
||||||
|
*** 56,68 ****
|
||||||
|
# SERVICE DE LA ROTATION TERRESTRE
|
||||||
|
# OBSERVATOIRE DE PARIS
|
||||||
|
# 61, Av. de l'Observatoire 75014 PARIS (France)
|
||||||
|
! # Tel. : 33 (0) 1 40 51 22 26
|
||||||
|
# FAX : 33 (0) 1 40 51 22 91
|
||||||
|
# Internet : services.iers@obspm.fr
|
||||||
|
#
|
||||||
|
! # Paris, 14 July 2010
|
||||||
|
#
|
||||||
|
! # Bulletin C 40
|
||||||
|
#
|
||||||
|
# To authorities responsible
|
||||||
|
# for the measurement and
|
||||||
|
--- 56,68 ----
|
||||||
|
# SERVICE DE LA ROTATION TERRESTRE
|
||||||
|
# OBSERVATOIRE DE PARIS
|
||||||
|
# 61, Av. de l'Observatoire 75014 PARIS (France)
|
||||||
|
! # Tel. : 33 (0) 1 40 51 22 29
|
||||||
|
# FAX : 33 (0) 1 40 51 22 91
|
||||||
|
# Internet : services.iers@obspm.fr
|
||||||
|
#
|
||||||
|
! # Paris, 2 February 2011
|
||||||
|
#
|
||||||
|
! # Bulletin C 41
|
||||||
|
#
|
||||||
|
# To authorities responsible
|
||||||
|
# for the measurement and
|
||||||
|
***************
|
||||||
|
*** 70,78 ****
|
||||||
|
#
|
||||||
|
# INFORMATION ON UTC - TAI
|
||||||
|
#
|
||||||
|
! # NO positive leap second will be introduced at the end of December 2010.
|
||||||
|
# The difference between Coordinated Universal Time UTC and the
|
||||||
|
! # International Atomic Time TAI is :
|
||||||
|
#
|
||||||
|
# from 2009 January 1, 0h UTC, until further notice : UTC-TAI = -34 s
|
||||||
|
#
|
||||||
|
--- 70,78 ----
|
||||||
|
#
|
||||||
|
# INFORMATION ON UTC - TAI
|
||||||
|
#
|
||||||
|
! # NO positive leap second will be introduced at the end of June 2011.
|
||||||
|
# The difference between Coordinated Universal Time UTC and the
|
||||||
|
! # International Atomic Time TAI is :
|
||||||
|
#
|
||||||
|
# from 2009 January 1, 0h UTC, until further notice : UTC-TAI = -34 s
|
||||||
|
#
|
||||||
|
***************
|
||||||
|
*** 82,87 ****
|
||||||
|
# will be no time step at the next possible date.
|
||||||
|
#
|
||||||
|
# Daniel GAMBIS
|
||||||
|
! # Director
|
||||||
|
! # Earth Orientation Center of IERS
|
||||||
|
# Observatoire de Paris, France
|
||||||
|
--- 82,87 ----
|
||||||
|
# will be no time step at the next possible date.
|
||||||
|
#
|
||||||
|
# Daniel GAMBIS
|
||||||
|
! # Head
|
||||||
|
! # Earth Orientation Center of the IERS
|
||||||
|
# Observatoire de Paris, France
|
||||||
|
diff -r -c tzdata2011b/northamerica tzdata2011b/northamerica
|
||||||
|
*** tzdata2011b/northamerica Wed Jan 26 17:13:48 2011
|
||||||
|
--- tzdata2011b/northamerica Wed Feb 9 14:00:33 2011
|
||||||
|
***************
|
||||||
|
*** 1,5 ****
|
||||||
|
# <pre>
|
||||||
|
! # @(#)northamerica 8.40
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
--- 1,5 ----
|
||||||
|
# <pre>
|
||||||
|
! # @(#)northamerica 8.41
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
***************
|
||||||
|
*** 426,431 ****
|
||||||
|
--- 426,473 ----
|
||||||
|
# were nearby inhabitants in some cases and for our purposes perhaps
|
||||||
|
# it's best to simply use the official transition.
|
||||||
|
#
|
||||||
|
+
|
||||||
|
+ # From Steve Ferguson (2011-01-31):
|
||||||
|
+ # The author lives in Alaska and many of the references listed are only
|
||||||
|
+ # available to Alaskan residents.
|
||||||
|
+ #
|
||||||
|
+ # <a href="http://www.alaskahistoricalsociety.org/index.cfm?section=discover%20alaska&page=Glimpses%20of%20the%20Past&viewpost=2&ContentId=98">
|
||||||
|
+ # http://www.alaskahistoricalsociety.org/index.cfm?section=discover%20alaska&page=Glimpses%20of%20the%20Past&viewpost=2&ContentId=98
|
||||||
|
+ # </a>
|
||||||
|
+
|
||||||
|
+ # From Arthur David Olson (2011-02-01):
|
||||||
|
+ # Here's database-relevant material from the 2001 "Alaska History" article:
|
||||||
|
+ #
|
||||||
|
+ # On September 20 [1979]...DOT...officials decreed that on April 27,
|
||||||
|
+ # 1980, Juneau and other nearby communities would move to Yukon Time.
|
||||||
|
+ # Sitka, Petersburg, Wrangell, and Ketchikan, however, would remain on
|
||||||
|
+ # Pacific Time.
|
||||||
|
+ #
|
||||||
|
+ # ...on September 22, 1980, DOT Secretary Neil E. Goldschmidt rescinded the
|
||||||
|
+ # Department's September 1979 decision. Juneau and other communities in
|
||||||
|
+ # northern Southeast reverted to Pacific Time on October 26.
|
||||||
|
+ #
|
||||||
|
+ # On October 28 [1983]...the Metlakatla Indian Community Council voted
|
||||||
|
+ # unanimously to keep the reservation on Pacific Time.
|
||||||
|
+ #
|
||||||
|
+ # According to DOT official Joanne Petrie, Indian reservations are not
|
||||||
|
+ # bound to follow time zones imposed by neighboring jurisdictions.
|
||||||
|
+ #
|
||||||
|
+ # (The last is consistent with how the database now handles the Navajo
|
||||||
|
+ # Nation.)
|
||||||
|
+
|
||||||
|
+ # From Arthur David Olson (2011-02-09):
|
||||||
|
+ # I just spoke by phone with a staff member at the Metlakatla Indian
|
||||||
|
+ # Community office (using contact information available at
|
||||||
|
+ # <a href="http://www.commerce.state.ak.us/dca/commdb/CIS.cfm?Comm_Boro_name=Metlakatla">
|
||||||
|
+ # http://www.commerce.state.ak.us/dca/commdb/CIS.cfm?Comm_Boro_name=Metlakatla
|
||||||
|
+ # </a>).
|
||||||
|
+ # It's shortly after 1:00 here on the east coast of the United States;
|
||||||
|
+ # the staffer said it was shortly after 10:00 there. When I asked whether
|
||||||
|
+ # that meant they were on Pacific time, they said no--they were on their
|
||||||
|
+ # own time. I asked about daylight saving; they said it wasn't used. I
|
||||||
|
+ # did not inquire about practices in the past.
|
||||||
|
+
|
||||||
|
# Zone NAME GMTOFF RULES FORMAT [UNTIL]
|
||||||
|
Zone America/Juneau 15:02:19 - LMT 1867 Oct 18
|
||||||
|
-8:57:41 - LMT 1900 Aug 20 12:00
|
||||||
|
***************
|
||||||
|
*** 432,440 ****
|
||||||
|
--- 474,499 ----
|
||||||
|
-8:00 - PST 1942
|
||||||
|
-8:00 US P%sT 1946
|
||||||
|
-8:00 - PST 1969
|
||||||
|
+ -8:00 US P%sT 1980 Apr 27 2:00
|
||||||
|
+ -9:00 US Y%sT 1980 Oct 26 2:00
|
||||||
|
-8:00 US P%sT 1983 Oct 30 2:00
|
||||||
|
-9:00 US Y%sT 1983 Nov 30
|
||||||
|
-9:00 US AK%sT
|
||||||
|
+ Zone America/Sitka -14:58:47 - LMT 1867 Oct 18
|
||||||
|
+ -9:01:13 - LMT 1900 Aug 20 12:00
|
||||||
|
+ -8:00 - PST 1942
|
||||||
|
+ -8:00 US P%sT 1946
|
||||||
|
+ -8:00 - PST 1969
|
||||||
|
+ -8:00 US P%sT 1983 Oct 30 2:00
|
||||||
|
+ -9:00 US Y%sT 1983 Nov 30
|
||||||
|
+ -9:00 US AK%sT
|
||||||
|
+ Zone America/Metlakatla 15:13:42 - LMT 1867 Oct 18
|
||||||
|
+ -8:46:18 - LMT 1900 Aug 20 12:00
|
||||||
|
+ -8:00 - PST 1942
|
||||||
|
+ -8:00 US P%sT 1946
|
||||||
|
+ -8:00 - PST 1969
|
||||||
|
+ -8:00 US P%sT 1983 Oct 30 2:00
|
||||||
|
+ -8:00 US MeST
|
||||||
|
Zone America/Yakutat 14:41:05 - LMT 1867 Oct 18
|
||||||
|
-9:18:55 - LMT 1900 Aug 20 12:00
|
||||||
|
-9:00 - YST 1942
|
||||||
|
diff -r -c tzdata2011b/southamerica tzdata2011b/southamerica
|
||||||
|
*** tzdata2011b/southamerica Thu Dec 16 12:24:20 2010
|
||||||
|
--- tzdata2011b/southamerica Wed Mar 2 12:47:20 2011
|
||||||
|
***************
|
||||||
|
*** 1,5 ****
|
||||||
|
# <pre>
|
||||||
|
! # @(#)southamerica 8.44
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
--- 1,5 ----
|
||||||
|
# <pre>
|
||||||
|
! # @(#)southamerica 8.45
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
|
||||||
|
***************
|
||||||
|
*** 1154,1159 ****
|
||||||
|
--- 1154,1176 ----
|
||||||
|
# From Arthur Daivd Olson (2010-03-06):
|
||||||
|
# Angel Chiang's message confirmed by Julio Pacheco; Julio provided a patch.
|
||||||
|
|
||||||
|
+ # From Glenn Eychaner (2011-03-02): [geychaner@mac.com]
|
||||||
|
+ # It appears that the Chilean government has decided to postpone the
|
||||||
|
+ # change from summer time to winter time again, by three weeks to April
|
||||||
|
+ # 2nd:
|
||||||
|
+ # <a href="http://www.emol.com/noticias/nacional/detalle/detallenoticias.asp?idnoticia=467651">
|
||||||
|
+ # http://www.emol.com/noticias/nacional/detalle/detallenoticias.asp?idnoticia=467651
|
||||||
|
+ # </a>
|
||||||
|
+ #
|
||||||
|
+ # This is not yet reflected in the offical "cambio de hora" site, but
|
||||||
|
+ # probably will be soon:
|
||||||
|
+ # <a href="http://www.horaoficial.cl/cambio.htm">
|
||||||
|
+ # http://www.horaoficial.cl/cambio.htm
|
||||||
|
+ # </a>
|
||||||
|
+
|
||||||
|
+ # From Arthur David Olson (2011-03-02):
|
||||||
|
+ # The emol.com article mentions a water shortage as the cause of the
|
||||||
|
+ # postponement, which may mean that it's not a permanent change.
|
||||||
|
# Rule NAME FROM TO TYPE IN ON AT SAVE LETTER/S
|
||||||
|
Rule Chile 1927 1932 - Sep 1 0:00 1:00 S
|
||||||
|
Rule Chile 1928 1932 - Apr 1 0:00 0 -
|
||||||
|
***************
|
||||||
|
*** 1189,1196 ****
|
||||||
|
# which is used below in specifying the transition.
|
||||||
|
Rule Chile 2008 only - Mar 30 3:00u 0 -
|
||||||
|
Rule Chile 2009 only - Mar Sun>=9 3:00u 0 -
|
||||||
|
! Rule Chile 2010 only - Apr 4 3:00u 0 -
|
||||||
|
! Rule Chile 2011 max - Mar Sun>=9 3:00u 0 -
|
||||||
|
# IATA SSIM anomalies: (1992-02) says 1992-03-14;
|
||||||
|
# (1996-09) says 1998-03-08. Ignore these.
|
||||||
|
# Zone NAME GMTOFF RULES FORMAT [UNTIL]
|
||||||
|
--- 1206,1213 ----
|
||||||
|
# which is used below in specifying the transition.
|
||||||
|
Rule Chile 2008 only - Mar 30 3:00u 0 -
|
||||||
|
Rule Chile 2009 only - Mar Sun>=9 3:00u 0 -
|
||||||
|
! Rule Chile 2010 2011 - Apr Sun>=1 3:00u 0 -
|
||||||
|
! Rule Chile 2012 max - Mar Sun>=9 3:00u 0 -
|
||||||
|
# IATA SSIM anomalies: (1992-02) says 1992-03-14;
|
||||||
|
# (1996-09) says 1998-03-08. Ignore these.
|
||||||
|
# Zone NAME GMTOFF RULES FORMAT [UNTIL]
|
||||||
|
diff -r -c tzdata2011b/tz-art.htm tzdata2011b/tz-art.htm
|
||||||
|
*** tzcode2011b/tz-art.htm Wed Jan 19 13:47:16 2011
|
||||||
|
--- tzcode2011b/tz-art.htm Mon Feb 14 16:22:50 2011
|
||||||
|
***************
|
||||||
|
*** 9,15 ****
|
||||||
|
<body>
|
||||||
|
<h1>Time and the Arts</h1>
|
||||||
|
<address>
|
||||||
|
! @(#)tz-art.htm 8.19
|
||||||
|
</address>
|
||||||
|
<p>
|
||||||
|
This file is in the public domain, so clarified as of
|
||||||
|
--- 9,15 ----
|
||||||
|
<body>
|
||||||
|
<h1>Time and the Arts</h1>
|
||||||
|
<address>
|
||||||
|
! @(#)tz-art.htm 8.20
|
||||||
|
</address>
|
||||||
|
<p>
|
||||||
|
This file is in the public domain, so clarified as of
|
||||||
|
***************
|
||||||
|
*** 417,422 ****
|
||||||
|
--- 417,427 ----
|
||||||
|
http://us.imdb.com/title/tt0137494/
|
||||||
|
</a>. (Mark Brader, 2009-10-02)
|
||||||
|
</li>
|
||||||
|
+ <li>
|
||||||
|
+ In "The Todd Couple" episode of "Outsourced" (first aired 2011-02-10),
|
||||||
|
+ Manmeet sets up teledates for 6:00 and 9:00;
|
||||||
|
+ since one is with a New Yorker and the other with a San Franciscan,
|
||||||
|
+ hilarity ensues.
|
||||||
|
</li>
|
||||||
|
</ul>
|
||||||
|
<hr>
|
||||||
|
diff -r -c tzdata2011b/zone.tab tzdata2011b/zone.tab
|
||||||
|
*** tzdata2011b/zone.tab Wed Jan 26 18:47:09 2011
|
||||||
|
--- tzdata2011b/zone.tab Wed Feb 9 14:00:33 2011
|
||||||
|
***************
|
||||||
|
*** 1,5 ****
|
||||||
|
# <pre>
|
||||||
|
! # @(#)zone.tab 8.40
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
#
|
||||||
|
--- 1,5 ----
|
||||||
|
# <pre>
|
||||||
|
! # @(#)zone.tab 8.41
|
||||||
|
# This file is in the public domain, so clarified as of
|
||||||
|
# 2009-05-17 by Arthur David Olson.
|
||||||
|
#
|
||||||
|
***************
|
||||||
|
*** 412,420 ****
|
||||||
|
--- 412,422 ----
|
||||||
|
US +340308-1181434 America/Los_Angeles Pacific Time
|
||||||
|
US +611305-1495401 America/Anchorage Alaska Time
|
||||||
|
US +581807-1342511 America/Juneau Alaska Time - Alaska panhandle
|
||||||
|
+ US +571035-1351807 America/Sitka Alaska Time - southeast Alaska panhandle
|
||||||
|
US +593249-1394338 America/Yakutat Alaska Time - Alaska panhandle neck
|
||||||
|
US +643004-1652423 America/Nome Alaska Time - west Alaska
|
||||||
|
US +515248-1763929 America/Adak Aleutian Islands
|
||||||
|
+ US +550737-1313435 America/Metlakatla Metlakatla Time - Annette Island
|
||||||
|
US +211825-1575130 Pacific/Honolulu Hawaii
|
||||||
|
UY -3453-05611 America/Montevideo
|
||||||
|
UZ +3940+06648 Asia/Samarkand west Uzbekistan
|
||||||
|
|
11
tzdata-2011d-kemerovo.patch
Normal file
11
tzdata-2011d-kemerovo.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- tzdata2011d/europe 2011-03-11 04:03:39.000000000 +0100
|
||||||
|
+++ tzdata2011d/europe-gil 2011-03-26 07:52:32.000000000 +0100
|
||||||
|
@@ -2131,7 +2131,7 @@
|
||||||
|
7:00 Russia KRA%sT 1991 Mar 31 2:00s
|
||||||
|
6:00 Russia KRA%sT 1992 Jan 19 2:00s
|
||||||
|
7:00 Russia KRA%sT 2010 Mar 28 2:00s
|
||||||
|
- 6:00 Russia NOV%sT # Novosibirsk/Novokuznetsk Time
|
||||||
|
+ 6:00 Russia OMS%sT # Novosibirsk/Novokuznetsk Time
|
||||||
|
|
||||||
|
#
|
||||||
|
# From Oscar van Vlijmen (2001-08-25): [This region consists of]
|
164
tzdata.spec
Normal file
164
tzdata.spec
Normal file
@ -0,0 +1,164 @@
|
|||||||
|
%define tzcode_version %{version}
|
||||||
|
%define with_openjdk 0
|
||||||
|
%if %with_openjdk
|
||||||
|
%define javahome %{_jvmdir}/jdk
|
||||||
|
%define buildopts -source 1.5 -target 1.5
|
||||||
|
%else
|
||||||
|
%define javahome %{java_home}
|
||||||
|
%define buildopts %{nil}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Name: tzdata
|
||||||
|
Version: 2014b
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: timezone data
|
||||||
|
Group: System/Internationalization
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: ftp://elsie.nci.nih.gov/pub/
|
||||||
|
# wget ftp://distfiles.pld-linux.org/distfiles/by-md5/9/0/906a4c98cc5240f416524a256b039c42/tzdata-base-0.tar.bz2
|
||||||
|
Source0: http://www.iana.org/time-zones/repository/releases/tzdata%{version}.tar.gz
|
||||||
|
#Source1: http://www.iana.org/time-zones/repository/releases/tzcode%{tzcode_version}.tar.gz
|
||||||
|
# the sources are inside the package OpenJDK
|
||||||
|
Source3: javazic.tar.gz
|
||||||
|
Patch0: javazic-fixup.patch
|
||||||
|
Patch1: tzdata-2011b-c.patch
|
||||||
|
Patch2: tzdata-2011d-kemerovo.patch
|
||||||
|
License: Public Domain
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: gawk
|
||||||
|
BuildRequires: glibc
|
||||||
|
BuildRequires: perl
|
||||||
|
BuildRequires: timezone
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
%if %with_openjdk
|
||||||
|
BuildRequires: java-openjdk
|
||||||
|
%else
|
||||||
|
BuildRequires: java-gcj-compat
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package contains data files with rules for various timezones around the world.
|
||||||
|
|
||||||
|
%package java
|
||||||
|
Summary: Timezone data for Java
|
||||||
|
Group: System/Internationalization
|
||||||
|
|
||||||
|
%description java
|
||||||
|
This package contains timezone information for use by Java runtimes.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c
|
||||||
|
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
mkdir javazic
|
||||||
|
tar zxf %{S:3} -C javazic
|
||||||
|
cd javazic
|
||||||
|
%patch0
|
||||||
|
# Hack alert! sun.tools may be defined and installed in the
|
||||||
|
# VM. In order to guarantee that we are using IcedTea/OpenJDK
|
||||||
|
# for creating the zoneinfo files, rebase all the packages
|
||||||
|
# from "sun." to "rht.". Unfortunately, gcj does not support
|
||||||
|
# any of the -Xclasspath options, so we must go this route
|
||||||
|
# to ensure the greatest compatibility.
|
||||||
|
mv sun rht
|
||||||
|
find . -type f -name '*.java' -print0 \
|
||||||
|
| xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
|
||||||
|
-e 's:sun\.util\.:rht.util.:g'
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%build
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
cd javazic
|
||||||
|
%{javahome}/bin/javac %{buildopts} -classpath . `find . -name \*.java`
|
||||||
|
cd ..
|
||||||
|
%{javahome}/bin/java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
|
||||||
|
-d zoneinfo/java \
|
||||||
|
africa antarctica asia australasia backward etcetera europe \
|
||||||
|
northamerica pacificnew southamerica systemv \
|
||||||
|
javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
timezones=('africa' 'antarctica' 'asia' 'australasia'
|
||||||
|
'europe' 'northamerica' 'southamerica'
|
||||||
|
'pacificnew' 'etcetera' 'backward'
|
||||||
|
'systemv' 'factory')
|
||||||
|
|
||||||
|
%{_sbindir}/zic -y ./yearistype -d %{buildroot}%{_datadir}/zoneinfo ${timezones[@]}
|
||||||
|
%{_sbindir}/zic -y ./yearistype -d %{buildroot}%{_datadir}/zoneinfo/posix ${timezones[@]}
|
||||||
|
%{_sbindir}/zic -y ./yearistype -d %{buildroot}%{_datadir}/zoneinfo/right -L leapseconds ${timezones[@]}
|
||||||
|
%{_sbindir}/zic -y ./yearistype -d %{buildroot}%{_datadir}/zoneinfo -p America/New_York
|
||||||
|
install -m444 -t %{buildroot}%{_datadir}/zoneinfo iso3166.tab zone.tab
|
||||||
|
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
cp -pr zoneinfo/java %{buildroot}%{_datadir}/javazi
|
||||||
|
%endif
|
||||||
|
|
||||||
|
# FIXME
|
||||||
|
# *** Timezone: Asia/Tokyo, daylight is: 0 but should be: 1
|
||||||
|
# *** Timezone: Asia/Tokyo, tzname[1] is: JST but should be: JDT
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/zoneinfo
|
||||||
|
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
%files java
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/javazi
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 28 2014 Automatic Build System <autodist@mambasoft.it> 2014b-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 10 2014 Automatic Build System <autodist@mambasoft.it> 2014a-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Feb 08 2014 Automatic Build System <autodist@mambasoft.it> 2013i-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Oct 27 2013 Automatic Build System <autodist@mambasoft.it> 2013h-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 15 2013 Automatic Build System <autodist@mambasoft.it> 2013g-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Sep 01 2013 Automatic Build System <autodist@mambasoft.it> 2013d-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 2013c-1mamba
|
||||||
|
- update to 2013c
|
||||||
|
|
||||||
|
* Fri Apr 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2011d-2mamba
|
||||||
|
- build using %{_java_home}
|
||||||
|
- remove conflict with timezone (will be fixed after glibc update)
|
||||||
|
- add stage1 for non-java build
|
||||||
|
|
||||||
|
* Sat Mar 26 2011 gil <puntogil@libero.it> 2011d-1mamba
|
||||||
|
- update to 2011d
|
||||||
|
|
||||||
|
* Fri Mar 11 2011 gil <puntogil@libero.it> 2011b-2mamba
|
||||||
|
- add fix for kemerovo area should use OMST/OMSST abbreviation
|
||||||
|
- add fix for delay end of DST in chile in 2011 until first sunday in april
|
||||||
|
|
||||||
|
* Wed Feb 16 2011 gil <puntogil@libero.it> 2011b-1mamba
|
||||||
|
- update to 2011b
|
||||||
|
|
||||||
|
* Thu Dec 30 2010 gil <puntogil@libero.it> 2010o-2mamba
|
||||||
|
- rebuilt with java-openjdk
|
||||||
|
|
||||||
|
* Mon Dec 27 2010 gil <puntogil@libero.it> 2010o-1mamba
|
||||||
|
- update to 2010o
|
||||||
|
|
||||||
|
* Tue Feb 24 2009 gil <puntogil@libero.it> 2009b-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user