added build patch against libpng 1.5 [release 0.9.21-2mamba;Sun Apr 06 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 18:44:15 +01:00
parent eadceb16c8
commit a4ce464862
3 changed files with 144 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# tuxpaint
Tux Paint is a free drawing program designed for young children (kids ages 3 and up). It has a simple, easy-to-use interface, fun sound effects, and an encouraging cartoon mascot who helps guide children as they use the program.

View File

@ -0,0 +1,28 @@
--- tuxpaint-0.9.21/src/tuxpaint.c.orig 2014-04-06 15:01:47.705587844 +0000
+++ tuxpaint-0.9.21/src/tuxpaint.c 2014-04-06 15:02:22.850246198 +0000
@@ -12898,13 +12898,7 @@
{
png_init_io(png_ptr, fi);
- info_ptr->width = surf->w;
- info_ptr->height = surf->h;
- info_ptr->bit_depth = 8;
- info_ptr->color_type = PNG_COLOR_TYPE_RGB;
- info_ptr->interlace_type = 1;
- info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */
-
+ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8, PNG_COLOR_TYPE_RGB, 1, PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
PNG_sRGB_INTENT_PERCEPTUAL);
--- tuxpaint-0.9.21/Makefile.orig 2014-04-06 15:16:49.468030974 +0000
+++ tuxpaint-0.9.21/Makefile 2014-04-06 15:17:11.747818328 +0000
@@ -834,7 +834,7 @@
@echo "...Linking Tux Paint..."
$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(FRIBIDI_CFLAGS) $(DEFS) \
-o tuxpaint $^ \
- $(SDL_LIBS) $(SVG_LIB) $(ARCH_LINKS)
+ $(SDL_LIBS) $(SVG_LIB) $(ARCH_LINKS) -lpng
@$(RSRC_CMD)
@$(MIMESET_CMD)

114
tuxpaint.spec Normal file
View File

@ -0,0 +1,114 @@
Name: tuxpaint
Version: 0.9.21
Release: 2mamba
Summary: Free drawing program designed for young children
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.newbreedsoftware.com/tuxpaint/
Source: http://downloads.sourceforge.net/sourceforge/tuxpaint/%{name}-%{version}.tar.gz
Patch0: tuxpaint-0.9.21-libpng-1.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libSDL-devel
BuildRequires: libSDL_Pango-devel
BuildRequires: libSDL_image-devel
BuildRequires: libSDL_mixer-devel
BuildRequires: libSDL_ttf-devel
BuildRequires: libcairo-devel
BuildRequires: libfribidi-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libpaper-devel
BuildRequires: libpng-devel
BuildRequires: librsvg-devel
## AUTOBUILDREQ-END
BuildRequires: libfreetype-devel
BuildRequires: gettext-devel
BuildRequires: netpbm-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Tux Paint is a free drawing program designed for young children (kids ages 3 and up). It has a simple, easy-to-use interface, fun sound effects, and an encouraging cartoon mascot who helps guide children as they use the program.
%prep
%setup -q
%patch0 -p1
find -type d -name CVS | xargs rm -fr
%build
%make -j1 PREFIX=%{_prefix}
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall \
PKG_ROOT=%{buildroot} \
PREFIX=%{_prefix} \
KDE_ICON_PREFIX=%{_datadir}/icons \
GNOME_PREFIX=. \
X11_ICON_PREFIX=.
mkdir -p %{buildroot}%{_datadir}/applications
cp %{buildroot}%{_kdedatadir}/applnk/Graphics/tuxpaint.desktop \
%{buildroot}%{_datadir}/applications/
rm -rf %{buildroot}%{_kdedatadir}/applnk/Graphics/
%{find_lang} %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files -f %{name}.lang
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/tuxpaint/tuxpaint.conf
%{_bindir}/tuxpaint*
%{_bindir}/tp-magic-config
%dir %{_prefix}/lib/tuxpaint
%{_prefix}/lib/tuxpaint/plugins/*.so
%{_includedir}/tuxpaint/tp_magic_api.h
%{_datadir}/applications/tuxpaint.desktop
%{_datadir}/icons/hicolor/*/apps/tuxpaint.png
%{_datadir}/icons/hicolor/scalable/apps/tuxpaint.svg
%{_datadir}/pixmaps/*
%dir %{_datadir}/tuxpaint
%{_datadir}/tuxpaint/*
%{_datadir}/doc/tuxpaint-dev/*
%dir %{_docdir}/tuxpaint
%{_docdir}/tuxpaint/*
%{_mandir}/man1/*
%lang (pl) %{_mandir}/pl/man1/*
%changelog
* Sun Apr 06 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.21-2mamba
- added build patch against libpng 1.5
* Thu Jul 09 2009 Automatic Build System <autodist@mambasoft.it> 0.9.21-1mamba
- automatic update by autodist
* Tue Jul 15 2008 gil <puntogil@libero.it> 0.9.20-1mamba
- update to 0.9.20
- removed ARCH_LINKS="-lpng12" option
* Mon Jan 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.18-1mamba
- update to 0.9.18
* Fri Feb 09 2007 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.16-1qilnx
- update to version 0.9.16 by autospec
- do not install X11 icon
- do not install a desktop file for gnome
- dropped security patch for tempdir setting (fixed upstream)
* Tue Jan 17 2006 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.9.14-3qilnx
- Added patch for tuxpaint tempdir
* Wed Nov 30 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.14-2qilnx
- fixed package group
- do not include all the documentation
- CVS directories removed from package
* Thu Jul 07 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.9.14-1qilnx
- package created by autospec