update to 2.0.3 [release 2.0.3-1mamba;Sat Nov 26 2022]
This commit is contained in:
parent
6d0c1e79db
commit
093b3732ff
54
tuxmath-2.0.3-rename-blits-to-tmblits.patch
Normal file
54
tuxmath-2.0.3-rename-blits-to-tmblits.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
Bug-Debian: https://bugs.debian.org/986623
|
||||||
|
Forwarded: no
|
||||||
|
Last-Update: 2021-04-20
|
||||||
|
|
||||||
|
--- tuxmath-2.0.3.orig/src/titlescreen.c
|
||||||
|
+++ tuxmath-2.0.3/src/titlescreen.c
|
||||||
|
@@ -55,7 +55,7 @@ struct blit {
|
||||||
|
SDL_Rect *srcrect;
|
||||||
|
SDL_Rect *dstrect;
|
||||||
|
unsigned char type;
|
||||||
|
-} blits[MAX_UPDATES];
|
||||||
|
+} tmblits[MAX_UPDATES];
|
||||||
|
|
||||||
|
// Lessons available for play
|
||||||
|
char **lesson_list_titles = NULL;
|
||||||
|
@@ -1019,8 +1019,8 @@ void init_blits(void) {
|
||||||
|
int i;
|
||||||
|
|
||||||
|
for (i = 0; i < MAX_UPDATES; ++i) {
|
||||||
|
- blits[i].srcrect = &srcupdate[i];
|
||||||
|
- blits[i].dstrect = &dstupdate[i];
|
||||||
|
+ tmblits[i].srcrect = &srcupdate[i];
|
||||||
|
+ tmblits[i].dstrect = &dstupdate[i];
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -1032,14 +1032,14 @@ void update_screen(int *frame) {
|
||||||
|
|
||||||
|
/* -- First erase everything we need to -- */
|
||||||
|
for (i = 0; i < numupdates; i++)
|
||||||
|
- if (blits[i].type == 'E')
|
||||||
|
- SDL_LowerBlit(blits[i].src, blits[i].srcrect, screen, blits[i].dstrect);
|
||||||
|
+ if (tmblits[i].type == 'E')
|
||||||
|
+ SDL_LowerBlit(tmblits[i].src, tmblits[i].srcrect, screen, tmblits[i].dstrect);
|
||||||
|
// SNOW_erase();
|
||||||
|
|
||||||
|
/* -- then draw -- */
|
||||||
|
for (i = 0; i < numupdates; i++)
|
||||||
|
- if (blits[i].type == 'D')
|
||||||
|
- SDL_BlitSurface(blits[i].src, blits[i].srcrect, screen, blits[i].dstrect);
|
||||||
|
+ if (tmblits[i].type == 'D')
|
||||||
|
+ SDL_BlitSurface(tmblits[i].src, tmblits[i].srcrect, screen, tmblits[i].dstrect);
|
||||||
|
// SNOW_draw();
|
||||||
|
|
||||||
|
/* -- update the screen only where we need to! -- */
|
||||||
|
@@ -1067,7 +1067,7 @@ void add_rect(SDL_Rect* src, SDL_Rect* d
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
- update = &blits[numupdates++];
|
||||||
|
+ update = &tmblits[numupdates++];
|
||||||
|
|
||||||
|
update->srcrect->x = src->x;
|
||||||
|
update->srcrect->y = src->y;
|
@ -0,0 +1,26 @@
|
|||||||
|
From c471e2a94798787afbad4e547a1e2485ef9835db Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adrian Bunk <bunk@debian.org>
|
||||||
|
Date: Sun, 3 Jan 2021 14:22:29 +0200
|
||||||
|
Subject: src/menu_lan.c: Remove unused duplicate lan_player_info definition
|
||||||
|
|
||||||
|
This broke the build with gcc 10:
|
||||||
|
https://bugs.debian.org/976513
|
||||||
|
---
|
||||||
|
src/menu_lan.c | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/menu_lan.c b/src/menu_lan.c
|
||||||
|
index 4512eb1..d85f2c6 100644
|
||||||
|
--- a/src/menu_lan.c
|
||||||
|
+++ b/src/menu_lan.c
|
||||||
|
@@ -37,7 +37,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
|
|
||||||
|
/* lan_player_type now defined in network.h */
|
||||||
|
-lan_player_type lan_player_info[MAX_CLIENTS];
|
||||||
|
|
||||||
|
/* Local function prototypes: ------------------- */
|
||||||
|
void draw_player_table(void);
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
32
tuxmath.spec
32
tuxmath.spec
@ -1,32 +1,45 @@
|
|||||||
Epoch: 1
|
Epoch: 1
|
||||||
Name: tuxmath
|
Name: tuxmath
|
||||||
Version: 2.0.1
|
Version: 2.0.3
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: TuxMath is an educational arcade game starring Tux, the Linux mascot!
|
Summary: TuxMath is an educational arcade game starring Tux, the Linux mascot!
|
||||||
Group: Graphical Desktop/Applications/Educational
|
Group: Graphical Desktop/Applications/Educational
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://tux4kids.alioth.debian.org
|
URL: https://github.com/tux4kids/tuxmath
|
||||||
Source: http://downloads.sourceforge.net/project/tuxmath/tuxmath-source/TuxMath%20%{version}%20-%20Source/tuxmath_w_fonts-%{version}.tar.gz
|
Source: https://github.com/tux4kids/tuxmath.git/debian%2f%{version}-1/tuxmath-%{version}.tar.bz2
|
||||||
|
Patch0: tuxmath-2.0.3-src-menu_lan.c-Remove-unused-duplicate-lan_player_in.patch
|
||||||
|
Patch1: tuxmath-2.0.3-rename-blits-to-tmblits.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libSDL_Pango-devel
|
||||||
BuildRequires: libSDL_image-devel
|
BuildRequires: libSDL_image-devel
|
||||||
BuildRequires: libSDL_mixer-devel
|
BuildRequires: libSDL_mixer-devel
|
||||||
BuildRequires: libSDL_ttf-devel
|
BuildRequires: libSDL_net-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libharfbuzz-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: librsvg-devel
|
||||||
|
BuildRequires: libt4kcommon-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libt4k_common-devel
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
"Tux, of Math Command" ("TuxMath," for short) is an educational arcade game starring Tux, the Linux mascot!
|
"Tux, of Math Command" ("TuxMath," for short) is an educational arcade game starring Tux, the Linux mascot!
|
||||||
Based on the classic arcade game "Missile Command," Tux must defend his cities.
|
Based on the classic arcade game "Missile Command," Tux must defend his cities.
|
||||||
In this case, though, he must do it by solving math problems.
|
In this case, though, he must do it by solving math problems.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}_w_fonts-%{version}
|
%setup -q
|
||||||
|
%patch0 -p1 -b .src-menu_lan.c-Remove-unused-duplicate-lan_player_in
|
||||||
|
%patch1 -p1 -b .rename-blits-to-tmblits
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -70,6 +83,9 @@ EOF
|
|||||||
%{_datadir}/%{name}/*
|
%{_datadir}/%{name}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 26 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.3-1mamba
|
||||||
|
- update to 2.0.3
|
||||||
|
|
||||||
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
|
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user