automatic version update by autodist [release 0.2.1-4mamba;Wed Jul 10 2013]
This commit is contained in:
parent
a90ae1634c
commit
57f383f025
@ -1,2 +1,6 @@
|
|||||||
# trm
|
# trm
|
||||||
|
|
||||||
|
The TRM Generator is a small test application that generates Relatable TRM acoustic fingerprints.
|
||||||
|
This tool is mainly designed as a test/debugging tool for software developers, and is both an application and a developer library.
|
||||||
|
The developer library provides developers with the functionality to generate TRM ids from Wav, MP3, and Ogg Vorbis files.
|
||||||
|
|
||||||
|
11
trm-0.2.1-gcc4.patch
Normal file
11
trm-0.2.1-gcc4.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- trm-0.2.1/defs.h~ 2003-01-30 22:13:05.000000000 +0100
|
||||||
|
+++ trm-0.2.1/defs.h 2006-12-21 12:36:59.000000000 +0100
|
||||||
|
@@ -16,7 +16,7 @@
|
||||||
|
string fileName;
|
||||||
|
unsigned long duration;
|
||||||
|
|
||||||
|
- Metadata::Metadata(void) { trackNum = 0; };
|
||||||
|
+ Metadata(void) { trackNum = 0; };
|
||||||
|
Metadata &operator=(const Metadata &other)
|
||||||
|
{
|
||||||
|
artist = other.artist;
|
11
trm-0.2.1-gcc43_include.patch
Normal file
11
trm-0.2.1-gcc43_include.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -Nru trm-0.2.1.orig/mbid3.cpp trm-0.2.1/mbid3.cpp
|
||||||
|
--- trm-0.2.1.orig/mbid3.cpp 2002-10-02 11:02:56.000000000 +0200
|
||||||
|
+++ trm-0.2.1/mbid3.cpp 2009-01-10 19:15:04.000000000 +0100
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
|
||||||
|
#ifdef HAVE_LIBID3
|
||||||
|
|
||||||
|
+#include <cstring>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include "mbid3.h"
|
||||||
|
|
59
trm.spec
Normal file
59
trm.spec
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
Name: trm
|
||||||
|
Version: 0.2.1
|
||||||
|
Release: 4mamba
|
||||||
|
Summary: MusicBrainz TRM Generator
|
||||||
|
Group: Applications/Multimedia
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.musicbrainz.org/
|
||||||
|
Source: http://ftp.musicbrainz.org/pub/musicbrainz/trm-%{version}.tar.gz
|
||||||
|
Patch: %{name}-0.2.1-gcc4.patch
|
||||||
|
Patch1: %{name}-0.2.1-gcc43_include.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: libmusicbrainz-devel >= 2.0.0
|
||||||
|
BuildRequires: libogg-devel
|
||||||
|
BuildRequires: libvorbis-devel
|
||||||
|
BuildRequires: libmad-devel
|
||||||
|
BuildRequires: libid3-devel
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The TRM Generator is a small test application that generates Relatable TRM acoustic fingerprints.
|
||||||
|
This tool is mainly designed as a test/debugging tool for software developers, and is both an application and a developer library.
|
||||||
|
The developer library provides developers with the functionality to generate TRM ids from Wav, MP3, and Ogg Vorbis files.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
install -d %{buildroot}%{_bindir}
|
||||||
|
%makeoldinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%attr(0755,root,root) %{_bindir}/%{name}
|
||||||
|
%doc AUTHORS COPYING INSTALL README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jul 10 2013 Automatic Build System <autodist@mambasoft.it> 0.2.1-4mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jan 26 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.1-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Jul 15 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.2.1-2mamba
|
||||||
|
- rebuilt with gcc4
|
||||||
|
|
||||||
|
* Thu Apr 29 2004 Davide Madrisan <davide.madrisan@qilinux.it> 3.2.2-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user