automatic version update by autodist [release 1.6.1.2-1mamba;Thu Oct 11 2012]
This commit is contained in:
parent
b2b10658f0
commit
fefa9382e7
@ -1,2 +1,4 @@
|
||||
# triplea
|
||||
|
||||
TripleA is a turn based strategy game engine and axis and allies clone.
|
||||
|
||||
|
15
triplea-0.9.0.2-disable_LookAndFeel.patch
Normal file
15
triplea-0.9.0.2-disable_LookAndFeel.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -Nru triplea_0_9_0_2.orig/src/games/strategy/engine/framework/GameRunner2.java triplea_0_9_0_2/src/games/strategy/engine/framework/GameRunner2.java
|
||||
--- triplea_0_9_0_2.orig/src/games/strategy/engine/framework/GameRunner2.java 2007-01-17 19:43:52.000000000 +0100
|
||||
+++ triplea_0_9_0_2/src/games/strategy/engine/framework/GameRunner2.java 2008-03-11 11:50:28.000000000 +0100
|
||||
@@ -161,11 +161,6 @@
|
||||
//macs are already beautiful
|
||||
if (!GameRunner.isMac())
|
||||
{
|
||||
- com.jgoodies.looks.plastic.PlasticLookAndFeel.setTabStyle(com.jgoodies.looks.plastic.PlasticLookAndFeel.TAB_STYLE_METAL_VALUE);
|
||||
- //com.jgoodies.plaf.plastic.PlasticXPLookAndFeel.setTabStyle(com.jgoodies.plaf.plastic.PlasticLookAndFeel.TAB_STYLE_METAL_VALUE);
|
||||
- UIManager.setLookAndFeel(new com.jgoodies.looks.plastic.PlasticXPLookAndFeel());
|
||||
- com.jgoodies.looks.Options.setPopupDropShadowEnabled(true);
|
||||
-
|
||||
}
|
||||
} catch (Throwable ex)
|
||||
{
|
21
triplea-0.9.0.2-getWindows_conflict.patch
Normal file
21
triplea-0.9.0.2-getWindows_conflict.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -Nru triplea_0_9_0_2.orig/src/games/strategy/debug/Console.java triplea_0_9_0_2/src/games/strategy/debug/Console.java
|
||||
--- triplea_0_9_0_2.orig/src/games/strategy/debug/Console.java 2007-01-17 19:43:56.000000000 +0100
|
||||
+++ triplea_0_9_0_2/src/games/strategy/debug/Console.java 2008-03-11 11:26:48.000000000 +0100
|
||||
@@ -275,7 +275,7 @@
|
||||
result.append(getThreadDumps());
|
||||
result.append(getProperties());
|
||||
result.append(getMemory());
|
||||
- result.append(getWindows());
|
||||
+ result.append(getMyWindows());
|
||||
result.append("ENGINE VERSION").append(EngineVersion.VERSION).append("\n");
|
||||
|
||||
|
||||
@@ -283,7 +283,7 @@
|
||||
return result.toString();
|
||||
}
|
||||
|
||||
- public static String getWindows()
|
||||
+ public static String getMyWindows()
|
||||
{
|
||||
StringBuilder builder = new StringBuilder("WINDOWS\n");
|
||||
|
76
triplea.spec
Normal file
76
triplea.spec
Normal file
@ -0,0 +1,76 @@
|
||||
%define sourcever %(echo %version | tr . _)
|
||||
Name: triplea
|
||||
Version: 1.6.1.2
|
||||
Release: 1mamba
|
||||
Summary: A turn based strategy game engine and axis and allies clone
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://triplea.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/sourceforge/triplea/triplea_%{sourcever}_source_code_only.zip
|
||||
Patch0: triplea-0.9.0.2-getWindows_conflict.patch
|
||||
Patch1: triplea-0.9.0.2-disable_LookAndFeel.patch
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: apache-ant
|
||||
Requires: jre
|
||||
|
||||
%description
|
||||
TripleA is a turn based strategy game engine and axis and allies clone.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_%{sourcever}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
ant
|
||||
cd classes
|
||||
jar -cf ../bin/triplea.jar games
|
||||
jar -cf ../bin/patch.jar util
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
install -d %{buildroot}%{_libdir}/java/%{name}
|
||||
install -m0755 bin/triplea.jar bin/patch.jar %{buildroot}%{_libdir}/java/%{name}
|
||||
|
||||
# create menu link
|
||||
install -d %{buildroot}/%{_datadir}/applications
|
||||
cat > %{buildroot}/%{_datadir}/applications/%{name}.desktop <<EOF
|
||||
[Desktop Entry]
|
||||
Name=TripleA
|
||||
GenericName=A strategy game
|
||||
GenericName[it]=Un gioco di strategia
|
||||
Exec=java -Xmx128m -cp %{_libdir}/java/%{name}/patch.jar:%{_libdir}/java/%{name}/triplea.jar games.strategy.engine.framework.GameRunner
|
||||
Type=Application
|
||||
Icon=kmines
|
||||
Terminal=false
|
||||
Categories=Application;Game;StrategyGame;
|
||||
EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/java/%{name}/patch.jar
|
||||
%{_libdir}/java/%{name}/triplea.jar
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
|
||||
%changelog
|
||||
* Thu Oct 11 2012 Automatic Build System <autodist@mambasoft.it> 1.6.1.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jul 21 2012 Automatic Build System <autodist@mambasoft.it> 1.5.2.1-1mamba
|
||||
- update to 1.5.2.1
|
||||
|
||||
* Mon Dec 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0.3-1mamba
|
||||
- update to 1.0.0.3
|
||||
|
||||
* Mon Dec 08 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Mar 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0.2-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user