rebuilt with librasqal 3 [release 0.49.2-2mamba;Sat Oct 29 2011]
This commit is contained in:
parent
20d7477211
commit
eb79a9276f
@ -1,2 +1,4 @@
|
||||
# traverso
|
||||
|
||||
Traverso is a free, cross platform multitrack audio recording and editing suite, with an innovative and easy to master User Interface. It's suited for both the professional and home user, who needs a robust and solid DAW.
|
||||
|
||||
|
21
traverso-0.42.0-desktops.patch
Normal file
21
traverso-0.42.0-desktops.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -Nru traverso-0.42.0/resources/traverso.desktop traverso-0.42.0-gil/resources/traverso.desktop
|
||||
--- traverso-0.42.0/resources/traverso.desktop 2007-12-10 13:51:49.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/resources/traverso.desktop 2008-08-26 23:15:46.000000000 +0200
|
||||
@@ -16,4 +16,4 @@
|
||||
Terminal=false
|
||||
StartupNotify=true
|
||||
|
||||
-Icon=traverso.png
|
||||
+Icon=/usr/share/icons/hicolor/48x48/apps/traverso.png
|
||||
diff -Nru traverso-0.42.0/traverso.desktop traverso-0.42.0-gil/traverso.desktop
|
||||
--- traverso-0.42.0/traverso.desktop 2007-12-10 13:51:49.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/traverso.desktop 2008-08-26 23:15:14.000000000 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
GenericName=Multitrack Recorder
|
||||
GenericName[de]=Multitrack Recorder
|
||||
Exec=traverso
|
||||
-Icon=traverso
|
||||
+Icon=/usr/share/icons/hicolor/48x48/apps/traverso.png
|
||||
Path=
|
||||
Type=Application
|
||||
Terminal=false
|
16
traverso-0.42.0-fix-fpu.patch
Normal file
16
traverso-0.42.0-fix-fpu.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- traverso-0.42.0/src/common/fpu.cc 2008-08-26 17:45:54.000000000 +0200
|
||||
+++ traverso-0.42.0-gil/src/common/fpu.cc 2008-08-26 18:27:10.000000000 +0200
|
||||
@@ -75,11 +75,12 @@
|
||||
if (cpuflags & (1 << 24)) {
|
||||
|
||||
char* fxbuf = 0;
|
||||
+ char** temp = &fxbuf;
|
||||
|
||||
#ifdef NO_POSIX_MEMALIGN
|
||||
if ((fxbuf = (char *) malloc(512)) == 0)
|
||||
#else
|
||||
- if (posix_memalign ((void**)temp, 16, 512))
|
||||
+ if (posix_memalign ((void**)temp, 16, 512))
|
||||
#endif
|
||||
{
|
||||
printf("FPU() ERROR: cannot allocate 16 byte aligned buffer for h/w feature detection");
|
11
traverso-0.42.0-fix-options.patch
Normal file
11
traverso-0.42.0-fix-options.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- traverso-0.42.0/CMakeLists.txt 2008-08-26 17:36:14.000000000 +0200
|
||||
+++ traverso-0.42.0-gil/CMakeLists.txt 2008-08-26 17:39:18.000000000 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
OPTION(WANT_MP3_ENCODE "Include mp3 encoding support, for creating mp3 files" OFF)
|
||||
OPTION(WANT_PCH "Use precompiled headers" OFF)
|
||||
OPTION(WANT_DEBUG "Debug build" OFF)
|
||||
-OPTION(WANT_OPENGL "Build Traverso with OpenGL support" OFF)
|
||||
+OPTION(WANT_OPENGL "Build Traverso with OpenGL support" ON)
|
||||
OPTION(WANT_TRAVERSO_DEBUG "Provides 4 levels of debug ouput on the command line, always on for DEBUG builds" OFF)
|
||||
OPTION(WANT_THREAD_CHECK "Checks at runtime if functions are called from the correct thread, used by developers for debugging" OFF)
|
||||
OPTION(WANT_VECLIB_OPTIMIZATIONS "Build with veclib optimizations (Only for PPC based Mac OS X)" OFF)
|
86
traverso-0.42.0-fix.patch
Normal file
86
traverso-0.42.0-fix.patch
Normal file
@ -0,0 +1,86 @@
|
||||
diff -Nru traverso-0.42.0/CMakeLists.txt traverso-0.42.0-gil/CMakeLists.txt
|
||||
--- traverso-0.42.0/CMakeLists.txt 2007-12-10 13:51:49.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/CMakeLists.txt 2008-08-26 16:47:58.000000000 +0200
|
||||
@@ -249,6 +249,7 @@
|
||||
IF(NOT HAVE_LAME_H)
|
||||
MESSAGE(FATAL_ERROR "MP3 encoding support requested, but mp3 development headers (lame.h) could not be found!\nPlease install the lame development package (Usually called liblame-dev), remove CMakeCache.txt and run cmake again")
|
||||
ENDIF(NOT HAVE_LAME_H)
|
||||
+ IF(LAME_FOUND)
|
||||
LIST(APPEND TRAVERSO_DEFINES -DMP3_ENCODE_SUPPORT)
|
||||
MESSAGE("-- Building with mp3 encoding support enabled")
|
||||
SET(HAVE_MP3_ENCODING TRUE)
|
||||
diff -Nru traverso-0.42.0/src/3rdparty/slv2/CMakeLists.txt traverso-0.42.0-gil/src/3rdparty/slv2/CMakeLists.txt
|
||||
--- traverso-0.42.0/src/3rdparty/slv2/CMakeLists.txt 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/3rdparty/slv2/CMakeLists.txt 2008-08-26 16:55:16.000000000 +0200
|
||||
@@ -25,4 +25,4 @@
|
||||
|
||||
|
||||
ADD_LIBRARY(${TRAVERSO_SLV2_LIBRARY} STATIC ${TRAVERSO_SLV2_SOURCES})
|
||||
-
|
||||
+TARGET_LINK_LIBRARIES(${TRAVERSO_SLV2_LIBRARY} -lrdf)
|
||||
\ No newline at end of file
|
||||
diff -Nru traverso-0.42.0/src/common/fpu.cc traverso-0.42.0-gil/src/common/fpu.cc
|
||||
--- traverso-0.42.0/src/common/fpu.cc 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/common/fpu.cc 2008-08-26 17:01:58.000000000 +0200
|
||||
@@ -79,7 +79,7 @@
|
||||
#ifdef NO_POSIX_MEMALIGN
|
||||
if ((fxbuf = (char *) malloc(512)) == 0)
|
||||
#else
|
||||
- if (posix_memalign ((void**)&fxbuf, 16, 512))
|
||||
+ if (posix_memalign ((void**)temp, 16, 512))
|
||||
#endif
|
||||
{
|
||||
printf("FPU() ERROR: cannot allocate 16 byte aligned buffer for h/w feature detection");
|
||||
diff -Nru traverso-0.42.0/src/core/ReadSource.cpp traverso-0.42.0-gil/src/core/ReadSource.cpp
|
||||
--- traverso-0.42.0/src/core/ReadSource.cpp 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/core/ReadSource.cpp 2008-08-26 17:06:28.000000000 +0200
|
||||
@@ -35,7 +35,9 @@
|
||||
// Always put me below _all_ includes, this is needed
|
||||
// in case we run with memory leak detection enabled!
|
||||
#include "Debugger.h"
|
||||
-
|
||||
+#ifndef LONG_LONG_MAX
|
||||
+#define LONG_LONG_MAX __LONG_LONG_MAX__
|
||||
+#endif
|
||||
|
||||
/**
|
||||
* \class ReadSource
|
||||
diff -Nru traverso-0.42.0/src/traverso/CMakeLists.txt traverso-0.42.0-gil/src/traverso/CMakeLists.txt
|
||||
--- traverso-0.42.0/src/traverso/CMakeLists.txt 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/traverso/CMakeLists.txt 2008-08-26 16:59:54.000000000 +0200
|
||||
@@ -274,11 +274,11 @@
|
||||
)
|
||||
ENDIF(HAVE_ALSA)
|
||||
|
||||
-IF(HAVE_ALSA)
|
||||
+IF(HAVE_JACK)
|
||||
TARGET_LINK_LIBRARIES(traverso
|
||||
${JACK_LIB}
|
||||
)
|
||||
-ENDIF(HAVE_ALSA)
|
||||
+ENDIF(HAVE_JACK)
|
||||
|
||||
IF(USE_PCH)
|
||||
ADD_DEPENDENCIES(traverso precompiled_headers)
|
||||
diff -Nru traverso-0.42.0/src/traverso/Main.cpp traverso-0.42.0-gil/src/traverso/Main.cpp
|
||||
--- traverso-0.42.0/src/traverso/Main.cpp 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/traverso/Main.cpp 2008-08-26 17:05:07.000000000 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
// Always put me below _all_ includes, this is needed
|
||||
// in case we run with memory leak detection enabled!
|
||||
#include "Debugger.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
|
||||
Traverso* traverso;
|
||||
diff -Nru traverso-0.42.0/src/traverso/songcanvas/TimeLineView.cpp traverso-0.42.0-gil/src/traverso/songcanvas/TimeLineView.cpp
|
||||
--- traverso-0.42.0/src/traverso/songcanvas/TimeLineView.cpp 2007-12-10 13:51:50.000000000 +0100
|
||||
+++ traverso-0.42.0-gil/src/traverso/songcanvas/TimeLineView.cpp 2008-08-26 17:04:43.000000000 +0200
|
||||
@@ -48,6 +48,7 @@
|
||||
// Always put me below _all_ includes, this is needed
|
||||
// in case we run with memory leak detection enabled!
|
||||
#include "Debugger.h"
|
||||
+#include <cstdlib>
|
||||
|
||||
|
||||
#define MARKER_SOFT_SELECTION_DISTANCE 50
|
40
traverso-0.49.1-cmake-2.6.4-ftbfs-fix-nmu.patch
Normal file
40
traverso-0.49.1-cmake-2.6.4-ftbfs-fix-nmu.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff -u traverso-0.49.0~rc1/debian/changelog traverso-0.49.0~rc1/debian/changelog
|
||||
--- traverso-0.49.0~rc1.orig/src/CMakeLists.txt
|
||||
+++ traverso-0.49.0~rc1/src/CMakeLists.txt
|
||||
@@ -1,11 +1,11 @@
|
||||
-ADD_SUBDIRECTORY(engine ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(audiofileio ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(commands ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(core ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(3rdparty ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(plugins ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(sheetcanvas ${TRAVERSO_BUILD_DIR})
|
||||
-ADD_SUBDIRECTORY(traverso ${TRAVERSO_BUILD_DIR})
|
||||
+ADD_SUBDIRECTORY(engine)
|
||||
+ADD_SUBDIRECTORY(audiofileio)
|
||||
+ADD_SUBDIRECTORY(commands)
|
||||
+ADD_SUBDIRECTORY(core)
|
||||
+ADD_SUBDIRECTORY(3rdparty)
|
||||
+ADD_SUBDIRECTORY(plugins)
|
||||
+ADD_SUBDIRECTORY(sheetcanvas)
|
||||
+ADD_SUBDIRECTORY(traverso)
|
||||
|
||||
IF(USE_PCH)
|
||||
ADD_PRECOMPILED_HEADER(precompiled_headers precompile.h)
|
||||
only in patch2:
|
||||
unchanged:
|
||||
--- traverso-0.49.0~rc1.orig/src/commands/CMakeLists.txt
|
||||
+++ traverso-0.49.0~rc1/src/commands/CMakeLists.txt
|
||||
@@ -1,4 +1,4 @@
|
||||
-ADD_SUBDIRECTORY(plugins ${TRAVERSO_BUILD_DIR})
|
||||
+ADD_SUBDIRECTORY(plugins)
|
||||
|
||||
INCLUDE_DIRECTORIES(
|
||||
${CMAKE_SOURCE_DIR}/src/commands
|
||||
only in patch2:
|
||||
unchanged:
|
||||
--- traverso-0.49.0~rc1.orig/src/commands/plugins/CMakeLists.txt
|
||||
+++ traverso-0.49.0~rc1/src/commands/plugins/CMakeLists.txt
|
||||
@@ -1 +1 @@
|
||||
-ADD_SUBDIRECTORY(TraversoCommands ${TRAVERSO_BUILD_DIR})
|
||||
+ADD_SUBDIRECTORY(TraversoCommands)
|
15
traverso-0.49.2-raptor2.patch
Normal file
15
traverso-0.49.2-raptor2.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- traverso-0.49.2.orig/CMakeLists.txt 2011-10-29 17:42:11.732651048 +0200
|
||||
+++ traverso-0.49.2/CMakeLists.txt 2011-10-29 17:50:46.460279027 +0200
|
||||
@@ -207,10 +207,10 @@
|
||||
PKG_CHECK_MODULES(REDLAND redland>=${MINIMAL_REDLAND_VERSION})
|
||||
IF (REDLAND_FOUND)
|
||||
MESSAGE("-- REDLAND Library Found OK")
|
||||
- INCLUDE_DIRECTORIES(/usr/include/redland /usr/include/rasqal)
|
||||
+ INCLUDE_DIRECTORIES(/usr/include/redland /usr/include/rasqal /usr/include/raptor2)
|
||||
ELSE(REDLAND_FOUND)
|
||||
MESSAGE("-- REDLAND Library not found with pkg-config, looking for headers now")
|
||||
- INCLUDE_DIRECTORIES(/usr/include/redland /usr/include/rasqal)
|
||||
+ INCLUDE_DIRECTORIES(/usr/include/redland /usr/include/rasqal /usr/include/raptor2)
|
||||
CHECK_INCLUDE_FILE("librdf.h" HAVE_LIBRDF_H)
|
||||
IF(NOT HAVE_LIBRDF_H)
|
||||
CHECK_INCLUDE_FILE("redland/librdf.h" HAVE_REDLAND_LIBRDF_H)
|
218
traverso.spec
Normal file
218
traverso.spec
Normal file
@ -0,0 +1,218 @@
|
||||
%define prefix %(kde-config --prefix)
|
||||
Name: traverso
|
||||
Version: 0.49.2
|
||||
Release: 2mamba
|
||||
Summary: Cross Platform Multitrack Audio Recording and Editing Suite
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: gil <puntogil@libero.it>
|
||||
URL: http://traverso-daw.org/
|
||||
Source0: http://traverso-daw.org/download/releases/current/traverso-%{version}.tar.gz
|
||||
Source1: %{name}-0.42.0-fpucc.tar.bz2
|
||||
Patch0: %{name}-0.42.0-fix.patch
|
||||
## opengl support
|
||||
Patch1: %{name}-0.42.0-fix-options.patch
|
||||
Patch2: %{name}-0.42.0-fix-fpu.patch
|
||||
Patch3: %{name}-0.42.0-desktops.patch
|
||||
Patch4: %{name}-0.49.1-cmake-2.6.4-ftbfs-fix-nmu.patch
|
||||
Patch5: %{name}-0.49.2-raptor2.patch
|
||||
License: LGPL
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libportaudio-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libslv2-devel
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libfftw-devel
|
||||
BuildRequires: libflac-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libmad-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libraptor-devel
|
||||
BuildRequires: librasqal-devel
|
||||
BuildRequires: librdf-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libwavpack-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
#Build options:
|
||||
#Building in mode : DEBUG
|
||||
#ALSA support : TRUE
|
||||
#Jack support : TRUE
|
||||
#PortAudio support : FALSE
|
||||
#SLV2 support : TRUE (Using internal library) !!! do not use system library !!!
|
||||
#MP3 read support : TRUE
|
||||
#MP3 writing support :
|
||||
#OpenGL support : FALSE
|
||||
#01:00:18 :
|
||||
#ALSA Driver: The playback device alsa.conf is already in use. Please stop the application using it and run Traverso again
|
||||
#01:00:18 :
|
||||
#Audiodevice: Failed to create the ALSA Driver
|
||||
#01:00:18 :
|
||||
#Created new Project Untitled
|
||||
#01:00:18 :
|
||||
#Project Untitled saved
|
||||
#01:00:19 :
|
||||
#Project Untitled loaded
|
||||
#01:00:28 :
|
||||
#ALSA Driver: The playback device t.extended is already in use. Please stop the application using it and run Traverso again
|
||||
#01:00:28 :
|
||||
#Audiodevice: Failed to create the ALSA Driver
|
||||
#01:01:19 :
|
||||
#Project Untitled saved
|
||||
#01:01:39 :
|
||||
#Created new Project gil
|
||||
#01:01:39 :
|
||||
#Project gil saved
|
||||
#01:01:39 :
|
||||
#Project gil loaded
|
||||
#01:02:46 :
|
||||
#Jack Driver: Couldn't connect to the jack server, is jack running?
|
||||
#01:02:46 :
|
||||
#Audiodevice: Failed to create the Jack Driver
|
||||
|
||||
%description
|
||||
Traverso is a free, cross platform multitrack audio recording and editing suite, with an innovative and easy to master User Interface. It's suited for both the professional and home user, who needs a robust and solid DAW.
|
||||
|
||||
%package static
|
||||
Summary: %{name} static libraries
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description static
|
||||
%{name} is a free, cross platform multitrack audio recording and editing suite, with an innovative and easy to master User Interface. It's suited for both the professional and home user, who needs a robust and solid DAW.
|
||||
|
||||
This package contains static libraries need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
sed -i "s|:/traverso_|:%{_datadir}/%{name}/traverso_|" src/traverso/Main.cpp
|
||||
sed -i "s|wavpack/wavpack.h|%{_includedir}/wavpack/wavpack.h|" CMakeLists.txt
|
||||
chmod -x ChangeLog INSTALL TODO
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
-DWANT_MP3_DECODE=ON \
|
||||
-DWANT_MP3_ENCODE=ON
|
||||
# -DWANT_DEBUG=ON
|
||||
|
||||
make clean && %make
|
||||
|
||||
# DO NOT USE
|
||||
# -DWANT_PCH=ON \
|
||||
# -DWANT_OPENGL=ON
|
||||
# -DWANT_TRAVERSO_DEBUG=ON
|
||||
# -DUSE_SYSTEM_SLV2_LIBRARY=ON
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%makeinstall -C build
|
||||
install -D -m 0755 build/bin/%{name} %{buildroot}%{_bindir}/%{name}
|
||||
install -D -m 0755 resources/images/traverso-logo.svg %{buildroot}%{_datadir}/icons/gnome/scalable/apps/%{name}-logo.svg
|
||||
install -D -m 0755 resources/%{name}.desktop %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
rm resources/images/traverso-logo.svg -f
|
||||
mkdir -p %{buildroot}%{_datadir}/%{name}/themes
|
||||
cp -a resources/themes/* %{buildroot}%{_datadir}/%{name}/themes
|
||||
cp -a resources/projectconversion %{buildroot}%{_datadir}/%{name}
|
||||
cp -a resources/images %{buildroot}%{_datadir}/%{name}
|
||||
|
||||
install -m 644 resources/translations/%{name}_*.qm %{buildroot}%{_datadir}/%{name}
|
||||
install -m 644 resources/*.xml %{buildroot}%{_datadir}/%{name}
|
||||
install -m 644 resources/help.text %{buildroot}%{_datadir}/%{name}
|
||||
install -m 644 resources/README %{buildroot}%{_datadir}/%{name}
|
||||
install -m 755 resources/%{name}.desktop %{buildroot}%{_datadir}/%{name}
|
||||
|
||||
for size in 128x128 64x64 48x48 24x24 16x16 ; do
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/$size/apps
|
||||
install -m 644 resources/freedesktop/icons/$size/apps/*.png %{buildroot}%{_datadir}/icons/hicolor/$size/apps
|
||||
done
|
||||
|
||||
for size in 128x128 64x64 48x48 24x24 16x16 ;do
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/gnome/$size/mimetypes
|
||||
install -m 644 resources/freedesktop/icons/$size/mimetypes/*.png %{buildroot}%{_datadir}/icons/gnome/$size/mimetypes
|
||||
done
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/gnome/scalable/apps
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/gnome/scalable/mimetypes
|
||||
|
||||
install -m 644 resources/freedesktop/icons/scalable/apps/%{name}.svg %{buildroot}%{_datadir}/icons/gnome/scalable/apps
|
||||
install -m 644 resources/freedesktop/icons/scalable/mimetypes/gnome-mime-application-x-traverso.svg %{buildroot}%{_datadir}/icons/gnome/scalable/mimetypes
|
||||
|
||||
mkdir -p %{buildroot}%{_libdir}/%{name}
|
||||
install -m 0644 build/lib/*.a %{buildroot}%{_libdir}/%{name}
|
||||
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/%{name}
|
||||
%dir %{_datadir}/%{name}
|
||||
%{_datadir}/%{name}/*.xml
|
||||
%{_datadir}/%{name}/help.text
|
||||
%{_datadir}/%{name}/README
|
||||
%{_datadir}/%{name}/%{name}.desktop
|
||||
%{_datadir}/%{name}/themes
|
||||
%{_datadir}/%{name}/projectconversion
|
||||
%{_datadir}/%{name}/images
|
||||
%{_datadir}/%{name}/%{name}_*.qm
|
||||
%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/icons/hicolor/*x*/apps/*.png
|
||||
%{_datadir}/icons/gnome/*x*/mimetypes/*.png
|
||||
%{_datadir}/icons/gnome/scalable/apps/%{name}.svg
|
||||
%{_datadir}/icons/gnome/scalable/apps/%{name}-logo.svg
|
||||
%{_datadir}/icons/gnome/scalable/mimetypes/gnome-mime-application-x-traverso.svg
|
||||
%doc AUTHORS COPYING ChangeLog README TODO
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/%{name}/*.a
|
||||
|
||||
%changelog
|
||||
* Sat Oct 29 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.49.2-2mamba
|
||||
- rebuilt with librasqal 3
|
||||
|
||||
* Wed Oct 27 2010 Automatic Build System <autodist@mambasoft.it> 0.49.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jun 03 2010 Automatic Build System <autodist@mambasoft.it> 0.49.1-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.49.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Dec 07 2008 gil <puntogil@libero.it> 0.42.0-2mamba
|
||||
- added librdf (libredland) support
|
||||
|
||||
* Tue Aug 26 2008 gil <puntogil@libero.it> 0.42.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user