rebuilt with ImageMagick 6.8.8.6 [release 1.1.7-4mamba;Fri Feb 28 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 18:40:53 +01:00
parent 8e50a9c2b3
commit 60e14bdd5e
5 changed files with 887 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# transcode # transcode
Transcode is a text-console utility for video stream processing, running on a platform that supports shared libraries and threads.
Decoding and encoding is done by loading modules that are responsible for feeding transcode with raw video/audio streams (import modules) and encoding the frames (export modules).
It supports elementary video and audio frame transformations, including de-interlacing or fast resizing of video frames and loading of external filters.
It's modular concept is intended to provide flexibility and easy user extensibility to include other video/audio codecs or file types.

View File

@ -0,0 +1,13 @@
--- filter/filter_pp.c
+++ filter/filter_pp.c
@@ -38,8 +38,8 @@
/* FIXME: these use the filter ID as an index--the ID can grow
* arbitrarily large, so this needs to be fixed */
-static pp_mode_t *mode[100];
-static pp_context_t *context[100];
+static pp_mode *mode[100];
+static pp_context *context[100];
static int width[100], height[100];
static int pre[100];

View File

@ -0,0 +1,601 @@
Submitted By: Igor Živković <contact@igor-zivkovic.from.hr>
Date: 2013-10-08
Initial Package Version: 1.1.7
Upstream Status: Unknown
Origin: Gentoo
Description: Fixes building against FFmpeg version >= 2.0.0
diff -Naur transcode-1.1.7.orig/encode/encode_lavc.c transcode-1.1.7/encode/encode_lavc.c
--- transcode-1.1.7.orig/encode/encode_lavc.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/encode/encode_lavc.c 2013-10-08 13:06:58.368706154 +0200
@@ -74,6 +74,9 @@
int lmin;
int lmax;
int me_method;
+ int luma_elim_threshold;
+ int chroma_elim_threshold;
+ int quantizer_noise_shaping;
/* same as above for flags */
struct {
@@ -114,6 +117,7 @@
AVFrame ff_venc_frame;
AVCodecContext ff_vcontext;
+ AVDictionary * ff_opts;
AVCodec *ff_vcodec;
@@ -164,6 +168,7 @@
TC_CODEC_ERROR
};
+#if LIBAVCODEC_VERSION_MAJOR < 55
static const enum CodecID tc_lavc_internal_codecs[] = {
CODEC_ID_MPEG1VIDEO, CODEC_ID_MPEG2VIDEO, CODEC_ID_MPEG4,
CODEC_ID_H263I, CODEC_ID_H263P,
@@ -176,6 +181,20 @@
CODEC_ID_MSMPEG4V2, CODEC_ID_MSMPEG4V3,
CODEC_ID_NONE
};
+#else
+static const enum AVCodecID tc_lavc_internal_codecs[] = {
+ AV_CODEC_ID_MPEG1VIDEO, AV_CODEC_ID_MPEG2VIDEO, AV_CODEC_ID_MPEG4,
+ AV_CODEC_ID_H263I, AV_CODEC_ID_H263P,
+ AV_CODEC_ID_H264,
+ AV_CODEC_ID_WMV1, AV_CODEC_ID_WMV2,
+ AV_CODEC_ID_RV10,
+ AV_CODEC_ID_HUFFYUV, AV_CODEC_ID_FFV1,
+ AV_CODEC_ID_DVVIDEO,
+ AV_CODEC_ID_MJPEG, AV_CODEC_ID_LJPEG,
+ AV_CODEC_ID_MSMPEG4V2, AV_CODEC_ID_MSMPEG4V3,
+ AV_CODEC_ID_NONE
+};
+#endif
static const TCFormatID tc_lavc_formats[] = { TC_FORMAT_ERROR };
@@ -937,7 +956,11 @@
static void tc_lavc_config_defaults(TCLavcPrivateData *pd)
{
/* first of all reinitialize lavc data */
+#if LIBAVCODEC_VERSION_MAJOR < 55
avcodec_get_context_defaults(&pd->ff_vcontext);
+#else
+ avcodec_get_context_defaults3(&pd->ff_vcontext, NULL);
+#endif
pd->confdata.thread_count = 1;
@@ -955,8 +978,6 @@
/*
* context *transcode* (not libavcodec) defaults
*/
- pd->ff_vcontext.mb_qmin = 2;
- pd->ff_vcontext.mb_qmax = 31;
pd->ff_vcontext.max_qdiff = 3;
pd->ff_vcontext.max_b_frames = 0;
pd->ff_vcontext.me_range = 0;
@@ -977,8 +998,8 @@
pd->ff_vcontext.mpeg_quant = 0;
pd->ff_vcontext.rc_initial_cplx = 0.0;
pd->ff_vcontext.rc_qsquish = 1.0;
- pd->ff_vcontext.luma_elim_threshold = 0;
- pd->ff_vcontext.chroma_elim_threshold = 0;
+ pd->confdata.luma_elim_threshold = 0;
+ pd->confdata.chroma_elim_threshold = 0;
pd->ff_vcontext.strict_std_compliance = 0;
pd->ff_vcontext.dct_algo = FF_DCT_AUTO;
pd->ff_vcontext.idct_algo = FF_IDCT_AUTO;
@@ -1002,7 +1023,7 @@
pd->ff_vcontext.intra_quant_bias = FF_DEFAULT_QUANT_BIAS;
pd->ff_vcontext.inter_quant_bias = FF_DEFAULT_QUANT_BIAS;
pd->ff_vcontext.noise_reduction = 0;
- pd->ff_vcontext.quantizer_noise_shaping = 0;
+ pd->confdata.quantizer_noise_shaping = 0;
pd->ff_vcontext.flags = 0;
}
@@ -1034,16 +1055,11 @@
pd->ff_vcontext.flags = 0;
SET_FLAG(pd, mv0);
- SET_FLAG(pd, cbp);
SET_FLAG(pd, qpel);
- SET_FLAG(pd, alt);
- SET_FLAG(pd, vdpart);
SET_FLAG(pd, naq);
SET_FLAG(pd, ilme);
SET_FLAG(pd, ildct);
SET_FLAG(pd, aic);
- SET_FLAG(pd, aiv);
- SET_FLAG(pd, umv);
SET_FLAG(pd, psnr);
SET_FLAG(pd, trell);
SET_FLAG(pd, gray);
@@ -1064,6 +1080,30 @@
pd->ff_vcontext.flags |= CODEC_FLAG_INTERLACED_DCT;
pd->ff_vcontext.flags |= CODEC_FLAG_INTERLACED_ME;
}
+ if (pd->confdata.flags.alt) {
+ av_dict_set(&(pd->ff_opts), "alternate_scan", "1", 0);
+ }
+ if (pd->confdata.flags.vdpart) {
+ av_dict_set(&(pd->ff_opts), "data_partitioning", "1", 0);
+ }
+ if (pd->confdata.flags.umv) {
+ av_dict_set(&(pd->ff_opts), "umv", "1", 0);
+ }
+ if (pd->confdata.flags.aiv) {
+ av_dict_set(&(pd->ff_opts), "aiv", "1", 0);
+ }
+ if (pd->confdata.flags.cbp) {
+ av_dict_set(&(pd->ff_opts), "mpv_flags", "+cbp_rd", 0);
+ }
+
+ char buf[1024];
+#define set_dict_opt(val, opt) \
+ snprintf(buf, sizeof(buf), "%i", pd->confdata.val);\
+ av_dict_set(&(pd->ff_opts), opt, buf, 0)
+
+ set_dict_opt(luma_elim_threshold, "luma_elim_threshold");
+ set_dict_opt(chroma_elim_threshold, "chroma_elim_threshold");
+ set_dict_opt(quantizer_noise_shaping, "quantizer_noise_shaping");
}
#undef SET_FLAG
@@ -1116,8 +1156,6 @@
// handled by transcode core
// { "vqmax", PCTX(qmax), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 60 },
// handled by transcode core
- { "mbqmin", PCTX(mb_qmin), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 60 },
- { "mbqmax", PCTX(mb_qmax), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 60 },
{ "lmin", PAUX(lmin), TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.01, 255.0 },
{ "lmax", PAUX(lmax), TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.01, 255.0 },
{ "vqdiff", PCTX(max_qdiff), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31 },
@@ -1150,8 +1188,8 @@
{ "vrc_init_cplx", PCTX(rc_initial_cplx), TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.0, 9999999.0 },
// { "vrc_init_occupancy", }, // not yet supported
{ "vqsquish", PCTX(rc_qsquish), TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.0, 99.0 },
- { "vlelim", PCTX(luma_elim_threshold), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99 },
- { "vcelim", PCTX(chroma_elim_threshold), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99 },
+ { "vlelim", PAUX(luma_elim_threshold), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99 },
+ { "vcelim", PAUX(chroma_elim_threshold), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99 },
{ "vstrict", PCTX(strict_std_compliance), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99 },
{ "vpsize", PCTX(rtp_payload_size), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 100000000 },
{ "dct", PCTX(dct_algo), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 10 },
@@ -1177,25 +1215,25 @@
{ "ibias", PCTX(intra_quant_bias), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -512, 512 },
{ "pbias", PCTX(inter_quant_bias), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -512, 512 },
{ "nr", PCTX(noise_reduction), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 1000000},
- { "qns", PCTX(quantizer_noise_shaping), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 3 },
+ { "qns", PAUX(quantizer_noise_shaping), TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 3 },
{ "inter_matrix_file", inter_matrix_file, TCCONF_TYPE_STRING, 0, 0, 0 },
{ "intra_matrix_file", intra_matrix_file, TCCONF_TYPE_STRING, 0, 0, 0 },
{ "mv0", PAUX(flags.mv0), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_MV0 },
- { "cbp", PAUX(flags.cbp), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_CBP_RD },
+ { "cbp", PAUX(flags.cbp), TCCONF_TYPE_FLAG, 0, 0, 1 },
{ "qpel", PAUX(flags.qpel), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_QPEL },
- { "alt", PAUX(flags.alt), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_ALT_SCAN },
+ { "alt", PAUX(flags.alt), TCCONF_TYPE_FLAG, 0, 0, 1 },
{ "ilme", PAUX(flags.ilme), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_INTERLACED_ME },
{ "ildct", PAUX(flags.ildct), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_INTERLACED_DCT },
{ "naq", PAUX(flags.naq), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_NORMALIZE_AQP },
- { "vdpart", PAUX(flags.vdpart), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_PART },
+ { "vdpart", PAUX(flags.vdpart), TCCONF_TYPE_FLAG, 0, 0, 1 },
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
{ "aic", PAUX(flags.aic), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_H263P_AIC },
#else
{ "aic", PAUX(flags.aic), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_AC_PRED },
#endif
- { "aiv", PAUX(flags.aiv), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_H263P_AIV },
- { "umv", PAUX(flags.umv), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_H263P_UMV },
+ { "aiv", PAUX(flags.aiv), TCCONF_TYPE_FLAG, 0, 0, 1 },
+ { "umv", PAUX(flags.umv), TCCONF_TYPE_FLAG, 0, 0, 1 },
{ "psnr", PAUX(flags.psnr), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_PSNR },
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
{ "trell", PAUX(flags.trell), TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_TRELLIS_QUANT },
@@ -1345,6 +1383,8 @@
pd = self->userdata;
+ pd->ff_opts = NULL;
+
pd->flush_flag = vob->encoder_flush;
/* FIXME: move into core? */
@@ -1387,7 +1427,7 @@
pd->confdata.thread_count,
(pd->confdata.thread_count > 1) ?"s" :"");
}
- avcodec_thread_init(&pd->ff_vcontext, pd->confdata.thread_count);
+ pd->ff_vcontext.thread_count = pd->confdata.thread_count;
pd->ff_vcodec = avcodec_find_encoder(FF_VCODEC_ID(pd));
if (pd->ff_vcodec == NULL) {
@@ -1397,11 +1437,11 @@
}
TC_LOCK_LIBAVCODEC;
- ret = avcodec_open(&pd->ff_vcontext, pd->ff_vcodec);
+ ret = avcodec_open2(&pd->ff_vcontext, pd->ff_vcodec, &(pd->ff_opts));
TC_UNLOCK_LIBAVCODEC;
if (ret < 0) {
- tc_log_error(MOD_NAME, "avcodec_open() failed");
+ tc_log_error(MOD_NAME, "avcodec_open2() failed");
goto failed;
}
/* finally, pass up the extradata, if any */
diff -Naur transcode-1.1.7.orig/export/aud_aux.c transcode-1.1.7/export/aud_aux.c
--- transcode-1.1.7.orig/export/aud_aux.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/export/aud_aux.c 2013-10-08 13:06:58.369706141 +0200
@@ -346,7 +346,7 @@
//-- set parameters (bitrate, channels and sample-rate) --
//--------------------------------------------------------
- avcodec_get_context_defaults(&mpa_ctx);
+ avcodec_get_context_defaults3(&mpa_ctx, mpa_codec);
#if LIBAVCODEC_VERSION_MAJOR < 53
mpa_ctx.codec_type = CODEC_TYPE_AUDIO;
#else
@@ -359,7 +359,7 @@
//-- open codec --
//----------------
TC_LOCK_LIBAVCODEC;
- ret = avcodec_open(&mpa_ctx, mpa_codec);
+ ret = avcodec_open2(&mpa_ctx, mpa_codec, NULL);
TC_UNLOCK_LIBAVCODEC;
if (ret < 0) {
tc_warn("tc_audio_init_ffmpeg: could not open %s codec !",
diff -Naur transcode-1.1.7.orig/export/export_ffmpeg.c transcode-1.1.7/export/export_ffmpeg.c
--- transcode-1.1.7.orig/export/export_ffmpeg.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/export/export_ffmpeg.c 2013-10-08 13:06:58.370706129 +0200
@@ -122,6 +122,7 @@
static AVFrame *lavc_convert_frame = NULL;
static AVCodec *lavc_venc_codec = NULL;
+static AVDictionary *lavc_venc_opts = NULL;
static AVFrame *lavc_venc_frame = NULL;
static AVCodecContext *lavc_venc_context;
static avi_t *avifile = NULL;
@@ -180,7 +181,7 @@
/* START: COPIED FROM ffmpeg-0.5_p22846(ffmpeg.c, cmdutils.c) */
-#include <libavcodec/opt.h>
+#include <libavutil/opt.h>
#include <libavutil/avstring.h>
#include <libswscale/swscale.h>
@@ -470,7 +471,6 @@
}
TC_LOCK_LIBAVCODEC;
- avcodec_init();
avcodec_register_all();
TC_UNLOCK_LIBAVCODEC;
@@ -486,7 +486,7 @@
codec->name, codec->fourCC, codec->comments);
}
- lavc_venc_context = avcodec_alloc_context();
+ lavc_venc_context = avcodec_alloc_context3(lavc_venc_codec);
lavc_venc_frame = avcodec_alloc_frame();
lavc_convert_frame= avcodec_alloc_frame();
@@ -634,7 +634,7 @@
lavc_param_rc_max_rate = 2516;
lavc_param_rc_buffer_size = 224 * 8;
lavc_param_rc_buffer_aggressivity = 99;
- lavc_param_scan_offset = CODEC_FLAG_SVCD_SCAN_OFFSET;
+ lavc_param_scan_offset = 1;
break;
@@ -674,7 +674,7 @@
lavc_param_rc_buffer_size = 224 * 8;
lavc_param_rc_buffer_aggressivity = 99;
- lavc_param_scan_offset = CODEC_FLAG_SVCD_SCAN_OFFSET;
+ lavc_param_scan_offset = 1;
break;
@@ -838,8 +838,13 @@
lavc_venc_context->rc_strategy = lavc_param_vrc_strategy;
lavc_venc_context->b_frame_strategy = lavc_param_vb_strategy;
lavc_venc_context->b_quant_offset = lavc_param_vb_qoffset;
- lavc_venc_context->luma_elim_threshold= lavc_param_luma_elim_threshold;
- lavc_venc_context->chroma_elim_threshold= lavc_param_chroma_elim_threshold;
+
+ char buf[1024];
+#define set_dict_opt(val, opt) \
+ snprintf(buf, sizeof(buf), "%i", val); \
+ av_dict_set(&lavc_venc_opts, opt, buf, 0)
+ set_dict_opt(lavc_param_luma_elim_threshold, "luma_elim_threshold");
+ set_dict_opt(lavc_param_chroma_elim_threshold, "chroma_elim_threshold");
lavc_venc_context->rtp_payload_size = lavc_param_packet_size;
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
if (lavc_param_packet_size)
@@ -870,7 +875,7 @@
lavc_venc_context->context_model = lavc_param_context;
lavc_venc_context->scenechange_threshold= lavc_param_sc_threshold;
lavc_venc_context->noise_reduction = lavc_param_noise_reduction;
- lavc_venc_context->inter_threshold = lavc_param_inter_threshold;
+ set_dict_opt(lavc_param_inter_threshold, "inter_threshold");
lavc_venc_context->intra_dc_precision = lavc_param_intra_dc_precision;
lavc_venc_context->skip_top = lavc_param_skip_top;
lavc_venc_context->skip_bottom = lavc_param_skip_bottom;
@@ -887,7 +892,7 @@
lavc_venc_context->thread_count);
}
- avcodec_thread_init(lavc_venc_context, lavc_param_threads);
+ lavc_venc_context->thread_count = lavc_param_threads;
if (lavc_param_intra_matrix) {
char *tmp;
@@ -1065,15 +1070,12 @@
lavc_venc_context->flags |= lavc_param_closedgop;
lavc_venc_context->flags |= lavc_param_trunc;
lavc_venc_context->flags |= lavc_param_aic;
- lavc_venc_context->flags |= lavc_param_umv;
lavc_venc_context->flags |= lavc_param_v4mv;
- lavc_venc_context->flags |= lavc_param_data_partitioning;
- lavc_venc_context->flags |= lavc_param_cbp;
+ if(lavc_param_cbp)
+ av_dict_set(&lavc_venc_opts, "mpv_flags", "+cbp_rd", 0);
lavc_venc_context->flags |= lavc_param_mv0;
- lavc_venc_context->flags |= lavc_param_qp_rd;
- lavc_venc_context->flags |= lavc_param_scan_offset;
- lavc_venc_context->flags |= lavc_param_ss;
- lavc_venc_context->flags |= lavc_param_alt;
+ if(lavc_param_qp_rd)
+ av_dict_set(&lavc_venc_opts, "mpv_flags", "+qp_rd", 0);
lavc_venc_context->flags |= lavc_param_ilme;
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
lavc_venc_context->flags |= lavc_param_trell;
@@ -1203,9 +1205,8 @@
lavc_venc_context->me_method = ME_ZERO + lavc_param_vme;
-
/* FIXME: transcode itself contains "broken ffmpeg default settings", thus we need to override them! */
- if (lavc_param_video_preset) {
+ if (lavc_param_video_preset && strcmp(lavc_param_video_preset, "none")) {
avcodec_opts[AVMEDIA_TYPE_VIDEO] = lavc_venc_context;
video_codec_name = ffmpeg_codec_name(codec->name);
@@ -1241,20 +1242,39 @@
}
}
+ if (lavc_param_scan_offset) {
+ av_dict_set(&lavc_venc_opts, "scan_offset", "1", 0);
+ }
+
+ if (lavc_param_ss) {
+ av_dict_set(&lavc_venc_opts, "structured_slices", "1", 0);
+ }
+
+ if (lavc_param_alt) {
+ av_dict_set(&lavc_venc_opts, "alternate_scan", "1", 0);
+ }
+
+ if (lavc_param_umv) {
+ av_dict_set(&lavc_venc_opts, "umv", "1", 0);
+ }
+
+ if (lavc_param_data_partitioning) {
+ av_dict_set(&lavc_venc_opts, "vdpart", "1", 0);
+ }
//-- open codec --
//----------------
TC_LOCK_LIBAVCODEC;
- ret = avcodec_open(lavc_venc_context, lavc_venc_codec);
+ ret = avcodec_open2(lavc_venc_context, lavc_venc_codec, &lavc_venc_opts);
TC_UNLOCK_LIBAVCODEC;
if (ret < 0) {
tc_log_warn(MOD_NAME, "could not open FFMPEG codec");
return TC_EXPORT_ERROR;
}
- if (lavc_venc_context->codec->encode == NULL) {
+ if (av_codec_is_encoder(lavc_venc_context->codec) == 0) {
tc_log_warn(MOD_NAME, "could not open FFMPEG codec "
- "(lavc_venc_context->codec->encode == NULL)");
+ "(av_codec_is_encoder(lavc_venc_context->codec) == 0)");
return TC_EXPORT_ERROR;
}
diff -Naur transcode-1.1.7.orig/export/ffmpeg_cfg.c transcode-1.1.7/export/ffmpeg_cfg.c
--- transcode-1.1.7.orig/export/ffmpeg_cfg.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/export/ffmpeg_cfg.c 2013-10-08 13:06:58.370706129 +0200
@@ -34,8 +34,6 @@
//int lavc_param_vqscale = 0;
//int lavc_param_vqmin = 2;
//int lavc_param_vqmax = 31;
-int lavc_param_mb_qmin = 2;
-int lavc_param_mb_qmax = 31;
int lavc_param_lmin = 2;
int lavc_param_lmax = 31;
int lavc_param_vqdiff = 3;
@@ -126,7 +124,7 @@
//int lavc_param_atag = 0;
//int lavc_param_abitrate = 224;
-char *lavc_param_video_preset = "medium";
+char *lavc_param_video_preset = "none";
char *lavc_param_ffmpeg_datadir = "/usr/share/ffmpeg";
TCConfigEntry lavcopts_conf[]={
@@ -143,8 +141,6 @@
// {"vqscale", &lavc_param_vqscale, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
// {"vqmin", &lavc_param_vqmin, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
// {"vqmax", &lavc_param_vqmax, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
- {"mbqmin", &lavc_param_mb_qmin, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
- {"mbqmax", &lavc_param_mb_qmax, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
{"lmin", &lavc_param_lmin, TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.01, 255.0},
{"lmax", &lavc_param_lmax, TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.01, 255.0},
{"vqdiff", &lavc_param_vqdiff, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 31},
@@ -160,9 +156,9 @@
{"vcelim", &lavc_param_chroma_elim_threshold, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99},
{"vpsize", &lavc_param_packet_size, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 100000000},
{"vstrict", &lavc_param_strict, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -99, 99},
- {"vdpart", &lavc_param_data_partitioning, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_PART},
+ {"vdpart", &lavc_param_data_partitioning, TCCONF_TYPE_FLAG, 0, 0, 1},
// {"keyint", &lavc_param_keyint, TCCONF_TYPE_INT, 0, 0, 0},
- {"gray", &lavc_param_gray, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_PART},
+ {"gray", &lavc_param_gray, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_GRAY},
{"mpeg_quant", &lavc_param_mpeg_quant, TCCONF_TYPE_FLAG, 0, 0, 1},
{"vi_qfactor", &lavc_param_vi_qfactor, TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, -31.0, 31.0},
{"vi_qoffset", &lavc_param_vi_qoffset, TCCONF_TYPE_FLOAT, TCCONF_FLAG_RANGE, 0.0, 31.0},
@@ -211,21 +207,21 @@
#else
{"aic", &lavc_param_aic, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_AC_PRED},
#endif
- {"umv", &lavc_param_umv, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_H263P_UMV},
+ {"umv", &lavc_param_umv, TCCONF_TYPE_FLAG, 0, 0, 1},
{"ibias", &lavc_param_ibias, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -512, 512},
{"pbias", &lavc_param_pbias, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -512, 512},
{"coder", &lavc_param_coder, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 10},
{"context", &lavc_param_context, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 10},
{"intra_matrix", &lavc_param_intra_matrix, TCCONF_TYPE_STRING, 0, 0, 0},
{"inter_matrix", &lavc_param_inter_matrix, TCCONF_TYPE_STRING, 0, 0, 0},
- {"cbp", &lavc_param_cbp, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_CBP_RD},
+ {"cbp", &lavc_param_cbp, TCCONF_TYPE_FLAG, 0, 0, 1},
{"mv0", &lavc_param_mv0, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_MV0},
{"nr", &lavc_param_noise_reduction, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 0, 1000000},
- {"qprd", &lavc_param_qp_rd, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_QP_RD},
+ {"qprd", &lavc_param_qp_rd, TCCONF_TYPE_FLAG, 0, 0, 1},
{"threads", &lavc_param_threads, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, 1, 16},
- {"ss", &lavc_param_ss, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_H263P_SLICE_STRUCT},
- {"svcd_sof", &lavc_param_scan_offset, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_SVCD_SCAN_OFFSET},
- {"alt", &lavc_param_alt, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_ALT_SCAN},
+ {"ss", &lavc_param_ss, TCCONF_TYPE_FLAG, 0, 0, 1},
+ {"svcd_sof", &lavc_param_scan_offset, TCCONF_TYPE_FLAG, 0, 0, 1},
+ {"alt", &lavc_param_alt, TCCONF_TYPE_FLAG, 0, 0, 1},
{"ilme", &lavc_param_ilme, TCCONF_TYPE_FLAG, 0, 0, CODEC_FLAG_INTERLACED_ME},
{"inter_threshold", &lavc_param_inter_threshold, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -1000000, 1000000},
{"sc_threshold", &lavc_param_sc_threshold, TCCONF_TYPE_INT, TCCONF_FLAG_RANGE, -1000000, 1000000},
diff -Naur transcode-1.1.7.orig/export/ffmpeg_cfg.h transcode-1.1.7/export/ffmpeg_cfg.h
--- transcode-1.1.7.orig/export/ffmpeg_cfg.h 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/export/ffmpeg_cfg.h 2013-10-08 13:06:58.371706116 +0200
@@ -13,8 +13,6 @@
//extern int lavc_param_vqscale;
//extern int lavc_param_vqmin;
//extern int lavc_param_vqmax;
-extern int lavc_param_mb_qmin;
-extern int lavc_param_mb_qmax;
extern int lavc_param_lmin;
extern int lavc_param_lmax;
extern int lavc_param_vqdiff;
diff -Naur transcode-1.1.7.orig/filter/filter_pp.c transcode-1.1.7/filter/filter_pp.c
--- transcode-1.1.7.orig/filter/filter_pp.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/filter/filter_pp.c 2013-10-08 13:06:58.371706116 +0200
@@ -38,8 +38,8 @@
/* FIXME: these use the filter ID as an index--the ID can grow
* arbitrarily large, so this needs to be fixed */
-static pp_mode_t *mode[100];
-static pp_context_t *context[100];
+static pp_mode *mode[100];
+static pp_context *context[100];
static int width[100], height[100];
static int pre[100];
diff -Naur transcode-1.1.7.orig/import/decode_lavc.c transcode-1.1.7/import/decode_lavc.c
--- transcode-1.1.7.orig/import/decode_lavc.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/import/decode_lavc.c 2013-10-08 13:06:58.372706104 +0200
@@ -170,7 +170,7 @@
// Set these to the expected values so that ffmpeg's decoder can
// properly detect interlaced input.
- lavc_dec_context = avcodec_alloc_context();
+ lavc_dec_context = avcodec_alloc_context3(NULL);
if (lavc_dec_context == NULL) {
tc_log_error(__FILE__, "Could not allocate enough memory.");
goto decoder_error;
@@ -181,12 +181,12 @@
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
lavc_dec_context->error_resilience = 2;
#else
- lavc_dec_context->error_recognition = 2;
+ lavc_dec_context->err_recognition = 2;
#endif
lavc_dec_context->error_concealment = 3;
lavc_dec_context->workaround_bugs = FF_BUG_AUTODETECT;
- if (avcodec_open(lavc_dec_context, lavc_dec_codec) < 0) {
+ if (avcodec_open2(lavc_dec_context, lavc_dec_codec, NULL) < 0) {
tc_log_error(__FILE__, "Could not initialize the '%s' codec.",
codec->name);
goto decoder_error;
diff -Naur transcode-1.1.7.orig/import/import_ffmpeg.c transcode-1.1.7/import/import_ffmpeg.c
--- transcode-1.1.7.orig/import/import_ffmpeg.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/import/import_ffmpeg.c 2013-10-08 13:06:58.372706104 +0200
@@ -302,7 +302,7 @@
// Set these to the expected values so that ffmpeg's decoder can
// properly detect interlaced input.
- lavc_dec_context = avcodec_alloc_context();
+ lavc_dec_context = avcodec_alloc_context3(lavc_dec_codec);
if (lavc_dec_context == NULL) {
tc_log_error(MOD_NAME, "Could not allocate enough memory.");
return TC_IMPORT_ERROR;
@@ -314,7 +314,7 @@
#if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
lavc_dec_context->error_resilience = 2;
#else
- lavc_dec_context->error_recognition = 2;
+ lavc_dec_context->err_recognition = 2;
#endif
lavc_dec_context->error_concealment = 3;
lavc_dec_context->workaround_bugs = FF_BUG_AUTODETECT;
@@ -344,7 +344,7 @@
}
TC_LOCK_LIBAVCODEC;
- ret = avcodec_open(lavc_dec_context, lavc_dec_codec);
+ ret = avcodec_open2(lavc_dec_context, lavc_dec_codec, NULL);
TC_UNLOCK_LIBAVCODEC;
if (ret < 0) {
tc_log_warn(MOD_NAME, "Could not initialize the '%s' codec.",
diff -Naur transcode-1.1.7.orig/import/probe_ffmpeg.c transcode-1.1.7/import/probe_ffmpeg.c
--- transcode-1.1.7.orig/import/probe_ffmpeg.c 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/import/probe_ffmpeg.c 2013-10-08 13:06:58.373706091 +0200
@@ -99,8 +99,8 @@
TC_INIT_LIBAVCODEC;
- ret = av_open_input_file(&lavf_dmx_context, ipipe->name,
- NULL, 0, NULL);
+ ret = avformat_open_input(&lavf_dmx_context, ipipe->name,
+ NULL, NULL);
if (ret != 0) {
tc_log_error(__FILE__, "unable to open '%s'"
" (libavformat failure)",
@@ -109,7 +109,7 @@
return;
}
- ret = av_find_stream_info(lavf_dmx_context);
+ ret = avformat_find_stream_info(lavf_dmx_context, NULL);
if (ret < 0) {
tc_log_error(__FILE__, "unable to fetch informations from '%s'"
" (libavformat failure)",
diff -Naur transcode-1.1.7.orig/libtc/tcavcodec.h transcode-1.1.7/libtc/tcavcodec.h
--- transcode-1.1.7.orig/libtc/tcavcodec.h 2011-11-19 17:50:27.000000000 +0100
+++ transcode-1.1.7/libtc/tcavcodec.h 2013-10-08 13:06:58.373706091 +0200
@@ -53,7 +53,6 @@
#define TC_INIT_LIBAVCODEC do { \
TC_LOCK_LIBAVCODEC; \
- avcodec_init(); \
avcodec_register_all(); \
TC_UNLOCK_LIBAVCODEC; \
} while (0)

View File

@ -0,0 +1,11 @@
--- transcode-1.1.7/filter/subtitler/load_font.c.orig 2014-02-28 18:36:53.610542242 +0100
+++ transcode-1.1.7/filter/subtitler/load_font.c 2014-02-28 18:37:05.372429979 +0100
@@ -48,7 +48,7 @@
#include <ft2build.h>
#include FT_FREETYPE_H
-#include <freetype/ftglyph.h>
+#include <ftglyph.h>
/**
* @file bswap.h

257
transcode.spec Normal file
View File

@ -0,0 +1,257 @@
Name: transcode
Version: 1.1.7
Release: 4mamba
Summary: A text-console utility for video stream processing
Group: Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.transcoding.org/cgi-bin/transcode
Source: https://bitbucket.org/france/transcode-tcforge/downloads/transcode-%{version}.tar.bz2
Patch1: %{name}-1.1.7-ffmpeg-0.10.patch
Patch2: transcode-1.1.7-ffmpeg-2.patch
Patch3: transcode-1.1.7-freetype-2.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libICE-devel
BuildRequires: libMagick-devel
BuildRequires: libSDL-devel
BuildRequires: libSM-devel
BuildRequires: libX11-devel
BuildRequires: libXaw-devel
BuildRequires: libXext-devel
BuildRequires: libXpm-devel
BuildRequires: libXt-devel
BuildRequires: libXv-devel
BuildRequires: liba52dec-devel
BuildRequires: libalsa-devel
BuildRequires: libavcodec-ffmpeg-devel
BuildRequires: libavformat-ffmpeg-devel
BuildRequires: libdv-devel
BuildRequires: libdvdread-devel
BuildRequires: libfreetype-devel
BuildRequires: libgomp-devel
BuildRequires: libjpeg-devel
BuildRequires: liblame-devel
BuildRequires: liblzo-devel
BuildRequires: libmjpegtools-devel
BuildRequires: libogg-devel
BuildRequires: libpostproc-ffmpeg-devel
BuildRequires: libquicktime-devel
BuildRequires: libtheora-devel
BuildRequires: libvorbis-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libmpeg3-devel
#%ifarch %ix86 x86_64
#BuildRequires: divx4linux-devel
#%endif
BuildRequires: liblqr-devel
BuildRequires: libltdl-devel
Requires: vorbis-tools
Requires: libmjpegtools-devel >= 2.0.0
BuildRoot: %{_tmppath}/%{name}-%{version}-root
# FIXME:
# hardware support
# ----------------------------------------
# bktr no
# sunau no
#
# optional package support
# ----------------------------------------
# IBP no
# pvm3 no
# bsdav no
#
#
# ERROR: option '--enable-libjpegmmx' failed: cannot link against libjpeg-mmx
# x\can be found in the following packages:
# jpeg-mmx http://sourceforge.net/projects/mjpeg/
%description
Transcode is a text-console utility for video stream processing, running on a platform that supports shared libraries and threads.
Decoding and encoding is done by loading modules that are responsible for feeding transcode with raw video/audio streams (import modules) and encoding the frames (export modules).
It supports elementary video and audio frame transformations, including de-interlacing or fast resizing of video frames and loading of external filters.
It's modular concept is intended to provide flexibility and easy user extensibility to include other video/audio codecs or file types.
%prep
%setup -q
#%patch1 -p0
%patch2 -p1
%patch3 -p1
%build
%configure \
--with-qt \
--enable-mmx \
--enable-oss \
--enable-freetype2 \
--enable-avifile \
--with-avifile-includes=%{_includedir}/avifile-0.7 \
--enable-lame \
--enable-ogg \
--enable-vorbis \
--enable-theora \
--enable-libdvdread \
--enable-libdv \
--enable-libquicktime \
--enable-lzo \
--with-lzo-includes=%{_includedir}/lzo \
--enable-alsa \
--enable-a52 \
--enable-a52-default-decoder \
--enable-libmpeg3 \
--enable-libxml2 \
--enable-mjpegtools \
--enable-sdl \
--enable-gtk \
--enable-libfame \
--enable-imagemagick \
--enable-libjpeg \
--enable-libdv \
--enable-libpostproc \
--with-libpostproc-includes=%{_includedir}/postproc \
--enable-v4l2 \
--enable-v4lconvert \
--enable-netstream \
--with-libjpegmmx-libs=%{_libdir} \
--with-lame-libs=%{_libdir} \
--with-libdvdread-libs=%{_libdir} \
--with-lzo-libs=%{_libdir} \
--with-a52-libs=%{_libdir} \
--with-faac-libs=%{_libdir} \
LIBMPEG3_EXTRA_LIBS="-pthread"
# --enable-libjpegmmx
# --enable-bktr
# --enable-sunau
# --enable-ibp
# --enable-pvm3
# --enable-bsdav
%make \
LZO_LIBS="-L%{_libdir} -llzo2" \
LIBJPEG_LIBS="%{_libdir}"
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
rm -fr %{buildroot}%{_datadir}/doc/transcode/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/avifix
%{_bindir}/aviindex
%{_bindir}/avimerge
%{_bindir}/avisplit
%{_bindir}/avisync
%{_bindir}/tccat
%{_bindir}/tcdecode
%{_bindir}/tcdemux
%{_bindir}/tcextract
%{_bindir}/tcmodinfo
%{_bindir}/tcmp3cut
%{_bindir}/tcprobe
%{_bindir}/tcscan
%{_bindir}/tcyait
%{_bindir}/tcxmlcheck
%{_bindir}/tcxpm2rgb
%{_bindir}/transcode
%dir %{_libdir}/transcode
%{_libdir}/transcode/*
%{_mandir}/man1/*
%doc AUTHORS COPYING
#%doc ChangeLog README TODO
#%doc docs/*.txt docs/faq
#%doc docs/html/*.html docs/html/*.php docs/html/*.png
%changelog
* Fri Feb 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-4mamba
- rebuilt with ImageMagick 6.8.8.6
* Wed Feb 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-3mamba
- removed build requirement for divx4linux-devel
* Wed Sep 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-2mamba
- rebuilt with mjpegtools 2.0.0
* Wed Apr 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.7-1mamba
- update to 1.1.7
* Wed Apr 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.5-4mamba
- rebuilt with ffmpeg 0.10
* Fri Jul 09 2010 Automatic Build System <autodist@mambasoft.it> 1.1.5-3mamba
- automatic rebuild by autodist
* Thu Jan 14 2010 Automatic Build System <autodist@mambasoft.it> 1.1.5-2mamba
- automatic rebuild by autodist
* Thu Nov 19 2009 Automatic Build System <autodist@mambasoft.it> 1.1.5-1mamba
- automatic update by autodist
* Sun Aug 23 2009 Automatic Build System <autodist@mambasoft.it> 1.1.4-1mamba
- automatic update by autodist
* Thu Jul 23 2009 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
- automatic update by autodist
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.2-1mamba
- automatic update by autodist
* Mon Mar 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.1-1mamba
- automatic update by autodist
* Wed Feb 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.7-3mamba
- automatic rebuild by autodist
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.7-2mamba
- automatic rebuild by autodist
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.7-1mamba
- update to 1.0.7
* Mon Nov 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.5-4mamba
- automatic rebuild by autodist
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.5-3mamba
- rebuilt against ImageMagick 6.4
* Mon Jun 02 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.5-2mamba
- rebuilt against recent libdc1394
* Mon May 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.5-1mamba
- update to 1.0.5
* Fri Jan 19 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.2-2qilnx
- rebuilt against new ffmpeg library
- added build requirements for xorg 7
- fixed broken configure checks for ffmpeg and lzo libraries
- enabled support for v4l/v4l2 and libdv
* Mon Jan 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.2-1qilnx
- update to version 1.0.2 by autospec
* Thu Oct 20 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.0.1-1qilnx
- update to version 1.0.1 by autospec
* Mon Aug 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0-1qilnx
- update to version 1.0.0 by autospec
- enabled most of the available extensions
* Mon Jan 31 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.12-2qilnx
- added requirement for vorbis-tools (oggenc)
* Fri Oct 08 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.12-1qilnx
- new version build
- added a lot of required dependencies. Still missing pvm3 and the experimental lve
* Fri Dec 19 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.11-1qilnx
- first build