automatic version update by autodist [release 3.0.3-1mamba;Wed Nov 25 2020]
This commit is contained in:
parent
68efae3f00
commit
88c210699c
44
tpm2-tss-3.0.3-autoconf-2.70.patch
Normal file
44
tpm2-tss-3.0.3-autoconf-2.70.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 03cca78d24d716eec792f86f5b0bc69886fad981 Mon Sep 17 00:00:00 2001
|
||||
From: Patrick McCarty <patrick.mccarty@intel.com>
|
||||
Date: Fri, 18 Dec 2020 01:54:05 +0000
|
||||
Subject: [PATCH] configure.ac: fix compatibility with autoconf 2.70
|
||||
|
||||
With autoconf 2.70, not quoting the second argument to one of the AS_IF
|
||||
macro expansions leads to generation of invalid shell code affecting the
|
||||
first nested ERROR_IF_NO_PROG expansion.
|
||||
|
||||
The invalid shell code leads to an error resembling:
|
||||
|
||||
./configure: line 18826: syntax error near unexpected token `newline'
|
||||
./configure: line 18826: ` '''
|
||||
|
||||
Fix the issue by quoting the second argument to the affected AS_IF,
|
||||
similar to the quoting found elsewhere in configure.ac.
|
||||
|
||||
Signed-off-by: Patrick McCarty <patrick.mccarty@intel.com>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ff59dd7ce..3049032bc 100755
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -285,7 +285,7 @@ AC_ARG_ENABLE([integration],
|
||||
[build and execute integration tests])],,
|
||||
[enable_integration=no])
|
||||
AS_IF([test "x$enable_integration" = "xyes"],
|
||||
- AS_IF([test "$HOSTOS" = "Linux"],
|
||||
+ [AS_IF([test "$HOSTOS" = "Linux"],
|
||||
[ERROR_IF_NO_PROG([ss])],
|
||||
[ERROR_IF_NO_PROG([sockstat])])
|
||||
ERROR_IF_NO_PROG([echo])
|
||||
@@ -335,7 +335,7 @@ AS_IF([test "x$enable_integration" = "xyes"],
|
||||
[AC_MSG_ERROR([No simulator executable found in PATH for testing TCTI.])])
|
||||
AC_SUBST([INTEGRATION_TCTI], [$integration_tcti])
|
||||
AC_SUBST([INTEGRATION_ARGS], [$integration_args])
|
||||
- AC_SUBST([ENABLE_INTEGRATION], [$enable_integration]))
|
||||
+ AC_SUBST([ENABLE_INTEGRATION], [$enable_integration])])
|
||||
AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
|
||||
#
|
||||
# sanitizer compiler flags
|
@ -1,5 +1,5 @@
|
||||
Name: tpm2-tss
|
||||
Version: 3.0.2
|
||||
Version: 3.0.3
|
||||
Release: 1mamba
|
||||
Summary: OSS implementation of the TCG TPM2 Software Stack (TSS2)
|
||||
Group: System/Libraries
|
||||
@ -7,8 +7,8 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://tpm2-software.github.io
|
||||
## GITSOURCE https://github.com/tpm2-software/tpm2-tss.git 2.4.0
|
||||
Source: https://github.com/tpm2-software/tpm2-tss.git/%{version}/tpm2-tss-%{version}.tar.bz2
|
||||
Patch0: tpm2-tss-3.0.3-autoconf-2.70.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -56,6 +56,7 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
./bootstrap
|
||||
|
||||
%build
|
||||
@ -107,6 +108,9 @@ This package contains libraries and header files for developing applications tha
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Wed Nov 25 2020 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 20 2020 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user