add missing .conf extensions to sysusers_create and tmpfiles_create macros arguments [release 4.1.3-2mamba;Thu Dec 05 2024]
This commit is contained in:
parent
9acab29481
commit
5660a30b40
@ -1,44 +0,0 @@
|
||||
From 03cca78d24d716eec792f86f5b0bc69886fad981 Mon Sep 17 00:00:00 2001
|
||||
From: Patrick McCarty <patrick.mccarty@intel.com>
|
||||
Date: Fri, 18 Dec 2020 01:54:05 +0000
|
||||
Subject: [PATCH] configure.ac: fix compatibility with autoconf 2.70
|
||||
|
||||
With autoconf 2.70, not quoting the second argument to one of the AS_IF
|
||||
macro expansions leads to generation of invalid shell code affecting the
|
||||
first nested ERROR_IF_NO_PROG expansion.
|
||||
|
||||
The invalid shell code leads to an error resembling:
|
||||
|
||||
./configure: line 18826: syntax error near unexpected token `newline'
|
||||
./configure: line 18826: ` '''
|
||||
|
||||
Fix the issue by quoting the second argument to the affected AS_IF,
|
||||
similar to the quoting found elsewhere in configure.ac.
|
||||
|
||||
Signed-off-by: Patrick McCarty <patrick.mccarty@intel.com>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ff59dd7ce..3049032bc 100755
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -285,7 +285,7 @@ AC_ARG_ENABLE([integration],
|
||||
[build and execute integration tests])],,
|
||||
[enable_integration=no])
|
||||
AS_IF([test "x$enable_integration" = "xyes"],
|
||||
- AS_IF([test "$HOSTOS" = "Linux"],
|
||||
+ [AS_IF([test "$HOSTOS" = "Linux"],
|
||||
[ERROR_IF_NO_PROG([ss])],
|
||||
[ERROR_IF_NO_PROG([sockstat])])
|
||||
ERROR_IF_NO_PROG([echo])
|
||||
@@ -335,7 +335,7 @@ AS_IF([test "x$enable_integration" = "xyes"],
|
||||
[AC_MSG_ERROR([No simulator executable found in PATH for testing TCTI.])])
|
||||
AC_SUBST([INTEGRATION_TCTI], [$integration_tcti])
|
||||
AC_SUBST([INTEGRATION_ARGS], [$integration_args])
|
||||
- AC_SUBST([ENABLE_INTEGRATION], [$enable_integration]))
|
||||
+ AC_SUBST([ENABLE_INTEGRATION], [$enable_integration])])
|
||||
AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
|
||||
#
|
||||
# sanitizer compiler flags
|
@ -1,6 +1,6 @@
|
||||
Name: tpm2-tss
|
||||
Version: 4.1.3
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: OSS implementation of the TCG TPM2 Software Stack (TSS2)
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://tpm2-software.github.io
|
||||
Source: https://github.com/tpm2-software/tpm2-tss.git/%{version}/tpm2-tss-%{version}.tar.bz2
|
||||
Patch0: tpm2-tss-3.0.3-autoconf-2.70.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -49,7 +48,6 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
echo %{VERSION} > VERSION
|
||||
sed -i "s|^git describe|#git describe|" bootstrap
|
||||
./bootstrap
|
||||
@ -65,8 +63,6 @@ export PATH=/usr/sbin:$PATH
|
||||
--with-udevrulesprefix=60- \
|
||||
--enable-unit
|
||||
|
||||
# --enable-integration
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
@ -77,13 +73,10 @@ export PATH=/usr/sbin:$PATH
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%sysusers_create tpm2-tss
|
||||
%tmpfiles_create tpm2-tss-fapi
|
||||
%sysusers_create tpm2-tss.conf
|
||||
%tmpfiles_create tpm2-tss-fapi.conf
|
||||
:
|
||||
|
||||
%post -n libtss2 -p /sbin/ldconfig
|
||||
%postun -n libtss2 -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/tpm2-tss
|
||||
@ -116,6 +109,9 @@ export PATH=/usr/sbin:$PATH
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Thu Dec 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 4.1.3-2mamba
|
||||
- add missing .conf extensions to sysusers_create and tmpfiles_create macros arguments
|
||||
|
||||
* Fri May 24 2024 Automatic Build System <autodist@openmamba.org> 4.1.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user