rebuilt with openssl 1.0 [release 1.6-2mamba;Wed Nov 24 2010]

This commit is contained in:
Silvan Calarco 2024-01-05 18:34:24 +01:00
parent 97d4b1a1ca
commit 1148fcb188
4 changed files with 122 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# tls # tls
TLS is an OpenSSL / RSA-bsafe Tcl extension that provides secure connections on top of the Tcl socket mechanism.
Within a few lines of code, users can query https servers (see the tclhttpd project for an https server using TLS).

View File

@ -0,0 +1,44 @@
--- tls1.5/tests/ciphers.test.orig 2003-10-08 02:44:35.000000000 +0200
+++ tls1.5/tests/ciphers.test 2007-04-21 12:33:47.000000000 +0200
@@ -85,7 +85,6 @@
DES-CBC3-SHA
DHE-DSS-AES128-SHA
DHE-DSS-AES256-SHA
-DHE-DSS-RC4-SHA
DHE-RSA-AES128-SHA
DHE-RSA-AES256-SHA
EDH-DSS-DES-CBC-SHA
@@ -97,12 +96,6 @@
EXP-EDH-RSA-DES-CBC-SHA
EXP-RC2-CBC-MD5
EXP-RC4-MD5
-EXP1024-DES-CBC-SHA
-EXP1024-DHE-DSS-DES-CBC-SHA
-EXP1024-DHE-DSS-RC4-SHA
-EXP1024-RC2-CBC-MD5
-EXP1024-RC4-MD5
-EXP1024-RC4-SHA
IDEA-CBC-SHA
RC4-MD5
RC4-SHA
@@ -123,7 +116,6 @@
DES-CBC3-SHA
DHE-DSS-AES128-SHA
DHE-DSS-AES256-SHA
-DHE-DSS-RC4-SHA
DHE-RSA-AES128-SHA
DHE-RSA-AES256-SHA
EDH-DSS-DES-CBC-SHA
@@ -135,12 +127,6 @@
EXP-EDH-RSA-DES-CBC-SHA
EXP-RC2-CBC-MD5
EXP-RC4-MD5
-EXP1024-DES-CBC-SHA
-EXP1024-DHE-DSS-DES-CBC-SHA
-EXP1024-DHE-DSS-RC4-SHA
-EXP1024-RC2-CBC-MD5
-EXP1024-RC4-MD5
-EXP1024-RC4-SHA
IDEA-CBC-SHA
RC4-MD5
RC4-SHA

10
tls-1.5.0-pkgIndex.patch Normal file
View File

@ -0,0 +1,10 @@
diff -Nru tls1.5.orig/pkgIndex.tcl.in tls1.5/pkgIndex.tcl.in
--- tls1.5.orig/pkgIndex.tcl.in 2003-12-15 19:46:20.000000000 +0100
+++ tls1.5/pkgIndex.tcl.in 2008-05-09 21:00:49.000000000 +0200
@@ -5,5 +5,5 @@
# replace the original which didn't include the commands from "tls.tcl".
#
-package ifneeded tls 1.5 "[list load [file join $dir @RELPATH@ @tls_LIB_FILE@] ] ; [list source [file join $dir tls.tcl] ]"
+package ifneeded tls 1.50 "[list load [file join $dir @RELPATH@ @tls_LIB_FILE@] ] ; [list source [file join $dir tls.tcl] ]"

65
tls.spec Normal file
View File

@ -0,0 +1,65 @@
%define majversion %(echo %version | cut -d. -f 1-2)
Name: tls
Version: 1.6
Release: 2mamba
Summary: OpenSSL/RSA-bsafe Tcl extension
Group: Development/Bindings
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://tls.sourceforge.net
Source: http://downloads.sourceforge.net/tls/tls%{version}-src.tar.gz
Patch: %{name}-1.5.0-ciphertest.patch
Patch1: %{name}-1.5.0-pkgIndex.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libopenssl-devel
## AUTOBUILDREQ-END
BuildRequires: libtcl85-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
TLS is an OpenSSL / RSA-bsafe Tcl extension that provides secure connections on top of the Tcl socket mechanism.
Within a few lines of code, users can query https servers (see the tclhttpd project for an https server using TLS).
%prep
%setup -q -n %{name}%{majversion}
#%patch -p1
#%patch1 -p1
%build
%configure \
--with-ssl-dir=%{_prefix}
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeoldinstall \
pkglibdir=%{buildroot}%{_libdir}/%{name}%{version}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_includedir}/*.h
#%{_libdir}/*.so
%{_libdir}/%{name}%{version}
%doc ChangeLog README.txt license.terms tls.htm
%changelog
* Wed Nov 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-2mamba
- rebuilt with openssl 1.0
* Mon Mar 30 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6-1mamba
- automatic update by autodist
* Fri May 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.0-2mamba
- minor version fix in pkgIndex.tcl to work with amsn
* Fri Apr 20 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.5.0-1mamba
- package created by autospec