automatic version update by autodist [release 17.0.8-1mamba;Sat Aug 10 2013]

This commit is contained in:
Automatic Build System 2024-01-05 18:29:31 +01:00
parent 670b30432e
commit c1fb3e0605
23 changed files with 1843 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# thunderbird # thunderbird
The Mozilla Thunderbird project is a redesign of Mozilla's email/news component, written using the XUL user interface language and designed to be cross-platform.
Clarification: "Mozilla Thunderbird" is just a project name, in the same way as the Mozilla Application Suite is codenamed "SeaMonkey". For more details, read about the Mozilla Branding Strategy and the Mozilla Roadmap.
If you're interested in where we're going and when we expect to get there then you probably want the Mozilla Thunderbird Roadmap.We track bugs using Bugzilla.
Because the project is small and tightly managed, bugs targeted to a particular milestone generally will be fixed by that milestone. In fact, our milestone releases are bug-driven, not date-driven. Before filing any bugs on Mozilla Thunderbird, please read the bug filing instructions.

BIN
calendar-it.jar Normal file

Binary file not shown.

BIN
gdata-provider-it.jar Normal file

Binary file not shown.

BIN
lightning-it.jar Normal file

Binary file not shown.

View File

@ -0,0 +1,24 @@
diff -r f1af606531f5 memory/jemalloc/jemalloc.h
--- mozilla/memory/jemalloc/jemalloc.h Sat Nov 22 20:22:22 2008 +0100
+++ mozilla/memory/jemalloc/jemalloc.h Mon Dec 01 16:53:06 2008 -0500
@@ -45,14 +45,14 @@
} jemalloc_stats_t;
#ifndef MOZ_MEMORY_DARWIN
-void *malloc(size_t size);
-void *valloc(size_t size);
-void *calloc(size_t num, size_t size);
-void *realloc(void *ptr, size_t size);
-void free(void *ptr);
+void *malloc(size_t size) __THROW __attribute_malloc__ __wur;
+void *valloc(size_t size) __THROW __attribute_malloc__ __wur;
+void *calloc(size_t num, size_t size) __THROW __attribute_malloc__ __wur;
+void *realloc(void *ptr, size_t size) __THROW __attribute_malloc__ __wur;
+void free(void *ptr) __THROW __attribute_malloc__ __wur;
#endif
-int posix_memalign(void **memptr, size_t alignment, size_t size);
+int posix_memalign(void **memptr, size_t alignment, size_t size) __THROW __attribute_malloc__ __wur;
void *memalign(size_t alignment, size_t size);
size_t malloc_usable_size(const void *ptr);
void jemalloc_stats(jemalloc_stats_t *stats);

Binary file not shown.

After

Width:  |  Height:  |  Size: 31 KiB

View File

@ -0,0 +1,21 @@
--- comm-1.9.1/calendar/providers/storage/calStorageUpgrade.jsm 2009-12-05 02:53:54.000000000 +0100
+++ comm-1.9.1/calendar/providers/storage/calStorageUpgrade.jsm-gil 2009-12-21 01:03:19.000000000 +0100
@@ -1141,10 +1141,17 @@
// then swallowing
// the error is ok too since the cols will already be added in
// v16.
- db.createStatement("SELECT recurrence_id_tz," +
+ // Stepping this statement will fail if the columns don't exist.
+ // We don't use the delegate here since it would show an error to
+ // the user, even through we expect the error. If the db is null,
+ // then swallowing the error is ok too since the cols will
+ // already be added in v16.
+ let stmt = db.createStatement("SELECT recurrence_id_tz," +
" recurrence_id" +
" FROM cal_" + tblName +
" LIMIT 1");
+ stmt.step();
+ stmt.finalize();
} catch (e) {
// An error happened, which means the cols don't exist
hasColumns = false;

View File

@ -0,0 +1,74 @@
diff -Nru comm-1.9.1/mozilla/widget/src/gtk2/nsClipboard.cpp comm-1.9.1/mozilla/widget/src/gtk2-gil/nsClipboard.cpp
--- comm-1.9.1/mozilla/widget/src/gtk2/nsClipboard.cpp 2009-12-05 02:56:52.000000000 +0100
+++ comm-1.9.1/mozilla/widget/src/gtk2-gil/nsClipboard.cpp 2009-12-20 16:56:48.000000000 +0100
@@ -445,11 +445,11 @@
for (PRInt32 j = 0; j < n_targets; j++) {
gchar *atom_name = gdk_atom_name(targets[j]);
- if (!strcmp(atom_name, aFlavorList[i]))
+ if (!g_strcmp0(atom_name, aFlavorList[i]))
*_retval = PR_TRUE;
// X clipboard wants image/jpeg, not image/jpg
- if (!strcmp(aFlavorList[i], kJPEGImageMime) && !strcmp(atom_name, "image/jpeg"))
+ if (!g_strcmp0(aFlavorList[i], kJPEGImageMime) && !g_strcmp0(atom_name, "image/jpeg"))
*_retval = PR_TRUE;
g_free(atom_name);
diff -Nru comm-1.9.1/mozilla/widget/src/gtk2/nsDragService.cpp comm-1.9.1/mozilla/widget/src/gtk2-gil/nsDragService.cpp
--- comm-1.9.1/mozilla/widget/src/gtk2/nsDragService.cpp 2009-12-05 02:56:52.000000000 +0100
+++ comm-1.9.1/mozilla/widget/src/gtk2-gil/nsDragService.cpp 2009-12-20 17:02:42.000000000 +0100
@@ -801,15 +801,14 @@
name = gdk_atom_name(atom);
PR_LOG(sDragLm, PR_LOG_DEBUG,
("checking %s against %s\n", name, aDataFlavor));
- if (name && (strcmp(name, aDataFlavor) == 0)) {
+ if (g_strcmp0(name, aDataFlavor) == 0) {
PR_LOG(sDragLm, PR_LOG_DEBUG, ("good!\n"));
*_retval = PR_TRUE;
}
// check for automatic text/uri-list -> text/x-moz-url mapping
if (*_retval == PR_FALSE &&
- name &&
- (strcmp(name, gTextUriListType) == 0) &&
- (strcmp(aDataFlavor, kURLMime) == 0)) {
+ (g_strcmp0(name, gTextUriListType) == 0) &&
+ (g_strcmp0(aDataFlavor, kURLMime) == 0)) {
PR_LOG(sDragLm, PR_LOG_DEBUG,
("good! ( it's text/uri-list and \
we're checking against text/x-moz-url )\n"));
@@ -817,9 +816,8 @@
}
// check for automatic _NETSCAPE_URL -> text/x-moz-url mapping
if (*_retval == PR_FALSE &&
- name &&
- (strcmp(name, gMozUrlType) == 0) &&
- (strcmp(aDataFlavor, kURLMime) == 0)) {
+ (g_strcmp0(name, gMozUrlType) == 0) &&
+ (g_strcmp0(aDataFlavor, kURLMime) == 0)) {
PR_LOG(sDragLm, PR_LOG_DEBUG,
("good! ( it's _NETSCAPE_URL and \
we're checking against text/x-moz-url )\n"));
@@ -827,10 +825,9 @@
}
// check for auto text/plain -> text/unicode mapping
if (*_retval == PR_FALSE &&
- name &&
- (strcmp(name, kTextMime) == 0) &&
- ((strcmp(aDataFlavor, kUnicodeMime) == 0) ||
- (strcmp(aDataFlavor, kFileMime) == 0))) {
+ (g_strcmp0(name, kTextMime) == 0) &&
+ ((g_strcmp0(aDataFlavor, kUnicodeMime) == 0) ||
+ (g_strcmp0(aDataFlavor, kFileMime) == 0))) {
PR_LOG(sDragLm, PR_LOG_DEBUG,
("good! ( it's text plain and we're checking \
against text/unicode or application/x-moz-file)\n"));
@@ -951,7 +948,7 @@
GdkAtom atom = GDK_POINTER_TO_ATOM(tmp->data);
gchar *name = NULL;
name = gdk_atom_name(atom);
- if (strcmp(name, gMimeListType) == 0)
+ if (g_strcmp0(name, gMimeListType) == 0)
retval = PR_TRUE;
g_free(name);
if (retval)

View File

@ -0,0 +1,33 @@
diff -Nru comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/client/linux/handler/exception_handler.cc comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/client/linux/handler/exception_handler.cc
--- comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/client/linux/handler/exception_handler.cc 2009-12-05 02:56:50.000000000 +0100
+++ comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/client/linux/handler/exception_handler.cc 2009-12-20 16:07:47.000000000 +0100
@@ -33,6 +33,7 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <unistd.h>
+#include <stdio.h>
#include <cassert>
#include <cstdlib>
diff -Nru comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/client/linux/handler/minidump_generator.cc comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/client/linux/handler/minidump_generator.cc
--- comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/client/linux/handler/minidump_generator.cc 2009-12-05 02:56:50.000000000 +0100
+++ comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/client/linux/handler/minidump_generator.cc 2009-12-20 16:08:37.000000000 +0100
@@ -37,6 +37,7 @@
#include <unistd.h>
#include <sys/utsname.h>
#include <sys/wait.h>
+#include <stdio.h>
#include <cstdlib>
#include <ctime>
diff -Nru comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/common/linux/dump_symbols.cc
--- comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc 2009-12-05 02:56:50.000000000 +0100
+++ comm-1.9.1/mozilla/toolkit/crashreporter/google-breakpad/src-gil/common/linux/dump_symbols.cc 2009-12-20 16:10:42.000000000 +0100
@@ -41,6 +41,7 @@
#include <sys/types.h>
#include <unistd.h>
#include <algorithm>
+#include <stdio.h>
#include <functional>
#include <list>

View File

@ -0,0 +1,13 @@
--- comm-1.9.1/mail/app/profile/all-thunderbird.js 2009-12-21 01:34:07.000000000 +0100
+++ comm-1.9.1/mail/app/profile/all-thunderbird.js-gil 2009-12-21 02:00:31.000000000 +0100
@@ -308,6 +308,10 @@
pref("network.protocol-handler.warn-external.https", false);
pref("network.protocol-handler.warn-external.ftp", false);
+pref("network.protocol-handler.app.http", "/usr/bin/@DEFAULT_BROWSER@");
+pref("network.protocol-handler.app.https", "/usr/bin/@DEFAULT_BROWSER@");
+pref("network.protocol-handler.app.ftp", "/usr/bin/@DEFAULT_BROWSER@");
+
pref("network.hosts.smtp_server", "mail");
pref("network.hosts.pop_server", "mail");

View File

@ -0,0 +1,12 @@
--- comm-1.9.1/mail/app/profile/all-thunderbird.js 2009-12-05 02:53:47.000000000 +0100
+++ comm-1.9.1/mail/app/profile/all-thunderbird.js-gil 2009-12-20 21:53:05.000000000 +0100
@@ -45,7 +45,8 @@
pref("general.useragent.extra.thunderbird", "@APP_UA_NAME@/@APP_VERSION@");
-pref("general.useragent.locale", "@AB_CD@");
+pref("intl.locale.matchOS", true);
+pref("general.useragent.locale", "chrome://global/locale/intl.properties");
pref("general.skins.selectedSkin", "classic/1.0");
#ifdef XP_MACOSX

View File

@ -0,0 +1,11 @@
--- comm-1.9.1/mail/app/profile/all-thunderbird.js 2009-12-20 21:53:05.000000000 +0100
+++ comm-1.9.1/mail/app/profile/all-thunderbird.js-gil 2009-12-20 22:01:07.000000000 +0100
@@ -71,6 +71,8 @@
pref("nglayout.enable_drag_images", false);
#endif
+pref("mail.strictly_mime.parm_folding", 0);
+pref("dom.max_chrome_script_run_time", 0);
// App-specific update preferences
// Whether or not app updates are enabled

View File

@ -0,0 +1,14 @@
--- comm-1.9.1/mail/installer/Makefile.in 2009-12-05 02:53:48.000000000 +0100
+++ comm-1.9.1/mail/installer/Makefile.in-gil 2009-12-20 16:45:28.000000000 +0100
@@ -95,9 +95,11 @@
# mozconfig instead.
ifndef MAIL_PKG_SHARED
ifndef BUILD_STATIC_LIBS
+ifeq (BUILD_STATIC_LIBS, 1)
$(error you need an "--enable-static" build to package a build)
endif
endif
+endif
# On mozilla-central, packager.mk uses core_abspath to redefine DIST
# As the comm-central config.mk doesn't set it, do it ourselves instead

View File

@ -0,0 +1,11 @@
diff -up mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc.stat mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc
--- mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc.stat 2010-06-16 15:12:57.000000000 +0200
+++ mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc 2010-06-16 15:13:02.000000000 +0200
@@ -42,6 +42,7 @@
#include <link.h>
#include <string.h>
#include <sys/mman.h>
+#include <sys/stat.h>
#include <unistd.h>
#include <algorithm>

View File

@ -0,0 +1,11 @@
--- comm-1.9.2/mozilla/layout/generic/nsFrame.h 2010-06-23 19:46:42.000000000 +0200
+++ comm-1.9.2/mozilla/layout/generic/nsFrame.h-gil 2010-06-30 17:46:06.000000000 +0200
@@ -157,7 +157,7 @@
// Left undefined; nsFrame objects are never allocated from the heap.
void* operator new(size_t sz) CPP_THROW_NEW;
-protected:
+public:
// Overridden to prevent the global delete from being called, since
// the memory came out of an arena instead of the heap.
//

View File

@ -0,0 +1,12 @@
diff -up comm-1.9.2/mail/installer/Makefile.in.version comm-1.9.2/mail/installer/Makefile.in
--- comm-1.9.2/mail/installer/Makefile.in.version 2010-05-21 11:42:45.000000000 -0700
+++ comm-1.9.2/mail/installer/Makefile.in 2010-05-25 15:16:18.446197181 -0700
@@ -44,6 +44,8 @@ include $(DEPTH)/config/autoconf.mk
include $(topsrcdir)/config/rules.mk
+MOZ_APP_VERSION="__RPM_VERSION_INTERNAL__"
+
MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in

View File

@ -0,0 +1,53 @@
--- mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp 2010-07-13 23:28:39.000000000 +0200
+++ mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp-gil 2010-07-25 18:04:35.000000000 +0200
@@ -57,19 +57,6 @@
extern "C" {
#include "iccjpeg.h"
-
-/* Colorspace conversion (copied from jpegint.h) */
-struct jpeg_color_deconverter {
- JMETHOD(void, start_pass, (j_decompress_ptr cinfo));
- JMETHOD(void, color_convert, (j_decompress_ptr cinfo,
- JSAMPIMAGE input_buf, JDIMENSION input_row,
- JSAMPARRAY output_buf, int num_rows));
-};
-
-METHODDEF(void)
-ycc_rgb_convert_argb (j_decompress_ptr cinfo,
- JSAMPIMAGE input_buf, JDIMENSION input_row,
- JSAMPARRAY output_buf, int num_rows);
}
NS_IMPL_ISUPPORTS1(nsJPEGDecoder, imgIDecoder)
@@ -514,14 +501,6 @@
return NS_OK; /* I/O suspension */
}
- /* Force to use our YCbCr to Packed RGB converter when possible */
- if (!mTransform && (gfxPlatform::GetCMSMode() == eCMSMode_Off) &&
- mInfo.jpeg_color_space == JCS_YCbCr && mInfo.out_color_space == JCS_RGB) {
- /* Special case for the most common case: transform from YCbCr direct into packed ARGB */
- mInfo.out_color_components = 4; /* Packed ARGB pixels are always 4 bytes...*/
- mInfo.cconvert->color_convert = ycc_rgb_convert_argb;
- }
-
/* If this is a progressive JPEG ... */
mState = mInfo.buffered_image ? JPEG_DECOMPRESS_PROGRESSIVE : JPEG_DECOMPRESS_SEQUENTIAL;
}
@@ -678,15 +657,6 @@
PRUint32 *imageRow = ((PRUint32*)mImageData) +
(mInfo.output_scanline * mInfo.output_width);
- if (mInfo.cconvert->color_convert == ycc_rgb_convert_argb) {
- /* Special case: scanline will be directly converted into packed ARGB */
- if (jpeg_read_scanlines(&mInfo, (JSAMPARRAY)&imageRow, 1) != 1) {
- *suspend = PR_TRUE; /* suspend */
- break;
- }
- continue; /* all done for this row! */
- }
-
JSAMPROW sampleRow = (JSAMPROW)imageRow;
if (mInfo.output_components == 3) {
/* Put the pixels at end of row to enable in-place expansion */

View File

@ -0,0 +1,8 @@
--- mozilla/toolkit/system/gnome/Makefile.in 2010-08-25 16:28:36.000000000 +0200
+++ mozilla/toolkit/system/gnome/Makefile.in-gil 2010-10-05 02:51:42.000000000 +0200
@@ -93,4 +93,5 @@
$(MOZ_GNOMEVFS_CFLAGS) \
$(GLIB_CFLAGS) \
$(MOZ_LIBNOTIFY_CFLAGS) \
+ $(MOZ_GTK2_CFLAGS) \
$(NULL)

View File

@ -0,0 +1,11 @@
--- mozilla/gfx/ots/src/os2.cc 2011-03-03 12:42:31.000000000 +0100
+++ mozilla/gfx/ots/src/os2.cc-gil 2011-03-09 02:23:16.000000000 +0100
@@ -2,6 +2,8 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
+#include <cstddef>
+
#include "os2.h"
#include "head.h"

16
thunderbird-lang.sh Normal file
View File

@ -0,0 +1,16 @@
#!/bin/sh
# gil
THUNDERBIRD_VERSION=$1
if [ -z "$THUNDERBIRD_VERSION" ]; then
echo "Usage: $0 <version>"
exit 2
fi
rm -rf thunderbird-$THUNDERBIRD_VERSION
mkdir thunderbird-$THUNDERBIRD_VERSION
cd thunderbird-$THUNDERBIRD_VERSION
wget -r -N -l 1 -np -nd -A "*.xpi" ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$THUNDERBIRD_VERSION/linux-i686/xpi/
rm -f robots.txt
tar -cj *.xpi > ../thunderbird-$THUNDERBIRD_VERSION-langpacks.tar.bz2
#rm -rf thunderbird-$THUNDERBIRD_VERSION

79
thunderbird-script Normal file
View File

@ -0,0 +1,79 @@
#!/bin/sh
#
# gil
# Startup script for the openmamba Thunderbird RPM
# (based on the Mozilla & Fedora RPM launch script)
#
##
## Variables
##
MOZ_DIST_BIN="LIBDIR/thunderbird-MOZILLA_VERSION"
MOZ_PROGRAM="LIBDIR/thunderbird-MOZILLA_VERSION/thunderbird"
MOZ_EXTENSIONS_DIR="$MOZ_DIST_BIN/extensions"
MOZILLA_FIVE_HOME="LIBDIR/thunderbird-MOZILLA_VERSION"
export MOZILLA_FIVE_HOME
##
## Select the propper plugin dir
## Wrapped plug-ins are located in /lib/mozilla/plugins-wrapped
##
if [ -x "/usr/bin/mozilla-plugin-config" ]
then
MOZ_PLUGIN_DIR="plugins-wrapped"
else
MOZ_PLUGIN_DIR="plugins"
fi
##
## Set LD_LIBRARY_PATH
##
if [ "$LD_LIBRARY_PATH" ]
then
LD_LIBRARY_PATH=LIBDIR/thunderbird-MOZILLA_VERSION:LIBDIR/thunderbird-MOZILLA_VERSION/plugins:$LD_LIBRARY_PATH
else
LD_LIBRARY_PATH=LIBDIR/thunderbird-MOZILLA_VERSION:LIBDIR/thunderbird-MOZILLA_VERSION/plugins
fi
export LD_LIBRARY_PATH
##
## Make sure that we set the plugin path for backwards compatibility
##
if [ "$MOZ_PLUGIN_PATH" ]
then
MOZ_PLUGIN_PATH=$MOZ_PLUGIN_PATH:LIBDIR/mozilla/$MOZ_PLUGIN_DIR:LIBDIR/thunderbird-MOZILLA_VERSION/plugins
else
MOZ_PLUGIN_PATH=LIBDIR/mozilla/$MOZ_PLUGIN_DIR:LIBDIR/thunderbird-MOZILLA_VERSION/plugins
fi
export MOZ_PLUGIN_PATH
SHORTMOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*||g"`
[ -f $MOZ_EXTENSIONS_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org/chrome/$SHORTMOZLOCALE.jar ] && MOZARGS="-UILocale $SHORTMOZLOCALE"
MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
[ -f $MOZ_EXTENSIONS_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale $MOZLOCALE"
##
## Set MOZ_ENABLE_PANGO is no longer used because Pango is enabled by default
## you may use MOZ_DISABLE_PANGO=1 to force disabling of pango
##
#MOZ_DISABLE_PANGO=1
#export MOZ_DISABLE_PANGO
##
## Set MOZ_APP_LAUNCHER for gnome-session
##
export MOZ_APP_LAUNCHER="/usr/bin/thunderbird"
##
## Disable the GNOME crash dialog, Moz has it's own
##
GNOME_DISABLE_CRASH_DIALOG=1
export GNOME_DISABLE_CRASH_DIALOG
exec $MOZ_PROGRAM $MOZARGS ${1+"$@"}

16
thunderbird.desktop Normal file
View File

@ -0,0 +1,16 @@
[Desktop Entry]
Categories=Application;Network;
Comment=Send and Receive Email with Mozilla Thunderbird
Comment[it]=Inviare e Ricevere Email con Mozilla Thunderbird
Encoding=UTF-8
Exec=thunderbird
GenericName=Email
Icon=thunderbird
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vn;
Name=Mozilla Thunderbird Mail/News
Name[it]=Mozilla Thunderbird email client
Terminal=0
Type=Application
X-KDE-StartupNotify=true
X-MultipleArgs=false
StartupWMClass=Thunderbird-bin

1419
thunderbird.spec Normal file

File diff suppressed because it is too large Load Diff