package created using the webbuild interface [release 4.3.1-1mamba;Thu Sep 01 2022]
This commit is contained in:
parent
3d98667bdc
commit
d7272ab6eb
11
texstudio-4.3.1-fs54269.patch
Normal file
11
texstudio-4.3.1-fs54269.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -r c61879e1dfa9 minisplitter.cpp
|
||||
--- a/minisplitter.cpp Sun Aug 06 17:32:28 2017 +0200
|
||||
+++ b/minisplitter.cpp Tue Aug 08 15:33:21 2017 +0200
|
||||
@@ -72,7 +72,6 @@
|
||||
else
|
||||
setContentsMargins(0, 2, 0, 2);
|
||||
setMask(QRegion(contentsRect()));
|
||||
- QSplitterHandle::resizeEvent(event);
|
||||
}
|
||||
|
||||
void MiniSplitterHandle::paintEvent(QPaintEvent *event)
|
25
texstudio-4.3.1-fs72345.patch
Normal file
25
texstudio-4.3.1-fs72345.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- a/configmanager.cpp
|
||||
+++ b/configmanager.cpp
|
||||
@@ -631,7 +631,7 @@ ConfigManager::ConfigManager(QObject *pa
|
||||
#else
|
||||
registerOption("Grammar/Language Tool URL", &grammarCheckerConfig->languageToolURL, "http://localhost:8081/", &pseudoDialog->lineEditGrammarLTUrl);
|
||||
#endif
|
||||
- registerOption("Grammar/Language Tool Path", &grammarCheckerConfig->languageToolPath, "", &pseudoDialog->lineEditGrammarLTPath);
|
||||
+ registerOption("Grammar/Language Tool Path", &grammarCheckerConfig->languageToolPath, "/usr/share/languagetool:/usr/share/java/languagetool/*", &pseudoDialog->lineEditGrammarLTPath);
|
||||
registerOption("Grammar/Language Tool Arguments", &grammarCheckerConfig->languageToolArguments, "org.languagetool.server.HTTPServer -p 8081", &pseudoDialog->lineEditGrammarLTArguments);
|
||||
registerOption("Grammar/Language Tool Java Path", &grammarCheckerConfig->languageToolJavaPath, "java", &pseudoDialog->lineEditGrammarLTJava);
|
||||
registerOption("Grammar/Language Tool Autorun", &grammarCheckerConfig->languageToolAutorun, true, &pseudoDialog->checkBoxGrammarLTAutorun);
|
||||
--- a/grammarcheck.cpp
|
||||
+++ b/grammarcheck.cpp
|
||||
@@ -639,11 +639,6 @@ void GrammarCheckLanguageToolJSON::tryTo
|
||||
startTime = 0;
|
||||
if (ltPath == "")
|
||||
return;
|
||||
- if(!QFileInfo::exists(ltPath)){
|
||||
- errorText=QString("LT path \" %1 \" not found !").arg(ltPath);
|
||||
- emit errorMessage(errorText);
|
||||
- return;
|
||||
- }
|
||||
javaProcess = new QProcess();
|
||||
connect(javaProcess, SIGNAL(finished(int,QProcess::ExitStatus)), javaProcess, SLOT(deleteLater()));
|
||||
connect(this, SIGNAL(destroyed()), javaProcess, SLOT(deleteLater()));
|
71
texstudio.spec
Normal file
71
texstudio.spec
Normal file
@ -0,0 +1,71 @@
|
||||
Name: texstudio
|
||||
Version: 4.3.1
|
||||
Release: 1mamba
|
||||
Summary: A fully featured LaTeX editor
|
||||
Group: Graphical Desktop/Applications/Publishing
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.texstudio.org/
|
||||
Source: https://github.com/texstudio-org/texstudio.git/%{version}/texstudio-%{version}.tar.bz2
|
||||
Patch0: texstudio-4.3.1-fs54269.patch
|
||||
Patch1: texstudio-4.3.1-fs72345.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libhunspell-devel
|
||||
BuildRequires: libpoppler-cpp-devel
|
||||
BuildRequires: libpoppler-qt6-devel
|
||||
BuildRequires: libquazip-qt6-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt6-qt5compat-devel
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
BuildRequires: qt6-qtdeclarative-devel
|
||||
BuildRequires: qt6-qtsvg-devel
|
||||
BuildRequires: qt6-qttools-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: texlive-latex
|
||||
|
||||
%description
|
||||
A fully featured LaTeX editor.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
cd src
|
||||
%patch0 -p1 -b .fs54269
|
||||
%patch1 -p1 -b .fs72345
|
||||
cd ..
|
||||
|
||||
%build
|
||||
qmake-qt6 CONFIG-="debug" USE_SYSTEM_QUAZIP=1 USE_SYSTEM_HUNSPELL=1 QUAZIP_LIB=-lquazip1-qt6 \
|
||||
QUAZIP_INCLUDE="%{_includedir}/QuaZip-Qt6-1.3/quazip" texstudio.pro
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%makeinstall INSTALL_ROOT=%{buildroot} STRIP=/bin/true
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/texstudio
|
||||
%{_datadir}/applications/texstudio.desktop
|
||||
%{_datadir}/icons/hicolor/scalable/apps/texstudio.svg
|
||||
%{_datadir}/metainfo/texstudio.metainfo.xml
|
||||
%dir %{_datadir}/texstudio
|
||||
%{_datadir}/texstudio/*
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Thu Sep 01 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.1-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user