package created using the webbuild interface [release 2.1.1-1mamba;Fri Mar 04 2022]
This commit is contained in:
parent
b61abec39a
commit
02b8c8413f
@ -0,0 +1,28 @@
|
||||
From a65eb174adaa08cce0029ac38c5bc58ff8adaa7b Mon Sep 17 00:00:00 2001
|
||||
From: Ken <ken@kenh.fr>
|
||||
Date: Mon, 21 Dec 2020 19:43:06 +0100
|
||||
Subject: [PATCH] fixed 'validate' module import for newer version of configobj
|
||||
|
||||
---
|
||||
terminatorlib/config.py | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/terminatorlib/config.py b/terminatorlib/config.py
|
||||
index ec7a2a2e..ff37597d 100644
|
||||
--- a/terminatorlib/config.py
|
||||
+++ b/terminatorlib/config.py
|
||||
@@ -74,7 +74,10 @@ import os
|
||||
import shutil
|
||||
from copy import copy
|
||||
from configobj import ConfigObj, flatten_errors
|
||||
-from validate import Validator
|
||||
+try:
|
||||
+ from validate import Validator
|
||||
+except ModuleNotFoundError:
|
||||
+ from configobj.validate import Validator
|
||||
from .borg import Borg
|
||||
from .util import dbg, err, DEBUG, get_system_config_dir, get_config_dir, dict_diff
|
||||
|
||||
--
|
||||
2.29.2
|
||||
|
58
terminator.spec
Normal file
58
terminator.spec
Normal file
@ -0,0 +1,58 @@
|
||||
Name: terminator
|
||||
Version: 2.1.1
|
||||
Release: 1mamba
|
||||
Summary: Multiple GNOME terminals in one window
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://gnome-terminator.org/
|
||||
Source: https://github.com/gnome-terminator/terminator.git/v%{version}/terminator-%{version}.tar.bz2
|
||||
Patch0: terminator-2.1.1-0001-fixed-validate-module-import-for-newer-version-of-co.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython3-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
Multiple GNOME terminals in one window.
|
||||
|
||||
#% debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .0001-fixed-validate-module-import-for-newer-version-of-co
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python3} setup.py build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python3} setup.py install \
|
||||
-O1 --skip-build \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{python3_inc} \
|
||||
--install-lib=%{python3_sitearch} \
|
||||
--record=%{name}.filelist
|
||||
|
||||
%find_lang %{name} || touch %{name}.lang
|
||||
|
||||
sed -i "/share\/man/d" %{name}.filelist
|
||||
|
||||
rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.filelist
|
||||
%defattr(-,root,root)
|
||||
%dir %{python3_sitearch}/terminatorlib
|
||||
%{python3_sitearch}/terminatorlib/*
|
||||
%{_mandir}/man1/terminator.1*
|
||||
%{_mandir}/man5/terminator_config.5*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 04 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.1-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user