update to 1.1.23 [release 1.1.23-1mamba;Fri Oct 27 2017]
This commit is contained in:
parent
6ce4c4de25
commit
0d85a32b96
@ -1,211 +0,0 @@
|
|||||||
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
|
|
||||||
index 0e8db70..2934e50 100644
|
|
||||||
--- a/Telegram/gyp/Telegram.gyp
|
|
||||||
+++ b/Telegram/gyp/Telegram.gyp
|
|
||||||
@@ -69,19 +69,15 @@
|
|
||||||
],
|
|
||||||
|
|
||||||
'defines': [
|
|
||||||
- 'AL_LIBTYPE_STATIC',
|
|
||||||
+ 'TDESKTOP_DISABLE_AUTOUPDATE',
|
|
||||||
+ 'TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME',
|
|
||||||
],
|
|
||||||
|
|
||||||
'include_dirs': [
|
|
||||||
'<(src_loc)',
|
|
||||||
'<(SHARED_INTERMEDIATE_DIR)',
|
|
||||||
- '<(libs_loc)/breakpad/src',
|
|
||||||
- '<(libs_loc)/lzma/C',
|
|
||||||
- '<(libs_loc)/libexif-0.6.20',
|
|
||||||
- '<(libs_loc)/zlib-1.2.8',
|
|
||||||
- '<(libs_loc)/ffmpeg',
|
|
||||||
- '<(libs_loc)/openal-soft/include',
|
|
||||||
'<(minizip_loc)',
|
|
||||||
+ '/usr/include/breakpad',
|
|
||||||
],
|
|
||||||
'sources': [
|
|
||||||
'<@(qrc_files)',
|
|
||||||
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
|
|
||||||
index ea6f0f5..dcd2cfd 100644
|
|
||||||
--- a/Telegram/gyp/qt.gypi
|
|
||||||
+++ b/Telegram/gyp/qt.gypi
|
|
||||||
@@ -29,7 +29,6 @@
|
|
||||||
'Qt5Network',
|
|
||||||
'Qt5Widgets',
|
|
||||||
'Qt5Gui',
|
|
||||||
- 'qtharfbuzzng',
|
|
||||||
],
|
|
||||||
'conditions': [
|
|
||||||
[ 'build_macold', {
|
|
||||||
@@ -78,7 +77,7 @@
|
|
||||||
],
|
|
||||||
}],
|
|
||||||
[ 'build_linux', {
|
|
||||||
- 'qt_loc_unix': '/usr/local/tdesktop/Qt-<(qt_version)',
|
|
||||||
+ 'qt_loc_unix': '../../../qt',
|
|
||||||
'qt_lib_prefix': 'lib',
|
|
||||||
'qt_lib_debug_postfix': '.a',
|
|
||||||
'qt_lib_release_postfix': '.a',
|
|
||||||
@@ -91,21 +90,6 @@
|
|
||||||
'<@(qt_libs)',
|
|
||||||
'Qt5DBus',
|
|
||||||
'Qt5Core',
|
|
||||||
- 'qtpcre',
|
|
||||||
- 'ssl',
|
|
||||||
- 'crypto',
|
|
||||||
- 'Xi',
|
|
||||||
- 'Xext',
|
|
||||||
- 'SM',
|
|
||||||
- 'ICE',
|
|
||||||
- 'fontconfig',
|
|
||||||
- 'expat',
|
|
||||||
- 'freetype',
|
|
||||||
- 'xcb',
|
|
||||||
- 'xcb-shm',
|
|
||||||
- 'xcb-xfixes',
|
|
||||||
- 'xcb-render',
|
|
||||||
- 'xcb-static',
|
|
||||||
],
|
|
||||||
}],
|
|
||||||
],
|
|
||||||
@@ -206,8 +190,15 @@
|
|
||||||
'<(qt_loc)/plugins/platforms/xcb/xcb-static',
|
|
||||||
],
|
|
||||||
'libraries': [
|
|
||||||
- '/usr/local/lib/libxkbcommon.a',
|
|
||||||
'<@(qt_libs_release)',
|
|
||||||
+ 'z',
|
|
||||||
+ 'pcre16',
|
|
||||||
+ 'harfbuzz',
|
|
||||||
+ 'icuuc',
|
|
||||||
+ 'icutu',
|
|
||||||
+ 'icui18n',
|
|
||||||
+ 'png16',
|
|
||||||
+ 'jpeg',
|
|
||||||
'X11',
|
|
||||||
'X11-xcb',
|
|
||||||
'dbus-1',
|
|
||||||
@@ -215,6 +206,19 @@
|
|
||||||
'gthread-2.0',
|
|
||||||
'glib-2.0',
|
|
||||||
'pthread',
|
|
||||||
+ 'ssl',
|
|
||||||
+ 'crypto',
|
|
||||||
+ 'Xi',
|
|
||||||
+ 'Xext',
|
|
||||||
+ 'SM',
|
|
||||||
+ 'ICE',
|
|
||||||
+ 'fontconfig',
|
|
||||||
+ 'expat',
|
|
||||||
+ 'freetype',
|
|
||||||
+ 'xcb',
|
|
||||||
+ 'xcb-shm',
|
|
||||||
+ 'xcb-xfixes',
|
|
||||||
+ 'xcb-render',
|
|
||||||
],
|
|
||||||
'include_dirs': [
|
|
||||||
'<(qt_loc)/mkspecs/linux-g++',
|
|
||||||
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
|
|
||||||
index 15bfbb6..5992643 100644
|
|
||||||
--- a/Telegram/gyp/telegram_linux.gypi
|
|
||||||
+++ b/Telegram/gyp/telegram_linux.gypi
|
|
||||||
@@ -29,31 +29,41 @@
|
|
||||||
],
|
|
||||||
},
|
|
||||||
'include_dirs': [
|
|
||||||
- '/usr/local/include',
|
|
||||||
- '<(libs_loc)/openssl-xcode/include'
|
|
||||||
+ '/usr/include',
|
|
||||||
],
|
|
||||||
'library_dirs': [
|
|
||||||
- '/usr/local/lib',
|
|
||||||
- '<(libs_loc)/libexif-0.6.20/libexif/.libs',
|
|
||||||
- '<(libs_loc)/breakpad/src/client/linux',
|
|
||||||
+ '/usr/lib',
|
|
||||||
],
|
|
||||||
'libraries': [
|
|
||||||
'breakpad_client',
|
|
||||||
'composeplatforminputcontextplugin',
|
|
||||||
'ibusplatforminputcontextplugin',
|
|
||||||
'fcitxplatforminputcontextplugin',
|
|
||||||
- 'liblzma.a',
|
|
||||||
- 'libopenal.a',
|
|
||||||
- 'libavformat.a',
|
|
||||||
- 'libavcodec.a',
|
|
||||||
- 'libswresample.a',
|
|
||||||
- 'libswscale.a',
|
|
||||||
- 'libavutil.a',
|
|
||||||
- 'libopus.a',
|
|
||||||
- 'libva-x11.a',
|
|
||||||
- 'libva-drm.a',
|
|
||||||
- 'libva.a',
|
|
||||||
- 'libz.a',
|
|
||||||
+ 'xkbcommon',
|
|
||||||
+ 'xkbcommon-x11',
|
|
||||||
+ 'xcb-randr',
|
|
||||||
+ 'xcb-xinerama',
|
|
||||||
+ 'xcb-xkb',
|
|
||||||
+ 'xcb-shape',
|
|
||||||
+ 'xcb-icccm',
|
|
||||||
+ 'xcb-sync',
|
|
||||||
+ 'xcb-keysyms',
|
|
||||||
+ 'xcb-image',
|
|
||||||
+ 'xcb-render-util',
|
|
||||||
+ 'proxy',
|
|
||||||
+ 'lzma',
|
|
||||||
+ 'openal',
|
|
||||||
+ 'avformat',
|
|
||||||
+ 'avcodec',
|
|
||||||
+ 'swresample',
|
|
||||||
+ 'swscale',
|
|
||||||
+ 'avutil',
|
|
||||||
+ 'opus',
|
|
||||||
+ 'va-x11',
|
|
||||||
+ 'va-drm',
|
|
||||||
+ 'va',
|
|
||||||
+ 'z',
|
|
||||||
+ 'webp',
|
|
||||||
# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
|
|
||||||
],
|
|
||||||
'cflags_cc': [
|
|
||||||
diff --git a/Telegram/gyp/utils.gyp b/Telegram/gyp/utils.gyp
|
|
||||||
index 117c87a..5ff1a4c 100644
|
|
||||||
--- a/Telegram/gyp/utils.gyp
|
|
||||||
+++ b/Telegram/gyp/utils.gyp
|
|
||||||
@@ -101,8 +101,6 @@
|
|
||||||
},
|
|
||||||
'include_dirs': [
|
|
||||||
'<(src_loc)',
|
|
||||||
- '<(libs_loc)/lzma/C',
|
|
||||||
- '<(libs_loc)/zlib-1.2.8',
|
|
||||||
],
|
|
||||||
'sources': [
|
|
||||||
'<(src_loc)/_other/packer.cpp',
|
|
||||||
@@ -122,11 +120,10 @@
|
|
||||||
],
|
|
||||||
}, {
|
|
||||||
'include_dirs': [
|
|
||||||
- '/usr/local/include',
|
|
||||||
- '<(libs_loc)/openssl-xcode/include'
|
|
||||||
+ '/usr/include',
|
|
||||||
],
|
|
||||||
'library_dirs': [
|
|
||||||
- '/usr/local/lib',
|
|
||||||
+ '/usr/lib',
|
|
||||||
],
|
|
||||||
}]
|
|
||||||
],
|
|
||||||
@@ -144,11 +141,10 @@
|
|
||||||
],
|
|
||||||
}, {
|
|
||||||
'include_dirs': [
|
|
||||||
- '/usr/local/include',
|
|
||||||
- '<(libs_loc)/openssl-xcode/include'
|
|
||||||
+ '/usr/include',
|
|
||||||
],
|
|
||||||
'library_dirs': [
|
|
||||||
- '/usr/local/lib',
|
|
||||||
+ '/usr/lib',
|
|
||||||
],
|
|
||||||
}]
|
|
||||||
],
|
|
227
telegram-1.1.23-fix-build.patch
Normal file
227
telegram-1.1.23-fix-build.patch
Normal file
@ -0,0 +1,227 @@
|
|||||||
|
diff --git a/Telegram/SourceFiles/qt_static_plugins.cpp b/Telegram/SourceFiles/qt_static_plugins.cpp
|
||||||
|
index b975c7a8..5ad461a4 100644
|
||||||
|
--- a/Telegram/SourceFiles/qt_static_plugins.cpp
|
||||||
|
+++ b/Telegram/SourceFiles/qt_static_plugins.cpp
|
||||||
|
@@ -30,6 +30,7 @@ Q_IMPORT_PLUGIN(QGenericEnginePlugin)
|
||||||
|
#elif defined Q_OS_LINUX // Q_OS_WIN | Q_OS_MAC
|
||||||
|
Q_IMPORT_PLUGIN(QWebpPlugin)
|
||||||
|
Q_IMPORT_PLUGIN(QXcbIntegrationPlugin)
|
||||||
|
+Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
|
||||||
|
Q_IMPORT_PLUGIN(QConnmanEnginePlugin)
|
||||||
|
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
|
||||||
|
Q_IMPORT_PLUGIN(QNetworkManagerEnginePlugin)
|
||||||
|
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
|
||||||
|
index 0d1f38aa..0665cce1 100644
|
||||||
|
--- a/Telegram/gyp/Telegram.gyp
|
||||||
|
+++ b/Telegram/gyp/Telegram.gyp
|
||||||
|
@@ -85,25 +85,21 @@
|
||||||
|
],
|
||||||
|
|
||||||
|
'defines': [
|
||||||
|
- 'AL_LIBTYPE_STATIC',
|
||||||
|
'AL_ALEXT_PROTOTYPES',
|
||||||
|
'TGVOIP_USE_CXX11_LIB',
|
||||||
|
'<!@(python -c "for s in \'<(build_defines)\'.split(\',\'): print(s)")',
|
||||||
|
+ '__STDC_FORMAT_MACROS',
|
||||||
|
+ 'TDESKTOP_DISABLE_AUTOUPDATE',
|
||||||
|
+ 'TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME',
|
||||||
|
],
|
||||||
|
|
||||||
|
'include_dirs': [
|
||||||
|
'<(src_loc)',
|
||||||
|
'<(SHARED_INTERMEDIATE_DIR)',
|
||||||
|
- '<(libs_loc)/breakpad/src',
|
||||||
|
- '<(libs_loc)/lzma/C',
|
||||||
|
- '<(libs_loc)/libexif-0.6.20',
|
||||||
|
- '<(libs_loc)/zlib-1.2.8',
|
||||||
|
- '<(libs_loc)/ffmpeg',
|
||||||
|
- '<(libs_loc)/openal-soft/include',
|
||||||
|
- '<(libs_loc)/opus/include',
|
||||||
|
'<(minizip_loc)',
|
||||||
|
'<(sp_media_key_tap_loc)',
|
||||||
|
'<(emoji_suggestions_loc)',
|
||||||
|
+ '/usr/include/breakpad',
|
||||||
|
'<(submodules_loc)/GSL/include',
|
||||||
|
'<(submodules_loc)/variant/include',
|
||||||
|
],
|
||||||
|
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
|
||||||
|
index 6032d066..567cdb95 100644
|
||||||
|
--- a/Telegram/gyp/qt.gypi
|
||||||
|
+++ b/Telegram/gyp/qt.gypi
|
||||||
|
@@ -38,7 +38,6 @@
|
||||||
|
'Qt5Network',
|
||||||
|
'Qt5Widgets',
|
||||||
|
'Qt5Gui',
|
||||||
|
- 'qtharfbuzzng',
|
||||||
|
],
|
||||||
|
'qt_version%': '<(qt_version)',
|
||||||
|
'conditions': [
|
||||||
|
@@ -97,20 +96,9 @@
|
||||||
|
'<@(qt_libs)',
|
||||||
|
'Qt5DBus',
|
||||||
|
'Qt5Core',
|
||||||
|
- 'qtpcre',
|
||||||
|
- 'Xi',
|
||||||
|
- 'Xext',
|
||||||
|
- 'Xfixes',
|
||||||
|
- 'SM',
|
||||||
|
- 'ICE',
|
||||||
|
- 'fontconfig',
|
||||||
|
- 'expat',
|
||||||
|
- 'freetype',
|
||||||
|
- 'z',
|
||||||
|
- 'xcb-shm',
|
||||||
|
- 'xcb-xfixes',
|
||||||
|
- 'xcb-render',
|
||||||
|
- 'xcb-static',
|
||||||
|
+ 'Qt5WaylandClient',
|
||||||
|
+ 'qwayland-generic',
|
||||||
|
+ 'qwayland-egl',
|
||||||
|
],
|
||||||
|
}],
|
||||||
|
],
|
||||||
|
@@ -200,6 +188,7 @@
|
||||||
|
'<(qt_loc)/include/QtGui/<(qt_version)',
|
||||||
|
'<(qt_loc)/include/QtCore/<(qt_version)/QtCore',
|
||||||
|
'<(qt_loc)/include/QtGui/<(qt_version)/QtGui',
|
||||||
|
+ '/usr/include/openssl-1.0',
|
||||||
|
],
|
||||||
|
'library_dirs': [
|
||||||
|
'<(qt_loc)/lib',
|
||||||
|
@@ -220,7 +209,6 @@
|
||||||
|
'<(qt_loc)/plugins/platforminputcontexts',
|
||||||
|
],
|
||||||
|
'libraries': [
|
||||||
|
- '<(linux_path_xkbcommon)/lib/libxkbcommon.a',
|
||||||
|
'<@(qt_libs_release)',
|
||||||
|
'<(linux_lib_ssl)',
|
||||||
|
'<(linux_lib_crypto)',
|
||||||
|
@@ -233,12 +221,32 @@
|
||||||
|
'-lgthread-2.0',
|
||||||
|
'-lglib-2.0',
|
||||||
|
'-lpthread',
|
||||||
|
+
|
||||||
|
+ '-lXi',
|
||||||
|
+ '-lXext',
|
||||||
|
+ '-lXfixes',
|
||||||
|
+ '-lSM',
|
||||||
|
+ '-lICE',
|
||||||
|
+ '-lfontconfig',
|
||||||
|
+ '-lexpat',
|
||||||
|
+ '-lfreetype',
|
||||||
|
+
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs xkbcommon xkbcommon-x11)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs harfbuzz)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs libpcre16)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs zlib)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs libpng16)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs libjpeg)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs libwebp)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs xcb-shm xcb-xfixes xcb-render xcb-renderutil xcb-sync xcb-randr xcb-xinerama xcb-xkb xcb-icccm xcb-image xcb-shape xcb-keysyms xcb-util)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs wayland-client wayland-cursor)',
|
||||||
|
+ '-lproxy',
|
||||||
|
+ '-lGL',
|
||||||
|
],
|
||||||
|
'include_dirs': [
|
||||||
|
'<(qt_loc)/mkspecs/linux-g++',
|
||||||
|
],
|
||||||
|
'ldflags': [
|
||||||
|
- '-static-libstdc++',
|
||||||
|
'-pthread',
|
||||||
|
'-g',
|
||||||
|
'-rdynamic',
|
||||||
|
diff --git a/Telegram/gyp/settings_linux.gypi b/Telegram/gyp/settings_linux.gypi
|
||||||
|
index fde88dcd..1fd1b9cb 100644
|
||||||
|
--- a/Telegram/gyp/settings_linux.gypi
|
||||||
|
+++ b/Telegram/gyp/settings_linux.gypi
|
||||||
|
@@ -25,7 +25,6 @@
|
||||||
|
'-pipe',
|
||||||
|
'-g',
|
||||||
|
'-Wall',
|
||||||
|
- '-Werror',
|
||||||
|
'-W',
|
||||||
|
'-fPIC',
|
||||||
|
'-Wno-unused-variable',
|
||||||
|
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
|
||||||
|
index 2c464928..2112496b 100644
|
||||||
|
--- a/Telegram/gyp/telegram_linux.gypi
|
||||||
|
+++ b/Telegram/gyp/telegram_linux.gypi
|
||||||
|
@@ -21,11 +21,20 @@
|
||||||
|
'conditions': [[ 'build_linux', {
|
||||||
|
'variables': {
|
||||||
|
'pkgconfig_libs': [
|
||||||
|
-# In order to work libxkbcommon must be linked statically,
|
||||||
|
-# PKGCONFIG links it like "-L/usr/local/lib -lxkbcommon"
|
||||||
|
-# which makes a dynamic link which leads to segfault in
|
||||||
|
-# QApplication() -> createPlatformIntegration -> QXcbIntegrationPlugin::create
|
||||||
|
- #'xkbcommon',
|
||||||
|
+ 'liblzma',
|
||||||
|
+ 'openal',
|
||||||
|
+ 'libavformat',
|
||||||
|
+ 'libavcodec',
|
||||||
|
+ 'libswresample',
|
||||||
|
+ 'libswscale',
|
||||||
|
+ 'libavutil',
|
||||||
|
+ 'opus',
|
||||||
|
+ 'libva-x11',
|
||||||
|
+ 'libva-drm',
|
||||||
|
+ 'libva',
|
||||||
|
+ 'vdpau',
|
||||||
|
+ 'libdrm',
|
||||||
|
+ 'zlib',
|
||||||
|
],
|
||||||
|
'linux_path_ffmpeg%': '/usr/local',
|
||||||
|
'linux_path_openal%': '/usr/local',
|
||||||
|
@@ -36,20 +45,11 @@
|
||||||
|
'linux_path_opus_include%': '<(libs_loc)/opus/include',
|
||||||
|
},
|
||||||
|
'include_dirs': [
|
||||||
|
- '/usr/local/include',
|
||||||
|
- '<(linux_path_ffmpeg)/include',
|
||||||
|
- '<(linux_path_openal)/include',
|
||||||
|
- '<(linux_path_breakpad)/include/breakpad',
|
||||||
|
'<(linux_path_opus_include)',
|
||||||
|
+ '/usr/include',
|
||||||
|
],
|
||||||
|
'library_dirs': [
|
||||||
|
- '/usr/local/lib',
|
||||||
|
- '<(linux_path_ffmpeg)/lib',
|
||||||
|
- '<(linux_path_openal)/lib',
|
||||||
|
- '<(linux_path_libexif_lib)',
|
||||||
|
- '<(linux_path_va)/lib',
|
||||||
|
- '<(linux_path_vdpau)/lib',
|
||||||
|
- '<(linux_path_breakpad)/lib',
|
||||||
|
+ '/usr/lib',
|
||||||
|
],
|
||||||
|
'libraries': [
|
||||||
|
'breakpad_client',
|
||||||
|
@@ -57,27 +57,14 @@
|
||||||
|
'ibusplatforminputcontextplugin',
|
||||||
|
'fcitxplatforminputcontextplugin',
|
||||||
|
'himeplatforminputcontextplugin',
|
||||||
|
- 'liblzma.a',
|
||||||
|
- 'libopenal.a',
|
||||||
|
- 'libavformat.a',
|
||||||
|
- 'libavcodec.a',
|
||||||
|
- 'libswresample.a',
|
||||||
|
- 'libswscale.a',
|
||||||
|
- 'libavutil.a',
|
||||||
|
- 'libopus.a',
|
||||||
|
- 'libva-x11.a',
|
||||||
|
- 'libva-drm.a',
|
||||||
|
- 'libva.a',
|
||||||
|
- 'libvdpau.a',
|
||||||
|
- 'libdrm.a',
|
||||||
|
- 'libz.a',
|
||||||
|
-# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
|
||||||
|
],
|
||||||
|
'cflags_cc': [
|
||||||
|
'<!(pkg-config 2> /dev/null --cflags appindicator-0.1)',
|
||||||
|
'<!(pkg-config 2> /dev/null --cflags gtk+-2.0)',
|
||||||
|
'<!(pkg-config 2> /dev/null --cflags glib-2.0)',
|
||||||
|
'<!(pkg-config 2> /dev/null --cflags dee-1.0)',
|
||||||
|
+ '<!(pkg-config 2> /dev/null --cflags <@(pkgconfig_libs))',
|
||||||
|
],
|
||||||
|
'configurations': {
|
||||||
|
'Release': {
|
12
telegram-1.1.23-libtgvoip-fixes.patch
Normal file
12
telegram-1.1.23-libtgvoip-fixes.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/libtgvoip.gyp b/libtgvoip.gyp
|
||||||
|
index 52fbea1..d5c6ec4 100644
|
||||||
|
--- a/libtgvoip.gyp
|
||||||
|
+++ b/libtgvoip.gyp
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
'include_dirs': [
|
||||||
|
'<(tgvoip_src_loc)/webrtc_dsp',
|
||||||
|
'<(linux_path_opus_include)',
|
||||||
|
+ '/usr/include/openssl-1.0',
|
||||||
|
],
|
||||||
|
'direct_dependent_settings': {
|
||||||
|
'include_dirs': [
|
112
telegram.spec
112
telegram.spec
@ -1,9 +1,9 @@
|
|||||||
%define qt_ver 5.6.0
|
%define qt_ver 5.6.2
|
||||||
%define qt_patchver %(echo %qt_ver | tr . _)
|
%define qt_patchver %(echo %qt_ver | tr . _)
|
||||||
%define qt_majver %(echo %qt_ver | cut -d. -f1-2)
|
%define qt_majver %(echo %qt_ver | cut -d. -f1-2)
|
||||||
|
|
||||||
Name: telegram
|
Name: telegram
|
||||||
Version: 0.10.6
|
Version: 1.1.23
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The official desktop client for the Telegram messenger
|
Summary: The official desktop client for the Telegram messenger
|
||||||
Group: Graphical Desktop/Applications/Internet
|
Group: Graphical Desktop/Applications/Internet
|
||||||
@ -17,8 +17,10 @@ Source1: telegramdesktop.desktop
|
|||||||
Source2: tg.protocol
|
Source2: tg.protocol
|
||||||
Source3: http://download.qt-project.org/official_releases/qt/%{qt_majver}/%{qt_ver}/submodules/qtbase-opensource-src-%{qt_ver}.tar.xz
|
Source3: http://download.qt-project.org/official_releases/qt/%{qt_majver}/%{qt_ver}/submodules/qtbase-opensource-src-%{qt_ver}.tar.xz
|
||||||
Source4: http://download.qt-project.org/official_releases/qt/%{qt_majver}/%{qt_ver}/submodules/qtimageformats-opensource-src-%{qt_ver}.tar.xz
|
Source4: http://download.qt-project.org/official_releases/qt/%{qt_majver}/%{qt_ver}/submodules/qtimageformats-opensource-src-%{qt_ver}.tar.xz
|
||||||
|
Source5: http://download.qt-project.org/official_releases/qt/%{qt_majver}/%{qt_ver}/submodules/qtwayland-opensource-src-%{qt_ver}.tar.xz
|
||||||
Patch0: telegram-0.10.6-disable-unity.patch
|
Patch0: telegram-0.10.6-disable-unity.patch
|
||||||
Patch1: telegram-0.10.6-fix-build.patch
|
Patch1: telegram-1.1.23-fix-build.patch
|
||||||
|
Patch2: telegram-1.1.23-libtgvoip-fixes.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -59,6 +61,7 @@ BuildRequires: libxkbcommon-devel
|
|||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libbreakpad-devel
|
BuildRequires: libbreakpad-devel
|
||||||
|
BuildRequires: libunity-devel
|
||||||
Requires: kconfig
|
Requires: kconfig
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -68,7 +71,7 @@ The official desktop client for the Telegram messenger.
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -c -a0 -a3 -a4
|
%setup -q -c -a0 -a3 -a4 -a5
|
||||||
#% setup -q -c -D -T
|
#% setup -q -c -D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
|
|
||||||
@ -78,6 +81,7 @@ mkdir -p Libraries/qt%{qt_ver}
|
|||||||
|
|
||||||
mv qtbase-opensource-src-%{qt_ver} Libraries/qt%{qt_ver}/qtbase
|
mv qtbase-opensource-src-%{qt_ver} Libraries/qt%{qt_ver}/qtbase
|
||||||
mv qtimageformats-opensource-src-%{qt_ver} Libraries/qt%{qt_ver}/qtimageformats
|
mv qtimageformats-opensource-src-%{qt_ver} Libraries/qt%{qt_ver}/qtimageformats
|
||||||
|
mv qtwayland-opensource-src-%{qt_ver} Libraries/qt%{qt_ver}/qtwayland
|
||||||
|
|
||||||
cd Libraries/qt%{qt_ver}/qtbase
|
cd Libraries/qt%{qt_ver}/qtbase
|
||||||
patch -p1 < ../../../tdesktop-%{version}/Telegram/Patches/qtbase_%{qt_patchver}.diff
|
patch -p1 < ../../../tdesktop-%{version}/Telegram/Patches/qtbase_%{qt_patchver}.diff
|
||||||
@ -93,29 +97,43 @@ mkdir -p Libraries/cmake-3.6.2/bin
|
|||||||
ln -s %{_bindir}/cmake Libraries/cmake-3.6.2/bin/cmake
|
ln -s %{_bindir}/cmake Libraries/cmake-3.6.2/bin/cmake
|
||||||
|
|
||||||
cd tdesktop-%{version}
|
cd tdesktop-%{version}
|
||||||
%patch1 -p1
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
#sed -i 's/CUSTOM_API_ID//g' Telegram/Telegram.pro
|
%patch1 -p1
|
||||||
#sed -i 's,LIBS += /usr/local/lib/libxkbcommon.a,,g' Telegram/Telegram.pro
|
|
||||||
#sed -i 's,LIBS += /usr/local/lib/libz.a,LIBS += -lz,g' Telegram/Telegram.pro
|
cd Telegram/ThirdParty
|
||||||
#
|
git clone https://github.com/telegramdesktop/libtgvoip.git
|
||||||
#(
|
git clone https://github.com/Microsoft/GSL.git
|
||||||
# echo "DEFINES += TDESKTOP_DISABLE_AUTOUPDATE"
|
git clone https://github.com/mapbox/variant.git
|
||||||
# echo "DEFINES += TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME"
|
git clone https://github.com/philsquared/Catch.git
|
||||||
# echo 'INCLUDEPATH += "%{_libdir}/glib-2.0/include"'
|
|
||||||
# echo 'INCLUDEPATH += "%{_libdir}/gtk-2.0/include"'
|
cd libtgvoip
|
||||||
# echo 'INCLUDEPATH += "%{_includedir}/opus"'
|
%patch2 -p1
|
||||||
# echo 'LIBS += -lcrypto -lssl'
|
|
||||||
#) >> Telegram/Telegram.pro
|
cd ../../..
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Build patched Qt
|
# Build patched Qt
|
||||||
cd Libraries/qt%{qt_ver}/qtbase
|
cd Libraries/qt%{qt_ver}/qtbase
|
||||||
./configure -prefix "%{_builddir}/telegram-%{version}/qt" -release -force-debug-info \
|
./configure \
|
||||||
-opensource -confirm-license -system-zlib -system-libpng -system-libjpeg \
|
-prefix "%{_builddir}/telegram-%{version}/qt" \
|
||||||
-system-freetype -system-harfbuzz -system-pcre -system-xcb -system-xkbcommon-x11 \
|
-release \
|
||||||
-no-opengl -no-gtkstyle -static -nomake examples -nomake tests
|
-force-debug-info \
|
||||||
|
-opensource \
|
||||||
|
-confirm-license \
|
||||||
|
-system-zlib \
|
||||||
|
-system-libpng \
|
||||||
|
-system-libjpeg \
|
||||||
|
-system-freetype \
|
||||||
|
-system-harfbuzz \
|
||||||
|
-system-pcre \
|
||||||
|
-system-xcb \
|
||||||
|
-system-xkbcommon-x11 \
|
||||||
|
-no-gtkstyle \
|
||||||
|
-static \
|
||||||
|
-nomake examples \
|
||||||
|
-nomake tests
|
||||||
|
#-no-opengl
|
||||||
|
|
||||||
%make
|
%make
|
||||||
#module-qtbase module-qtimageformats
|
#module-qtbase module-qtimageformats
|
||||||
make install
|
make install
|
||||||
@ -128,39 +146,30 @@ qmake .
|
|||||||
%make
|
%make
|
||||||
make install
|
make install
|
||||||
|
|
||||||
|
cd ../qtwayland
|
||||||
|
qmake .
|
||||||
|
%make
|
||||||
|
make install
|
||||||
|
|
||||||
cd ../../../tdesktop-%{version}/Telegram
|
cd ../../../tdesktop-%{version}/Telegram
|
||||||
gyp/refresh.sh
|
gyp/refresh.sh
|
||||||
|
|
||||||
cd ../out/Release
|
# Build Telegram Desktop
|
||||||
%make
|
cd gyp
|
||||||
|
../../../Libraries/gyp/gyp \
|
||||||
|
-Dlinux_path_qt="%{_builddir}/%{name}-%{version}/qt" \
|
||||||
|
-Dlinux_lib_icu="-licuuc -licutu -licui18n" \
|
||||||
|
-Dlinux_lib_ssl='-L%{_libdir}/openssl-1.0.1 -lssl' \
|
||||||
|
-Dlinux_lib_crypto='-L%{_libdir}/openssl-1.0.1 -lcrypto' \
|
||||||
|
-Dlinux_path_opus_include="%{_includedir}/opus" \
|
||||||
|
--depth=. --generator-output=../.. -Goutput_dir=out Telegram.gyp --format=cmake
|
||||||
|
|
||||||
|
cd %{_builddir}/%{name}-%{version}/tdesktop-%{version}/out/Release
|
||||||
|
cmake .
|
||||||
|
|
||||||
|
make
|
||||||
chrpath --delete Telegram
|
chrpath --delete Telegram
|
||||||
|
|
||||||
## Build MetaStyle
|
|
||||||
#mkdir -p Linux/DebugIntermediateStyle
|
|
||||||
#cd Linux/DebugIntermediateStyle
|
|
||||||
#qmake CONFIG+=debug "../../Telegram/MetaStyle.pro"
|
|
||||||
#%make
|
|
||||||
#cd ../..
|
|
||||||
|
|
||||||
## Build MetaLang
|
|
||||||
#mkdir -p Linux/DebugIntermediateLang
|
|
||||||
#cd Linux/DebugIntermediateLang
|
|
||||||
#qmake CONFIG+=debug "../../Telegram/MetaLang.pro"
|
|
||||||
#%make
|
|
||||||
#cd ../..
|
|
||||||
|
|
||||||
## Build Telegram Desktop
|
|
||||||
#mkdir -p Linux/ReleaseIntermediate
|
|
||||||
#cd Linux/ReleaseIntermediate
|
|
||||||
#
|
|
||||||
#qmake CONFIG+=release ../../Telegram/Telegram.pro
|
|
||||||
#pattern="^PRE_TARGETDEPS +="
|
|
||||||
#grep "$pattern" ../../Telegram/Telegram.pro | sed "s/$pattern//g" | xargs make
|
|
||||||
#
|
|
||||||
#qmake CONFIG+=release ../../Telegram/Telegram.pro
|
|
||||||
#%make
|
|
||||||
#cd ../..
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
cd tdesktop-%{version}
|
cd tdesktop-%{version}
|
||||||
@ -185,6 +194,9 @@ done
|
|||||||
%doc tdesktop-%{version}/LICENSE
|
%doc tdesktop-%{version}/LICENSE
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 27 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.23-1mamba
|
||||||
|
- update to 1.1.23
|
||||||
|
|
||||||
* Tue Sep 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.6-1mamba
|
* Tue Sep 13 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.10.6-1mamba
|
||||||
- update to 0.10.6
|
- update to 0.10.6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user