legacy package [release 2020.3-2mamba;Sun Feb 26 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 18:21:10 +01:00
parent 24be837bbe
commit 3bec7f831e
7 changed files with 5363 additions and 0 deletions

BIN
Getting_Started.pdf Normal file

Binary file not shown.

View File

@ -1,2 +1,5 @@
# tbb2
Threading Building Blocks (TBB) is a C++ runtime library that abstracts the low-level threading details necessary for optimal multi-core performance. It uses common C++ templates and coding style to eliminate tedious threading implementation work.
TBB requires fewer lines of code to achieve parallelism than other threading models. The applications you write are portable across platforms. Since the library is also inherently scalable, no code maintenance is required as more processor cores become available.

5190
Reference.pdf Normal file

File diff suppressed because one or more lines are too long

BIN
Tutorial.pdf Normal file

Binary file not shown.

View File

@ -0,0 +1,15 @@
--- tbb22_20090809oss_src/build/linux.gcc.inc 2007-09-28 22:13:21.000000000 +0200
+++ tbb22_20090809oss_src.pm/build/linux.gcc.inc 2007-12-19 16:56:13.000000000 +0100
@@ -45,10 +45,10 @@ LIBS = -lpthread -lrt -ldl
C_FLAGS = $(CPLUS_FLAGS)
ifeq ($(cfg), release)
- CPLUS_FLAGS = -DDO_ITT_NOTIFY -O2 -DUSE_PTHREAD
+ CPLUS_FLAGS = $(CXXFLAGS) -DDO_ITT_NOTIFY -O2 -DUSE_PTHREAD
endif
ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG -DDO_ITT_NOTIFY -g -O0 -DUSE_PTHREAD
+ CPLUS_FLAGS = $(CXXFLAGS) -DTBB_USE_DEBUG -DDO_ITT_NOTIFY -g -O0 -DUSE_PTHREAD
endif
ASM=

20
tbb-2.2-mfence.patch Normal file
View File

@ -0,0 +1,20 @@
diff -up /home/petr/fedora/tbb/devel/tbb22_20090809oss-pm/include/tbb/machine/linux_ia32.h\~ /home/petr/fedora/tbb/devel/tbb22_20090809oss-pm/include/tbb/machine/linux_ia32.h
--- tbb22_20090809oss-pm/include/tbb/machine/linux_ia32.h~ 2009-08-12 09:05:03.000000000 +0200
+++ tbb22_20090809oss-pm/include/tbb/machine/linux_ia32.h 2010-06-10 17:11:17.000000000 +0200
@@ -39,7 +39,13 @@
#define __TBB_release_consistency_helper() __asm__ __volatile__("": : :"memory")
-inline void __TBB_rel_acq_fence() { __asm__ __volatile__("mfence": : :"memory"); }
+inline void __TBB_rel_acq_fence() {
+ int tmp;
+ __asm__ __volatile__("xchg %0,%0"
+ : "=r"(tmp)
+ : "r"(tmp)
+ : "memory");
+}
#define __MACHINE_DECL_ATOMICS(S,T,X) \
static inline T __TBB_machine_cmpswp##S (volatile void *ptr, T value, T comparand ) \
Diff finished. Thu Jun 10 17:13:43 2010

135
tbb2.spec Normal file
View File

@ -0,0 +1,135 @@
%define pkg_version %(echo %version | tr -d .)
Name: tbb2
Version: 2020.3
Release: 2mamba
Summary: The Threading Building Blocks library abstracts low-level threading details
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/oneapi-src/oneTBB
Source0: https://github.com/intel/tbb.git/v%{version}/tbb-%{version}.tar.bz2
#Source0: https://www.threadingbuildingblocks.org/sites/default/files/software_releases/source/tbb%{pkg_version}oss_src.tgz
Source1: http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Getting_Started.pdf
Source2: http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Reference.pdf
Source3: http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Tutorial.pdf
Patch0: tbb-2.2-20090809-cxxflags.patch
Patch1: tbb-2.2-mfence.patch
License: GPL with exceptions
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: net-tools
BuildRequires: util-linux-ng
%description
Threading Building Blocks (TBB) is a C++ runtime library that abstracts the low-level threading details necessary for optimal multi-core performance. It uses common C++ templates and coding style to eliminate tedious threading implementation work.
TBB requires fewer lines of code to achieve parallelism than other threading models. The applications you write are portable across platforms. Since the library is also inherently scalable, no code maintenance is required as more processor cores become available.
%package -n lib%{name}
Group: System/Libraries
Summary: The Threading Building Blocks C++ headers and shared development libraries
%description -n lib%{name}
Threading Building Blocks (TBB) is a C++ runtime library that abstracts the low-level threading details necessary for optimal multi-core performance. It uses common C++ templates and coding style to eliminate tedious threading implementation work.
TBB requires fewer lines of code to achieve parallelism than other threading models. The applications you write are portable across platforms. Since the library is also inherently scalable, no code maintenance is required as more processor cores become available.
This package contains header files and shared object symlinks for the Threading Building Blocks (TBB) C++ libraries.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: The Threading Building Blocks C++ headers and shared development libraries
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
The Threading Building Blocks library abstracts low-level threading details.
This package contains header files and shared object symlinks for the Threading Building Blocks (TBB) C++ libraries.
%package doc
Group: Documentation
Summary: The Threading Building Blocks documentation
%description doc
The Threading Building Blocks library abstracts low-level threading details.
This package contains the Threading Building Blocks (TBB) documentation.
%debug_package
%prep
%setup -q -n tbb-%{version}
#%patch0 -p1
#%patch1 -p1
%build
%make CXXFLAGS="$RPM_OPT_FLAGS" tbb_build_prefix=obj
cp -p "%{SOURCE1}" "%{SOURCE2}" "%{SOURCE3}" .
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p %{buildroot}%{_libdir}
#,malloc_proxy
pushd build/obj_release
for file in libtbb; do
install -pm 755 ${file}.so.2 %{buildroot}%{_libdir}
ln -s $file.so.2 %{buildroot}%{_libdir}/$file.so
done
popd
mkdir -p %{buildroot}%{_includedir}
cp -a include/tbb %{buildroot}%{_includedir}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libtbb.so.*
#%{_libdir}/libtbbmalloc.so.*
%doc LICENSE
%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/tbb
%{_includedir}/tbb/index.html
%{_includedir}/tbb/*.h
%dir %{_includedir}/tbb/compat
%{_includedir}/tbb/compat/*
%dir %{_includedir}/tbb/internal
%{_includedir}/tbb/internal/*.h
%dir %{_includedir}/tbb/machine
%{_includedir}/tbb/machine/*.h
%{_libdir}/libtbb.so
#%{_libdir}/libtbbmalloc.so
%doc doc/Release_Notes.txt
%doc CHANGES README
%files doc
%defattr(-,root,root)
%doc Getting_Started.pdf Reference.pdf Tutorial.pdf
%changelog
* Sun Feb 26 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2020.3-2mamba
- legacy package
* Wed Sep 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2020.3-1mamba
- update to 2020.3
* Wed Dec 25 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2020-1mamba
- update to 2020
* Wed Dec 11 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 2019_U9-1mamba
- update to 2019_U9
* Sat Mar 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.2_20140122-1mamba
- update to 4.2_20140122
* Mon Nov 08 2010 gil <puntogil@libero.it> 2.2-1mamba
- package created by autospec