require lzip [release 1.27.1-2mamba;Fri Feb 28 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 18:20:50 +01:00
parent 5529903c10
commit c1df7d412f
3 changed files with 500 additions and 0 deletions

View File

@ -1,2 +1,8 @@
# tar # tar
The GNU tar program saves many files together into one archive and can restore individual files (or all of the files) from the archive.
Tar can also be used to add supplemental files to an archive and to update or list files in the archive.
Tar includes multivolume support, automatic archive compression/decompression, the ability to perform remote archives and the ability to perform incremental and full backups.
If you want to use Tar for remote backups, you'll also need to install the rmt package.
You should install the tar package, because you'll find its compression and decompression utilities essential for working with files.

338
tar-1.13.18-manpage.patch Normal file
View File

@ -0,0 +1,338 @@
--- tar-1.13.18/tar.1.manpage Mon Oct 30 12:52:03 2000
+++ tar-1.13.18/tar.1 Mon Oct 30 12:56:15 2000
@@ -0,0 +1,335 @@
+.\" @(#)tar.1 1.13.14 2000/10/30 Bero;
+.TH TAR 1 "30 October 2000"
+.SH NAME
+tar \- The GNU version of the tar archiving utility
+.SH SYNOPSIS
+.B tar
+[
+.B \-
+]
+.B A --catenate --concatenate \||\| c --create \||\| d --diff --compare \||\| r --append \||\| t --list \||\| u --update \||\| x -extract --get
+[
+.B --atime-preserve
+]
+[
+.B -b, --block-size N
+]
+[
+.B -B, --read-full-blocks
+]
+[
+.B -C, --directory DIR
+]
+[
+.B --checkpoint
+]
+[
+.B -f, --file [HOSTNAME:]F
+]
+[
+.B --force-local
+]
+[
+.B -F, --info-script F --new-volume-script F
+]
+[
+.B -G, --incremental
+]
+[
+.B -g, --listed-incremental F
+]
+[
+.B -h, --dereference
+]
+[
+.B -i, --ignore-zeros
+]
+[
+.B -j, --bzip
+]
+[
+.B --ignore-failed-read
+]
+[
+.B -k, --keep-old-files
+]
+[
+.B -K, --starting-file F
+]
+[
+.B -l, --one-file-system
+]
+[
+.B -L, --tape-length N
+]
+[
+.B -m, --modification-time
+]
+[
+.B -M, --multi-volume
+]
+[
+.B -N, --after-date DATE, --newer DATE
+]
+[
+.B -o, --old-archive, --portability
+]
+[
+.B -O, --to-stdout
+]
+[
+.B -p, --same-permissions, --preserve-permissions
+]
+[
+.B -P, --absolute-paths
+]
+[
+.B --preserve
+]
+[
+.B -R, --record-number
+]
+[
+.B --remove-files
+]
+[
+.B -s, --same-order, --preserve-order
+]
+[
+.B --same-owner
+]
+[
+.B -S, --sparse
+]
+[
+.B -T, -I, --files-from=F
+]
+[
+.B --null
+]
+[
+.B --totals
+]
+[
+.B -v, --verbose
+]
+[
+.B -V, --label NAME
+]
+[
+.B --version
+]
+[
+.B -w, --interactive, --confirmation
+]
+[
+.B -W, --verify
+]
+[
+.B --exclude FILE
+]
+[
+.B -X, --exclude-from FILE
+]
+[
+.B -Z, --compress, --uncompress
+]
+[
+.B -z, --gzip, --ungzip
+]
+[
+.B --use-compress-program PROG
+]
+[
+.B --block-compress
+]
+[
+.B -[0-7][lmh]
+]
+.TP
+.I filename1 [ filename2, ... filenameN ]
+.TP
+.I directory1 [ directory2, ...directoryN ]
+.SH DESCRIPTION
+.LP
+This manual page documents the GNU version of
+.B tar
+, an archiving program designed to store and extract files from
+an archive file known as a
+.IR tarfile.
+A
+.IR tarfile
+may be made on a tape drive, however, it is also common
+to write a
+.IR tarfile
+to a normal file.
+The first argument to
+.B tar
+must be one of the options:
+.BR Acdrtux ,
+followed by any optional functions.
+The final arguments to
+.B tar
+are the names of the files or directories which should be archived. The use
+of a directory name always implies that the subdirectories below should be
+included in the archive.
+.SH "FUNCTION LETTERS"
+.TP
+.B One of the following options must be used:
+.TP
+.B -A, --catenate, --concatenate
+append tar files to an archive
+.TP
+.B -c, --create
+create a new archive
+.TP
+.B -d, --diff, --compare
+find differences between archive and file system
+.TP
+.B --delete
+delete from the archive (not for use on mag tapes!)
+.TP
+.B -r, --append
+append files to the end of an archive
+.TP
+.B -t, --list
+list the contents of an archive
+.TP
+.B -u, --update
+only append files that are newer than copy in archive
+.TP
+.B -x, --extract, --get
+extract files from an archive
+.SH "OTHER OPTIONS"
+.TP
+.B --atime-preserve
+don't change access times on dumped files
+.TP
+.B -b, --block-size N
+block size of Nx512 bytes (default N=20)
+.TP
+.B -B, --read-full-blocks
+reblock as we read (for reading 4.2BSD pipes)
+.TP
+.B -C, --directory DIR
+change to directory DIR
+.TP
+.B --checkpoint
+print directory names while reading the archive
+.TP
+.B -f, --file [HOSTNAME:]F
+use archive file or device F (default /dev/rmt0)
+.TP
+.B --force-local
+archive file is local even if has a colon
+.TP
+.B -F, --info-script F --new-volume-script F
+run script at end of each tape (implies -M)
+.TP
+.B -G, --incremental
+create/list/extract old GNU-format incremental backup
+.TP
+.B -g, --listed-incremental F
+create/list/extract new GNU-format incremental backup
+.TP
+.B -h, --dereference
+don't dump symlinks; dump the files they point to
+.TP
+.B -i, --ignore-zeros
+ignore blocks of zeros in archive (normally mean EOF)
+.TP
+.B -j, --bzip
+filter the archive through bzip2
+.TP
+.B --ignore-failed-read
+don't exit with non-zero status on unreadable files
+.TP
+.B -k, --keep-old-files
+keep existing files; don't overwrite them from archive
+.TP
+.B -K, --starting-file F
+begin at file F in the archive
+.TP
+.B -l, --one-file-system
+stay in local file system when creating an archive
+.TP
+.B -L, --tape-length N
+change tapes after writing N*1024 bytes
+.TP
+.B -m, --modification-time
+don't extract file modified time
+.TP
+.B -M, --multi-volume
+create/list/extract multi-volume archive
+.TP
+.B -N, --after-date DATE, --newer DATE
+only store files newer than DATE
+.TP
+.B -o, --old-archive, --portability
+write a V7 format archive, rather than ANSI format
+.TP
+.B -O, --to-stdout
+extract files to standard output
+.TP
+.B -p, --same-permissions, --preserve-permissions
+extract all protection information
+.TP
+.B -P, --absolute-paths
+don't strip leading `/'s from file names
+.TP
+.B --preserve
+like -p -s
+.TP
+.B -R, --record-number
+show record number within archive with each message
+.TP
+.B --remove-files
+remove files after adding them to the archive
+.TP
+.B -s, --same-order, --preserve-order
+list of names to extract is sorted to match archive
+.TP
+.B --same-owner
+create extracted files with the same ownership
+.TP
+.B -S, --sparse
+handle sparse files efficiently
+.TP
+.B -T, -I, --files-from=F
+get names to extract or create from file F
+.TP
+.B --null
+-T reads null-terminated names, disable -C
+.TP
+.B --totals
+print total bytes written with --create
+.TP
+.B -v, --verbose
+verbosely list files processed
+.TP
+.B -V, --label NAME
+create archive with volume name NAME
+.TP
+.B --version
+print tar program version number
+.TP
+.B -w, --interactive, --confirmation
+ask for confirmation for every action
+.TP
+.B -W, --verify
+attempt to verify the archive after writing it
+.TP
+.B --exclude FILE
+exclude file FILE
+.TP
+.B -X, --exclude-from FILE
+exclude files listed in FILE
+.TP
+.B -Z, --compress, --uncompress
+filter the archive through compress
+.TP
+.B -z, --gzip, --ungzip
+filter the archive through gzip
+.TP
+.B --use-compress-program PROG
+filter the archive through PROG (which must accept -d)

156
tar.spec Normal file
View File

@ -0,0 +1,156 @@
Name: tar
Version: 1.27.1
Release: 2mamba
Summary: A GNU file archiving program
Group: Applications/Archiving
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://www.gnu.org/software/tar/tar.html
Source: ftp://ftp.gnu.org/gnu/tar/%{name}-%{version}.tar.bz2
Patch0: %{name}-1.13.18-manpage.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libacl-devel
BuildRequires: libselinux-devel
## AUTOBUILDREQ-END
BuildRequires: gettext-devel
Requires: gzip
Requires: bzip2
Requires: xz
Requires: lzip
Requires(post):%{__install_info}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The GNU tar program saves many files together into one archive and can restore individual files (or all of the files) from the archive.
Tar can also be used to add supplemental files to an archive and to update or list files in the archive.
Tar includes multivolume support, automatic archive compression/decompression, the ability to perform remote archives and the ability to perform incremental and full backups.
If you want to use Tar for remote backups, you'll also need to install the rmt package.
You should install the tar package, because you'll find its compression and decompression utilities essential for working with files.
%prep
%setup -q
# fixme: tar 1.14 has some new command line options, so this man page is obsolete
# (find for updates on Mandrake site).
%patch0 -p1
%build
%configure \
--bindir=/bin \
--libexecdir=/sbin
# --enable-backup-scripts
%make
%install
[ "%buildroot" != / ] && rm -rf "%buildroot"
%makeinstall
ln -sf tar %{buildroot}/bin/gtar
install -p -D -m644 tar.1 %{buildroot}%{_mandir}/man1/tar.1
%find_lang %{name}
%clean
[ "%buildroot" != / ] && rm -rf "%buildroot"
%post
%install_info %{name}.info
exit 0
%preun
%uninstall_info %{name}.info
exit 0
%files -f %{name}.lang
%defattr(-,root,root)
/bin/tar
/bin/gtar
/sbin/rmt
%{_infodir}/tar.*
%{_mandir}/man1/tar.*
%doc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
%changelog
* Fri Feb 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.27.1-2mamba
- require lzip
* Mon Nov 18 2013 Automatic Build System <autodist@mambasoft.it> 1.27.1-1mamba
- automatic version update by autodist
* Sun Oct 06 2013 Automatic Build System <autodist@mambasoft.it> 1.27-1mamba
- automatic version update by autodist
* Sun Feb 26 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.26-2mamba
- added requirement for gzip,bzip2 and xz
* Sat Mar 12 2011 Automatic Build System <autodist@mambasoft.it> 1.26-1mamba
- automatic update by autodist
* Mon Nov 08 2010 Automatic Build System <autodist@mambasoft.it> 1.25-1mamba
- automatic update to 1.25 by autodist
* Mon Oct 25 2010 Automatic Build System <autodist@mambasoft.it> 1.24-1mamba
- automatic update to 1.24 by autodist
* Fri Mar 12 2010 Davide Madrisan <davide.madrisan@gmail.com> 1.23-1mamba
- update to 1.23
* Thu Mar 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.22-1mamba
- automatic update to 1.22 by autodist
* Sat Dec 27 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.21-1mamba
- automatic update to 1.21 by autodist
* Tue Apr 15 2008 Aleph0 <aleph0@openmamba.org> 1.20-1mamba
- update to 1.20
- removed patch against CVE-2007-4476: merged upstream
* Thu Nov 29 2007 Aleph0 <aleph0@openmamba.org> 1.18-2mamba
- fix against tar stack crashing in safer_name_suffix (CVE-2007-4476)
* Mon Jul 02 2007 Aleph0 <aleph0@openmamba.org> 1.18-1mamba
- update to 1.18
* Mon Jun 11 2007 Aleph0 <aleph0@openmamba.org> 1.17-1mamba
- update to 1.17
* Wed Jan 17 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.16.1-1qilnx
- update to version 1.16.1 by autospec
- security update: fixes CVE-2006-6097
- dropped patch against CVE-2006-0300: fixed upstream
* Tue May 16 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.15.1-4qilnx
- rebuilt
* Wed Mar 01 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.15.1-3qilnx
- security update for CVE-2006-0300
* Fri Apr 08 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.15.1-2qilnx
- added scripts to install/remove info files
- added manpage for tar created by mandrake people
* Wed Jan 05 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.15.1-1qilnx
- update to version 1.15.1 by autospec
* Tue Dec 21 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.15-1qilnx
- update to version 1.15 by autospec
* Wed Sep 01 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.14-3qilnx
- moved executables into the /bin directory
- added a symbolic link for gtar
- added standard documentation files
* Tue Jul 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.14-2qilnx
- trivial fixes in the specfile needed by the QiLinux distromatic parser
* Tue May 11 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.14-1qilnx
- new version rebuild
* Tue Apr 22 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.13-2qilnx
- relocation of info dir under usr/share/info
* Tue Apr 09 2003 Luca Tinelli <luca.tinelli@qinet.it> 1.13-1qilnx
- first build