Release 238-2mamba
This commit is contained in:
parent
705cc94e26
commit
bd3fe9429d
72
systemd-238-upstream-dont-include-libmount-h.patch
Normal file
72
systemd-238-upstream-dont-include-libmount-h.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
From 227b8a762fea1458547be2cdf0e6e4aac0079730 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Olbrich <m.olbrich@pengutronix.de>
|
||||||
|
Date: Mon, 26 Mar 2018 17:34:53 +0200
|
||||||
|
Subject: [PATCH] core: don't include libmount.h in a header file (#8580)
|
||||||
|
|
||||||
|
linux/fs.h sys/mount.h, libmount.h and missing.h all include MS_*
|
||||||
|
definitions.
|
||||||
|
|
||||||
|
To avoid problems, only one of linux/fs.h, sys/mount.h and libmount.h
|
||||||
|
should be included. And missing.h must be included last.
|
||||||
|
|
||||||
|
Without this, building systemd may fail with:
|
||||||
|
|
||||||
|
In file included from [...]/libmount/libmount.h:31:0,
|
||||||
|
from ../systemd-238/src/core/manager.h:23,
|
||||||
|
from ../systemd-238/src/core/emergency-action.h:37,
|
||||||
|
from ../systemd-238/src/core/unit.h:34,
|
||||||
|
from ../systemd-238/src/core/dbus-timer.h:25,
|
||||||
|
from ../systemd-238/src/core/timer.c:26:
|
||||||
|
[...]/sys/mount.h:57:2: error: expected identifier before numeric constant
|
||||||
|
---
|
||||||
|
src/core/dbus-execute.c | 1 +
|
||||||
|
src/core/manager.h | 3 ++-
|
||||||
|
src/core/mount.c | 2 ++
|
||||||
|
3 files changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/core/dbus-execute.c b/src/core/dbus-execute.c
|
||||||
|
index 7344623ebf6..c342093bca4 100644
|
||||||
|
--- a/src/core/dbus-execute.c
|
||||||
|
+++ b/src/core/dbus-execute.c
|
||||||
|
@@ -18,6 +18,7 @@
|
||||||
|
along with systemd; If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
***/
|
||||||
|
|
||||||
|
+#include <sys/mount.h>
|
||||||
|
#include <sys/prctl.h>
|
||||||
|
#include <stdio_ext.h>
|
||||||
|
|
||||||
|
diff --git a/src/core/manager.h b/src/core/manager.h
|
||||||
|
index 28c5da225b1..e09e0cdf5e9 100644
|
||||||
|
--- a/src/core/manager.h
|
||||||
|
+++ b/src/core/manager.h
|
||||||
|
@@ -20,7 +20,6 @@
|
||||||
|
along with systemd; If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
***/
|
||||||
|
|
||||||
|
-#include <libmount.h>
|
||||||
|
#include <stdbool.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
|
||||||
|
@@ -34,6 +33,8 @@
|
||||||
|
#include "list.h"
|
||||||
|
#include "ratelimit.h"
|
||||||
|
|
||||||
|
+struct libmnt_monitor;
|
||||||
|
+
|
||||||
|
/* Enforce upper limit how many names we allow */
|
||||||
|
#define MANAGER_MAX_NAMES 131072 /* 128K */
|
||||||
|
|
||||||
|
diff --git a/src/core/mount.c b/src/core/mount.c
|
||||||
|
index 0e755da5c02..0154ebda5d6 100644
|
||||||
|
--- a/src/core/mount.c
|
||||||
|
+++ b/src/core/mount.c
|
||||||
|
@@ -23,6 +23,8 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <sys/epoll.h>
|
||||||
|
|
||||||
|
+#include <libmount.h>
|
||||||
|
+
|
||||||
|
#include "sd-messages.h"
|
||||||
|
|
||||||
|
#include "alloc-util.h"
|
40
systemd.spec
40
systemd.spec
@ -22,10 +22,11 @@
|
|||||||
%define group_systemd_journal_remote 65
|
%define group_systemd_journal_remote 65
|
||||||
%define user_systemd_journal_upload 66
|
%define user_systemd_journal_upload 66
|
||||||
%define group_systemd_journal_upload 66
|
%define group_systemd_journal_upload 66
|
||||||
|
%define group_render 71
|
||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 236
|
Version: 238
|
||||||
Release: 2mamba
|
Release: 2mamba
|
||||||
Summary: A system and service manager compatible with SysV and LSB init scripts
|
Summary: A system and service manager compatible with SysV and LSB init scripts
|
||||||
Group: System/Configuration
|
Group: System/Configuration
|
||||||
@ -63,6 +64,7 @@ Patch14: systemd-219-silend-about-device-appeared-twice.patch
|
|||||||
Patch15: systemd-232-udev-rootlibdir.patch
|
Patch15: systemd-232-udev-rootlibdir.patch
|
||||||
Patch16: systemd-232-i586-disable_restrict_address_families.patch
|
Patch16: systemd-232-i586-disable_restrict_address_families.patch
|
||||||
Patch17: systemd-236-use_raw_file_descriptor_in_sysctl_write.patch
|
Patch17: systemd-236-use_raw_file_descriptor_in_sysctl_write.patch
|
||||||
|
Patch18: systemd-238-upstream-dont-include-libmount-h.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -98,6 +100,7 @@ Conflicts: initscripts-sysv5
|
|||||||
Requires: sysvinit-tools
|
Requires: sysvinit-tools
|
||||||
Requires: udev = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: udev = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Requires: kbd
|
Requires: kbd
|
||||||
|
Requires: dbus >= 1.13.2
|
||||||
Provides: laptop-mode-tools
|
Provides: laptop-mode-tools
|
||||||
Obsoletes: laptop-mode-tools
|
Obsoletes: laptop-mode-tools
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -229,7 +232,8 @@ This package include development files for building software using udev librarie
|
|||||||
#%patch14 -p1
|
#%patch14 -p1
|
||||||
#%patch15 -p1
|
#%patch15 -p1
|
||||||
%patch16 -p1
|
%patch16 -p1
|
||||||
%patch17 -p1
|
#%patch17 -p1
|
||||||
|
%patch18 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#./autogen.sh
|
#./autogen.sh
|
||||||
@ -248,6 +252,7 @@ meson build \
|
|||||||
--localstatedir=%{_localstatedir} \
|
--localstatedir=%{_localstatedir} \
|
||||||
--mandir=%{_mandir} \
|
--mandir=%{_mandir} \
|
||||||
--infodir=%{_datadir}/info \
|
--infodir=%{_datadir}/info \
|
||||||
|
-Dc_std=gnu11 \
|
||||||
-Drootlibdir=/%{_lib} \
|
-Drootlibdir=/%{_lib} \
|
||||||
-Dpamlibdir=/%{_lib}/security \
|
-Dpamlibdir=/%{_lib}/security \
|
||||||
-Dtty-gid=4 \
|
-Dtty-gid=4 \
|
||||||
@ -257,7 +262,8 @@ meson build \
|
|||||||
-Dsystem-uid-max=998 \
|
-Dsystem-uid-max=998 \
|
||||||
-Dsystem-gid-max=998 \
|
-Dsystem-gid-max=998 \
|
||||||
-Drpmmacrosdir=%{_sysconfdir}/rpm \
|
-Drpmmacrosdir=%{_sysconfdir}/rpm \
|
||||||
-Dsupport-url="https://openmamba.org"
|
-Dsupport-url="https://openmamba.org" \
|
||||||
|
-Dntp-servers="0.europe.pool.ntp.org 1.europe.pool.ntp.org 2.europe.pool.ntp.org 3.europe.pool.ntp.org"
|
||||||
|
|
||||||
|
|
||||||
# KMOD=/sbin/kmod
|
# KMOD=/sbin/kmod
|
||||||
@ -280,23 +286,23 @@ make
|
|||||||
%makeinstall rpmmacrosdir=%{_sysconfdir}/rpm
|
%makeinstall rpmmacrosdir=%{_sysconfdir}/rpm
|
||||||
|
|
||||||
|
|
||||||
# compatibility links
|
## compatibility links
|
||||||
install -d -m0755 %{buildroot}/sbin
|
#install -d -m0755 %{buildroot}/sbin
|
||||||
for f in halt poweroff reboot runlevel shutdown telinit; do
|
#for f in halt poweroff reboot runlevel shutdown telinit; do
|
||||||
ln -s ../bin/systemctl %{buildroot}/sbin/$f
|
# ln -s ../bin/systemctl %{buildroot}/sbin/$f
|
||||||
done
|
#done
|
||||||
ln -s ../lib/systemd/systemd %{buildroot}/sbin/init
|
#ln -s ../lib/systemd/systemd %{buildroot}/sbin/init
|
||||||
|
|
||||||
# udev
|
# udev
|
||||||
#install -D -m755 %{S:1} %{buildroot}%{_initrddir}/udev
|
#install -D -m755 %{S:1} %{buildroot}%{_initrddir}/udev
|
||||||
#install -D -m755 %{S:15} %{buildroot}%{_initrddir}/udev-post
|
#install -D -m755 %{S:15} %{buildroot}%{_initrddir}/udev-post
|
||||||
#install -D -m644 %{S:16} %{buildroot}%{_sysconfdir}/sysconfig/udev
|
#install -D -m644 %{S:16} %{buildroot}%{_sysconfdir}/sysconfig/udev
|
||||||
install -D -m755 %{S:2} \
|
install -D -m644 %{S:2} \
|
||||||
%{buildroot}/lib/udev/rules.d/60-permissions.rules
|
%{buildroot}/lib/udev/rules.d/60-permissions.rules
|
||||||
install -D -m755 %{S:4} \
|
install -D -m644 %{S:4} \
|
||||||
%{buildroot}/lib/udev/rules.d/55-udev-openmamba.rules
|
%{buildroot}/lib/udev/rules.d/55-udev-openmamba.rules
|
||||||
install -D -m755 %{S:14} \
|
#install -D -m755 %{S:14} \
|
||||||
%{buildroot}/lib/udev/rules.d/85-ifupdown.rules
|
# %{buildroot}/lib/udev/rules.d/85-ifupdown.rules
|
||||||
install -D -m755 %{S:8} \
|
install -D -m755 %{S:8} \
|
||||||
%{buildroot}/lib/udev/check-cdrom.sh
|
%{buildroot}/lib/udev/check-cdrom.sh
|
||||||
|
|
||||||
@ -440,6 +446,7 @@ groupadd camera -g %{group_camera} 2>/dev/null
|
|||||||
groupadd scanner -g %{group_scanner} 2>/dev/null
|
groupadd scanner -g %{group_scanner} 2>/dev/null
|
||||||
groupadd nvram -g %{group_nvram} 2>/dev/null
|
groupadd nvram -g %{group_nvram} 2>/dev/null
|
||||||
groupadd kvm -g %{group_kvm} 2>/dev/null
|
groupadd kvm -g %{group_kvm} 2>/dev/null
|
||||||
|
groupadd render -g %{group_render} 2>/dev/null
|
||||||
:
|
:
|
||||||
|
|
||||||
%post -n libudev
|
%post -n libudev
|
||||||
@ -721,6 +728,13 @@ fi
|
|||||||
%{_libdir}/pkgconfig/libudev.pc
|
%{_libdir}/pkgconfig/libudev.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 238-2mamba
|
||||||
|
- create render group
|
||||||
|
- removed obsolete ifupdown rule and fixed permissions of other custom rules
|
||||||
|
|
||||||
|
* Wed Mar 21 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 238-1mamba
|
||||||
|
- update to 238
|
||||||
|
|
||||||
* Tue Jan 02 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 236-2mamba
|
* Tue Jan 02 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 236-2mamba
|
||||||
- upstream patch to fix sysctl boot error
|
- upstream patch to fix sysctl boot error
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user