Release 232-8mamba
This commit is contained in:
parent
a761f8775a
commit
b7944c1bbf
30
systemd-232-i586-disable_restrict_address_families.patch
Normal file
30
systemd-232-i586-disable_restrict_address_families.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From ff59e06f9423af0532aaeedf931474823f764875 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Dave Reisner <dreisner@archlinux.org>
|
||||||
|
Date: Wed, 9 Nov 2016 08:00:26 -0500
|
||||||
|
Subject: [PATCH] disable RestrictAddressFamilies on i686
|
||||||
|
|
||||||
|
Shit's broke, yo.
|
||||||
|
|
||||||
|
https://github.com/systemd/systemd/issues/4575
|
||||||
|
---
|
||||||
|
src/core/execute.c | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/core/execute.c b/src/core/execute.c
|
||||||
|
index f666f7c..7d09154 100644
|
||||||
|
--- a/src/core/execute.c
|
||||||
|
+++ b/src/core/execute.c
|
||||||
|
@@ -1254,6 +1254,10 @@ static int apply_address_families(const Unit* u, const ExecContext *c) {
|
||||||
|
Iterator i;
|
||||||
|
int r;
|
||||||
|
|
||||||
|
+#if defined(__i386__)
|
||||||
|
+ return 0;
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
assert(c);
|
||||||
|
|
||||||
|
if (skip_seccomp_unavailable(u, "RestrictAddressFamilies="))
|
||||||
|
--
|
||||||
|
2.10.2
|
||||||
|
|
11
systemd-232-udev-rootlibdir.patch
Normal file
11
systemd-232-udev-rootlibdir.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- systemd-232/src/libudev/libudev.pc.in.orig 2016-12-01 12:21:25.504783677 +0100
|
||||||
|
+++ systemd-232/src/libudev/libudev.pc.in 2016-12-01 12:21:50.412921862 +0100
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
|
||||||
|
prefix=@prefix@
|
||||||
|
exec_prefix=@exec_prefix@
|
||||||
|
-libdir=@libdir@
|
||||||
|
+libdir=@rootlibdir@
|
||||||
|
includedir=@includedir@
|
||||||
|
|
||||||
|
Name: libudev
|
73
systemd.spec
73
systemd.spec
@ -25,8 +25,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 231
|
Version: 232
|
||||||
Release: 1mamba
|
Release: 8mamba
|
||||||
Summary: A system and service manager compatible with SysV and LSB init scripts
|
Summary: A system and service manager compatible with SysV and LSB init scripts
|
||||||
Group: System/Configuration
|
Group: System/Configuration
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -60,6 +60,8 @@ Patch11: systemd-219-rework_device_state_logic.patch
|
|||||||
Patch12: systemd-219-upstream_dont_change_devices_state_to_tentative.patch
|
Patch12: systemd-219-upstream_dont_change_devices_state_to_tentative.patch
|
||||||
Patch13: systemd-219-upstream_do_not_spawn_jobs_or_during_coldplug.patch
|
Patch13: systemd-219-upstream_do_not_spawn_jobs_or_during_coldplug.patch
|
||||||
Patch14: systemd-219-silend-about-device-appeared-twice.patch
|
Patch14: systemd-219-silend-about-device-appeared-twice.patch
|
||||||
|
Patch15: systemd-232-udev-rootlibdir.patch
|
||||||
|
Patch16: systemd-232-i586-disable_restrict_address_families.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -203,6 +205,8 @@ This package include development files for building software using udev librarie
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
|
|
||||||
## ARM only patch: old_cloexec compatibility patch with old kernels
|
## ARM only patch: old_cloexec compatibility patch with old kernels
|
||||||
@ -221,8 +225,11 @@ This package include development files for building software using udev librarie
|
|||||||
#%patch12 -p1
|
#%patch12 -p1
|
||||||
#%patch13 -p1
|
#%patch13 -p1
|
||||||
#%patch14 -p1
|
#%patch14 -p1
|
||||||
|
#%patch15 -p1
|
||||||
|
%patch16 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< _EOF
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
%configure \
|
%configure \
|
||||||
--with-rootprefix= \
|
--with-rootprefix= \
|
||||||
@ -235,6 +242,8 @@ This package include development files for building software using udev librarie
|
|||||||
--with-debug-shell=/bin/sh \
|
--with-debug-shell=/bin/sh \
|
||||||
KMOD=/sbin/kmod
|
KMOD=/sbin/kmod
|
||||||
|
|
||||||
|
#sed -i "s|@rootlibdir@|/%{_lib}|" src/libudev/libudev.pc
|
||||||
|
|
||||||
# TODO?
|
# TODO?
|
||||||
# --enable-terminal \
|
# --enable-terminal \
|
||||||
# --enable-kdbus \
|
# --enable-kdbus \
|
||||||
@ -282,11 +291,22 @@ install -d -m0755 %{buildroot}/sbin
|
|||||||
ln -s /lib/systemd/systemd-udevd %{buildroot}/sbin/udevd
|
ln -s /lib/systemd/systemd-udevd %{buildroot}/sbin/udevd
|
||||||
ln -s libudev.so.1 %{buildroot}/%{_lib}/libudev.so.0
|
ln -s libudev.so.1 %{buildroot}/%{_lib}/libudev.so.0
|
||||||
|
|
||||||
|
# fix libudev.so link since 232
|
||||||
|
#mv %{buildroot}/%{_lib}/libudev.la %{buildroot}%{_libdir}/
|
||||||
|
#rm -f %{buildroot}/%{_lib}/libudev.so
|
||||||
|
ln -sf /%{_lib}/libudev.la %{buildroot}%{_libdir}/libudev.la
|
||||||
|
ln -sf /%{_lib}/libudev.so.1 %{buildroot}%{_libdir}/libudev.so
|
||||||
|
# same for libsystemd.so
|
||||||
|
#mv %{buildroot}/%{_lib}/libsystemd.la %{buildroot}%{_libdir}/
|
||||||
|
#rm -f %{buildroot}/%{_lib}/libsystemd.so
|
||||||
|
ln -sf /%{_lib}/libsystemd.la %{buildroot}%{_libdir}/libsystemd.la
|
||||||
|
ln -sf /%{_lib}/libsystemd.so.0 %{buildroot}%{_libdir}/libsystemd.so
|
||||||
|
|
||||||
# /etc/mtab symlink
|
# /etc/mtab symlink
|
||||||
ln -s /proc/mounts %{buildroot}%{_sysconfdir}/mtab
|
ln -s /proc/mounts %{buildroot}%{_sysconfdir}/mtab
|
||||||
|
|
||||||
# install libnss_myhostname.so.* to /%{lib}
|
# install libnss_myhostname.so.* to /%{lib}
|
||||||
mv %{buildroot}%{_libdir}/libnss_myhostname.so.* %{buildroot}/%{_lib}/
|
#mv %{buildroot}%{_libdir}/libnss_myhostname.so.* %{buildroot}/%{_lib}/
|
||||||
|
|
||||||
# install our systemd-sysv-install
|
# install our systemd-sysv-install
|
||||||
install -D -m0755 %{SOURCE17} %{buildroot}/lib/systemd/systemd-sysv-install
|
install -D -m0755 %{SOURCE17} %{buildroot}/lib/systemd/systemd-sysv-install
|
||||||
@ -320,6 +340,9 @@ if [ "$1" -ge 1 ]; then
|
|||||||
-d /var/log/journal -s /sbin/nologin -c "Journal Gateway" \
|
-d /var/log/journal -s /sbin/nologin -c "Journal Gateway" \
|
||||||
systemd-journal-gateway 2>/dev/null
|
systemd-journal-gateway 2>/dev/null
|
||||||
groupadd systemd-journal-remote -g %{group_systemd_journal_remote} 2>/dev/null
|
groupadd systemd-journal-remote -g %{group_systemd_journal_remote} 2>/dev/null
|
||||||
|
useradd -u %{user_systemd_journal_remote} -g systemd-journal-remote \
|
||||||
|
-d /dev/null -s /sbin/nologin -c "Systemd journal remote" \
|
||||||
|
systemd-journal-remote 2>/dev/null
|
||||||
groupadd systemd-journal-upload -g %{group_systemd_journal_upload} 2>/dev/null
|
groupadd systemd-journal-upload -g %{group_systemd_journal_upload} 2>/dev/null
|
||||||
useradd -u %{user_systemd_journal_upload} -g systemd-timesync \
|
useradd -u %{user_systemd_journal_upload} -g systemd-timesync \
|
||||||
-d /dev/null -s /sbin/nologin -c "Systemd journal upload" \
|
-d /dev/null -s /sbin/nologin -c "Systemd journal upload" \
|
||||||
@ -455,8 +478,9 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/systemd/timesyncd.conf
|
%config(noreplace) %{_sysconfdir}/systemd/timesyncd.conf
|
||||||
%dir %{_sysconfdir}/systemd/network
|
%dir %{_sysconfdir}/systemd/network
|
||||||
%dir %{_sysconfdir}/systemd/system
|
%dir %{_sysconfdir}/systemd/system
|
||||||
|
%{_sysconfdir}/systemd/system/ctrl-alt-del.target
|
||||||
%dir %{_sysconfdir}/systemd/system/multi-user.target.wants
|
%dir %{_sysconfdir}/systemd/system/multi-user.target.wants
|
||||||
%{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
|
%{_sysconfdir}/systemd/system/multi-user.target.wants/*.target
|
||||||
%{_sysconfdir}/systemd/system/multi-user.target.wants/systemd-networkd.service
|
%{_sysconfdir}/systemd/system/multi-user.target.wants/systemd-networkd.service
|
||||||
%{_sysconfdir}/systemd/system/sockets.target.wants/systemd-networkd.socket
|
%{_sysconfdir}/systemd/system/sockets.target.wants/systemd-networkd.socket
|
||||||
%{_sysconfdir}/systemd/system/multi-user.target.wants/systemd-resolved.service
|
%{_sysconfdir}/systemd/system/multi-user.target.wants/systemd-resolved.service
|
||||||
@ -482,6 +506,7 @@ fi
|
|||||||
%{_bindir}/hostnamectl
|
%{_bindir}/hostnamectl
|
||||||
%{_bindir}/kernel-install
|
%{_bindir}/kernel-install
|
||||||
%{_bindir}/localectl
|
%{_bindir}/localectl
|
||||||
|
%{_bindir}/systemd-mount
|
||||||
%{_bindir}/systemd-path
|
%{_bindir}/systemd-path
|
||||||
%{_bindir}/systemd-run
|
%{_bindir}/systemd-run
|
||||||
%{_bindir}/timedatectl
|
%{_bindir}/timedatectl
|
||||||
@ -571,12 +596,13 @@ fi
|
|||||||
%{_mandir}/man8/kernel-install.8*
|
%{_mandir}/man8/kernel-install.8*
|
||||||
%{_mandir}/man8/libnss_myhostname.so.2.8*
|
%{_mandir}/man8/libnss_myhostname.so.2.8*
|
||||||
%{_mandir}/man8/libnss_mymachines.so.2.8*
|
%{_mandir}/man8/libnss_mymachines.so.2.8*
|
||||||
|
%{_mandir}/man8/libnss_systemd.so.2.8*
|
||||||
%{_mandir}/man8/nss-myhostname.8*
|
%{_mandir}/man8/nss-myhostname.8*
|
||||||
%{_mandir}/man8/nss-mymachines.8*
|
%{_mandir}/man8/nss-mymachines.8*
|
||||||
|
%{_mandir}/man8/nss-systemd.8*
|
||||||
%{_mandir}/man8/nss-resolve.8*
|
%{_mandir}/man8/nss-resolve.8*
|
||||||
%{_mandir}/man8/pam_systemd.8*
|
%{_mandir}/man8/pam_systemd.8*
|
||||||
%{_mandir}/man8/systemd-*.8*
|
%{_mandir}/man8/systemd-*.8*
|
||||||
%doc LICENSE.LGPL2.1
|
|
||||||
|
|
||||||
#%files tools
|
#%files tools
|
||||||
#%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
@ -592,15 +618,16 @@ fi
|
|||||||
#/%{_lib}/libsystemd-journal.so.*
|
#/%{_lib}/libsystemd-journal.so.*
|
||||||
#/%{_lib}/libsystemd-login.so.*
|
#/%{_lib}/libsystemd-login.so.*
|
||||||
/%{_lib}/security/pam_systemd.*
|
/%{_lib}/security/pam_systemd.*
|
||||||
/%{_lib}/libnss_myhostname.so.*
|
/%{_lib}/libnss_*.so.*
|
||||||
%{_libdir}/libnss_mymachines.so.*
|
%doc LICENSE.LGPL2.1
|
||||||
%{_libdir}/libnss_resolve.so.*
|
|
||||||
|
|
||||||
%files -n libsystemd-devel
|
%files -n libsystemd-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_sysconfdir}/rpm/macros.systemd
|
%{_sysconfdir}/rpm/macros.systemd
|
||||||
%dir %{_includedir}/systemd
|
%dir %{_includedir}/systemd
|
||||||
%{_includedir}/systemd/*.h
|
%{_includedir}/systemd/*.h
|
||||||
|
/%{_lib}/libsystemd.la
|
||||||
|
/%{_lib}/libsystemd.so
|
||||||
%{_libdir}/libsystemd.la
|
%{_libdir}/libsystemd.la
|
||||||
%{_libdir}/libsystemd.so
|
%{_libdir}/libsystemd.so
|
||||||
#%{_libdir}/libsystemd-daemon.la
|
#%{_libdir}/libsystemd-daemon.la
|
||||||
@ -611,9 +638,7 @@ fi
|
|||||||
#%{_libdir}/libsystemd-journal.so
|
#%{_libdir}/libsystemd-journal.so
|
||||||
#%{_libdir}/libsystemd-login.la
|
#%{_libdir}/libsystemd-login.la
|
||||||
#%{_libdir}/libsystemd-login.so
|
#%{_libdir}/libsystemd-login.so
|
||||||
%{_libdir}/libnss_myhostname.la
|
/%{_lib}/libnss_*.la
|
||||||
%{_libdir}/libnss_mymachines.la
|
|
||||||
%{_libdir}/libnss_resolve.la
|
|
||||||
#%{_libdir}/pkgconfig/libsystemd-daemon.pc
|
#%{_libdir}/pkgconfig/libsystemd-daemon.pc
|
||||||
#%{_libdir}/pkgconfig/libsystemd-id128.pc
|
#%{_libdir}/pkgconfig/libsystemd-id128.pc
|
||||||
#%{_libdir}/pkgconfig/libsystemd-journal.pc
|
#%{_libdir}/pkgconfig/libsystemd-journal.pc
|
||||||
@ -659,11 +684,37 @@ fi
|
|||||||
%files -n libudev-devel
|
%files -n libudev-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/libudev.h
|
%{_includedir}/libudev.h
|
||||||
|
/%{_lib}/libudev.la
|
||||||
|
/%{_lib}/libudev.so
|
||||||
%{_libdir}/libudev.la
|
%{_libdir}/libudev.la
|
||||||
%{_libdir}/libudev.so
|
%{_libdir}/libudev.so
|
||||||
%{_libdir}/pkgconfig/libudev.pc
|
%{_libdir}/pkgconfig/libudev.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 24 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-8mamba
|
||||||
|
- patch to disable restrict_address_families causing protocol not supported errors on boot
|
||||||
|
|
||||||
|
* Mon Dec 05 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-7mamba
|
||||||
|
- also symlink libsystemd.l and libudev.la to %{_libdir}
|
||||||
|
|
||||||
|
* Sun Dec 04 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-6mamba
|
||||||
|
- retry fix just adding libsystemd.so and libudev.so symlinks to %{_libdir}
|
||||||
|
|
||||||
|
* Sat Dec 03 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-5mamba
|
||||||
|
- revert previous change; just fix %{_libdir}/libudev.so symlink to /%{_lib}/libudev.so
|
||||||
|
|
||||||
|
* Thu Dec 01 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-4mamba
|
||||||
|
- revert moving libudev.[so|la] to %_libdir; patching pkgconfig file instead
|
||||||
|
|
||||||
|
* Sun Nov 27 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-3mamba
|
||||||
|
- move libudev.la and libudev.so to %{_libdir}
|
||||||
|
|
||||||
|
* Sun Nov 20 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 232-2mamba
|
||||||
|
- create systemd-journal-remote user
|
||||||
|
|
||||||
|
* Tue Nov 15 2016 Automatic Build System <autodist@mambasoft.it> 232-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Jul 26 2016 Automatic Build System <autodist@mambasoft.it> 231-1mamba
|
* Tue Jul 26 2016 Automatic Build System <autodist@mambasoft.it> 231-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user