Release 251.2-2mamba
This commit is contained in:
parent
1c41bfd70e
commit
a2a26e66b4
10
systemd-251.2-add-stdbool-include-1.patch
Normal file
10
systemd-251.2-add-stdbool-include-1.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- systemd-stable-251.2/src/fundamental/sha256.c.orig 2022-06-13 15:52:57.119352352 +0200
|
||||
+++ systemd-stable-251.2/src/fundamental/sha256.c 2022-06-13 15:53:09.522271808 +0200
|
||||
@@ -29,6 +29,7 @@
|
||||
|
||||
#include "macro-fundamental.h"
|
||||
#include "sha256.h"
|
||||
+#include <stdbool.h>
|
||||
|
||||
#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
||||
# define SWAP(n) \
|
54
systemd.spec
54
systemd.spec
@ -26,8 +26,8 @@
|
||||
|
||||
Name: systemd
|
||||
Epoch: 2
|
||||
Version: 251.1
|
||||
Release: 1mamba
|
||||
Version: 251.2
|
||||
Release: 2mamba
|
||||
Summary: A system and service manager compatible with SysV and LSB init scripts
|
||||
Group: System/Configuration
|
||||
Vendor: openmamba
|
||||
@ -70,6 +70,7 @@ Patch19: systemd-239-glibc-2.28.patch
|
||||
Patch20: systemd-240-upstream_fix_return_values.patch
|
||||
Patch21: systemd-247-upstream-fixes-1.patch
|
||||
Patch22: systemd-251-fix-format-string-type-mismatch.patch
|
||||
Patch23: systemd-251.2-add-stdbool-include-1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -204,6 +205,9 @@ This package include development files for building software using udev librarie
|
||||
#:<< _EOF
|
||||
#%patch21 -p1
|
||||
%patch22 -p1 -b .fix-format-string-type-mismatch
|
||||
%ifarch %{ix86}
|
||||
%patch23 -p1
|
||||
%endif
|
||||
|
||||
#sed -i "s|@bindir@|/bin|g" src/core/macros.systemd.in
|
||||
|
||||
@ -241,7 +245,13 @@ export LC_ALL="en_US.UTF-8"
|
||||
-Drpmmacrosdir=%{_sysconfdir}/rpm \
|
||||
-Dsupport-url="https://openmamba.org" \
|
||||
-Dntp-servers="0.europe.pool.ntp.org 1.europe.pool.ntp.org 2.europe.pool.ntp.org 3.europe.pool.ntp.org" \
|
||||
-Ddefault-hierarchy=hybrid \
|
||||
-Ddefault-hierarchy=unified \
|
||||
-Dfallback-hostname="openmamba" \
|
||||
-Dsbat-distro="openmamba" \
|
||||
-Dsbat-distro-summary="openmamba Linux" \
|
||||
-Dsbat-distro-pkgname="%{name}" \
|
||||
-Dsbat-distro-version="%{version}" \
|
||||
-Dsbat-distro-url="https://openmamba.org/it/pacchetti/?tag=devel&pkg=systemd.source" \
|
||||
%ifarch arm
|
||||
-Dtests=false
|
||||
%endif
|
||||
@ -475,28 +485,23 @@ if [ $1 -ge 1 ]; then
|
||||
systemctl --no-reload preset systemd-timesyncd
|
||||
# remove broken left sysv5 symlink due to migrating services to systemd
|
||||
find /etc/rc*.d/* -xtype l -delete 2>/dev/null
|
||||
systemctl -q daemon-reload
|
||||
KVER=`uname -r`
|
||||
INITRAMFS=/boot/initramfs-$KVER.img
|
||||
KERNEL=/boot/vmlinuz-$KVER
|
||||
[ -e $INITRAMFS -a ${_sysconfdir}/systemd/system.conf -nt $INITRAMFS ] || continue
|
||||
[ -e $KERNEL -a -e /usr/bin/mkinitrd ] || continue
|
||||
mkinitrd $INITRAMFS $KVER -f -q
|
||||
# fix initial console fonts with lighter one and working FONT_MAP (219)
|
||||
grep -q "^FONT_MAP=8859-1_to_uni" /etc/vconsole.conf && {
|
||||
sed -i "s|^FONT_MAP=8859-1_to_uni|FONT_MAP=latin2u|" /etc/vconsole.conf
|
||||
sed -i "s|^FONT=lat9w-16|FONT=LatGrkCyr-8x16|" /etc/vconsole.conf
|
||||
}
|
||||
systemctl -q daemon-reload
|
||||
KVER=`uname -r`
|
||||
INITRAMFS=/boot/initramfs-$KVER.img
|
||||
KERNEL=/boot/vmlinuz-$KVER
|
||||
[ -e $INITRAMFS -a /etc/systemd/system.conf -nt $INITRAMFS ] || continue
|
||||
[ -e $KERNEL -a -e /usr/bin/mkinitrd ] || continue
|
||||
mkinitrd $INITRAMFS $KVER -f -q
|
||||
fi
|
||||
:
|
||||
|
||||
%post -n libsystemd
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%postun -n libsystemd
|
||||
/sbin/ldconfig
|
||||
:
|
||||
%post -n libsystemd -p /sbin/ldconfig
|
||||
%postun -n libsystemd -p /sbin/ldconfig
|
||||
|
||||
%pre -n udev
|
||||
# backup persistent-net rules file if it has an old syntax
|
||||
@ -535,13 +540,8 @@ groupadd render -g %{group_render} 2>/dev/null
|
||||
[ -e /lib/udev ] || ln -s ../usr/lib/udev /lib/udev
|
||||
:
|
||||
|
||||
%post -n libudev
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%postun -n libudev
|
||||
/sbin/ldconfig
|
||||
:
|
||||
%post -n libudev -p /sbin/ldconfig
|
||||
%postun -n libudev -p /sbin/ldconfig
|
||||
|
||||
%posttrans -n udev
|
||||
[ ! -L /lib -a ! -L /lib/udev ] && {
|
||||
@ -822,6 +822,12 @@ systemctl daemon-reload &>/dev/null || :
|
||||
%{_libdir}/pkgconfig/libudev.pc
|
||||
|
||||
%changelog
|
||||
* Thu Jun 09 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 251.2-2mamba
|
||||
- set default-hierarchy=unified; add fallback-hostname and sbat-distro info
|
||||
|
||||
* Sat Jun 04 2022 Automatic Build System <autodist@mambasoft.it> 251.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 25 2022 Automatic Build System <autodist@mambasoft.it> 251.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user