Release 239-1mamba

This commit is contained in:
Automatic Build System 2023-12-30 11:38:11 +01:00
parent bd3fe9429d
commit 9a6dab44eb
2 changed files with 118 additions and 3 deletions

View File

@ -0,0 +1,105 @@
From 75720bff62a84896e9a0654afc7cf9408cf89a38 Mon Sep 17 00:00:00 2001
From: Filipe Brandenburger <filbranden@google.com>
Date: Sun, 15 Jul 2018 22:43:35 -0700
Subject: [PATCH] build-sys: Detect whether struct statx is defined in
sys/stat.h
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Starting with glibc 2.27.9000-36.fc29, include file sys/stat.h will have a
definition for struct statx, in which case include file linux/stat.h should be
avoided, in order to prevent a duplicate definition.
In file included from ../src/basic/missing.h:18,
from ../src/basic/util.h:28,
from ../src/basic/hashmap.h:10,
from ../src/shared/bus-util.h:12,
from ../src/libsystemd/sd-bus/bus-creds.c:11:
/usr/include/linux/stat.h:99:8: error: redefinition of struct statx
struct statx {
^~~~~
In file included from /usr/include/sys/stat.h:446,
from ../src/basic/util.h:19,
from ../src/basic/hashmap.h:10,
from ../src/shared/bus-util.h:12,
from ../src/libsystemd/sd-bus/bus-creds.c:11:
/usr/include/bits/statx.h:36:8: note: originally defined here
struct statx
^~~~~
Extend our meson.build to look for struct statx when only sys/stat.h is
included and, in that case, do not include linux/stat.h anymore.
Tested that systemd builds correctly when using a glibc version that includes a
definition for struct statx.
glibc Fedora RPM update:
https://src.fedoraproject.org/rpms/glibc/c/28cb5d31fc1e5887912283c889689c47076278ae
glibc upstream commit:
https://sourceware.org/git/?p=glibc.git;a=commitdiff;h=fd70af45528d59a00eb3190ef6706cb299488fcd
---
meson.build | 5 +++++
src/basic/missing.h | 5 ++++-
src/basic/xattr-util.c | 1 -
3 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index dd904c71487..68423bdfa5e 100644
--- a/meson.build
+++ b/meson.build
@@ -425,6 +425,7 @@ decl_headers = '''
#include <sys/stat.h>
'''
# FIXME: key_serial_t is only defined in keyutils.h, this is bound to fail
+# FIXME: these should use -D_GNU_SOURCE, since that is defined at build time
foreach decl : ['char16_t',
'char32_t',
@@ -439,6 +440,10 @@ foreach decl : ['char16_t',
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
endforeach
+conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <sys/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
['IFLA_VRF_TABLE', 'linux/if_link.h'],
diff --git a/src/basic/missing.h b/src/basic/missing.h
index 71a07d05747..14ad3d49140 100644
--- a/src/basic/missing.h
+++ b/src/basic/missing.h
@@ -15,7 +15,6 @@
#include <linux/neighbour.h>
#include <linux/oom.h>
#include <linux/rtnetlink.h>
-#include <linux/stat.h>
#include <net/ethernet.h>
#include <stdlib.h>
#include <sys/resource.h>
@@ -25,6 +24,10 @@
#include <uchar.h>
#include <unistd.h>
+#if !HAVE_STRUCT_STATX_IN_SYS_STAT_H
+#include <linux/stat.h>
+#endif
+
#if HAVE_AUDIT
#include <libaudit.h>
#endif
diff --git a/src/basic/xattr-util.c b/src/basic/xattr-util.c
index c5c55ea8461..0ee0979837c 100644
--- a/src/basic/xattr-util.c
+++ b/src/basic/xattr-util.c
@@ -2,7 +2,6 @@
#include <errno.h>
#include <fcntl.h>
-#include <linux/stat.h>
#include <stdint.h>
#include <stdlib.h>
#include <string.h>

View File

@ -26,8 +26,8 @@
Name: systemd Name: systemd
Epoch: 2 Epoch: 2
Version: 238 Version: 239
Release: 2mamba Release: 1mamba
Summary: A system and service manager compatible with SysV and LSB init scripts Summary: A system and service manager compatible with SysV and LSB init scripts
Group: System/Configuration Group: System/Configuration
Vendor: openmamba Vendor: openmamba
@ -65,6 +65,7 @@ Patch15: systemd-232-udev-rootlibdir.patch
Patch16: systemd-232-i586-disable_restrict_address_families.patch Patch16: systemd-232-i586-disable_restrict_address_families.patch
Patch17: systemd-236-use_raw_file_descriptor_in_sysctl_write.patch Patch17: systemd-236-use_raw_file_descriptor_in_sysctl_write.patch
Patch18: systemd-238-upstream-dont-include-libmount-h.patch Patch18: systemd-238-upstream-dont-include-libmount-h.patch
Patch19: systemd-239-glibc-2.28.patch
License: GPL License: GPL
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -233,7 +234,8 @@ This package include development files for building software using udev librarie
#%patch15 -p1 #%patch15 -p1
%patch16 -p1 %patch16 -p1
#%patch17 -p1 #%patch17 -p1
%patch18 -p1 #%patch18 -p1
%patch19 -p1
%build %build
#./autogen.sh #./autogen.sh
@ -538,6 +540,7 @@ fi
%{_bindir}/hostnamectl %{_bindir}/hostnamectl
%{_bindir}/kernel-install %{_bindir}/kernel-install
%{_bindir}/localectl %{_bindir}/localectl
%{_bindir}/resolvectl
%{_bindir}/systemd-mount %{_bindir}/systemd-mount
%{_bindir}/systemd-umount %{_bindir}/systemd-umount
%{_bindir}/systemd-path %{_bindir}/systemd-path
@ -558,6 +561,7 @@ fi
/bin/systemd-tmpfiles /bin/systemd-tmpfiles
/bin/systemd-tty-ask-password-agent /bin/systemd-tty-ask-password-agent
/bin/systemd-sysusers /bin/systemd-sysusers
/sbin/resolvconf
%{_bindir}/systemd-cat %{_bindir}/systemd-cat
%{_bindir}/systemd-cgtop %{_bindir}/systemd-cgtop
%{_bindir}/systemd-delta %{_bindir}/systemd-delta
@ -623,6 +627,9 @@ fi
%{_mandir}/man1/loginctl.1* %{_mandir}/man1/loginctl.1*
%{_mandir}/man1/machinectl.1* %{_mandir}/man1/machinectl.1*
%{_mandir}/man1/networkctl.1* %{_mandir}/man1/networkctl.1*
%{_mandir}/man1/portablectl.1*
%{_mandir}/man1/resolvconf.1*
%{_mandir}/man1/resolvectl.1*
%{_mandir}/man1/systemctl.1* %{_mandir}/man1/systemctl.1*
%{_mandir}/man1/systemd-* %{_mandir}/man1/systemd-*
%{_mandir}/man1/systemd.1* %{_mandir}/man1/systemd.1*
@ -728,6 +735,9 @@ fi
%{_libdir}/pkgconfig/libudev.pc %{_libdir}/pkgconfig/libudev.pc
%changelog %changelog
* Sun Aug 12 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 239-1mamba
- update to 239
* Thu Mar 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 238-2mamba * Thu Mar 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 238-2mamba
- create render group - create render group
- removed obsolete ifupdown rule and fixed permissions of other custom rules - removed obsolete ifupdown rule and fixed permissions of other custom rules