Release 216-6mamba
This commit is contained in:
parent
a2cd6222d2
commit
9a0e15b564
25
systemd-216-sysv-generator-use-native-targets.patch
Normal file
25
systemd-216-sysv-generator-use-native-targets.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
--- systemd-216/src/sysv-generator/sysv-generator.c.orig 2014-09-27 16:57:35.327164853 +0200
|
||||||
|
+++ systemd-216/src/sysv-generator/sysv-generator.c 2014-09-27 16:59:01.635140790 +0200
|
||||||
|
@@ -52,15 +52,15 @@
|
||||||
|
const RunlevelType type;
|
||||||
|
} rcnd_table[] = {
|
||||||
|
/* Standard SysV runlevels for start-up */
|
||||||
|
- { "rc1.d", SPECIAL_RESCUE_TARGET, RUNLEVEL_UP },
|
||||||
|
- { "rc2.d", SPECIAL_RUNLEVEL2_TARGET, RUNLEVEL_UP },
|
||||||
|
- { "rc3.d", SPECIAL_RUNLEVEL3_TARGET, RUNLEVEL_UP },
|
||||||
|
- { "rc4.d", SPECIAL_RUNLEVEL4_TARGET, RUNLEVEL_UP },
|
||||||
|
- { "rc5.d", SPECIAL_RUNLEVEL5_TARGET, RUNLEVEL_UP },
|
||||||
|
+ { "rc1.d", "rescue.target", RUNLEVEL_UP },
|
||||||
|
+ { "rc2.d", "multi-user.target", RUNLEVEL_UP },
|
||||||
|
+ { "rc3.d", "multi-user.target", RUNLEVEL_UP },
|
||||||
|
+ { "rc4.d", "multi-user.target", RUNLEVEL_UP },
|
||||||
|
+ { "rc5.d", "graphical.target", RUNLEVEL_UP },
|
||||||
|
|
||||||
|
/* Standard SysV runlevels for shutdown */
|
||||||
|
- { "rc0.d", SPECIAL_POWEROFF_TARGET, RUNLEVEL_DOWN },
|
||||||
|
- { "rc6.d", SPECIAL_REBOOT_TARGET, RUNLEVEL_DOWN }
|
||||||
|
+ { "rc0.d", "poweroff.target", RUNLEVEL_DOWN },
|
||||||
|
+ { "rc6.d", "reboot.target", RUNLEVEL_DOWN }
|
||||||
|
|
||||||
|
/* Note that the order here matters, as we read the
|
||||||
|
directories in this order, and we want to make sure that
|
27
systemd.spec
27
systemd.spec
@ -23,7 +23,7 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 216
|
Version: 216
|
||||||
Release: 4mamba
|
Release: 6mamba
|
||||||
Summary: A system and service manager compatible with SysV and LSB init scripts
|
Summary: A system and service manager compatible with SysV and LSB init scripts
|
||||||
Group: System/Configuration
|
Group: System/Configuration
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -49,6 +49,7 @@ Patch5: udev-177-arm-pre-accept4.patch
|
|||||||
Patch6: systemd-207-swap_fix_reverse_dependencies.patch
|
Patch6: systemd-207-swap_fix_reverse_dependencies.patch
|
||||||
Patch7: systemd-207-create_wants_symlink.patch
|
Patch7: systemd-207-create_wants_symlink.patch
|
||||||
Patch8: systemd-208-journald-reduce-sizes.patch
|
Patch8: systemd-208-journald-reduce-sizes.patch
|
||||||
|
Patch9: systemd-216-sysv-generator-use-native-targets.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -195,6 +196,7 @@ This package include development files for building software using udev librarie
|
|||||||
#%patch4 -p1
|
#%patch4 -p1
|
||||||
#%patch6 -p1
|
#%patch6 -p1
|
||||||
#%patch7 -p1
|
#%patch7 -p1
|
||||||
|
%patch9 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -203,14 +205,13 @@ This package include development files for building software using udev librarie
|
|||||||
--with-pamlibdir=/%{_lib}/security \
|
--with-pamlibdir=/%{_lib}/security \
|
||||||
--with-firmware-path=/lib/firmware \
|
--with-firmware-path=/lib/firmware \
|
||||||
--with-tty-gid=4 \
|
--with-tty-gid=4 \
|
||||||
--enable-chkconfig \
|
|
||||||
--enable-split-usr \
|
--enable-split-usr \
|
||||||
|
--enable-chkconfig \
|
||||||
--with-rc-local-script-path-start=/etc/rc.d/init.d/rc.local \
|
--with-rc-local-script-path-start=/etc/rc.d/init.d/rc.local \
|
||||||
--enable-compat-libs \
|
--enable-compat-libs \
|
||||||
KMOD=/sbin/kmod
|
KMOD=/sbin/kmod
|
||||||
|
|
||||||
%make \
|
%make \
|
||||||
-j1 \
|
|
||||||
rpmmacrosdir=%{_sysconfdir}/rpm
|
rpmmacrosdir=%{_sysconfdir}/rpm
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -362,10 +363,11 @@ groupadd kvm -g %{group_kvm} 2>/dev/null
|
|||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
:
|
:
|
||||||
|
|
||||||
%posttrans
|
%posttrans core
|
||||||
if [ $1 -gt 1 ]; then
|
if [ $1 -ge 1 ]; then
|
||||||
# remove broken left sysv5 symlink due to migrating services to systemd
|
# remove broken left sysv5 symlink due to migrating services to systemd
|
||||||
find /etc/rc*.d/* -xtype l -delete
|
find /etc/rc*.d/* -xtype l -delete 2>/dev/null
|
||||||
|
systemctl -q daemon-reload
|
||||||
KVER=`uname -r`
|
KVER=`uname -r`
|
||||||
INITRAMFS=/boot/initramfs-$KVER.img
|
INITRAMFS=/boot/initramfs-$KVER.img
|
||||||
[ -e $INITRAMFS -a ${_sysconfdir}/systemd/system.conf -nt $INITRAMFS ] || continue
|
[ -e $INITRAMFS -a ${_sysconfdir}/systemd/system.conf -nt $INITRAMFS ] || continue
|
||||||
@ -393,6 +395,7 @@ fi
|
|||||||
|
|
||||||
%files core -f %{name}.lang
|
%files core -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%dir %{_sysconfdir}/kernel/install.d
|
||||||
%dir %{_sysconfdir}/systemd
|
%dir %{_sysconfdir}/systemd
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/bootchart.conf
|
%config(noreplace) %{_sysconfdir}/systemd/bootchart.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/coredump.conf
|
%config(noreplace) %{_sysconfdir}/systemd/coredump.conf
|
||||||
@ -403,6 +406,7 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/systemd/resolved.conf
|
%config(noreplace) %{_sysconfdir}/systemd/resolved.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/system.conf
|
%config(noreplace) %{_sysconfdir}/systemd/system.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/timesyncd.conf
|
%config(noreplace) %{_sysconfdir}/systemd/timesyncd.conf
|
||||||
|
%dir %{_sysconfdir}/systemd/network
|
||||||
%dir %{_sysconfdir}/systemd/system
|
%dir %{_sysconfdir}/systemd/system
|
||||||
%dir %{_sysconfdir}/systemd/system/multi-user.target.wants
|
%dir %{_sysconfdir}/systemd/system/multi-user.target.wants
|
||||||
%{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
|
%{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
|
||||||
@ -412,6 +416,7 @@ fi
|
|||||||
%{_sysconfdir}/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service
|
%{_sysconfdir}/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service
|
||||||
%dir %{_sysconfdir}/systemd/system/getty.target.wants
|
%dir %{_sysconfdir}/systemd/system/getty.target.wants
|
||||||
%{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
|
%{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
|
||||||
|
%dir %{_sysconfdir}/systemd/user
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/user.conf
|
%config(noreplace) %{_sysconfdir}/systemd/user.conf
|
||||||
%{_sysconfdir}/mtab
|
%{_sysconfdir}/mtab
|
||||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.*.conf
|
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.*.conf
|
||||||
@ -495,6 +500,7 @@ fi
|
|||||||
%{python_sitearch}/systemd/*
|
%{python_sitearch}/systemd/*
|
||||||
%{_localstatedir}/log/README
|
%{_localstatedir}/log/README
|
||||||
%dir %{_localstatedir}/log/journal
|
%dir %{_localstatedir}/log/journal
|
||||||
|
%dir %{_localstatedir}/log/journal/remote
|
||||||
%dir %{_localstatedir}/lib/systemd
|
%dir %{_localstatedir}/lib/systemd
|
||||||
%{_mandir}/man1/bootctl.1*
|
%{_mandir}/man1/bootctl.1*
|
||||||
%{_mandir}/man1/busctl.1*
|
%{_mandir}/man1/busctl.1*
|
||||||
@ -622,6 +628,15 @@ fi
|
|||||||
%{_datadir}/pkgconfig/udev.pc
|
%{_datadir}/pkgconfig/udev.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 27 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 216-6mamba
|
||||||
|
- patch sysv-generator to use native targets instead of runlevel*.target to fix broken sysv services startup
|
||||||
|
- fix poststrans script for broken old sysv symlinks removal
|
||||||
|
- restore chkconfig because this is not the problem
|
||||||
|
- added some new empty directories
|
||||||
|
|
||||||
|
* Fri Sep 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 216-5mamba
|
||||||
|
- disable chkconfig support to fix new systemd-sysv-generator legacy method
|
||||||
|
|
||||||
* Wed Sep 10 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 216-4mamba
|
* Wed Sep 10 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 216-4mamba
|
||||||
- remove broken sysv5 symlink left after migrating to systemd; fix mkinitrd trigger date check
|
- remove broken sysv5 symlink left after migrating to systemd; fix mkinitrd trigger date check
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user