Release 251.1-1mamba
This commit is contained in:
parent
bef429b8bc
commit
1c41bfd70e
25
systemd-251-fix-format-string-type-mismatch.patch
Normal file
25
systemd-251-fix-format-string-type-mismatch.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 08e86b15fc22a8e9f1ee0a791dfd35b2fc25e4c4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Daan De Meyer <daan.j.demeyer@gmail.com>
|
||||||
|
Date: Sun, 22 May 2022 14:36:07 +0200
|
||||||
|
Subject: [PATCH] coredump: Fix format string type mismatch
|
||||||
|
|
||||||
|
Fixes #23471
|
||||||
|
---
|
||||||
|
src/coredump/coredump.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/coredump/coredump.c b/src/coredump/coredump.c
|
||||||
|
index c9747416ad3c..994d968d871b 100644
|
||||||
|
--- a/src/coredump/coredump.c
|
||||||
|
+++ b/src/coredump/coredump.c
|
||||||
|
@@ -512,8 +512,8 @@ static int save_external_coredump(
|
||||||
|
|
||||||
|
if (truncated)
|
||||||
|
log_struct(LOG_INFO,
|
||||||
|
- LOG_MESSAGE("Core file was truncated to %zu bytes.", max_size),
|
||||||
|
- "SIZE_LIMIT=%zu", max_size,
|
||||||
|
+ LOG_MESSAGE("Core file was truncated to %"PRIu64" bytes.", max_size),
|
||||||
|
+ "SIZE_LIMIT=%"PRIu64, max_size,
|
||||||
|
"MESSAGE_ID=" SD_MESSAGE_TRUNCATED_CORE_STR);
|
||||||
|
|
||||||
|
r = fix_permissions(fd, tmp, fn, context, uid);
|
11
systemd.spec
11
systemd.spec
@ -26,7 +26,7 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 250.5
|
Version: 251.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: A system and service manager compatible with SysV and LSB init scripts
|
Summary: A system and service manager compatible with SysV and LSB init scripts
|
||||||
Group: System/Configuration
|
Group: System/Configuration
|
||||||
@ -69,6 +69,7 @@ Patch18: systemd-238-upstream-dont-include-libmount-h.patch
|
|||||||
Patch19: systemd-239-glibc-2.28.patch
|
Patch19: systemd-239-glibc-2.28.patch
|
||||||
Patch20: systemd-240-upstream_fix_return_values.patch
|
Patch20: systemd-240-upstream_fix_return_values.patch
|
||||||
Patch21: systemd-247-upstream-fixes-1.patch
|
Patch21: systemd-247-upstream-fixes-1.patch
|
||||||
|
Patch22: systemd-251-fix-format-string-type-mismatch.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -202,6 +203,7 @@ This package include development files for building software using udev librarie
|
|||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch21 -p1
|
#%patch21 -p1
|
||||||
|
%patch22 -p1 -b .fix-format-string-type-mismatch
|
||||||
|
|
||||||
#sed -i "s|@bindir@|/bin|g" src/core/macros.systemd.in
|
#sed -i "s|@bindir@|/bin|g" src/core/macros.systemd.in
|
||||||
|
|
||||||
@ -694,6 +696,7 @@ systemctl daemon-reload &>/dev/null || :
|
|||||||
%dir %{_datadir}/factory
|
%dir %{_datadir}/factory
|
||||||
%dir %{_datadir}/factory/etc
|
%dir %{_datadir}/factory/etc
|
||||||
%{_datadir}/factory/etc/issue
|
%{_datadir}/factory/etc/issue
|
||||||
|
%{_datadir}/factory/etc/locale.conf
|
||||||
%{_datadir}/factory/etc/nsswitch.conf
|
%{_datadir}/factory/etc/nsswitch.conf
|
||||||
%dir %{_datadir}/factory/etc/pam.d
|
%dir %{_datadir}/factory/etc/pam.d
|
||||||
%{_datadir}/factory/etc/pam.d/other
|
%{_datadir}/factory/etc/pam.d/other
|
||||||
@ -819,6 +822,12 @@ systemctl daemon-reload &>/dev/null || :
|
|||||||
%{_libdir}/pkgconfig/libudev.pc
|
%{_libdir}/pkgconfig/libudev.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 25 2022 Automatic Build System <autodist@mambasoft.it> 251.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun May 22 2022 Automatic Build System <autodist@mambasoft.it> 251-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Apr 30 2022 Automatic Build System <autodist@mambasoft.it> 250.5-1mamba
|
* Sat Apr 30 2022 Automatic Build System <autodist@mambasoft.it> 250.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user