update to 45.0 [release 45.0-1mamba;Fri Oct 06 2023]
This commit is contained in:
parent
5376116e8f
commit
60fb7bf517
@ -1,11 +0,0 @@
|
||||
--- sysprof-3.36.0/src/tests/allocs-by-size.c.orig 2020-03-25 09:24:40.338545357 +0100
|
||||
+++ sysprof-3.36.0/src/tests/allocs-by-size.c 2020-03-25 09:26:26.520451902 +0100
|
||||
@@ -109,7 +109,7 @@
|
||||
{
|
||||
const Item *item = &g_array_index (ar, Item, i);
|
||||
|
||||
- g_print ("%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT"\n",
|
||||
+ g_print ("%u,%u,%u\n",
|
||||
item->size, item->cmp, item->count);
|
||||
}
|
||||
}
|
35
sysprof.spec
35
sysprof.spec
@ -1,6 +1,6 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
%define majver %(echo %version | cut -d. -f1)
|
||||
Name: sysprof
|
||||
Version: 3.48.0
|
||||
Version: 45.0
|
||||
Release: 1mamba
|
||||
Summary: A sampling profiler that uses a kernel module to generate stacktraces
|
||||
Group: System/Libraries
|
||||
@ -9,21 +9,25 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://wiki.gnome.org/
|
||||
Source: http://ftp.acc.umu.se/pub/GNOME/sources/sysprof/%{majver}/sysprof-%{version}.tar.xz
|
||||
Patch0: sysprof-3.36.0-x86-fix-long-long-type.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libadwaita-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdex-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphene-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libjson-glib-devel
|
||||
BuildRequires: libpanel-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpolkit-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libunwind-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libdex-devel
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
@ -50,7 +54,6 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%meson
|
||||
@ -74,7 +77,6 @@ This package contains libraries and header files for developing applications tha
|
||||
%{_bindir}/sysprof*
|
||||
%{_datadir}/applications/org.gnome.Sysprof.desktop
|
||||
%{_datadir}/metainfo/org.gnome.Sysprof.appdata.xml
|
||||
%{_unitdir}/sysprof2.service
|
||||
%{_unitdir}/sysprof3.service
|
||||
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof*.xml
|
||||
%{_datadir}/dbus-1/system-services/org.gnome.Sysprof*.service
|
||||
@ -85,29 +87,30 @@ This package contains libraries and header files for developing applications tha
|
||||
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Sysprof.svg
|
||||
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
|
||||
%{_datadir}/icons/hicolor/scalable/actions/sysprof-*.svg
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libsysprof-4.so
|
||||
%{_libdir}/libsysprof-ui-5.so
|
||||
%{_libdir}/libsysprof-memory-4.so
|
||||
%{_libdir}/libsysprof-speedtrack-4.so
|
||||
%{_libdir}/libsysprof-6.so.*
|
||||
%{_libdir}/libsysprof-memory-6.so
|
||||
%{_libdir}/libsysprof-speedtrack-6.so
|
||||
%{_libdir}/libsysprof-tracer-6.so
|
||||
%{_libexecdir}/sysprofd
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/sysprof-4
|
||||
%{_includedir}/sysprof-4/*
|
||||
%dir %{_includedir}/sysprof-ui-5
|
||||
%{_includedir}/sysprof-ui-5/*
|
||||
%dir %{_includedir}/sysprof-6
|
||||
%{_includedir}/sysprof-6/*
|
||||
%{_libdir}/libsysprof-6.so
|
||||
%{_libdir}/libsysprof-capture-4.a
|
||||
%{_libdir}/pkgconfig/sysprof-4.pc
|
||||
%{_libdir}/pkgconfig/sysprof-capture-4.pc
|
||||
%{_libdir}/pkgconfig/sysprof-ui-5.pc
|
||||
%{_libdir}/pkgconfig/sysprof-6.pc
|
||||
#%doc NEWS README.md
|
||||
|
||||
%changelog
|
||||
* Fri Oct 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 45.0-1mamba
|
||||
- update to 45.0
|
||||
|
||||
* Sat Mar 18 2023 Automatic Build System <autodist@mambasoft.it> 3.48.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user