update to 1.4.5 [release 1.4.5-1mamba;Thu Nov 07 2024]

This commit is contained in:
Silvan Calarco 2024-11-08 10:16:53 +01:00
parent 04c9d3662d
commit f603a46213
4 changed files with 6 additions and 59 deletions

View File

@ -1,10 +0,0 @@
--- synfig-0.64.0/src/modules/mod_png/trgt_png.cpp.orig 2013-09-19 13:34:46.160236846 +0200
+++ synfig-0.64.0/src/modules/mod_png/trgt_png.cpp 2013-09-19 13:34:53.248166505 +0200
@@ -36,6 +36,7 @@
#include <png.h>
#include <ETL/stringf>
#include <cstdio>
+#include <cstring>
#include <algorithm>
#include <functional>
#include <ETL/misc>

View File

@ -1,20 +0,0 @@
--- synfig-0.64.0.orig/configure.ac 2013-05-09 18:32:41.000000000 +0200
+++ synfig-0.64.0/configure.ac 2013-09-20 15:35:06.273090631 +0200
@@ -452,12 +452,13 @@
TARGET_PNG="yes"
TARGET_MNG="yes"
-AC_CHECK_LIB(png14, png_write_row,[
- PNG_LIBS="-lpng14"
- AC_DEFINE(HAVE_LIBPNG14,[], [ Define if PNG 1.4 library is available ])
+AC_CHECK_LIB(png16, png_write_row,[
+ PNG_LIBS="-lpng16"
+ AC_DEFINE(HAVE_LIBPNG16,[], [ Define if PNG 1.6 library is available ])
AC_DEFINE(HAVE_LIBPNG,[], [ Define if PNG library is available ])
AC_SUBST(PNG_LIBS)
- AM_CONDITIONAL(HAVE_LIBPNG14,true)
+ AM_CONDITIONAL(HAVE_LIBPNG16,true)
+ AM_CONDITIONAL(HAVE_LIBPNG14,false)
AM_CONDITIONAL(HAVE_LIBPNG,true)
],[
AC_CHECK_LIB(png12, png_write_row,[

View File

@ -1,20 +0,0 @@
--- synfig-1.0.2/src/modules/mod_magickpp/trgt_magickpp.cpp.orig 2016-10-06 22:43:23.534630678 +0200
+++ synfig-1.0.2/src/modules/mod_magickpp/trgt_magickpp.cpp 2016-10-06 22:43:13.033630581 +0200
@@ -59,7 +59,7 @@
MagickCore::Image* previous = 0;
MagickCore::Image* first = NULL;
MagickCore::ExceptionInfo exceptionInfo;
- MagickCore::GetExceptionInfo(&exceptionInfo);
+ MagickCore::CloneExceptionInfo(&exceptionInfo);
for (Iter iter = container.begin(); iter != container.end(); ++iter)
{
MagickCore::Image* current;
@@ -87,7 +87,7 @@
magickpp_trgt::~magickpp_trgt()
{
MagickCore::ExceptionInfo exceptionInfo;
- MagickCore::GetExceptionInfo(&exceptionInfo);
+ MagickCore::CloneExceptionInfo(&exceptionInfo);
try
{

View File

@ -1,5 +1,5 @@
Name: synfig
Version: 1.4.4
Version: 1.4.5
Release: 1mamba
Summary: A vector based 2D animation package
Group: Applications/Graphics
@ -8,9 +8,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.synfig.org/
Source: https://sourceforge.net/projects/synfig/files/stable/%{version}/source/synfig-%{version}.tar.gz
Patch0: synfig-0.64.0-gcc-4.8.patch
Patch1: synfig-0.64.0-libpng-1.6.patch
Patch2: synfig-1.0.2-ImageMagick-7.0.3.2.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: etl-devel
@ -26,7 +23,7 @@ BuildRequires: libglibmm24-devel
BuildRequires: libgomp-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libimath-devel
BuildRequires: libjpeg-devel
BuildRequires: libjpeg-turbo
BuildRequires: libltdl-devel
BuildRequires: libmlt-devel
BuildRequires: libmng-devel
@ -40,8 +37,8 @@ BuildRequires: libxml2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libMagick-devel >= 7.1.0.35
BuildRequires: etl-devel >= %{version}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRequires: etl-devel
%description
synfig is a vector based 2D animation package. It is designed to be capable of producing feature-film quality animation. It eliminates the need for tweening, preventing the need to hand-draw each frame. synfig features spatial and temporal resolution independence (sharp and smooth at any resolution or framerate), high dynamic range images, and a flexible plugin system.
@ -62,7 +59,6 @@ Requires: pkg-config
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
@ -85,8 +81,6 @@ This package contains libraries and header files for developing applications tha
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files -f %{name}.lang
%defattr(-,root,root)
@ -111,6 +105,9 @@ This package contains libraries and header files for developing applications tha
%doc ChangeLog ChangeLog.old NEWS README TODO
%changelog
* Thu Nov 07 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.5-1mamba
- update to 1.4.5
* Sun Aug 20 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.4-1mamba
- update to 1.4.4