rebuilt with openexr 2.1.0 [release 0.64.1-2mamba;Tue Apr 01 2014]
This commit is contained in:
parent
040b7ce33b
commit
c10b09e5d9
@ -1,2 +1,4 @@
|
||||
# synfig
|
||||
|
||||
synfig is a vector based 2D animation package. It is designed to be capable of producing feature-film quality animation. It eliminates the need for tweening, preventing the need to hand-draw each frame. synfig features spatial and temporal resolution independence (sharp and smooth at any resolution or framerate), high dynamic range images, and a flexible plugin system.
|
||||
|
||||
|
10
synfig-0.64.0-gcc-4.8.patch
Normal file
10
synfig-0.64.0-gcc-4.8.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- synfig-0.64.0/src/modules/mod_png/trgt_png.cpp.orig 2013-09-19 13:34:46.160236846 +0200
|
||||
+++ synfig-0.64.0/src/modules/mod_png/trgt_png.cpp 2013-09-19 13:34:53.248166505 +0200
|
||||
@@ -36,6 +36,7 @@
|
||||
#include <png.h>
|
||||
#include <ETL/stringf>
|
||||
#include <cstdio>
|
||||
+#include <cstring>
|
||||
#include <algorithm>
|
||||
#include <functional>
|
||||
#include <ETL/misc>
|
20
synfig-0.64.0-libpng-1.6.patch
Normal file
20
synfig-0.64.0-libpng-1.6.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- synfig-0.64.0.orig/configure.ac 2013-05-09 18:32:41.000000000 +0200
|
||||
+++ synfig-0.64.0/configure.ac 2013-09-20 15:35:06.273090631 +0200
|
||||
@@ -452,12 +452,13 @@
|
||||
TARGET_PNG="yes"
|
||||
TARGET_MNG="yes"
|
||||
|
||||
-AC_CHECK_LIB(png14, png_write_row,[
|
||||
- PNG_LIBS="-lpng14"
|
||||
- AC_DEFINE(HAVE_LIBPNG14,[], [ Define if PNG 1.4 library is available ])
|
||||
+AC_CHECK_LIB(png16, png_write_row,[
|
||||
+ PNG_LIBS="-lpng16"
|
||||
+ AC_DEFINE(HAVE_LIBPNG16,[], [ Define if PNG 1.6 library is available ])
|
||||
AC_DEFINE(HAVE_LIBPNG,[], [ Define if PNG library is available ])
|
||||
AC_SUBST(PNG_LIBS)
|
||||
- AM_CONDITIONAL(HAVE_LIBPNG14,true)
|
||||
+ AM_CONDITIONAL(HAVE_LIBPNG16,true)
|
||||
+ AM_CONDITIONAL(HAVE_LIBPNG14,false)
|
||||
AM_CONDITIONAL(HAVE_LIBPNG,true)
|
||||
],[
|
||||
AC_CHECK_LIB(png12, png_write_row,[
|
163
synfig.spec
Normal file
163
synfig.spec
Normal file
@ -0,0 +1,163 @@
|
||||
Name: synfig
|
||||
Version: 0.64.1
|
||||
Release: 2mamba
|
||||
Summary: A vector based 2D animation package
|
||||
Group: Applications/Graphics
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.synfig.org/
|
||||
Source: http://downloads.sourceforge.net/project/synfig/releases/%{version}/source/synfig-%{version}.tar.gz
|
||||
Patch0: synfig-0.64.0-gcc-4.8.patch
|
||||
Patch1: synfig-0.64.0-libpng-1.6.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: etl-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglibmm-devel
|
||||
BuildRequires: libilmbase-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: libmng-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng14-devel
|
||||
BuildRequires: libsigc++-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxml++-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRequires: etl-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
synfig is a vector based 2D animation package. It is designed to be capable of producing feature-film quality animation. It eliminates the need for tweening, preventing the need to hand-draw each frame. synfig features spatial and temporal resolution independence (sharp and smooth at any resolution or framerate), high dynamic range images, and a flexible plugin system.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n lib%{name}
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name} || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/synfig
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/synfig_modules.cfg
|
||||
%{_libdir}/libsynfig.so.*
|
||||
%dir %{_libdir}/synfig/modules
|
||||
%{_libdir}/synfig/modules/liblyr_freetype.la
|
||||
%{_libdir}/synfig/modules/liblyr_freetype.so
|
||||
%{_libdir}/synfig/modules/liblyr_std.la
|
||||
%{_libdir}/synfig/modules/liblyr_std.so
|
||||
%{_libdir}/synfig/modules/libmod_bmp.la
|
||||
%{_libdir}/synfig/modules/libmod_bmp.so
|
||||
%{_libdir}/synfig/modules/libmod_dv.la
|
||||
%{_libdir}/synfig/modules/libmod_dv.so
|
||||
%{_libdir}/synfig/modules/libmod_example.la
|
||||
%{_libdir}/synfig/modules/libmod_example.so
|
||||
%{_libdir}/synfig/modules/libmod_ffmpeg.la
|
||||
%{_libdir}/synfig/modules/libmod_ffmpeg.so
|
||||
%{_libdir}/synfig/modules/libmod_filter.la
|
||||
%{_libdir}/synfig/modules/libmod_filter.so
|
||||
%{_libdir}/synfig/modules/libmod_geometry.la
|
||||
%{_libdir}/synfig/modules/libmod_geometry.so
|
||||
%{_libdir}/synfig/modules/libmod_gif.la
|
||||
%{_libdir}/synfig/modules/libmod_gif.so
|
||||
%{_libdir}/synfig/modules/libmod_gradient.la
|
||||
%{_libdir}/synfig/modules/libmod_gradient.so
|
||||
%{_libdir}/synfig/modules/libmod_imagemagick.la
|
||||
%{_libdir}/synfig/modules/libmod_imagemagick.so
|
||||
%{_libdir}/synfig/modules/libmod_jpeg.la
|
||||
%{_libdir}/synfig/modules/libmod_jpeg.so
|
||||
%{_libdir}/synfig/modules/libmod_magickpp.la
|
||||
%{_libdir}/synfig/modules/libmod_magickpp.so
|
||||
%{_libdir}/synfig/modules/libmod_mng.la
|
||||
%{_libdir}/synfig/modules/libmod_mng.so
|
||||
%{_libdir}/synfig/modules/libmod_noise.la
|
||||
%{_libdir}/synfig/modules/libmod_noise.so
|
||||
%{_libdir}/synfig/modules/libmod_openexr.la
|
||||
%{_libdir}/synfig/modules/libmod_openexr.so
|
||||
%{_libdir}/synfig/modules/libmod_particle.la
|
||||
%{_libdir}/synfig/modules/libmod_particle.so
|
||||
%{_libdir}/synfig/modules/libmod_png.la
|
||||
%{_libdir}/synfig/modules/libmod_png.so
|
||||
%{_libdir}/synfig/modules/libmod_ppm.la
|
||||
%{_libdir}/synfig/modules/libmod_ppm.so
|
||||
%{_libdir}/synfig/modules/libmod_svg.la
|
||||
%{_libdir}/synfig/modules/libmod_svg.so
|
||||
%{_libdir}/synfig/modules/libmod_yuv420p.la
|
||||
%{_libdir}/synfig/modules/libmod_yuv420p.so
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/synfig-config
|
||||
%dir %{_includedir}/synfig-0.0
|
||||
%dir %{_includedir}/synfig-0.0/synfig
|
||||
%{_includedir}/synfig-0.0/synfig/*.h
|
||||
%{_libdir}/libsynfig.la
|
||||
%{_libdir}/libsynfig.so
|
||||
%{_libdir}/pkgconfig/synfig.pc
|
||||
%doc ChangeLog ChangeLog.old NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Tue Apr 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.64.1-2mamba
|
||||
- rebuilt with openexr 2.1.0
|
||||
|
||||
* Fri Mar 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.64.1-1mamba
|
||||
- update to 0.64.1
|
||||
|
||||
* Mon Dec 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.64.0-3mamba
|
||||
- rebuilt with boost 1.55
|
||||
|
||||
* Fri Sep 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.64.0-2mamba
|
||||
- added configure.in patch to link against libpng16
|
||||
|
||||
* Thu Sep 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.64.0-1mamba
|
||||
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user