rebuilt with ImageMagick 7.0.3.2 [release 1.0.2-2mamba;Fri Oct 07 2016]
This commit is contained in:
parent
0321acb8c0
commit
1410e79df6
20
synfig-1.0.2-ImageMagick-7.0.3.2.patch
Normal file
20
synfig-1.0.2-ImageMagick-7.0.3.2.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- synfig-1.0.2/src/modules/mod_magickpp/trgt_magickpp.cpp.orig 2016-10-06 22:43:23.534630678 +0200
|
||||
+++ synfig-1.0.2/src/modules/mod_magickpp/trgt_magickpp.cpp 2016-10-06 22:43:13.033630581 +0200
|
||||
@@ -59,7 +59,7 @@
|
||||
MagickCore::Image* previous = 0;
|
||||
MagickCore::Image* first = NULL;
|
||||
MagickCore::ExceptionInfo exceptionInfo;
|
||||
- MagickCore::GetExceptionInfo(&exceptionInfo);
|
||||
+ MagickCore::CloneExceptionInfo(&exceptionInfo);
|
||||
for (Iter iter = container.begin(); iter != container.end(); ++iter)
|
||||
{
|
||||
MagickCore::Image* current;
|
||||
@@ -87,7 +87,7 @@
|
||||
magickpp_trgt::~magickpp_trgt()
|
||||
{
|
||||
MagickCore::ExceptionInfo exceptionInfo;
|
||||
- MagickCore::GetExceptionInfo(&exceptionInfo);
|
||||
+ MagickCore::CloneExceptionInfo(&exceptionInfo);
|
||||
|
||||
try
|
||||
{
|
22
synfig.spec
22
synfig.spec
@ -1,15 +1,16 @@
|
||||
Name: synfig
|
||||
Version: 1.0.1
|
||||
Release: 1mamba
|
||||
Version: 1.0.2
|
||||
Release: 2mamba
|
||||
Summary: A vector based 2D animation package
|
||||
Group: Applications/Graphics
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.synfig.org/
|
||||
Source: http://download.tuxfamily.org/synfig/releases/%{version}/synfig-%{version}.tar.gz
|
||||
Source: http://downloads.sourceforge.net/project/synfig/releases/%{version}/source/synfig-%{version}.tar.gz
|
||||
Patch0: synfig-0.64.0-gcc-4.8.patch
|
||||
Patch1: synfig-0.64.0-libpng-1.6.patch
|
||||
Patch2: synfig-1.0.2-ImageMagick-7.0.3.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: etl-devel
|
||||
@ -31,10 +32,10 @@ BuildRequires: libpng14-devel
|
||||
BuildRequires: libsigc++-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxml++-devel
|
||||
BuildRequires: libxml++2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libMagick-devel >= 6.9.1.4-1mamba
|
||||
BuildRequires: libMagick-devel >= 7.0.3.2
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRequires: etl-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -65,11 +66,14 @@ This package contains libraries and header files for developing applications tha
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
autoreconf -f -i
|
||||
%configure
|
||||
%make
|
||||
|
||||
%make \
|
||||
CXXFLAGS="$CXXFLAGS -std=c++11"
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -148,6 +152,12 @@ autoreconf -f -i
|
||||
%doc ChangeLog ChangeLog.old NEWS README TODO
|
||||
|
||||
%changelog
|
||||
* Fri Oct 07 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-2mamba
|
||||
- rebuilt with ImageMagick 7.0.3.2
|
||||
|
||||
* Thu Dec 03 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.2-1mamba
|
||||
- update to 1.0.2
|
||||
|
||||
* Wed Sep 16 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.1-1mamba
|
||||
- update to 1.0.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user