automatic version update by autodist [release 1.4.12-1mamba;Sat Aug 31 2013]

This commit is contained in:
Automatic Build System 2024-01-05 18:16:29 +01:00
parent e93028f8ad
commit e6ee22fac9
5 changed files with 317 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# synergy # synergy
Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems, each with its own display, without special hardware. It's intended for users with multiple computers on their desk since each system uses its own monitor(s).
Redirecting the mouse and keyboard is as simple as moving the mouse off the edge of your screen. Synergy also merges the clipboards of all the systems into one, allowing cut-and-paste between systems. Furthermore, it synchronizes screen savers so they all start and stop together and, if screen locking is enabled, only one screen requires a password to unlock them all. Learn more about how it works.

View File

@ -0,0 +1,74 @@
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -13,24 +13,6 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-set(cpp_dir cryptopp562)
-
-file(GLOB cpp_src ${cpp_dir}/*.cpp)
-
-if (WIN32)
- file(GLOB cpp_hdr ${cpp_dir}/*.h)
- list(APPEND cpp_src ${cpp_hdr})
-endif()
-
-file(GLOB cpp_ignore
- ${cpp_dir}/simple.cpp
- ${cpp_dir}/strciphr.cpp
- ${cpp_dir}/polynomi.cpp
- ${cpp_dir}/eprecomp.cpp
- ${cpp_dir}/eccrypto.cpp
- ${cpp_dir}/algebra.cpp)
-list(REMOVE_ITEM cpp_src ${cpp_ignore})
-
# if 64-bit windows, compile asm file.
if (CMAKE_CL_64)
list(APPEND cpp_src ${cpp_dir}/x64dll.asm ${cpp_dir}/x64masm.asm)
@@ -60,5 +42,3 @@
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=native")
endif()
endif()
-
-add_library(cryptopp STATIC ${cpp_src})
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,6 +128,10 @@
endif()
+ set(CMAKE_REQUIRED_LIBRARIES crypto++)
+ set(CMAKE_REQUIRED_LIBRARIES)
+ set(CMAKE_INCLUDE_DIRECTORIES)
+
check_type_size(char SIZEOF_CHAR)
check_type_size(int SIZEOF_INT)
check_type_size(long SIZEOF_LONG)
--- a/src/lib/synergy/CCryptoMode.h
+++ b/src/lib/synergy/CCryptoMode.h
@@ -17,9 +17,9 @@
#pragma once
-#include <cryptopp562/gcm.h>
-#include <cryptopp562/modes.h>
-#include <cryptopp562/aes.h>
+#include <crypto++/gcm.h>
+#include <crypto++/modes.h>
+#include <crypto++/aes.h>
#include "ECryptoMode.h"
#include "CString.h"
--- a/src/lib/synergy/CCryptoStream.h
+++ b/src/lib/synergy/CCryptoStream.h
@@ -20,8 +20,8 @@
#include "BasicTypes.h"
#include "CStreamFilter.h"
#include "CCryptoMode.h"
-#include <cryptopp562/osrng.h>
-#include <cryptopp562/sha.h>
+#include <crypto++/osrng.h>
+#include <crypto++/sha.h>
class CCryptoOptions;

View File

@ -0,0 +1,123 @@
--- synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+++ synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
@@ -14,6 +14,7 @@
#include "CArchDaemonUnix.h"
#include "XArchUnix.h"
+#include <stdlib.h>
#include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
--- synergy-1.3.1/lib/arch/CMultibyte.cpp
+++ synergy-1.3.1/lib/arch/CMultibyte.cpp
@@ -19,6 +19,7 @@
#include "CArch.h"
#include <limits.h>
#include <string.h>
+#include <stdlib.h>
#if HAVE_LOCALE_H
# include <locale.h>
#endif
--- synergy-1.3.1/lib/base/CStringUtil.cpp
+++ synergy-1.3.1/lib/base/CStringUtil.cpp
@@ -16,6 +16,7 @@
#include "CArch.h"
#include "common.h"
#include "stdvector.h"
+#include <string.h>
#include <cctype>
#include <cstdio>
#include <cstdlib>
--- synergy-1.3.1/lib/client/CClient.cpp
+++ synergy-1.3.1/lib/client/CClient.cpp
@@ -12,6 +12,8 @@
* GNU General Public License for more details.
*/
+#include <string.h>
+#include <stdlib.h>
#include "CClient.h"
#include "CServerProxy.h"
#include "CScreen.h"
--- synergy-1.3.1/lib/client/CserverProxy.cpp
+++ synergy-1.3.1/lib/client/CServerProxy.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <string.h>
#include "CServerProxy.h"
#include "CClient.h"
#include "CClipboard.h"
--- synergy-1.3.1/lib/net/CTCPSocket.cpp
+++ synergy-1.3.1/lib/net/CTCPSocket.cpp
@@ -24,6 +24,7 @@
#include "CArch.h"
#include "XArch.h"
#include <string.h>
+#include <stdlib.h>
//
// CTCPSocket
--- synergy-1.3.1/lib/platform/CXWindowsScreen.cpp
+++ synergy-1.3.1/lib/platform/CXWindowsScreen.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <stdlib.h>
#include "CXWindowsScreen.h"
#include "CXWindowsClipboard.h"
#include "CXWindowsEventQueueBuffer.h"
--- synergy-1.3.1/lib/server/CClientProxy1_3.cpp
+++ synergy-1.3.1/lib/server/CClientProxy1_3.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <string.h>
#include "CClientProxy1_3.h"
#include "CProtocolUtil.h"
#include "CLog.h"
--- synergy-1.3.1/lib/server/CServer.cpp
+++ synergy-1.3.1/lib/server/CServer.cpp
@@ -29,6 +29,7 @@
#include "TMethodEventJob.h"
#include "CArch.h"
#include <string.h>
+#include <stdlib.h>
//
// CServer
--- synergy-1.3.1/lib/synergy/CPacketStreamFilter.cpp
+++ synergy-1.3.1/lib/synergy/CPacketStreamFilter.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <string.h>
#include "CPacketStreamFilter.h"
#include "IEventQueue.h"
#include "CLock.h"
--- synergy-1.3.1/lib/synergy/IKeyState.cpp
+++ synergy-1.3.1/lib/synergy/IKeyState.cpp
@@ -14,6 +14,7 @@
#include "IKeyState.h"
#include <string.h>
+#include <stdlib.h>
//
// IKeyState
--- synergy-1.3.1/lib/synergy/IPrimaryScreen.cpp
+++ synergy-1.3.1/lib/synergy/IPrimaryScreen.cpp
@@ -12,6 +12,7 @@
* GNU General Public License for more details.
*/
+#include <stdlib.h>
#include "IPrimaryScreen.h"
//

View File

@ -0,0 +1,48 @@
--- synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
+++ synergy-1.3.1/lib/arch/CArchDaemonUnix.cpp
@@ -57,7 +57,8 @@
setsid();
// chdir to root so we don't keep mounted filesystems points busy
- chdir("/");
+ if(chdir("/") < 0)
+ perror("chdir(/)");
// mask off permissions for any but owner
umask(077);
@@ -71,7 +72,8 @@
// of standard I/O safely goes in the bit bucket.
open("/dev/null", O_RDONLY);
open("/dev/null", O_RDWR);
- dup(1);
+ if(dup(1) < 0)
+ perror("dup(1)");
// invoke function
return func(1, &name);
--- synergy-1.3.1/lib/arch/CArchNetworkBSD.cpp
+++ synergy-1.3.1/lib/arch/CArchNetworkBSD.cpp
@@ -326,7 +326,9 @@
// the unblock event was signalled. flush the pipe.
char dummy[100];
do {
- read(unblockPipe[0], dummy, sizeof(dummy));
+ if(read(unblockPipe[0], dummy, sizeof(dummy)) < 0) {
+ perror("read()");
+ }
} while (errno != EAGAIN);
// don't count this unblock pipe in return value
@@ -498,7 +500,9 @@
const int* unblockPipe = getUnblockPipeForThread(thread);
if (unblockPipe != NULL) {
char dummy = 0;
- write(unblockPipe[1], &dummy, 1);
+ if(write(unblockPipe[1], &dummy, 1) < 0) {
+ perror("write()");
+ }
}
}

69
synergy.spec Normal file
View File

@ -0,0 +1,69 @@
Name: synergy
Version: 1.4.12
Release: 1mamba
Summary: Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems
Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba
Distribution: openmamba
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
URL: http://synergy-foss.org/blog/
Source: http://synergy.googlecode.com/files/synergy-%{version}-Source.tar.gz
#Source: http://downloads.sourceforge.net/sourceforge/synergy2/synergy-%{version}.tar.gz
Patch0: synergy-noignoreretval.diff
Patch1: synergy-implicit-declaration.patch
Patch2: synergy-1.4.12-cryptopp-5.6.2.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libICE-devel
BuildRequires: libSM-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXinerama-devel
BuildRequires: libXtst-devel
## AUTOBUILDREQ-END
%description
Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems, each with its own display, without special hardware. It's intended for users with multiple computers on their desk since each system uses its own monitor(s).
Redirecting the mouse and keyboard is as simple as moving the mouse off the edge of your screen. Synergy also merges the clipboards of all the systems into one, allowing cut-and-paste between systems. Furthermore, it synchronizes screen savers so they all start and stop together and, if screen locking is enabled, only one screen requires a password to unlock them all. Learn more about how it works.
%prep
%setup -q -n %{name}-%{version}-Source
#%patch0 -p1
#%patch1 -p1
%patch2 -p1
%build
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#% makeinstall
for f in synergyc synergyd synergys; do
install -D -m0755 bin/$f %{buildroot}%{_bindir}/$f
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/synergyc
%{_bindir}/synergyd
%{_bindir}/synergys
%doc COPYING
#ChangeLog NEWS README
%changelog
* Sat Aug 31 2013 Automatic Build System <autodist@mambasoft.it> 1.4.12-1mamba
- automatic version update by autodist
* Thu Jan 31 2013 Automatic Build System <autodist@mambasoft.it> 1.4.10-1mamba
- update to 1.4.10
* Sun Mar 08 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.3.1-1mamba
- package created by autospec. Added 2 patch to permit the compilation against gcc versions above 4.3: don't use the ones on the web site of the project because are not with the correct syntax.