attempt to patch to fix synergyc crash on synergys resume from suspend [release 1.14.6.19-2mamba;Fri May 26 2023]
This commit is contained in:
parent
1c085d584e
commit
79d1369243
16
synergy-core-1.14.6.19-fix-ipv6-filtering-and-crash.patch
Normal file
16
synergy-core-1.14.6.19-fix-ipv6-filtering-and-crash.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- synergy-core-1.14.6.19/src/lib/net/NetworkAddress.cpp.orig 2023-05-26 12:03:36.888389196 +0200
|
||||||
|
+++ synergy-core-1.14.6.19/src/lib/net/NetworkAddress.cpp 2023-05-26 12:04:09.368276426 +0200
|
||||||
|
@@ -154,12 +154,7 @@
|
||||||
|
{
|
||||||
|
auto addresses = ARCH->nameToAddr(m_hostname);
|
||||||
|
for (auto address : addresses) {
|
||||||
|
- if (ARCH->getAddrFamily(address) == IArchNetwork::kINET) {
|
||||||
|
- ipv4OnlyAddresses.emplace_back(address);
|
||||||
|
- }
|
||||||
|
- else {
|
||||||
|
- ARCH->closeAddr(address);
|
||||||
|
- }
|
||||||
|
+ ipv4OnlyAddresses.emplace_back(address);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
24
synergy.spec
24
synergy.spec
@ -1,17 +1,18 @@
|
|||||||
Name: synergy
|
Name: synergy
|
||||||
Version: 1.14.6.13
|
Version: 1.14.6.19
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems
|
Summary: Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://symless.com/synergy/blog
|
URL: https://symless.com/synergy/blog
|
||||||
Source: https://github.com/symless/synergy-core.git/%{version}-snapshot/synergy-core-%{version}.tar.bz2
|
Source: https://github.com/symless/synergy-core.git/%{version}-stable/synergy-core-%{version}.tar.bz2
|
||||||
Patch0: synergy-noignoreretval.diff
|
Patch0: synergy-noignoreretval.diff
|
||||||
Patch1: synergy-implicit-declaration.patch
|
Patch1: synergy-implicit-declaration.patch
|
||||||
Patch2: synergy-1.4.12-cryptopp-5.6.2.patch
|
Patch2: synergy-1.4.12-cryptopp-5.6.2.patch
|
||||||
Patch3: synergy-1.10.1-libqt5-5.12.2.patch
|
Patch3: synergy-1.10.1-libqt5-5.12.2.patch
|
||||||
|
Patch4: synergy-core-1.14.6.19-fix-ipv6-filtering-and-crash.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -42,12 +43,15 @@ Redirecting the mouse and keyboard is as simple as moving the mouse off the edge
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n synergy-core-%{version}
|
%setup -q -n synergy-core-%{version}
|
||||||
#%patch3 -p1
|
#%patch3 -p1
|
||||||
|
%patch 4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build \
|
%cmake -d build
|
||||||
-DSYNERGY_REVISION="00000000" \
|
|
||||||
-DCMAKE_CXX_FLAGS="`pkg-config --cflags libdns_sd`" \
|
#\
|
||||||
-DCMAKE_REQUIRED_INCLUDES="%{_includedir}/avahi-compat-libdns_sd"
|
# -DSYNERGY_REVISION="00000000" \
|
||||||
|
# -DCMAKE_CXX_FLAGS="`pkg-config --cflags libdns_sd`" \
|
||||||
|
# -DCMAKE_REQUIRED_INCLUDES="%{_includedir}/avahi-compat-libdns_sd"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -70,6 +74,12 @@ Redirecting the mouse and keyboard is as simple as moving the mouse off the edge
|
|||||||
%doc LICENSE doc/synergy.conf.example
|
%doc LICENSE doc/synergy.conf.example
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 26 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.14.6.19-2mamba
|
||||||
|
- attempt to patch to fix synergyc crash on synergys resume from suspend
|
||||||
|
|
||||||
|
* Thu May 25 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.14.6.19-1mamba
|
||||||
|
- update to 1.14.6.19
|
||||||
|
|
||||||
* Mon Mar 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.14.6.13-1mamba
|
* Mon Mar 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.14.6.13-1mamba
|
||||||
- update to 1.14.6.13
|
- update to 1.14.6.13
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user