update to 1.10.1 [release 1.10.1-1mamba;Sun Mar 31 2019]
This commit is contained in:
parent
e617624ede
commit
1598bb72ee
20
synergy-1.10.1-libqt5-5.12.2.patch
Normal file
20
synergy-1.10.1-libqt5-5.12.2.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- synergy-core-1.10.1/src/gui/src/ActionDialog.cpp.orig 2019-03-31 17:26:12.157780129 +0200
|
||||||
|
+++ synergy-core-1.10.1/src/gui/src/ActionDialog.cpp 2019-03-31 17:26:22.689822574 +0200
|
||||||
|
@@ -25,6 +25,7 @@
|
||||||
|
|
||||||
|
#include <QtCore>
|
||||||
|
#include <QtGui>
|
||||||
|
+#include <QButtonGroup>
|
||||||
|
|
||||||
|
ActionDialog::ActionDialog(QWidget* parent, ServerConfig& config, Hotkey& hotkey, Action& action) :
|
||||||
|
QDialog(parent, Qt::WindowTitleHint | Qt::WindowSystemMenuHint),
|
||||||
|
--- synergy-core-1.10.1/src/gui/src/ScreenSetupView.cpp.orig 2019-03-31 17:32:38.090361871 +0200
|
||||||
|
+++ synergy-core-1.10.1/src/gui/src/ScreenSetupView.cpp 2019-03-31 17:31:32.313089148 +0200
|
||||||
|
@@ -22,6 +22,7 @@
|
||||||
|
|
||||||
|
#include <QtCore>
|
||||||
|
#include <QtGui>
|
||||||
|
+#include <QHeaderView>
|
||||||
|
|
||||||
|
ScreenSetupView::ScreenSetupView(QWidget* parent) :
|
||||||
|
QTableView(parent)
|
46
synergy.spec
46
synergy.spec
@ -1,5 +1,5 @@
|
|||||||
Name: synergy
|
Name: synergy
|
||||||
Version: 1.8.7
|
Version: 1.10.1
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems
|
Summary: Synergy lets you easily share a single mouse and keyboard between multiple computers with different operating systems
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
@ -7,13 +7,15 @@ Vendor: openmamba
|
|||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||||
URL: http://synergy-foss.org/blog/
|
URL: http://synergy-foss.org/blog/
|
||||||
Source: https://github.com/symless/synergy.git/master/synergy-%{version}.tar.bz2
|
Source: https://github.com/symless/synergy-core.git/v%{version}-stable/synergy-core-%{version}.tar.bz2
|
||||||
#Source: https://github.com/synergy/synergy.git/%{version}/synergy-%{version}.tar.bz2
|
#Source: https://github.com/synergy/synergy.git/%{version}/synergy-%{version}.tar.bz2
|
||||||
Patch0: synergy-noignoreretval.diff
|
Patch0: synergy-noignoreretval.diff
|
||||||
Patch1: synergy-implicit-declaration.patch
|
Patch1: synergy-implicit-declaration.patch
|
||||||
Patch2: synergy-1.4.12-cryptopp-5.6.2.patch
|
Patch2: synergy-1.4.12-cryptopp-5.6.2.patch
|
||||||
|
Patch3: synergy-1.10.1-libqt5-5.12.2.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: avahi-compat-libdns_sd-devel
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
@ -23,8 +25,9 @@ BuildRequires: libXi-devel
|
|||||||
BuildRequires: libXinerama-devel
|
BuildRequires: libXinerama-devel
|
||||||
BuildRequires: libXrandr-devel
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libXtst-devel
|
BuildRequires: libXtst-devel
|
||||||
BuildRequires: libcurl-devel
|
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libqt5-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -34,47 +37,36 @@ Synergy lets you easily share a single mouse and keyboard between multiple compu
|
|||||||
Redirecting the mouse and keyboard is as simple as moving the mouse off the edge of your screen. Synergy also merges the clipboards of all the systems into one, allowing cut-and-paste between systems. Furthermore, it synchronizes screen savers so they all start and stop together and, if screen locking is enabled, only one screen requires a password to unlock them all. Learn more about how it works.
|
Redirecting the mouse and keyboard is as simple as moving the mouse off the edge of your screen. Synergy also merges the clipboards of all the systems into one, allowing cut-and-paste between systems. Furthermore, it synchronizes screen savers so they all start and stop together and, if screen locking is enabled, only one screen requires a password to unlock them all. Learn more about how it works.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n synergy-core-%{version}
|
||||||
#%patch0 -p1
|
%patch3 -p1
|
||||||
#%patch1 -p1
|
|
||||||
#%patch2 -p1
|
|
||||||
cd ext
|
|
||||||
mkdir gmock-1.6.0
|
|
||||||
(cd gmock-1.6.0; unzip ../gmock-1.6.0.zip)
|
|
||||||
mkdir gtest-1.6.0
|
|
||||||
(cd gtest-1.6.0; unzip ../gtest-1.6.0.zip)
|
|
||||||
#mkdir cryptopp562
|
|
||||||
#(cd cryptopp562; unzip ../cryptopp562.zip)
|
|
||||||
#cd ..
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%cmake -d build \
|
||||||
|
-DCMAKE_CXX_FLAGS="`pkg-config --cflags libdns_sd`"
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
#% makeinstall
|
%makeinstall -C build
|
||||||
for f in synergyc synergyd synergys; do
|
|
||||||
install -D -m0755 bin/$f %{buildroot}%{_bindir}/$f
|
|
||||||
done
|
|
||||||
|
|
||||||
install -D -m0644 doc/synergyc.man %{buildroot}%{_mandir}/man1/synergyc.1
|
|
||||||
install -D -m0644 doc/synergys.man %{buildroot}%{_mandir}/man1/synergys.1
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/synergy
|
||||||
|
%{_bindir}/syntool
|
||||||
%{_bindir}/synergyc
|
%{_bindir}/synergyc
|
||||||
%{_bindir}/synergyd
|
|
||||||
%{_bindir}/synergys
|
%{_bindir}/synergys
|
||||||
%{_mandir}/man1/synergyc.1*
|
%{_datadir}/applications/synergy.desktop
|
||||||
%{_mandir}/man1/synergys.1*
|
%{_datadir}/icons/hicolor/scalable/apps/synergy.svg
|
||||||
%doc LICENSE doc/synergy.conf.example
|
%doc LICENSE doc/synergy.conf.example
|
||||||
#ChangeLog NEWS README
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 31 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-1mamba
|
||||||
|
- update to 1.10.1
|
||||||
|
|
||||||
* Thu Jan 26 2017 Automatic Build System <autodist@mambasoft.it> 1.8.7-1mamba
|
* Thu Jan 26 2017 Automatic Build System <autodist@mambasoft.it> 1.8.7-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user