legacy package [release 3.0.12-2mamba;Sun Feb 21 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 18:15:36 +01:00
parent 5f6328c887
commit 4b1a819c16
3 changed files with 157 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# swig3
SWIG is a software development tool that connects programs written in C and C++ with a variety of high-level programming languages

View File

@ -0,0 +1,10 @@
--- swig-2.0.9/Source/Modules/php.cxx.orig 2013-02-27 13:02:04.248418984 +0100
+++ swig-2.0.9/Source/Modules/php.cxx 2013-02-27 13:01:41.800681771 +0100
@@ -418,6 +418,7 @@
Append(s_header, "static void SWIG_FAIL() __attribute__ ((__noreturn__));\n");
Append(s_header, "#endif\n\n");
Append(s_header, "static void SWIG_FAIL() {\n");
+ Append(s_header, " TSRMLS_FETCH();\n");
Append(s_header, " zend_error(SWIG_ErrorCode(), \"%s\", SWIG_ErrorMsg());\n");
// zend_error() should never return with the parameters we pass, but if it
// does, we really don't want to let SWIG_FAIL() return. This also avoids

145
swig3.spec Normal file
View File

@ -0,0 +1,145 @@
Name: swig3
Version: 3.0.12
Release: 2mamba
Summary: SWIG is a software development tool that connects programs written in C and C++
Group: Applications/Development
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.swig.org/
Source: http://downloads.sourceforge.net/sourceforge/swig/swig-%{version}.tar.gz
Patch0: swig-2.0.9-php-5.4.11.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libgcc
BuildRequires: libpcre-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
%if "%{stage1}" != "1"
BuildRequires: php-devel
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
SWIG is a software development tool that connects programs written in C and C++ with a variety of high-level programming languages
%debug_package
%prep
%setup -q -n swig-%{version}
#-D -T
#%patch0 -p1
%build
#:<< _EOF
%configure
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
mv %{buildroot}%{_bindir}/swig %{buildroot}%{_bindir}/swig3
mv %{buildroot}%{_bindir}/ccache-swig %{buildroot}%{_bindir}/ccache-swig3
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_bindir}/swig3
%{_bindir}/ccache-swig3
%{_datadir}/swig/%{version}/*
%doc LICENSE
%changelog
* Sun Feb 21 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.12-2mamba
- legacy package
* Wed Mar 08 2017 Automatic Build System <autodist@mambasoft.it> 3.0.12-1mamba
- automatic version update by autodist
* Sat Jan 07 2017 Automatic Build System <autodist@mambasoft.it> 3.0.11-1mamba
- automatic version update by autodist
* Mon Jul 04 2016 Automatic Build System <autodist@mambasoft.it> 3.0.10-1mamba
- automatic version update by autodist
* Sun Jun 05 2016 Automatic Build System <autodist@mambasoft.it> 3.0.9-1mamba
- automatic version update by autodist
* Sat Jan 16 2016 Automatic Build System <autodist@mambasoft.it> 3.0.8-1mamba
- automatic version update by autodist
* Thu Aug 06 2015 Automatic Build System <autodist@mambasoft.it> 3.0.7-1mamba
- automatic version update by autodist
* Wed Jul 08 2015 Automatic Build System <autodist@mambasoft.it> 3.0.6-1mamba
- automatic update by autodist
* Sun Feb 01 2015 Automatic Build System <autodist@mambasoft.it> 3.0.5-1mamba
- automatic version update by autodist
* Thu Jan 15 2015 Automatic Build System <autodist@mambasoft.it> 3.0.4-1mamba
- automatic version update by autodist
* Wed Dec 31 2014 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
- automatic version update by autodist
* Fri Jun 06 2014 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
- automatic version update by autodist
* Wed Jun 04 2014 Automatic Build System <autodist@mambasoft.it> 3.0.1-1mamba
- automatic update by autodist
* Wed Mar 26 2014 Automatic Build System <autodist@mambasoft.it> 3.0.0-1mamba
- automatic version update by autodist
* Tue Feb 11 2014 Automatic Build System <autodist@mambasoft.it> 2.0.12-1mamba
- automatic version update by autodist
* Tue Sep 17 2013 Automatic Build System <autodist@mambasoft.it> 2.0.11-1mamba
- automatic version update by autodist
* Mon Jun 10 2013 Automatic Build System <autodist@mambasoft.it> 2.0.10-1mamba
- automatic version update by autodist
* Wed Feb 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.9-2mamba
- added patch for php 5.4.11
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 2.0.9-1mamba
- automatic version update by autodist
* Fri Aug 05 2011 Automatic Build System <autodist@mambasoft.it> 2.0.4-1mamba
- automatic version update by autodist
* Thu Feb 24 2011 Automatic Build System <autodist@mambasoft.it> 2.0.2-1mamba
- automatic update by autodist
* Mon Oct 11 2010 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
- automatic update by autodist
* Sun Jun 06 2010 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
- automatic update by autodist
* Fri Aug 28 2009 Automatic Build System <autodist@mambasoft.it> 1.3.40-1mamba
- automatic update by autodist
* Thu Jul 09 2009 Automatic Build System <autodist@mambasoft.it> 1.3.39-1mamba
- automatic update by autodist
* Sat Jul 19 2008 gil <puntogil@libero.it> 1.3.36-1mamba
- update to 1.3.36
* Sun Feb 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.33-1mamba
- update to 1.3.33
- changed maintainer
* Tue Jun 13 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.3.29-1qilnx
- update to version 1.3.29 by autospec
* Mon Jul 18 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 1.3.25-1qilnx
- package created by autospec