update to 1.2 [release 1.2-1mamba;Wed Sep 09 2020]
This commit is contained in:
parent
892203a686
commit
fbe29a01f0
@ -1,2 +1,4 @@
|
||||
# supertuxkart
|
||||
|
||||
SuperTuxKart is a Free 3D kart racing game, with many tracks, characters and items for you to try.
|
||||
|
||||
|
24
supertuxkart-0.7.3-irrlicht-1.8-2.patch
Normal file
24
supertuxkart-0.7.3-irrlicht-1.8-2.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -Nuar supertuxkart-0.7.3/src/guiengine/widgets/CGUIEditBox.cpp supertuxkart-0.7.3.work/src/guiengine/widgets/CGUIEditBox.cpp
|
||||
--- supertuxkart-0.7.3/src/guiengine/widgets/CGUIEditBox.cpp 2011-11-02 06:04:13.000000000 +0600
|
||||
+++ supertuxkart-0.7.3.work/src/guiengine/widgets/CGUIEditBox.cpp 2011-11-15 15:07:05.252312002 +0600
|
||||
@@ -115,7 +115,7 @@
|
||||
}
|
||||
|
||||
|
||||
-video::SColor const& CGUIEditBox::getOverrideColor() const
|
||||
+video::SColor CGUIEditBox::getOverrideColor() const
|
||||
{
|
||||
return OverrideColor;
|
||||
}
|
||||
diff -Nuar supertuxkart-0.7.3/src/guiengine/widgets/CGUIEditBox.h supertuxkart-0.7.3.work/src/guiengine/widgets/CGUIEditBox.h
|
||||
--- supertuxkart-0.7.3/src/guiengine/widgets/CGUIEditBox.h 2011-11-02 06:04:12.000000000 +0600
|
||||
+++ supertuxkart-0.7.3.work/src/guiengine/widgets/CGUIEditBox.h 2011-11-15 15:06:28.587310734 +0600
|
||||
@@ -36,7 +36,7 @@
|
||||
virtual void setOverrideColor(video::SColor color);
|
||||
|
||||
//! Gets the override color
|
||||
- virtual video::SColor const & getOverrideColor() const;
|
||||
+ virtual video::SColor getOverrideColor() const;
|
||||
|
||||
//! Sets if the text should use the overide color or the
|
||||
//! color in the gui skin.
|
24
supertuxkart-0.7.3-irrlicht-1.8.patch
Normal file
24
supertuxkart-0.7.3-irrlicht-1.8.patch
Normal file
@ -0,0 +1,24 @@
|
||||
Index: /main/trunk/src/graphics/material.cpp
|
||||
===================================================================
|
||||
--- main/trunk/src/graphics/material.cpp (revision 10675)
|
||||
+++ main/trunk/src/graphics/material.cpp (revision 10710)
|
||||
@@ -723,8 +723,8 @@
|
||||
m->MaterialType = video::EMT_ONETEXTURE_BLEND ;
|
||||
m->MaterialTypeParam =
|
||||
- pack_texureBlendFunc(video::EBF_SRC_ALPHA,
|
||||
- video::EBF_ONE_MINUS_SRC_ALPHA,
|
||||
- video::EMFN_MODULATE_1X,
|
||||
- video::EAS_TEXTURE | video::EAS_VERTEX_COLOR);
|
||||
+ pack_textureBlendFunc(video::EBF_SRC_ALPHA,
|
||||
+ video::EBF_ONE_MINUS_SRC_ALPHA,
|
||||
+ video::EMFN_MODULATE_1X,
|
||||
+ video::EAS_TEXTURE | video::EAS_VERTEX_COLOR);
|
||||
|
||||
modes++;
|
||||
@@ -765,5 +765,5 @@
|
||||
// more customizable EMT_ONETEXTURE_BLEND instead
|
||||
m->MaterialType = video::EMT_ONETEXTURE_BLEND ;
|
||||
- m->MaterialTypeParam = pack_texureBlendFunc(video::EBF_SRC_ALPHA,
|
||||
+ m->MaterialTypeParam = pack_textureBlendFunc(video::EBF_SRC_ALPHA,
|
||||
video::EBF_ONE,
|
||||
video::EMFN_MODULATE_1X,
|
128
supertuxkart.spec
Normal file
128
supertuxkart.spec
Normal file
@ -0,0 +1,128 @@
|
||||
Name: supertuxkart
|
||||
Version: 1.2
|
||||
Release: 1mamba
|
||||
Summary: A Free 3D kart racing game
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://supertuxkart.sourceforge.net/Main_Page
|
||||
Source: https://sourceforge.net/projects/supertuxkart/files/SuperTuxKart/%{version}/SuperTuxKart-%{version}-src.tar.xz
|
||||
Patch0: supertuxkart-0.7.3-irrlicht-1.8.patch
|
||||
Patch1: supertuxkart-0.7.3-irrlicht-1.8-2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libbluetooth-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
SuperTuxKart is a Free 3D kart racing game, with many tracks, characters and items for you to try.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n SuperTuxKart-%{version}-src
|
||||
#%patch0 -p2
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
## http://forum.freegamedev.net/viewtopic.php?f=17&t=3731
|
||||
#cd lib/irrlicht/source/Irrlicht/
|
||||
#NDEBUG=1 % make
|
||||
#cd ../../../..
|
||||
|
||||
%cmake -d build \
|
||||
-DBUILD_RECORDER=0
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
# FIXME: /usr/lib not a good place for internal .so plugin library
|
||||
#install -D -m0755 build/lib/wiiuse/libwiiuse.so %{buildroot}%{_libdir}/libwiiuse.so
|
||||
cp -a build/lib/angelscript/projects/cmake/libangelscript.so* %{buildroot}%{_libdir}/
|
||||
#install -D -m0755 build/lib/irrlicht/libstkirrlicht.so %{buildroot}%{_libdir}/libstkirrlicht.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/supertuxkart
|
||||
%dir %{_datadir}/supertuxkart
|
||||
%dir %{_datadir}/supertuxkart/data
|
||||
%{_datadir}/supertuxkart/data/*
|
||||
%{_datadir}/applications/supertuxkart.desktop
|
||||
%{_datadir}/metainfo/supertuxkart.appdata.xml
|
||||
%{_datadir}/pixmaps/supertuxkart.png
|
||||
#%{_datadir}/appdata/supertuxkart.appdata.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/supertuxkart.png
|
||||
#%{_datadir}/pixmaps/supertuxkart_128.png
|
||||
#%{_datadir}/pixmaps/supertuxkart_32.png
|
||||
%{_libdir}/libangelscript.so*
|
||||
%{_includedir}/wiiuse.h
|
||||
%{_libdir}/libwiiuse.a
|
||||
#%{_libdir}/libwiiuse.so
|
||||
#%{_libdir}/libstkirrlicht.so
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Wed Sep 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2-1mamba
|
||||
- update to 1.2
|
||||
|
||||
* Tue Mar 31 2020 Automatic Build System <autodist@mambasoft.it> 1.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jul 09 2016 Automatic Build System <autodist@mambasoft.it> 0.9.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Oct 21 2015 Automatic Build System <autodist@mambasoft.it> 0.9.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Apr 30 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9-1mamba
|
||||
- update to 0.9
|
||||
|
||||
* Wed Nov 27 2013 Automatic Build System <autodist@mambasoft.it> 0.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jun 05 2013 Automatic Build System <autodist@mambasoft.it> 0.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.3-1mamba
|
||||
- update to 0.7.3
|
||||
|
||||
* Sun Jul 24 2011 Automatic Build System <autodist@mambasoft.it> 0.7.2-1mamba
|
||||
- update to 0.7.2
|
||||
|
||||
* Fri Apr 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1a-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Tue Mar 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.1a-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Aug 08 2008 Marco Bellezza <superbel@hotmail.it> 0.5-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user