132 lines
4.1 KiB
RPMSpec
132 lines
4.1 KiB
RPMSpec
%define sourcever %(echo %version|sed "s|[a-z]||")
|
|
Name: supertux
|
|
Version: 0.6.3
|
|
Release: 1mamba
|
|
Summary: A classic 2D jump'n run sidescroller game
|
|
Group: Graphical Desktop/Applications/Games
|
|
Distribution: openmamba
|
|
Vendor: openmamba
|
|
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
|
URL: http://supertux.lethargik.org/
|
|
Source: https://github.com/SuperTux/supertux/releases/download/v%{version}/SuperTux-v%{version}-Source.tar.gz
|
|
Patch0: %{name}-0.3.1-gcc43.patch
|
|
Patch1: supertux-0.3.3-gcc-4.6.patch
|
|
Patch2: supertux-0.3.3-gcc-4.7.patch
|
|
Patch3: supertux-0.3.3-curl-7.30.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libGLU-devel
|
|
BuildRequires: libSDL2-devel
|
|
BuildRequires: libboost-devel
|
|
BuildRequires: libcurl-devel
|
|
BuildRequires: libfreetype-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglew-devel
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libogg-devel
|
|
BuildRequires: libopenal-devel
|
|
BuildRequires: libphysfs-devel
|
|
BuildRequires: libpng-devel
|
|
BuildRequires: libsdl2_image-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libvorbis-devel
|
|
BuildRequires: libz-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ftjam
|
|
#Requires: libSDL
|
|
#Requires: libSDL_image
|
|
#Requires: libSDL_mixer
|
|
|
|
%description
|
|
SuperTux is a jumping run like game, with strong inspiration from the Super Mario Bros games for Nintendo.
|
|
Run and jump through multiple worlds, fighting off enemies by jumping on them or bumping them from below. Grabbing power-ups and other stuff on the way.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n SuperTux-v%{sourcever}-Source
|
|
#%patch0 -p1
|
|
#%patch1 -p1
|
|
#%patch2 -p1
|
|
#%patch3 -p1
|
|
|
|
#cp docs/SuperTux.appdata.xml supertux2.appdata.xml
|
|
|
|
%build
|
|
# Fix the level names to work around an installer bug
|
|
#cd data/levels/world1/
|
|
#sed -i -e "s/ - .*\.stl/.stl/" worldmap.stwm
|
|
#for f in *" "-" "*.stl; do mv "$f" "${f/ - *.stl/.stl}"; done
|
|
#cd ../../..
|
|
|
|
%cmake -d build \
|
|
-DINSTALL_SUBDIR_BIN=bin
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
#install -D -m0755 ./build/external/squirrel/libsquirrel.so %{buildroot}%{_libdir}/libsquirrel.so
|
|
|
|
%clean
|
|
test "%{buildroot}" != "" && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/%{name}2
|
|
#%{_libdir}/libsquirrel.so
|
|
%dir %{_datadir}/games/%{name}2
|
|
%{_datadir}/games/%{name}2/*
|
|
%{_datadir}/applications/%{name}2.desktop
|
|
%{_datadir}/icons/hicolor/scalable/apps/supertux2.svg
|
|
%{_datadir}/metainfo/supertux2.appdata.xml
|
|
#%{_datadir}/appdata/supertux2.appdata.xml
|
|
%{_datadir}/pixmaps/%{name}.*
|
|
%dir %{_datadir}/doc/%{name}2
|
|
%{_datadir}/doc/%{name}2/*
|
|
#%doc COPYING
|
|
|
|
%changelog
|
|
* Fri Dec 24 2021 Automatic Build System <autodist@mambasoft.it> 0.6.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-2mamba
|
|
- rebuilt with debug package
|
|
|
|
* Fri May 15 2020 Automatic Build System <autodist@mambasoft.it> 0.6.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 31 2020 Automatic Build System <autodist@mambasoft.it> 0.6.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 18 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0-1mamba
|
|
- update to 0.6.0
|
|
|
|
* Mon Apr 13 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.5-1mamba
|
|
- update to 0.3.5
|
|
|
|
* Mon Aug 05 2013 Automatic Build System <autodist@mambasoft.it> 0.3.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 27 2013 Automatic Build System <autodist@mambasoft.it> 0.3.3-1mamba
|
|
- automatic version update by autodist
|
|
- added patch to fix gcc issue
|
|
|
|
* Tue Apr 21 2009 Automatic Build System <autodist@mambasoft.it> 0.3.1d-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Mon May 05 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.3.0-2mamba
|
|
- add autobuildreq, indent requirements
|
|
|
|
* Mon May 05 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.3.0-1mamba
|
|
- update to 0.3.0
|
|
|
|
* Tue Apr 05 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.1.2-2qilnx
|
|
- rebuild and moved from devel-contrib repository to devel repository
|
|
|
|
* Sat Sep 25 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.1.2-1
|
|
- first build
|