rebuilt with debug package [release 0.6.2-2mamba;Thu May 21 2020]
This commit is contained in:
parent
a0f550e666
commit
872bac1fbe
@ -1,2 +1,5 @@
|
||||
# supertux
|
||||
|
||||
SuperTux is a jumping run like game, with strong inspiration from the Super Mario Bros games for Nintendo.
|
||||
Run and jump through multiple worlds, fighting off enemies by jumping on them or bumping them from below. Grabbing power-ups and other stuff on the way.
|
||||
|
||||
|
78
supertux-0.3.1-gcc43.patch
Normal file
78
supertux-0.3.1-gcc43.patch
Normal file
@ -0,0 +1,78 @@
|
||||
diff -up supertux-0.3.1/src/addon_manager.cpp~ supertux-0.3.1/src/addon_manager.cpp
|
||||
--- supertux-0.3.1/src/addon_manager.cpp~ 2008-07-10 10:58:11.000000000 +0200
|
||||
+++ supertux-0.3.1/src/addon_manager.cpp 2008-07-10 10:58:11.000000000 +0200
|
||||
@@ -25,6 +25,7 @@
|
||||
#include <physfs.h>
|
||||
#include <sys/stat.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include "addon_manager.hpp"
|
||||
#include "config.h"
|
||||
#include "log.hpp"
|
||||
diff -up supertux-0.3.1/src/console.hpp~ supertux-0.3.1/src/console.hpp
|
||||
--- supertux-0.3.1/src/console.hpp~ 2008-07-10 10:48:45.000000000 +0200
|
||||
+++ supertux-0.3.1/src/console.hpp 2008-07-10 10:57:01.000000000 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <string>
|
||||
#include <sstream>
|
||||
#include <iostream>
|
||||
+#include <memory>
|
||||
#include <squirrel.h>
|
||||
|
||||
class Console;
|
||||
diff -up supertux-0.3.1/src/lisp/lexer.cpp~ supertux-0.3.1/src/lisp/lexer.cpp
|
||||
--- supertux-0.3.1/src/lisp/lexer.cpp~ 2008-07-10 11:00:49.000000000 +0200
|
||||
+++ supertux-0.3.1/src/lisp/lexer.cpp 2008-07-10 11:00:49.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <sstream>
|
||||
#include <stdexcept>
|
||||
#include <iostream>
|
||||
+#include <string.h>
|
||||
|
||||
#include "lexer.hpp"
|
||||
|
||||
diff -up supertux-0.3.1/src/resources.cpp~ supertux-0.3.1/src/resources.cpp
|
||||
diff -up supertux-0.3.1/src/sprite/sprite_manager.hpp~ supertux-0.3.1/src/sprite/sprite_manager.hpp
|
||||
--- supertux-0.3.1/src/sprite/sprite_manager.hpp~ 2008-07-10 10:58:59.000000000 +0200
|
||||
+++ supertux-0.3.1/src/sprite/sprite_manager.hpp 2008-07-10 10:58:59.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
#define SUPERTUX_SPRITE_MANAGER_H
|
||||
|
||||
#include <map>
|
||||
+#include <string>
|
||||
|
||||
class SpriteData;
|
||||
class Sprite;
|
||||
diff -up supertux-0.3.1/src/textscroller.hpp~ supertux-0.3.1/src/textscroller.hpp
|
||||
--- supertux-0.3.1/src/textscroller.hpp~ 2008-07-10 10:50:27.000000000 +0200
|
||||
+++ supertux-0.3.1/src/textscroller.hpp 2008-07-10 10:57:18.000000000 +0200
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <vector>
|
||||
#include <string>
|
||||
#include <map>
|
||||
+#include <memory>
|
||||
|
||||
#include "screen.hpp"
|
||||
#include "math/vector.hpp"
|
||||
diff -up supertux-0.3.1/src/title.cpp~ supertux-0.3.1/src/title.cpp
|
||||
--- supertux-0.3.1/src/title.cpp~ 2008-07-10 10:57:50.000000000 +0200
|
||||
+++ supertux-0.3.1/src/title.cpp 2008-07-10 10:57:50.000000000 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <iostream>
|
||||
#include <sstream>
|
||||
#include <stdexcept>
|
||||
+#include <algorithm>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
diff -up supertux-0.3.1/src/video/sdl_texture.hpp~ supertux-0.3.1/src/video/sdl_texture.hpp
|
||||
--- supertux-0.3.1/src/video/sdl_texture.hpp~ 2008-07-10 11:01:13.000000000 +0200
|
||||
+++ supertux-0.3.1/src/video/sdl_texture.hpp 2008-07-10 11:01:13.000000000 +0200
|
||||
@@ -22,6 +22,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <algorithm>
|
||||
#include <SDL.h>
|
||||
|
||||
#include "texture.hpp"
|
12
supertux-0.3.3-curl-7.30.patch
Normal file
12
supertux-0.3.3-curl-7.30.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr supertux-0.3.3_orig/src/addon/addon_manager.cpp supertux-0.3.3/src/addon/addon_manager.cpp
|
||||
--- supertux-0.3.3_orig/src/addon/addon_manager.cpp 2010-03-01 18:40:58.000000000 +0600
|
||||
+++ supertux-0.3.3/src/addon/addon_manager.cpp 2011-09-15 10:57:13.485913271 +0700
|
||||
@@ -29,7 +29,6 @@
|
||||
#ifdef HAVE_LIBCURL
|
||||
# include <curl/curl.h>
|
||||
# include <curl/easy.h>
|
||||
-# include <curl/types.h>
|
||||
#endif
|
||||
|
||||
#include "addon/addon.hpp"
|
||||
|
13
supertux-0.3.3-gcc-4.6.patch
Normal file
13
supertux-0.3.3-gcc-4.6.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Description: Add missing header. Fixes FTBFS with gcc 4.6.
|
||||
Author: Ilya Barygin <barygin@gmail.com>
|
||||
Bug-Ubuntu: https://launchpad.net/bugs/832874
|
||||
--- supertux-0.3.3.orig/src/supertux/screen_manager.hpp
|
||||
+++ supertux-0.3.3/src/supertux/screen_manager.hpp
|
||||
@@ -18,6 +18,7 @@
|
||||
#define HEADER_SUPERTUX_SUPERTUX_MAINLOOP_HPP
|
||||
|
||||
#include <memory>
|
||||
+#include <cstring>
|
||||
|
||||
#include "scripting/thread_queue.hpp"
|
||||
|
36
supertux-0.3.3-gcc-4.7.patch
Normal file
36
supertux-0.3.3-gcc-4.7.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -Naur supertux2-0.3.3.orig/external/squirrel/squirrel/sqmem.h supertux2-0.3.3/external/squirrel/squirrel/sqmem.h
|
||||
--- supertux2-0.3.3.orig/external/squirrel/squirrel/sqmem.h 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ supertux2-0.3.3/external/squirrel/squirrel/sqmem.h 2012-05-01 11:59:37.000000000 +0200
|
||||
@@ -0,0 +1,8 @@
|
||||
+/* see copyright notice in squirrel.h */
|
||||
+#ifndef _SQMEM_H_
|
||||
+#define _SQMEM_H_
|
||||
+
|
||||
+void *sq_vm_malloc(SQUnsignedInteger size);
|
||||
+void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
|
||||
+void sq_vm_free(void *p,SQUnsignedInteger size);
|
||||
+#endif //_SQMEM_H_
|
||||
diff -Naur supertux2-0.3.3.orig/external/squirrel/squirrel/sqstate.h supertux2-0.3.3/external/squirrel/squirrel/sqstate.h
|
||||
--- supertux2-0.3.3.orig/external/squirrel/squirrel/sqstate.h 2010-03-01 13:40:58.000000000 +0100
|
||||
+++ supertux2-0.3.3/external/squirrel/squirrel/sqstate.h 2012-05-01 11:59:37.000000000 +0200
|
||||
@@ -136,8 +136,4 @@
|
||||
extern SQObjectPtr _minusone_;
|
||||
|
||||
bool CompileTypemask(SQIntVec &res,const SQChar *typemask);
|
||||
-
|
||||
-void *sq_vm_malloc(SQUnsignedInteger size);
|
||||
-void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
|
||||
-void sq_vm_free(void *p,SQUnsignedInteger size);
|
||||
#endif //_SQSTATE_H_
|
||||
diff -Naur supertux2-0.3.3.orig/external/squirrel/squirrel/squtils.h supertux2-0.3.3/external/squirrel/squirrel/squtils.h
|
||||
--- supertux2-0.3.3.orig/external/squirrel/squirrel/squtils.h 2010-03-01 13:40:58.000000000 +0100
|
||||
+++ supertux2-0.3.3/external/squirrel/squirrel/squtils.h 2012-05-01 11:59:37.000000000 +0200
|
||||
@@ -2,6 +2,8 @@
|
||||
#ifndef _SQUTILS_H_
|
||||
#define _SQUTILS_H_
|
||||
|
||||
+#include "sqmem.h"
|
||||
+
|
||||
#define sq_new(__ptr,__type) {__ptr=(__type *)sq_vm_malloc(sizeof(__type));new (__ptr) __type;}
|
||||
#define sq_delete(__ptr,__type) {__ptr->~__type();sq_vm_free(__ptr,sizeof(__type));}
|
||||
#define SQ_MALLOC(__size) sq_vm_malloc((__size));
|
130
supertux.spec
Normal file
130
supertux.spec
Normal file
@ -0,0 +1,130 @@
|
||||
%define sourcever %(echo %version|sed "s|[a-z]||")
|
||||
Name: supertux
|
||||
Version: 0.6.2
|
||||
Release: 2mamba
|
||||
Summary: A classic 2D jump'n run sidescroller game
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Distribution: openmamba
|
||||
Vendor: openmamba
|
||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
||||
URL: http://super-tux.sourceforge.net/
|
||||
Source: https://github.com/SuperTux/supertux/releases/download/v%{version}/SuperTux-v%{version}-Source.tar.gz
|
||||
Patch0: %{name}-0.3.1-gcc43.patch
|
||||
Patch1: supertux-0.3.3-gcc-4.6.patch
|
||||
Patch2: supertux-0.3.3-gcc-4.7.patch
|
||||
Patch3: supertux-0.3.3-curl-7.30.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglew-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libphysfs-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libsdl2_image-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: ftjam
|
||||
#Requires: libSDL
|
||||
#Requires: libSDL_image
|
||||
#Requires: libSDL_mixer
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
SuperTux is a jumping run like game, with strong inspiration from the Super Mario Bros games for Nintendo.
|
||||
Run and jump through multiple worlds, fighting off enemies by jumping on them or bumping them from below. Grabbing power-ups and other stuff on the way.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n SuperTux-v%{sourcever}-Source
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1
|
||||
|
||||
#cp docs/SuperTux.appdata.xml supertux2.appdata.xml
|
||||
|
||||
%build
|
||||
# Fix the level names to work around an installer bug
|
||||
#cd data/levels/world1/
|
||||
#sed -i -e "s/ - .*\.stl/.stl/" worldmap.stwm
|
||||
#for f in *" "-" "*.stl; do mv "$f" "${f/ - *.stl/.stl}"; done
|
||||
#cd ../../..
|
||||
|
||||
%cmake -d build \
|
||||
-DINSTALL_SUBDIR_BIN=bin
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
#install -D -m0755 ./build/external/squirrel/libsquirrel.so %{buildroot}%{_libdir}/libsquirrel.so
|
||||
|
||||
%clean
|
||||
test "%{buildroot}" != "" && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/%{name}2
|
||||
#%{_libdir}/libsquirrel.so
|
||||
%dir %{_datadir}/games/%{name}2
|
||||
%{_datadir}/games/%{name}2/*
|
||||
%{_datadir}/applications/%{name}2.desktop
|
||||
%{_datadir}/icons/hicolor/scalable/apps/supertux2.svg
|
||||
%{_datadir}/metainfo/supertux2.appdata.xml
|
||||
#%{_datadir}/appdata/supertux2.appdata.xml
|
||||
%{_datadir}/pixmaps/%{name}.*
|
||||
%dir %{_datadir}/doc/%{name}2
|
||||
%{_datadir}/doc/%{name}2/*
|
||||
#%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.2-2mamba
|
||||
- rebuilt with debug package
|
||||
|
||||
* Fri May 15 2020 Automatic Build System <autodist@mambasoft.it> 0.6.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 31 2020 Automatic Build System <autodist@mambasoft.it> 0.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Aug 18 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0-1mamba
|
||||
- update to 0.6.0
|
||||
|
||||
* Mon Apr 13 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.5-1mamba
|
||||
- update to 0.3.5
|
||||
|
||||
* Mon Aug 05 2013 Automatic Build System <autodist@mambasoft.it> 0.3.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon May 27 2013 Automatic Build System <autodist@mambasoft.it> 0.3.3-1mamba
|
||||
- automatic version update by autodist
|
||||
- added patch to fix gcc issue
|
||||
|
||||
* Tue Apr 21 2009 Automatic Build System <autodist@mambasoft.it> 0.3.1d-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon May 05 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.3.0-2mamba
|
||||
- add autobuildreq, indent requirements
|
||||
|
||||
* Mon May 05 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.3.0-1mamba
|
||||
- update to 0.3.0
|
||||
|
||||
* Tue Apr 05 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.1.2-2qilnx
|
||||
- rebuild and moved from devel-contrib repository to devel repository
|
||||
|
||||
* Sat Sep 25 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.1.2-1
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user