automatic version update by autodist [release 1.14.3-1mamba;Wed Jan 03 2024]
This commit is contained in:
parent
7bb1604c9c
commit
4aa313101b
@ -1,30 +0,0 @@
|
||||
--- subversion-1.6.0/build/ac-macros/apr.m4.deplibs
|
||||
+++ subversion-1.6.0/build/ac-macros/apr.m4
|
||||
@@ -76,9 +76,9 @@ AC_DEFUN(SVN_LIB_APR,
|
||||
|
||||
dnl When APR stores the dependent libs in the .la file, we don't need
|
||||
dnl --libs.
|
||||
- SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
|
||||
+ SVN_APR_LIBS="`$apr_config --link-libtool`"
|
||||
if test $? -ne 0; then
|
||||
- AC_MSG_ERROR([apr-config --link-libtool --libs failed])
|
||||
+ AC_MSG_ERROR([apr-config --link-libtool failed])
|
||||
fi
|
||||
|
||||
SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"
|
||||
--- subversion-1.6.0/build/ac-macros/aprutil.m4.deplibs
|
||||
+++ subversion-1.6.0/build/ac-macros/aprutil.m4
|
||||
@@ -77,11 +77,9 @@ AC_DEFUN(SVN_LIB_APRUTIL,
|
||||
AC_MSG_ERROR([apu-config --prefix failed])
|
||||
fi
|
||||
|
||||
- dnl When APR stores the dependent libs in the .la file, we don't need
|
||||
- dnl --libs.
|
||||
- SVN_APRUTIL_LIBS="`$apu_config --link-libtool --libs`"
|
||||
+ SVN_APRUTIL_LIBS="`$apu_config --link-libtool`"
|
||||
if test $? -ne 0; then
|
||||
- AC_MSG_ERROR([apu-config --link-libtool --libs failed])
|
||||
+ AC_MSG_ERROR([apu-config --link-libtool failed])
|
||||
fi
|
||||
|
||||
SVN_APRUTIL_EXPORT_LIBS="`$apu_config --link-ld --libs`"
|
@ -1,11 +0,0 @@
|
||||
--- subversion-1.6.0/build/ac-macros/java.m4 2007-10-10 20:36:09.000000000 +0200
|
||||
+++ subversion-1.6.0/build/ac-macros/java.m4-gil 2009-04-09 10:09:19.000000000 +0200
|
||||
@@ -83,7 +83,7 @@
|
||||
if test "$os_arch" = "Darwin"; then
|
||||
AC_MSG_WARN([You may need to install the latest Java Development package from http://connect.apple.com/. Apple no longer includes the JNI header files by default on Java updates.])
|
||||
fi
|
||||
- JDK_SUITABLE=no
|
||||
+ JDK_SUITABLE=yes
|
||||
fi
|
||||
AC_MSG_RESULT([$JDK_SUITABLE])
|
||||
|
@ -1,62 +0,0 @@
|
||||
--- subversion-1.6.0/build.conf.pie
|
||||
+++ subversion-1.6.0/build.conf
|
||||
@@ -472,7 +472,7 @@ type = swig_lib
|
||||
lang = python
|
||||
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
|
||||
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
|
||||
install = swig-py-lib
|
||||
# need special build rule to include -DSWIGPYTHON
|
||||
compile-cmd = $(COMPILE_SWIG_PY)
|
||||
@@ -495,7 +495,7 @@ type = swig_lib
|
||||
lang = ruby
|
||||
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
|
||||
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
|
||||
install = swig-rb-lib
|
||||
# need special build rule to include
|
||||
compile-cmd = $(COMPILE_SWIG_RB)
|
||||
--- subversion-1.6.0/build/generator/gen_base.py.pie
|
||||
+++ subversion-1.6.0/build/generator/gen_base.py
|
||||
@@ -413,6 +413,9 @@ class TargetExe(TargetLinked):
|
||||
self.manpages = options.get('manpages', '')
|
||||
self.testing = options.get('testing')
|
||||
|
||||
+ if self.install == 'test' or self.install == 'bdb-test':
|
||||
+ self.link_cmd = '$(LINK_TEST)'
|
||||
+
|
||||
def add_dependencies(self):
|
||||
TargetLinked.add_dependencies(self)
|
||||
|
||||
@@ -455,8 +458,11 @@ class TargetLib(TargetLinked):
|
||||
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
|
||||
self.msvc_export = options.get('msvc-export', '').split()
|
||||
|
||||
- ### hmm. this is Makefile-specific
|
||||
- self.link_cmd = '$(LINK_LIB)'
|
||||
+ ### more Makefile-specific stuff:
|
||||
+ if self.install == 'test':
|
||||
+ self.link_cmd = '$(LINK_TEST_LIB)'
|
||||
+ elif self.link_cmd == '$(LINK)':
|
||||
+ self.link_cmd = '$(LINK_LIB)'
|
||||
|
||||
class TargetApacheMod(TargetLib):
|
||||
|
||||
--- subversion-1.6.0/Makefile.in.pie
|
||||
+++ subversion-1.6.0/Makefile.in
|
||||
@@ -184,8 +185,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
|
||||
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
|
||||
COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
||||
|
||||
-LINK_LIB = $(LINK) -rpath $(libdir)
|
||||
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||
+LINK = $(BASE_LINK) -pie
|
||||
+LINK_TEST = $(BASE_LINK) -no-install
|
||||
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
|
||||
+LINK_TEST_LIB = $(BASE_LINK)
|
||||
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
|
||||
# special link rule for mod_dav_svn
|
@ -1,53 +0,0 @@
|
||||
Libraries should be linked with -rpath $libdir but programs should not.
|
||||
Doing so for the latter means that a redundant RPATH entry of $libdir
|
||||
will end up in the binaries.
|
||||
|
||||
The redundant RPATH can also cause obscure build failures by causing
|
||||
in-build binaries to pick up libraries from the system environment,
|
||||
which libtool will otherwise avoid.
|
||||
|
||||
--- subversion-1.6.1/build.conf.rpath
|
||||
+++ subversion-1.6.1/build.conf
|
||||
@@ -472,7 +472,7 @@ type = swig_lib
|
||||
lang = python
|
||||
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
|
||||
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
|
||||
install = swig-py-lib
|
||||
# need special build rule to include -DSWIGPYTHON
|
||||
compile-cmd = $(COMPILE_SWIG_PY)
|
||||
@@ -495,7 +495,7 @@ type = swig_lib
|
||||
lang = ruby
|
||||
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
|
||||
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
|
||||
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
|
||||
install = swig-rb-lib
|
||||
# need special build rule to include
|
||||
compile-cmd = $(COMPILE_SWIG_RB)
|
||||
--- subversion-1.6.1/build/generator/gen_base.py.rpath
|
||||
+++ subversion-1.6.1/build/generator/gen_base.py
|
||||
@@ -455,6 +455,10 @@ class TargetLib(TargetLinked):
|
||||
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
|
||||
self.msvc_export = options.get('msvc-export', '').split()
|
||||
|
||||
+ ### hmm. this is Makefile-specific
|
||||
+ if self.link_cmd == '$(LINK)':
|
||||
+ self.link_cmd = '$(LINK_LIB)'
|
||||
+
|
||||
class TargetApacheMod(TargetLib):
|
||||
|
||||
def __init__(self, name, options, gen_obj):
|
||||
--- subversion-1.6.1/Makefile.in.rpath
|
||||
+++ subversion-1.6.1/Makefile.in
|
||||
@@ -184,7 +184,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
|
||||
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
|
||||
COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
||||
|
||||
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
+LINK_LIB = $(LINK) -rpath $(libdir)
|
||||
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||
|
||||
# special link rule for mod_dav_svn
|
@ -1,273 +0,0 @@
|
||||
diff -up svn2cl-0.11/svn2cl.xsl~ svn2cl-0.11/svn2cl.xsl
|
||||
--- svn2cl-0.11/svn2cl.xsl~ 2008-12-21 17:41:20.000000000 +0200
|
||||
+++ svn2cl-0.11/svn2cl.xsl 2009-11-02 22:29:34.000000000 +0200
|
||||
@@ -55,12 +55,6 @@
|
||||
|
||||
-->
|
||||
|
||||
-<!DOCTYPE xsl:stylesheet [
|
||||
- <!ENTITY tab "	">
|
||||
- <!ENTITY newl "&#xA;">
|
||||
- <!ENTITY space " ">
|
||||
-]>
|
||||
-
|
||||
<xsl:stylesheet
|
||||
version="1.0"
|
||||
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
|
||||
@@ -119,7 +113,7 @@
|
||||
</xsl:otherwise>
|
||||
</xsl:choose>
|
||||
<!-- add newlines at the end of the changelog -->
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:template>
|
||||
|
||||
<!-- format one entry from the log -->
|
||||
@@ -149,33 +143,33 @@
|
||||
<xsl:if test="($prevdate!=$date) or ($prevauthor!=$author)">
|
||||
<!-- add newline -->
|
||||
<xsl:if test="not(position()=1)">
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:if>
|
||||
<!-- date -->
|
||||
<xsl:value-of select="$date" />
|
||||
<!-- two spaces -->
|
||||
- <xsl:text>&space;&space;</xsl:text>
|
||||
+ <xsl:text>  </xsl:text>
|
||||
<!-- author's name -->
|
||||
<xsl:apply-templates select="author" />
|
||||
<!-- two newlines -->
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
- <xsl:if test="$separate-daylogs!='yes'"><xsl:text>&newl;</xsl:text></xsl:if>
|
||||
+ <xsl:text> </xsl:text>
|
||||
+ <xsl:if test="$separate-daylogs!='yes'"><xsl:text> </xsl:text></xsl:if>
|
||||
</xsl:if>
|
||||
</xsl:when>
|
||||
<!-- write the log header -->
|
||||
<xsl:otherwise>
|
||||
<!-- add newline -->
|
||||
<xsl:if test="not(position()=1)">
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:if>
|
||||
<!-- date -->
|
||||
<xsl:apply-templates select="date" />
|
||||
<!-- two spaces -->
|
||||
- <xsl:text>&space;&space;</xsl:text>
|
||||
+ <xsl:text>  </xsl:text>
|
||||
<!-- author's name -->
|
||||
<xsl:apply-templates select="author" />
|
||||
<!-- two newlines -->
|
||||
- <xsl:text>&newl;&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:otherwise>
|
||||
</xsl:choose>
|
||||
<!-- get paths string -->
|
||||
@@ -187,7 +181,7 @@
|
||||
<xsl:if test="$include-rev='yes'">
|
||||
<xsl:text>[r</xsl:text>
|
||||
<xsl:value-of select="@revision" />
|
||||
- <xsl:text>]&space;</xsl:text>
|
||||
+ <xsl:text>] </xsl:text>
|
||||
</xsl:if>
|
||||
</xsl:variable>
|
||||
<!-- trim trailing newlines -->
|
||||
@@ -195,7 +189,7 @@
|
||||
<!-- add a line break before the log message -->
|
||||
<xsl:choose>
|
||||
<xsl:when test="$breakbeforemsg='yes'">
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:when>
|
||||
<xsl:when test="number($breakbeforemsg)>0">
|
||||
<xsl:call-template name="newlines">
|
||||
@@ -208,14 +202,14 @@
|
||||
</xsl:call-template>
|
||||
</xsl:variable>
|
||||
<!-- add newline here if separate-daylogs is in effect -->
|
||||
- <xsl:if test="$groupbyday='yes' and $separate-daylogs='yes'"><xsl:text>&newl;</xsl:text></xsl:if>
|
||||
+ <xsl:if test="$groupbyday='yes' and $separate-daylogs='yes'"><xsl:text> </xsl:text></xsl:if>
|
||||
<!-- first line is indented (other indents are done in wrap template) -->
|
||||
- <xsl:text>&tab;*&space;</xsl:text>
|
||||
+ <xsl:text>	* </xsl:text>
|
||||
<!-- set up the text to wrap -->
|
||||
<xsl:variable name="txt">
|
||||
<xsl:value-of select="$rev" />
|
||||
<xsl:if test="$paths!=''">
|
||||
- <xsl:value-of select="concat($paths,':&space;')" />
|
||||
+ <xsl:value-of select="concat($paths,': ')" />
|
||||
</xsl:if>
|
||||
<xsl:value-of select="$msg" />
|
||||
</xsl:variable>
|
||||
@@ -232,7 +226,7 @@
|
||||
<xsl:value-of select="substring($date,1,10)" />
|
||||
<!-- output time part -->
|
||||
<xsl:if test="$groupbyday!='yes'">
|
||||
- <xsl:text>&space;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<xsl:value-of select="substring($date,12,5)" />
|
||||
</xsl:if>
|
||||
</xsl:template>
|
||||
@@ -306,7 +300,7 @@
|
||||
<xsl:sort select="normalize-space(.)" data-type="text" />
|
||||
<!-- unless we are the first entry, add a comma -->
|
||||
<xsl:if test="not(position()=1)">
|
||||
- <xsl:text>,&space;</xsl:text>
|
||||
+ <xsl:text>, </xsl:text>
|
||||
</xsl:if>
|
||||
<!-- print the path name -->
|
||||
<xsl:call-template name="printpath">
|
||||
@@ -324,7 +318,7 @@
|
||||
<xsl:sort select="normalize-space(.)" data-type="text" />
|
||||
<!-- unless we are the first entry, add a comma -->
|
||||
<xsl:if test="not(position()=1)">
|
||||
- <xsl:text>,&space;</xsl:text>
|
||||
+ <xsl:text>, </xsl:text>
|
||||
</xsl:if>
|
||||
<!-- print the path name -->
|
||||
<xsl:value-of select="normalize-space(.)" />
|
||||
@@ -382,23 +376,23 @@
|
||||
<xsl:param name="txt" />
|
||||
<xsl:variable name="normtxt" select="normalize-space($txt)" />
|
||||
<xsl:choose>
|
||||
- <xsl:when test="contains($txt,'&newl;')">
|
||||
+ <xsl:when test="contains($txt,' ')">
|
||||
<!-- text contains newlines, do the first line -->
|
||||
<xsl:call-template name="wrap">
|
||||
- <xsl:with-param name="txt" select="substring-before($txt,'&newl;')" />
|
||||
+ <xsl:with-param name="txt" select="substring-before($txt,' ')" />
|
||||
</xsl:call-template>
|
||||
<!-- print tab -->
|
||||
- <xsl:text>&tab;&space;&space;</xsl:text>
|
||||
+ <xsl:text>	  </xsl:text>
|
||||
<!-- wrap the rest of the text -->
|
||||
<xsl:call-template name="wrap">
|
||||
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;')" />
|
||||
+ <xsl:with-param name="txt" select="substring-after($txt,' ')" />
|
||||
</xsl:call-template>
|
||||
</xsl:when>
|
||||
<xsl:when test="(string-length($normtxt) < (($linelen)-9)) or not(contains($normtxt,' '))">
|
||||
<!-- this is easy, nothing to do -->
|
||||
<xsl:value-of select="$normtxt" />
|
||||
<!-- add newline -->
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
</xsl:when>
|
||||
<xsl:otherwise>
|
||||
<!-- find the first line -->
|
||||
@@ -420,7 +414,7 @@
|
||||
<!-- print line -->
|
||||
<xsl:value-of select="$line" />
|
||||
<!-- print newline and tab -->
|
||||
- <xsl:text>&newl;&tab;&space;&space;</xsl:text>
|
||||
+ <xsl:text> 	  </xsl:text>
|
||||
<!-- wrap the rest of the text -->
|
||||
<xsl:call-template name="wrap">
|
||||
<xsl:with-param name="txt" select="normalize-space(substring($normtxt,string-length($line)+1))" />
|
||||
@@ -449,26 +443,26 @@
|
||||
<xsl:param name="txt" />
|
||||
<xsl:choose>
|
||||
<!-- find starting newlines -->
|
||||
- <xsl:when test="substring($txt,1,1) = '&newl;'">
|
||||
+ <xsl:when test="substring($txt,1,1) = ' '">
|
||||
<xsl:call-template name="trim-newln">
|
||||
<xsl:with-param name="txt" select="substring($txt,2)" />
|
||||
</xsl:call-template>
|
||||
</xsl:when>
|
||||
<!-- find trailing newlines -->
|
||||
- <xsl:when test="substring($txt,string-length($txt),1) = '&newl;'">
|
||||
+ <xsl:when test="substring($txt,string-length($txt),1) = ' '">
|
||||
<xsl:call-template name="trim-newln">
|
||||
<xsl:with-param name="txt" select="substring($txt,1,string-length($txt)-1)" />
|
||||
</xsl:call-template>
|
||||
</xsl:when>
|
||||
<!-- if the message has paragrapgs, find the first one -->
|
||||
- <xsl:when test="$reparagraph='yes' and contains($txt,'&newl;&newl;')">
|
||||
+ <xsl:when test="$reparagraph='yes' and contains($txt,' ')">
|
||||
<!-- remove newlines from first paragraph -->
|
||||
- <xsl:value-of select="normalize-space(substring-before($txt,'&newl;&newl;'))" />
|
||||
+ <xsl:value-of select="normalize-space(substring-before($txt,' '))" />
|
||||
<!-- paragraph separator -->
|
||||
- <xsl:text>&newl;&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<!-- do the rest of the text -->
|
||||
<xsl:call-template name="trim-newln">
|
||||
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;&newl;')" />
|
||||
+ <xsl:with-param name="txt" select="substring-after($txt,' ')" />
|
||||
</xsl:call-template>
|
||||
</xsl:when>
|
||||
<!-- remove more single newlines -->
|
||||
@@ -485,7 +479,7 @@
|
||||
<!-- insert a number of newlines -->
|
||||
<xsl:template name="newlines">
|
||||
<xsl:param name="count" />
|
||||
- <xsl:text>&newl;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<xsl:if test="$count>1">
|
||||
<xsl:call-template name="newlines">
|
||||
<xsl:with-param name="count" select="($count)-1" />
|
||||
diff -up svn2cl-0.11/svn2html.xsl~ svn2cl-0.11/svn2html.xsl
|
||||
--- svn2cl-0.11/svn2html.xsl~ 2008-12-21 17:41:20.000000000 +0200
|
||||
+++ svn2cl-0.11/svn2html.xsl 2009-11-02 22:30:11.000000000 +0200
|
||||
@@ -47,11 +47,6 @@
|
||||
|
||||
-->
|
||||
|
||||
-<!DOCTYPE xsl:stylesheet [
|
||||
- <!ENTITY newl "&#xA;">
|
||||
- <!ENTITY space " ">
|
||||
-]>
|
||||
-
|
||||
<xsl:stylesheet
|
||||
version="1.0"
|
||||
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
@@ -134,7 +129,7 @@
|
||||
<li class="changelog_entry">
|
||||
<!-- date -->
|
||||
<span class="changelog_date"><xsl:value-of select="$date" /></span>
|
||||
- <xsl:text>&space;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<!-- author's name -->
|
||||
<span class="changelog_author"><xsl:apply-templates select="author" /></span>
|
||||
</li>
|
||||
@@ -145,7 +140,7 @@
|
||||
<li class="changelog_entry">
|
||||
<!-- date -->
|
||||
<span class="changelog_date"><xsl:apply-templates select="date" /></span>
|
||||
- <xsl:text>&space;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<!-- author's name -->
|
||||
<span class="changelog_author"><xsl:apply-templates select="author" /></span>
|
||||
</li>
|
||||
@@ -167,10 +162,10 @@
|
||||
<span class="changelog_revision">
|
||||
<a id="r{@revision}" href="{$revlink}">[r<xsl:value-of select="@revision" />]</a>
|
||||
</span>
|
||||
- <xsl:text>&space;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<!-- get paths string -->
|
||||
<span class="changelog_files"><xsl:apply-templates select="paths" /></span>
|
||||
- <xsl:text>&space;</xsl:text>
|
||||
+ <xsl:text> </xsl:text>
|
||||
<!-- get message text -->
|
||||
<xsl:variable name="msg">
|
||||
<xsl:call-template name="trim-newln">
|
||||
@@ -189,14 +184,14 @@
|
||||
<xsl:template name="newlinestobr">
|
||||
<xsl:param name="txt" />
|
||||
<xsl:choose>
|
||||
- <xsl:when test="contains($txt,'&newl;')">
|
||||
+ <xsl:when test="contains($txt,' ')">
|
||||
<!-- text contains newlines, do the first line -->
|
||||
- <xsl:value-of select="substring-before($txt,'&newl;')" />
|
||||
+ <xsl:value-of select="substring-before($txt,' ')" />
|
||||
<!-- print new line -->
|
||||
<br />
|
||||
<!-- wrap the rest of the text -->
|
||||
<xsl:call-template name="newlinestobr">
|
||||
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;')" />
|
||||
+ <xsl:with-param name="txt" select="substring-after($txt,' ')" />
|
||||
</xsl:call-template>
|
||||
</xsl:when>
|
||||
<xsl:otherwise>
|
@ -1,24 +0,0 @@
|
||||
The first half of this is certainly upstream-worthy, but the second half is presumably
|
||||
some Fedora-specific KDE packaging thing. It's not obvious how to get
|
||||
kde4-config to report the directory which contains the .so files.
|
||||
|
||||
--- subversion-1.6.6/build/ac-macros/kwallet.m4.kwallet
|
||||
+++ subversion-1.6.6/build/ac-macros/kwallet.m4
|
||||
@@ -47,14 +47,14 @@ AC_DEFUN(SVN_LIB_KWALLET,
|
||||
fi
|
||||
done
|
||||
qt_include_dirs="`$PKG_CONFIG --cflags-only-I QtCore QtDBus QtGui`"
|
||||
- kde_dir="`$kde4_config --prefix`"
|
||||
- SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs -I$kde_dir/include"
|
||||
+ kde_include_dirs="-I`$kde4_config --path include`"
|
||||
+ SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs $kde_include_dirs"
|
||||
qt_libs_other_options="`$PKG_CONFIG --libs-only-other QtCore QtDBus QtGui`"
|
||||
SVN_KWALLET_LIBS="$DBUS_LIBS -lQtCore -lQtDBus -lQtGui -lkdecore -lkdeui $qt_libs_other_options"
|
||||
CXXFLAGS="$CXXFLAGS $SVN_KWALLET_INCLUDES"
|
||||
LIBS="$LIBS $SVN_KWALLET_LIBS"
|
||||
qt_lib_dirs="`$PKG_CONFIG --libs-only-L QtCore QtDBus QtGui`"
|
||||
- LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L$kde_dir/lib`$kde4_config --libsuffix`"
|
||||
+ LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L/usr/lib`$kde4_config --libsuffix`/kde4/devel"
|
||||
AC_LANG(C++)
|
||||
AC_LINK_IFELSE([
|
||||
#include <kwallet.h>
|
@ -1,33 +0,0 @@
|
||||
Index: subversion/bindings/swig/include/proxy.swg
|
||||
===================================================================
|
||||
--- subversion/bindings/swig/include/proxy.swg (revision 1658942)
|
||||
+++ subversion/bindings/swig/include/proxy.swg (working copy)
|
||||
@@ -83,13 +83,13 @@
|
||||
|
||||
value = _swig_getattr(self, self.__class__, name)
|
||||
|
||||
- # If we got back a different object than we have, we need to copy all our
|
||||
- # metadata into it, so that it looks identical
|
||||
+%{ # If we got back a different object than we have, we need to copy all our
|
||||
+ # metadata into it, so that it looks identical%}
|
||||
members = self.__dict__.get("_members")
|
||||
if members is not None:
|
||||
_copy_metadata_deep(value, members.get(name))
|
||||
|
||||
- # Verify that the new object is good
|
||||
+%{ # Verify that the new object is good}%
|
||||
_assert_valid_deep(value)
|
||||
|
||||
return value
|
||||
@@ -98,9 +98,9 @@
|
||||
"""Set an attribute on this object"""
|
||||
self.assert_valid()
|
||||
|
||||
- # Save a copy of the object, so that the garbage
|
||||
+%{ # Save a copy of the object, so that the garbage
|
||||
# collector won't kill the object while it's in
|
||||
- # SWIG-land
|
||||
+ # SWIG-land%}
|
||||
self.__dict__.setdefault("_members",{})[name] = value
|
||||
|
||||
return _swig_setattr(self, self.__class__, name, value)
|
@ -9,8 +9,8 @@
|
||||
%define swigdirs swig_pydir=%{python3_sitearch}/libsvn swig_pydir_extra=%{python3_sitearch}/svn
|
||||
%define svn2cl_version 0.11
|
||||
Name: subversion
|
||||
Version: 1.14.2
|
||||
Release: 3mamba
|
||||
Version: 1.14.3
|
||||
Release: 1mamba
|
||||
Summary: A version control system that is a compelling replacement for CVS
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -20,15 +20,7 @@ URL: https://subversion.apache.org/
|
||||
Source0: https://www.apache.org/dist/subversion/subversion-%{version}.tar.bz2
|
||||
Source1: http://www.xsteve.at/prg/emacs/psvn.el
|
||||
Source2: psvn-init.el
|
||||
# http://bugs.debian.org/546990
|
||||
Patch0: subversion-1.6.5-newlines.patch
|
||||
Patch1: subversion-1.6.0-deplibs.patch
|
||||
Patch2: subversion-1.6.1-rpath.patch
|
||||
Patch3: subversion-1.6.0-pie.patch
|
||||
Patch4: subversion-1.6.0-java.patch
|
||||
Patch5: subversion-1.6.6-kwallet.patch
|
||||
Patch6: subversion-1.6.0-ruby185.patch
|
||||
Patch7: subversion-1.9.4-swig-3.0.10.patch
|
||||
Patch8: subversion-1.14.0-swig-4.0.2.patch
|
||||
Patch9: subversion-1.14.2-swig-4.1.1.patch
|
||||
License: Apache License, BSD
|
||||
@ -168,25 +160,13 @@ svn2cl is a simple XSL transformation and shell script wrapper forgenerating a c
|
||||
#:<< _EOF
|
||||
%patch 6 -p1
|
||||
|
||||
#sed -i -e 's|^XSL="$dir/|XSL="%{_datadir}/svn2cl/|' \
|
||||
# contrib/client-side/svn2cl/svn2cl.sh
|
||||
#v=$(contrib/client-side/svn2cl/svn2cl.sh -V | sed -n '1{s/.* //;p;}')
|
||||
#if [ "$v" != "%{svn2cl_version}" ]; then
|
||||
# echo -n "ERROR: svn2cl_version not up to date in specfile: "
|
||||
# echo "'$v' <> '%{svn2cl_version}'"
|
||||
# exit 1
|
||||
#fi
|
||||
|
||||
sed -i 's,Makefile.PL.in$,& libsvn_swig_perl,' Makefile.in
|
||||
|
||||
rm subversion/bindings/swig/proxy/*.swg
|
||||
|
||||
%patch 8 -p1
|
||||
%patch 9 -p1 -b .swig-4.1.1
|
||||
#%patch 9 -p1 -b .swig-4.1.1
|
||||
|
||||
# executing autogen.sh because there are problems with libtool and libs creation
|
||||
#./autogen.sh
|
||||
#autoheader && autoconf && ./gen-make.py --reload
|
||||
./autogen.sh --release
|
||||
|
||||
%build
|
||||
@ -412,6 +392,9 @@ fi
|
||||
#%{_mandir}/man1/svn2cl.1.gz
|
||||
|
||||
%changelog
|
||||
* Wed Jan 03 2024 Automatic Build System <autodist@mambasoft.it> 1.14.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 18 2023 Automatic Build System <autodist@mambasoft.it> 1.14.2-3mamba
|
||||
- rebuilt by autoport with build requirements: libutf8proc-devel>=2.9.0-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user