automatic version update by autodist [release 1.8.8-1mamba;Fri Feb 21 2014]

This commit is contained in:
Automatic Build System 2024-01-05 18:11:03 +01:00
parent 4191e0e940
commit 07390a6314
11 changed files with 7532 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# subversion # subversion
A version control system that is a compelling replacement for CVS.

3
psvn-init.el Normal file
View File

@ -0,0 +1,3 @@
(defalias 'svn-examine 'svn-status)
(autoload 'svn-status "psvn" "Examine the status of Subversion working copy in
directory DIR.")

6523
psvn.el Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,30 @@
--- subversion-1.6.0/build/ac-macros/apr.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/apr.m4
@@ -76,9 +76,9 @@ AC_DEFUN(SVN_LIB_APR,
dnl When APR stores the dependent libs in the .la file, we don't need
dnl --libs.
- SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
+ SVN_APR_LIBS="`$apr_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apr-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apr-config --link-libtool failed])
fi
SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"
--- subversion-1.6.0/build/ac-macros/aprutil.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/aprutil.m4
@@ -77,11 +77,9 @@ AC_DEFUN(SVN_LIB_APRUTIL,
AC_MSG_ERROR([apu-config --prefix failed])
fi
- dnl When APR stores the dependent libs in the .la file, we don't need
- dnl --libs.
- SVN_APRUTIL_LIBS="`$apu_config --link-libtool --libs`"
+ SVN_APRUTIL_LIBS="`$apu_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apu-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apu-config --link-libtool failed])
fi
SVN_APRUTIL_EXPORT_LIBS="`$apu_config --link-ld --libs`"

View File

@ -0,0 +1,11 @@
--- subversion-1.6.0/build/ac-macros/java.m4 2007-10-10 20:36:09.000000000 +0200
+++ subversion-1.6.0/build/ac-macros/java.m4-gil 2009-04-09 10:09:19.000000000 +0200
@@ -83,7 +83,7 @@
if test "$os_arch" = "Darwin"; then
AC_MSG_WARN([You may need to install the latest Java Development package from http://connect.apple.com/. Apple no longer includes the JNI header files by default on Java updates.])
fi
- JDK_SUITABLE=no
+ JDK_SUITABLE=yes
fi
AC_MSG_RESULT([$JDK_SUITABLE])

View File

@ -0,0 +1,62 @@
--- subversion-1.6.0/build.conf.pie
+++ subversion-1.6.0/build.conf
@@ -472,7 +472,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
@@ -495,7 +495,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
--- subversion-1.6.0/build/generator/gen_base.py.pie
+++ subversion-1.6.0/build/generator/gen_base.py
@@ -413,6 +413,9 @@ class TargetExe(TargetLinked):
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
+ if self.install == 'test' or self.install == 'bdb-test':
+ self.link_cmd = '$(LINK_TEST)'
+
def add_dependencies(self):
TargetLinked.add_dependencies(self)
@@ -455,8 +458,11 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = options.get('msvc-export', '').split()
- ### hmm. this is Makefile-specific
- self.link_cmd = '$(LINK_LIB)'
+ ### more Makefile-specific stuff:
+ if self.install == 'test':
+ self.link_cmd = '$(LINK_TEST_LIB)'
+ elif self.link_cmd == '$(LINK)':
+ self.link_cmd = '$(LINK_LIB)'
class TargetApacheMod(TargetLib):
--- subversion-1.6.0/Makefile.in.pie
+++ subversion-1.6.0/Makefile.in
@@ -184,8 +185,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK_LIB = $(LINK) -rpath $(libdir)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK = $(BASE_LINK) -pie
+LINK_TEST = $(BASE_LINK) -no-install
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
+LINK_TEST_LIB = $(BASE_LINK)
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
# special link rule for mod_dav_svn

View File

@ -0,0 +1,24 @@
--- subversion-1.6.0/subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.h 2009-02-16 21:08:57.000000000 +0100
+++ subversion-1.6.0/subversion/bindings/swig/ruby/libsvn_swig_ruby/swigutil_rb.h-gil 2009-04-09 10:45:31.000000000 +0200
@@ -49,6 +49,21 @@
#define RSTRING_PTR(x) RSTRING(x)->ptr
#endif
+/* If RARRAY_PTR is not defined in ruby.h then we have Ruby 1.8.5 or lower.
+ These definitions are correct for Ruby 1.8.x but not 1.9.0+. */
+#ifndef RARRAY_PTR
+#define RARRAY_PTR(s) (RARRAY(s)->ptr)
+#endif
+#ifndef RARRAY_LEN
+#define RARRAY_LEN(s) (RARRAY(s)->len)
+#endif
+#ifndef RSTRING_PTR
+#define RSTRING_PTR(s) (RSTRING(s)->ptr)
+#endif
+#ifndef RSTRING_LEN
+#define RSTRING_LEN(s) (RSTRING(s)->len)
+#endif
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

View File

@ -0,0 +1,53 @@
Libraries should be linked with -rpath $libdir but programs should not.
Doing so for the latter means that a redundant RPATH entry of $libdir
will end up in the binaries.
The redundant RPATH can also cause obscure build failures by causing
in-build binaries to pick up libraries from the system environment,
which libtool will otherwise avoid.
--- subversion-1.6.1/build.conf.rpath
+++ subversion-1.6.1/build.conf
@@ -472,7 +472,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
@@ -495,7 +495,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
--- subversion-1.6.1/build/generator/gen_base.py.rpath
+++ subversion-1.6.1/build/generator/gen_base.py
@@ -455,6 +455,10 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = options.get('msvc-export', '').split()
+ ### hmm. this is Makefile-specific
+ if self.link_cmd == '$(LINK)':
+ self.link_cmd = '$(LINK_LIB)'
+
class TargetApacheMod(TargetLib):
def __init__(self, name, options, gen_obj):
--- subversion-1.6.1/Makefile.in.rpath
+++ subversion-1.6.1/Makefile.in
@@ -184,7 +184,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
+LINK_LIB = $(LINK) -rpath $(libdir)
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
# special link rule for mod_dav_svn

View File

@ -0,0 +1,273 @@
diff -up svn2cl-0.11/svn2cl.xsl~ svn2cl-0.11/svn2cl.xsl
--- svn2cl-0.11/svn2cl.xsl~ 2008-12-21 17:41:20.000000000 +0200
+++ svn2cl-0.11/svn2cl.xsl 2009-11-02 22:29:34.000000000 +0200
@@ -55,12 +55,6 @@
-->
-<!DOCTYPE xsl:stylesheet [
- <!ENTITY tab "&#9;">
- <!ENTITY newl "&#38;#xA;">
- <!ENTITY space "&#32;">
-]>
-
<xsl:stylesheet
version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
@@ -119,7 +113,7 @@
</xsl:otherwise>
</xsl:choose>
<!-- add newlines at the end of the changelog -->
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
</xsl:template>
<!-- format one entry from the log -->
@@ -149,33 +143,33 @@
<xsl:if test="($prevdate!=$date) or ($prevauthor!=$author)">
<!-- add newline -->
<xsl:if test="not(position()=1)">
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
</xsl:if>
<!-- date -->
<xsl:value-of select="$date" />
<!-- two spaces -->
- <xsl:text>&space;&space;</xsl:text>
+ <xsl:text>&#32;&#32;</xsl:text>
<!-- author's name -->
<xsl:apply-templates select="author" />
<!-- two newlines -->
- <xsl:text>&newl;</xsl:text>
- <xsl:if test="$separate-daylogs!='yes'"><xsl:text>&newl;</xsl:text></xsl:if>
+ <xsl:text>&#10;</xsl:text>
+ <xsl:if test="$separate-daylogs!='yes'"><xsl:text>&#10;</xsl:text></xsl:if>
</xsl:if>
</xsl:when>
<!-- write the log header -->
<xsl:otherwise>
<!-- add newline -->
<xsl:if test="not(position()=1)">
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
</xsl:if>
<!-- date -->
<xsl:apply-templates select="date" />
<!-- two spaces -->
- <xsl:text>&space;&space;</xsl:text>
+ <xsl:text>&#32;&#32;</xsl:text>
<!-- author's name -->
<xsl:apply-templates select="author" />
<!-- two newlines -->
- <xsl:text>&newl;&newl;</xsl:text>
+ <xsl:text>&#10;&#10;</xsl:text>
</xsl:otherwise>
</xsl:choose>
<!-- get paths string -->
@@ -187,7 +181,7 @@
<xsl:if test="$include-rev='yes'">
<xsl:text>[r</xsl:text>
<xsl:value-of select="@revision" />
- <xsl:text>]&space;</xsl:text>
+ <xsl:text>]&#32;</xsl:text>
</xsl:if>
</xsl:variable>
<!-- trim trailing newlines -->
@@ -195,7 +189,7 @@
<!-- add a line break before the log message -->
<xsl:choose>
<xsl:when test="$breakbeforemsg='yes'">
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
</xsl:when>
<xsl:when test="number($breakbeforemsg)&gt;0">
<xsl:call-template name="newlines">
@@ -208,14 +202,14 @@
</xsl:call-template>
</xsl:variable>
<!-- add newline here if separate-daylogs is in effect -->
- <xsl:if test="$groupbyday='yes' and $separate-daylogs='yes'"><xsl:text>&newl;</xsl:text></xsl:if>
+ <xsl:if test="$groupbyday='yes' and $separate-daylogs='yes'"><xsl:text>&#10;</xsl:text></xsl:if>
<!-- first line is indented (other indents are done in wrap template) -->
- <xsl:text>&tab;*&space;</xsl:text>
+ <xsl:text>&#9;*&#32;</xsl:text>
<!-- set up the text to wrap -->
<xsl:variable name="txt">
<xsl:value-of select="$rev" />
<xsl:if test="$paths!=''">
- <xsl:value-of select="concat($paths,':&space;')" />
+ <xsl:value-of select="concat($paths,':&#32;')" />
</xsl:if>
<xsl:value-of select="$msg" />
</xsl:variable>
@@ -232,7 +226,7 @@
<xsl:value-of select="substring($date,1,10)" />
<!-- output time part -->
<xsl:if test="$groupbyday!='yes'">
- <xsl:text>&space;</xsl:text>
+ <xsl:text>&#32;</xsl:text>
<xsl:value-of select="substring($date,12,5)" />
</xsl:if>
</xsl:template>
@@ -306,7 +300,7 @@
<xsl:sort select="normalize-space(.)" data-type="text" />
<!-- unless we are the first entry, add a comma -->
<xsl:if test="not(position()=1)">
- <xsl:text>,&space;</xsl:text>
+ <xsl:text>,&#32;</xsl:text>
</xsl:if>
<!-- print the path name -->
<xsl:call-template name="printpath">
@@ -324,7 +318,7 @@
<xsl:sort select="normalize-space(.)" data-type="text" />
<!-- unless we are the first entry, add a comma -->
<xsl:if test="not(position()=1)">
- <xsl:text>,&space;</xsl:text>
+ <xsl:text>,&#32;</xsl:text>
</xsl:if>
<!-- print the path name -->
<xsl:value-of select="normalize-space(.)" />
@@ -382,23 +376,23 @@
<xsl:param name="txt" />
<xsl:variable name="normtxt" select="normalize-space($txt)" />
<xsl:choose>
- <xsl:when test="contains($txt,'&newl;')">
+ <xsl:when test="contains($txt,'&#10;')">
<!-- text contains newlines, do the first line -->
<xsl:call-template name="wrap">
- <xsl:with-param name="txt" select="substring-before($txt,'&newl;')" />
+ <xsl:with-param name="txt" select="substring-before($txt,'&#10;')" />
</xsl:call-template>
<!-- print tab -->
- <xsl:text>&tab;&space;&space;</xsl:text>
+ <xsl:text>&#9;&#32;&#32;</xsl:text>
<!-- wrap the rest of the text -->
<xsl:call-template name="wrap">
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;')" />
+ <xsl:with-param name="txt" select="substring-after($txt,'&#10;')" />
</xsl:call-template>
</xsl:when>
<xsl:when test="(string-length($normtxt) &lt; (($linelen)-9)) or not(contains($normtxt,' '))">
<!-- this is easy, nothing to do -->
<xsl:value-of select="$normtxt" />
<!-- add newline -->
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
</xsl:when>
<xsl:otherwise>
<!-- find the first line -->
@@ -420,7 +414,7 @@
<!-- print line -->
<xsl:value-of select="$line" />
<!-- print newline and tab -->
- <xsl:text>&newl;&tab;&space;&space;</xsl:text>
+ <xsl:text>&#10;&#9;&#32;&#32;</xsl:text>
<!-- wrap the rest of the text -->
<xsl:call-template name="wrap">
<xsl:with-param name="txt" select="normalize-space(substring($normtxt,string-length($line)+1))" />
@@ -449,26 +443,26 @@
<xsl:param name="txt" />
<xsl:choose>
<!-- find starting newlines -->
- <xsl:when test="substring($txt,1,1) = '&newl;'">
+ <xsl:when test="substring($txt,1,1) = '&#10;'">
<xsl:call-template name="trim-newln">
<xsl:with-param name="txt" select="substring($txt,2)" />
</xsl:call-template>
</xsl:when>
<!-- find trailing newlines -->
- <xsl:when test="substring($txt,string-length($txt),1) = '&newl;'">
+ <xsl:when test="substring($txt,string-length($txt),1) = '&#10;'">
<xsl:call-template name="trim-newln">
<xsl:with-param name="txt" select="substring($txt,1,string-length($txt)-1)" />
</xsl:call-template>
</xsl:when>
<!-- if the message has paragrapgs, find the first one -->
- <xsl:when test="$reparagraph='yes' and contains($txt,'&newl;&newl;')">
+ <xsl:when test="$reparagraph='yes' and contains($txt,'&#10;&#10;')">
<!-- remove newlines from first paragraph -->
- <xsl:value-of select="normalize-space(substring-before($txt,'&newl;&newl;'))" />
+ <xsl:value-of select="normalize-space(substring-before($txt,'&#10;&#10;'))" />
<!-- paragraph separator -->
- <xsl:text>&newl;&newl;</xsl:text>
+ <xsl:text>&#10;&#10;</xsl:text>
<!-- do the rest of the text -->
<xsl:call-template name="trim-newln">
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;&newl;')" />
+ <xsl:with-param name="txt" select="substring-after($txt,'&#10;&#10;')" />
</xsl:call-template>
</xsl:when>
<!-- remove more single newlines -->
@@ -485,7 +479,7 @@
<!-- insert a number of newlines -->
<xsl:template name="newlines">
<xsl:param name="count" />
- <xsl:text>&newl;</xsl:text>
+ <xsl:text>&#10;</xsl:text>
<xsl:if test="$count&gt;1">
<xsl:call-template name="newlines">
<xsl:with-param name="count" select="($count)-1" />
diff -up svn2cl-0.11/svn2html.xsl~ svn2cl-0.11/svn2html.xsl
--- svn2cl-0.11/svn2html.xsl~ 2008-12-21 17:41:20.000000000 +0200
+++ svn2cl-0.11/svn2html.xsl 2009-11-02 22:30:11.000000000 +0200
@@ -47,11 +47,6 @@
-->
-<!DOCTYPE xsl:stylesheet [
- <!ENTITY newl "&#38;#xA;">
- <!ENTITY space "&#32;">
-]>
-
<xsl:stylesheet
version="1.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
@@ -134,7 +129,7 @@
<li class="changelog_entry">
<!-- date -->
<span class="changelog_date"><xsl:value-of select="$date" /></span>
- <xsl:text>&space;</xsl:text>
+ <xsl:text>&#32;</xsl:text>
<!-- author's name -->
<span class="changelog_author"><xsl:apply-templates select="author" /></span>
</li>
@@ -145,7 +140,7 @@
<li class="changelog_entry">
<!-- date -->
<span class="changelog_date"><xsl:apply-templates select="date" /></span>
- <xsl:text>&space;</xsl:text>
+ <xsl:text>&#32;</xsl:text>
<!-- author's name -->
<span class="changelog_author"><xsl:apply-templates select="author" /></span>
</li>
@@ -167,10 +162,10 @@
<span class="changelog_revision">
<a id="r{@revision}" href="{$revlink}">[r<xsl:value-of select="@revision" />]</a>
</span>
- <xsl:text>&space;</xsl:text>
+ <xsl:text>&#32;</xsl:text>
<!-- get paths string -->
<span class="changelog_files"><xsl:apply-templates select="paths" /></span>
- <xsl:text>&space;</xsl:text>
+ <xsl:text>&#32;</xsl:text>
<!-- get message text -->
<xsl:variable name="msg">
<xsl:call-template name="trim-newln">
@@ -189,14 +184,14 @@
<xsl:template name="newlinestobr">
<xsl:param name="txt" />
<xsl:choose>
- <xsl:when test="contains($txt,'&newl;')">
+ <xsl:when test="contains($txt,'&#10;')">
<!-- text contains newlines, do the first line -->
- <xsl:value-of select="substring-before($txt,'&newl;')" />
+ <xsl:value-of select="substring-before($txt,'&#10;')" />
<!-- print new line -->
<br />
<!-- wrap the rest of the text -->
<xsl:call-template name="newlinestobr">
- <xsl:with-param name="txt" select="substring-after($txt,'&newl;')" />
+ <xsl:with-param name="txt" select="substring-after($txt,'&#10;')" />
</xsl:call-template>
</xsl:when>
<xsl:otherwise>

View File

@ -0,0 +1,24 @@
The first half of this is certainly upstream-worthy, but the second half is presumably
some Fedora-specific KDE packaging thing. It's not obvious how to get
kde4-config to report the directory which contains the .so files.
--- subversion-1.6.6/build/ac-macros/kwallet.m4.kwallet
+++ subversion-1.6.6/build/ac-macros/kwallet.m4
@@ -47,14 +47,14 @@ AC_DEFUN(SVN_LIB_KWALLET,
fi
done
qt_include_dirs="`$PKG_CONFIG --cflags-only-I QtCore QtDBus QtGui`"
- kde_dir="`$kde4_config --prefix`"
- SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs -I$kde_dir/include"
+ kde_include_dirs="-I`$kde4_config --path include`"
+ SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs $kde_include_dirs"
qt_libs_other_options="`$PKG_CONFIG --libs-only-other QtCore QtDBus QtGui`"
SVN_KWALLET_LIBS="$DBUS_LIBS -lQtCore -lQtDBus -lQtGui -lkdecore -lkdeui $qt_libs_other_options"
CXXFLAGS="$CXXFLAGS $SVN_KWALLET_INCLUDES"
LIBS="$LIBS $SVN_KWALLET_LIBS"
qt_lib_dirs="`$PKG_CONFIG --libs-only-L QtCore QtDBus QtGui`"
- LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L$kde_dir/lib`$kde4_config --libsuffix`"
+ LDFLAGS="$old_LDFLAGS $qt_lib_dirs -L/usr/lib`$kde4_config --libsuffix`/kde4/devel"
AC_LANG(C++)
AC_LINK_IFELSE([
#include <kwallet.h>

527
subversion.spec Normal file
View File

@ -0,0 +1,527 @@
%ifarch %{ix86} x86_64
%define with_java_subpackage 1
%else
%define with_java_subpackage 0
%endif
%define with_perl_subpackage 1
##%define make_check 1
%define majversion %(echo %version | cut -d. -f 1)
%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
%define svn2cl_version 0.11
Name: subversion
Version: 1.8.8
Release: 1mamba
Summary: A version control system that is a compelling replacement for CVS
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://subversion.apache.org/
Source0: http://mirror.nohup.it/apache/subversion/subversion-%{version}.tar.bz2
Source1: http://www.xsteve.at/prg/emacs/psvn.el
Source2: psvn-init.el
# http://bugs.debian.org/546990
Patch0: subversion-1.6.5-newlines.patch
Patch1: subversion-1.6.0-deplibs.patch
Patch2: subversion-1.6.1-rpath.patch
Patch3: subversion-1.6.0-pie.patch
Patch4: subversion-1.6.0-java.patch
Patch5: subversion-1.6.6-kwallet.patch
Patch6: subversion-1.6.0-ruby185.patch
License: Apache License, BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libapr-devel
BuildRequires: libaprutil-devel
BuildRequires: libdb51-devel
BuildRequires: libdbus-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libgcc
BuildRequires: libgcrypt-devel
BuildRequires: libglib-devel
BuildRequires: libgnome-keyring-devel
BuildRequires: libgpg-error-devel
BuildRequires: libmagic-devel
BuildRequires: libpython-devel
BuildRequires: libsasl-devel
BuildRequires: libserf-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libuuid-devel
BuildRequires: libz-devel
BuildRequires: perl-devel
BuildRequires: ruby-devel
## AUTOBUILDREQ-END
BuildRequires: apache
BuildRequires: apache-devel
BuildRequires: gettext-devel
%if %{with_java_subpackage}
BuildRequires: jpackage-utils
BuildRequires: jdk
%endif
BuildRequires: libmysql5-devel
BuildRequires: libneon-devel
BuildRequires: libopenssl-devel
BuildRequires: libpostgresql-devel
BuildRequires: libz-devel
BuildRequires: perl
BuildRequires: perl-Config-IniFiles
BuildRequires: python
BuildRequires: ruby-devel
BuildRequires: swig
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
A version control system that is a compelling replacement for CVS.
%package -n apache-mod_svn
Summary: Subversion module for Apache Web Server
Group: System/Servers
Requires: apache
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n apache-mod_svn
This package adds Subversion support to the Apache Web Server.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%if %{with_java_subpackage}
Requires: java-subversion = %{?epoch:%epoch:}%{version}-%{release}
%endif
%if %{with_perl_subpackage}
Requires: perl-subversion = %{?epoch:%epoch:}%{version}-%{release}
%endif
Requires: python-subversion = %{?epoch:%epoch:}%{version}-%{release}
Requires: ruby-subversion = %{?epoch:%epoch:}%{version}-%{release}
%description devel
A version control system that is a compelling replacement for CVS.
This package contains static libraries and header files need for development.
%if %{with_java_subpackage}
%package -n java-subversion
Group: Development/Libraries/Java
Summary: JNI bindings to the Subversion libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: jpackage-utils
Requires: jdk
%description -n java-subversion
This package includes the JNI bindings to the Subversion libraries.
%endif
%if %{with_perl_subpackage}
%package -n perl-subversion
Summary: Perl bindings to the Subversion libraries
Group: Development/Libraries/Perl
Requires: perl
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: perl-Config-IniFiles
Provides: subversion-perl
Obsoletes: subversion-perl
%description -n perl-subversion
A version control system that is a compelling replacement for CVS.
This package includes the Perl bindings to the Subversion libraries.
%endif
%package -n python-subversion
Group: Development/Libraries/Python
Summary: JNI bindings to the Subversion libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n python-subversion
This package includes the Python bindings to the Subversion libraries.
%package -n ruby-subversion
Group: Development/Libraries
Summary: Ruby bindings to the Subversion libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n ruby-subversion
This package includes the Ruby bindings to the Subversion libraries.
%package svn2cl
Group: Development/Tools
Summary: Create a ChangeLog from a Subversion log
Provides: svn2cl = %{svn2cl_version}-5
Requires: libxslt
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description svn2cl
svn2cl is a simple XSL transformation and shell script wrapper forgenerating a classic GNU-style ChangeLog from a subversion repository log. It is made from several changelog-like scripts using common XSLT constructs found in different places.
%prep
%setup -q
#pushd contrib/client-side/svn2cl
#%patch0 -p1 -b .newlines
#popd
#%patch1 -p1 -b .deplibs
#%patch2 -p1 -b .rpath
#patch3 -p1 -b .pie
#%if %{with_java_subpackage}
#%patch4 -p1
#%endif
#%patch5 -p1 -b .kwallet
%patch6 -p1
#sed -i -e 's|^XSL="$dir/|XSL="%{_datadir}/svn2cl/|' \
# contrib/client-side/svn2cl/svn2cl.sh
#v=$(contrib/client-side/svn2cl/svn2cl.sh -V | sed -n '1{s/.* //;p;}')
#if [ "$v" != "%{svn2cl_version}" ]; then
# echo -n "ERROR: svn2cl_version not up to date in specfile: "
# echo "'$v' <> '%{svn2cl_version}'"
# exit 1
#fi
sed -i 's,Makefile.PL.in$,& libsvn_swig_perl,' Makefile.in
%build
# executing autogen.sh because there are problems with libtool and libs creation
#./autogen.sh
#autoheader && autoconf && ./gen-make.py --reload
./autogen.sh --release
perl -pi -e 's|/usr/bin/env perl -w|%{__perl} -w|' tools/hook-scripts/*.pl.in
export svn_cv_ruby_link="%{__cc} -shared"
export svn_cv_ruby_sitedir_libsuffix=""
export svn_cv_ruby_sitedir_archsuffix=""
## force compilation with last version of libapr and libaprutil
#unset JAVA_HOME
export CC=gcc CXX=g++
%configure \
--with-apr=%{_bindir}/apr-1-config \
--with-apr-util=%{_bindir}/apu-1-config \
--with-neon=%{_prefix} \
--with-jdk=%{_jvmdir}/jdk \
--without-jikes \
--with-swig \
--with-zlib=%{_prefix} \
--with-ssl=%{_prefix} \
--with-neon=%{_prefix} \
--with-apxs=apxs \
--with-ruby-sitedir=%{ruby_sitearch} \
--with-sasl=%{_prefix} \
--with-serf \
--with-apache-libexecdir=%{_libdir}/apache
%make all
make swig-py swig-py-lib %{swigdirs}
make swig-rb swig-rb-lib
%if %{with_java_subpackage}
make javahl-java javahl-javah
make javahl
%endif
%if %{with_perl_subpackage}
pushd subversion/bindings/swig/perl/native
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
popd
make swig-pl swig-pl-lib
%endif
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
# svn-config isn't quite built correctly; it contains references to
# @SVN_DB_LIBS@ and @SVN_DB_INCLUDES@. It appears the best thing is
# to remove that.
#sed -i 's/@SVN_DB_[^@]*@//g' svn-config
#install -D -m 755 svn-config \
# %{buildroot}%{_bindir}/svn-config
%if %{with_java_subpackage}
make install-javahl-java install-javahl-lib javahl_javadir=%{_javadir} DESTDIR=%{buildroot}
%endif
make install-swig-rb \
DESTDIR=%{buildroot}
make install-swig-py \
DESTDIR=%{buildroot} %{swigdirs}
make install-swig-pl-lib \
DESTDIR=%{buildroot}
%if %{with_perl_subpackage}
%makeinstall_perl -C subversion/bindings/swig/perl/native
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
%endif
find %{buildroot}%{_prefix}/lib/perl5 -type f -perm 555 -print0 |
xargs -0 chmod 755
rm -rf tools/*/*.in tools/test-scripts
#for f in emacs/site-lisp xemacs/site-packages/lisp; do
# mkdir -p %{buildroot}%{_datadir}/$f
# install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/$f
#done
#install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/emacs/site-lisp
mkdir -p %{buildroot}%{_bindir}
#mkdir -p %{buildroot}%{_datadir}/svn2cl
mkdir -p %{buildroot}%{_mandir}/man1
#pushd contrib/client-side/svn2cl
# install -pm 755 svn2cl.sh %{buildroot}%{_bindir}/svn2cl
# install -pm 644 *.xsl %{buildroot}%{_datadir}/svn2cl
# install -pm 644 svn2cl.1 %{buildroot}%{_mandir}/man1/
#popd
%find_lang %{name}
#%if %{make_check}
##heck
#export LANG=C LC_ALL=C
#ake check check-swig-pl check-swig-py CLEANUP=yes
# check-swig-rb omitted: it runs svnserve
#endif
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
rm -f .packlist
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post -n apache-mod_svn
if [ $1 -eq 1 ]; then
#install
# please note: the modules order matters
apxs -e -a -n dav_svn %{_libdir}/apache/mod_dav_svn.so > /dev/null
apxs -e -a -n authz_svn %{_libdir}/apache/mod_authz_svn.so > /dev/null
%{_initrddir}/httpd condrestart
fi
:
%postun -n apache-mod_svn
if [ $1 -eq 0 ]; then
#erase
sed -i "/mod_authz_svn.so/d" %{_sysconfdir}/httpd/httpd.conf
sed -i "/mod_dav_svn.so/d" %{_sysconfdir}/httpd/httpd.conf
%{_initrddir}/httpd condrestart
fi
:
%if %{with_java_subpackage}
%post -n java-subversion -p /sbin/ldconfig
%postun -n java-subversion -p /sbin/ldconfig
%endif
%post -n ruby-subversion -p /sbin/ldconfig
%postun -n ruby-subversion -p /sbin/ldconfig
%files -f %{name}.lang
%defattr(-,root,root)
%{_bindir}/svn
%{_bindir}/svnadmin
%{_bindir}/svndumpfilter
%{_bindir}/svnlook
%{_bindir}/svnmucc
%{_bindir}/svnrdump
%{_bindir}/svnserve
%{_bindir}/svnsync
%{_bindir}/svnversion
%{_libdir}/libsvn_auth_gnome_keyring-1.so.*
%{_libdir}/libsvn_client-1.so.*
%{_libdir}/libsvn_delta-1.so.*
%{_libdir}/libsvn_diff-1.so.*
%{_libdir}/libsvn_fs-1.so.*
%{_libdir}/libsvn_fs_base-1.so.*
%{_libdir}/libsvn_fs_fs-1.so.*
%{_libdir}/libsvn_fs_util-1.so.*
%{_libdir}/libsvn_ra-1.so.*
%{_libdir}/libsvn_ra_local-1.so.*
%{_libdir}/libsvn_ra_serf-1.so.*
%{_libdir}/libsvn_ra_svn-1.so.*
%{_libdir}/libsvn_repos-1.so.*
%{_libdir}/libsvn_subr-1.so.*
%{_libdir}/libsvn_wc-1.so.*
%{_mandir}/man1/*
%{_mandir}/man5/*
%{_mandir}/man8/*
%doc LICENSE
%files -n apache-mod_svn
%defattr(-,root,root)
%{_libdir}/apache/*.so
%files devel
%defattr(-,root,root)
%dir %{_includedir}/subversion-%{majversion}
%{_includedir}/subversion-%{majversion}/*
%{_libdir}/libsvn_*.so
%{_libdir}/libsvn_*.a
%{_libdir}/libsvn_*.la
%doc BUGS CHANGES README
%if %{with_java_subpackage}
%files -n java-subversion
%defattr(-,root,root)
%{_libdir}/libsvnjavahl-1.*a
%{_libdir}/libsvnjavahl-1.so*
%{_javadir}/svn-javahl.jar
%endif
%files -n ruby-subversion
%defattr(-,root,root)
%{_libdir}/libsvn_swig_ruby-1.so.*
%dir %{ruby_sitearch}/svn
%{ruby_sitearch}/svn/*
%if %{with_perl_subpackage}
%files -n perl-subversion -f .packlist
%defattr(-,root,root)
%{_libdir}/libsvn_swig_perl-1.so.*
%endif
%files -n python-subversion
%defattr(-,root,root)
%{_libdir}/libsvn_swig_py-1.so.*
%{python_sitearch}/svn
%{python_sitearch}/libsvn
#%files svn2cl
#%defattr(-,root,root)
#%{_bindir}/svn2cl
#%{_datadir}/svn2cl
#%{_mandir}/man1/svn2cl.1.gz
%changelog
* Fri Feb 21 2014 Automatic Build System <autodist@mambasoft.it> 1.8.8-1mamba
- automatic version update by autodist
* Sat Dec 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.5-3mamba
- build with libserf to fix http* download
- new package python-subversion
* Wed Nov 27 2013 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.8.5-2mamba
- add perl bindings dependencies upon libsvn_swig_perl-1.so
* Tue Nov 26 2013 Automatic Build System <autodist@mambasoft.it> 1.8.5-1mamba
- automatic version update by autodist
* Wed Oct 30 2013 Automatic Build System <autodist@mambasoft.it> 1.8.4-1mamba
- automatic version update by autodist
* Fri Aug 30 2013 Automatic Build System <autodist@mambasoft.it> 1.8.3-1mamba
- automatic update by autodist
* Thu Jul 25 2013 Automatic Build System <autodist@mambasoft.it> 1.8.1-1mamba
- automatic version update by autodist
* Wed Jun 19 2013 Automatic Build System <autodist@mambasoft.it> 1.8.0-1mamba
- automatic version update by autodist
* Sun Jun 02 2013 Automatic Build System <autodist@mambasoft.it> 1.7.10-1mamba
- automatic version update by autodist
* Fri Apr 05 2013 Automatic Build System <autodist@mambasoft.it> 1.7.9-1mamba
- automatic version update by autodist
* Fri Dec 21 2012 Automatic Build System <autodist@mambasoft.it> 1.7.8-1mamba
- automatic version update by autodist
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.7-2mamba
- perl 5.16 mass rebuild
* Wed Oct 10 2012 Automatic Build System <autodist@mambasoft.it> 1.7.7-1mamba
- automatic version update by autodist
* Wed Aug 22 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.7.6-2mamba
- require jdk, not sun-java
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 1.7.6-1mamba
- automatic version update by autodist
* Tue Jun 26 2012 Automatic Build System <autodist@mambasoft.it> 1.7.5-1mamba
- automatic version update by autodist
* Tue Apr 10 2012 Automatic Build System <autodist@mambasoft.it> 1.7.4-1mamba
- update to 1.7.4
* Sat Aug 13 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.17-3mamba
- update to 1.6.17 (rebase from milestone1-contrib adding java and ruby subpackages)
* Wed Dec 16 2009 gil <puntogil@libero.it> 1.6.6-1mamba
- update to 1.6.6
* Wed Jul 29 2009 gil <puntogil@libero.it> 1.6.3-1mamba
- update to 1.6.3
* Fri Apr 10 2009 gil <puntogil@libero.it> 1.5.5-1mamba
- update to 1.5.5
* Thu Apr 09 2009 gil <puntogil@libero.it> 1.4.6-3mamba
- edit spec file
* Thu Apr 09 2009 gil <puntogil@libero.it> 1.4.6-2mamba
- edit spec file
- added java ruby bindings subpackages
* Sat Mar 21 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-1mamba
- automatic update to 1.6.0 by autodist
* Fri Feb 27 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.6-1mamba
- automatic update to 1.5.6 by autodist
* Tue Dec 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.5-1mamba
- automatic update to 1.5.5 by autodist
* Thu Nov 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.4-2mamba
- automatic rebuild by autodist
* Sat Oct 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.4-1mamba
- automatic update to 1.5.4 by autodist
* Tue Oct 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.3-1mamba
- automatic update to 1.5.3 by autodist
* Sun Sep 07 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-1mamba
- automatic update to 1.5.2 by autodist
* Sun Feb 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.6-1mamba
- update to 1.4.6
* Fri Jul 07 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.3.2-2qilnx
- added perl bindings subpackage
- added missing build requirement
* Tue Jun 13 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.3.2-1qilnx
- update to version 1.3.2 by autospec
- added missing build requirements
* Mon Aug 29 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.2.3-1qilnx
- update to version 1.2.3 by autospec
- update dynamic linker run time bindings
- svn-config now provided by devel package
* Thu Jul 07 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-1qilnx
- update to version 1.2.1 by autospec
* Mon Feb 07 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.3-1qilnx
- package created by autospec