update to 2.2.2 [release 2.2.2-1mamba;Fri May 27 2022]
This commit is contained in:
parent
77adc4349b
commit
2558f12ee5
37
streamtuner-2.2.2-make-install.patch
Normal file
37
streamtuner-2.2.2-make-install.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
--- streamtuner2/Makefile.orig 2022-05-27 16:39:07.577426034 +0200
|
||||||
|
+++ streamtuner2/Makefile 2022-05-27 16:40:59.998772385 +0200
|
||||||
|
@@ -82,20 +82,20 @@
|
||||||
|
|
||||||
|
# manual installation
|
||||||
|
install:
|
||||||
|
- mkdir -p $(DEST)/channels
|
||||||
|
- mkdir -p $(DOCS)/streamtuner2/help/img
|
||||||
|
- install -m 755 bin /usr/bin/streamtuner2
|
||||||
|
- $(INST) *py -t $(DEST)
|
||||||
|
- $(INST) gtk3* -t $(DEST)
|
||||||
|
- $(INST) channels/*py -t $(DEST)/channels
|
||||||
|
- $(INST) help/*page -t $(DOCS)/streamtuner2/help
|
||||||
|
- $(INST) help/img/* -t $(DOCS)/streamtuner2/help/img
|
||||||
|
- $(INST) CREDITS -t $(DEST)
|
||||||
|
- $(INST) README -t $(DOCS)
|
||||||
|
- $(INST) *.desktop -t /usr/share/applications/
|
||||||
|
- $(INST) icon.png /usr/share/pixmaps/streamtuner2.png
|
||||||
|
- $(INST) help/str*2.1 -t /usr/share/man/man1/
|
||||||
|
- pip install requests pyquery lxml pillow xdg keybinder
|
||||||
|
+ mkdir -p $(DESTDIR)$(DEST)/channels
|
||||||
|
+ mkdir -p $(DESTDIR)$(DOCS)/streamtuner2/help/img
|
||||||
|
+ install -D -m 755 bin $(DESTDIR)/usr/bin/streamtuner2
|
||||||
|
+ $(INST) *py -t $(DESTDIR)$(DEST)
|
||||||
|
+ $(INST) gtk3* -t $(DESTDIR)$(DEST)
|
||||||
|
+ $(INST) channels/*py -t $(DESTDIR)$(DEST)/channels
|
||||||
|
+ $(INST) help/*page -t $(DESTDIR)$(DOCS)/streamtuner2/help
|
||||||
|
+ $(INST) help/img/* -t $(DESTDIR)$(DOCS)/streamtuner2/help/img
|
||||||
|
+ $(INST) CREDITS -t $(DESTDIR)$(DEST)
|
||||||
|
+ $(INST) README -t $(DESTDIR)$(DOCS)
|
||||||
|
+ $(INST) -D *.desktop -t $(DESTDIR)/usr/share/applications/
|
||||||
|
+ $(INST) -D icon.png $(DESTDIR)/usr/share/pixmaps/streamtuner2.png
|
||||||
|
+ $(INST) -D help/str*2.1 -t $(DESTDIR)/usr/share/man/man1/
|
||||||
|
+# pip install requests pyquery lxml pillow xdg keybinder
|
||||||
|
|
||||||
|
# start locally
|
||||||
|
st2: run
|
@ -1,101 +1,54 @@
|
|||||||
Name: streamtuner
|
Name: streamtuner
|
||||||
Version: 0.99.99
|
Version: 2.2.2
|
||||||
Release: 5mamba
|
Release: 1mamba
|
||||||
Summary: Streamtuner is a stream directory browser
|
Summary: Streamtuner is a stream directory browser
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Tiziana Ferro <tiziana.ferro@email.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://www.nongnu.org/streamtuner/
|
URL: http://www.nongnu.org/streamtuner/
|
||||||
Source: http://download.savannah.gnu.org/releases/streamtuner/streamtuner-%{version}.tar.gz
|
Source: https://sourceforge.net/projects/streamtuner2/files/streamtuner2-%{version}.src.txz
|
||||||
|
Patch0: streamtuner-2.2.2-make-install.patch
|
||||||
License: BSD
|
License: BSD
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libcairo-devel
|
|
||||||
BuildRequires: libcares-devel
|
|
||||||
BuildRequires: libcurl-devel
|
|
||||||
BuildRequires: libe2fs-devel
|
|
||||||
BuildRequires: libexpat-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
|
||||||
BuildRequires: libgcrypt-devel
|
|
||||||
BuildRequires: libglib-devel
|
|
||||||
BuildRequires: libglitz-devel
|
|
||||||
BuildRequires: libgpg-error-devel
|
|
||||||
BuildRequires: libgtk-devel
|
|
||||||
BuildRequires: libidn-devel
|
|
||||||
BuildRequires: libkrb5-devel
|
|
||||||
BuildRequires: libopenldap-devel
|
|
||||||
BuildRequires: libopenssl-devel
|
|
||||||
BuildRequires: libpango-devel
|
|
||||||
BuildRequires: libpixman-devel
|
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: libsasl-devel
|
|
||||||
BuildRequires: libselinux
|
|
||||||
BuildRequires: libssh2-devel
|
|
||||||
BuildRequires: libtag-devel
|
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libXau-devel
|
|
||||||
BuildRequires: libxcb-devel
|
|
||||||
BuildRequires: libxcb-util-devel
|
|
||||||
BuildRequires: libXdmcp-devel
|
|
||||||
BuildRequires: libxml2-devel
|
|
||||||
BuildRequires: libXrender-devel
|
|
||||||
BuildRequires: libz-devel
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libtag-devel >= 1.9.1
|
Obsoletes: streamtuner-devel < 2.2.2
|
||||||
BuildRequires: python-devel
|
|
||||||
BuildRequires: pygtk-devel
|
|
||||||
BuildRequires: libpthread-stubs-devel
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Streamtuner is a stream directory browser. Through the use of a plugin system, it offers an intuitive GTK+ 2.0 interface to Internet radio directories.
|
Streamtuner is a stream directory browser. Through the use of a plugin system, it offers an intuitive GTK+ 2.0 interface to Internet radio directories.
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: Devel package for %{name}
|
|
||||||
Group: Development/Libraries
|
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}
|
|
||||||
|
|
||||||
%description devel
|
|
||||||
Devel package for streamtuner
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q -n streamtuner2
|
||||||
|
%patch0 -p1
|
||||||
|
sed -i "s|python$|python3|" bin
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
|
||||||
%make
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
%makeinstall
|
%makeinstall DOCS=%{_docdir}
|
||||||
|
|
||||||
%find_lang %{name}
|
rm -f %{buildroot}%{_docdir}/README
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS COPYING NEWS README TODO
|
%{_bindir}/streamtuner2
|
||||||
%{_bindir}/streamtuner
|
%{_datadir}/applications/streamtuner2.desktop
|
||||||
%{_libdir}/streamtuner/plugins/*
|
%{_datadir}/pixmaps/streamtuner2.png
|
||||||
%{_datadir}/applications/streamtuner.desktop
|
%dir %{_datadir}/streamtuner2
|
||||||
%{_datadir}/gtk-doc/html/streamtuner/*
|
%{_datadir}/streamtuner2/*
|
||||||
%{_datadir}/pixmaps/streamtuner.png
|
%dir %{_docdir}/streamtuner2
|
||||||
%dir %{_datadir}/streamtuner
|
%dir %{_docdir}/streamtuner2/help
|
||||||
%{_datadir}/streamtuner/*
|
%{_docdir}/streamtuner2/help/*
|
||||||
%{_datadir}/help/streamtuner/C/*
|
%{_mandir}/man1/streamtuner2.1*
|
||||||
%{_datadir}/omf/streamtuner/streamtuner-C.omf
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_includedir}/streamtuner/*.h
|
|
||||||
%{_libdir}/pkgconfig/*.pc
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 27 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-1mamba
|
||||||
|
- update to 2.2.2
|
||||||
|
|
||||||
* Wed Dec 30 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.99-5mamba
|
* Wed Dec 30 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.99-5mamba
|
||||||
- mass rebuild with libtag 1.9.1
|
- mass rebuild with libtag 1.9.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user